20:00:27 <ildikov> #startmeeting openstack_upstream_institute
20:00:27 <openstack> Meeting started Mon May  1 20:00:27 2017 UTC and is due to finish in 60 minutes.  The chair is ildikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:31 <openstack> The meeting name has been set to 'openstack_upstream_institute'
20:00:35 <mrmartin> o/
20:00:37 <blancos__> o/
20:00:39 <jungleboyj> o/
20:01:00 <ildikov> ping jungleboyj, knikolla, jaypipes, mlavalle, spotz, csatari, mrmartin, marst, blancos, smcginnis, trevormc, vkmc, PagliaccisCloud, madorn, kmARC
20:01:05 <marst> o/
20:01:09 <ildikov> sorry guys, I'm slow copy-pasting today
20:01:12 <trevormc> o/
20:01:13 <ianychoi> o/
20:01:16 <kmARC> o/
20:01:38 <ildikov> ianychoi: kudos, if you're home!
20:01:40 <jungleboyj> ildikov: We are just overly excited to be here.  ;-)
20:01:52 <ianychoi> ildikov, :)
20:01:54 <ildikov> ianychoi: that's very early :/
20:01:57 <mlavalle> o/
20:03:41 <ianychoi> ildikov, I am now in Oslo Norway - it's 10pm not early. I will arrive at Boston on Saturday evening.
20:04:00 <ildikov> ianychoi: ok good, that's survivable
20:04:01 <smcginnis> o/
20:04:06 <jungleboyj> ianychoi:  I thought you had mentioned you were going to be traveling.  Hope it was a good trip.
20:04:06 <ianychoi> :)
20:04:09 <ildikov> ok, I'm finished hunting down people
20:04:09 <diablo_rojo> Hello :)
20:04:18 <ildikov> so we can start :)
20:04:30 <ildikov> agenda is here: https://etherpad.openstack.org/p/openstack-upstream-institute-meetings
20:05:07 <spotz_> Hey all doing double meeting
20:05:07 <ildikov> as it wasn't prepared by diablo_rojo this time it's pretty thin, but hopefully we will be still good :)
20:05:14 <ildikov> spotz_: :(
20:05:15 <diablo_rojo> Lol
20:05:21 <ianychoi> jungleboyj, hi thank you :)
20:05:23 <ildikov> spotz_: thanks for coming :)
20:05:29 <diablo_rojo> Not as much to do since we are so close.
20:05:30 <spotz_> hey so is diablo_rojo!
20:05:30 <ildikov> #topic Announcements
20:05:47 <ildikov> so we have 38 confirmations so far!
20:05:59 <spotz_> woot
20:06:07 <smcginnis> How many were in BCN?
20:06:12 <ildikov> I think that's pretty good, I hope we will have a bit more people showing up
20:06:20 <ildikov> smcginnis: around 70
20:06:41 <ildikov> smcginnis: the outside US ones I think are more popular
20:07:03 <ildikov> smcginnis: we had like less than 20 students in the room in Austin last year for instance
20:07:28 <ildikov> so we start Saturday at 1pm
20:07:29 <smcginnis> Hmm, guess that kind of makes sense.
20:07:29 <diablo_rojo> I expect people will show up that didnt register too
20:07:43 <smcginnis> diablo_rojo: Probably.
20:07:45 <ildikov> those of you who're around it would be great to catch up for lunch
20:08:13 <ianychoi> 38 people looks great!
20:08:37 <ildikov> I sent out a mail to all the trainers/mentors I know plan to join
20:09:00 <ildikov> please let me know if you cannot come and you're on the list or if you know anyone who's coming and not on the list
20:09:29 <ildikov> if anyone has a preference on where to meet plz share that too, otherwise, I'll pick one :)
20:10:16 <smcginnis> I think I arrive around lunch time, but would love to catch up with everyone if I can make it there in time.
20:10:41 <ildikov> we start at 9am on Sunday, those of you who can join only that day please try to be around from 8:30am in case students with questions show up or just simply to catch up and see how things were going on Saturday and get ready for the day
20:11:03 <ianychoi> Yep :_
20:11:06 <ianychoi> :)
20:11:11 <jungleboyj> I am with smcginnis
20:11:26 <ildikov> smcginnis: jungleboyj: ok, tnx, noted
20:11:30 <smcginnis> Literally.
20:11:31 <ildikov> :)
20:11:49 <diablo_rojo> At a minimim if you all could plan to be there 15 min early that would be wonderful- 30 min would be better of course :)
20:12:17 <ildikov> diablo_rojo: +1
20:12:31 <ianychoi> diablo_rojo, +1
20:12:44 <ildikov> ok, let's move on
20:12:52 <ildikov> #topic Open Reviews
20:13:18 <ildikov> #link https://review.openstack.org/#/q/project:openstack/training-guides
20:13:31 <ildikov> there are two tiny ones in the training-guides repo
20:13:47 <diablo_rojo> I just pushed one up today to add continued education stuff to the website i.e. onboarding rooms and git and gerrit lunch and learn
20:13:49 <ildikov> one is for the dev enb
20:14:05 <ildikov> and the other is a few pointers to students on the website for the week
20:14:17 <ildikov> we chose the web to make it visible
20:15:27 <ildikov> I have three housekeeping patches for Sandbox: https://review.openstack.org/#/q/project:openstack-dev/sandbox
20:15:53 <ildikov> will merge them and we can play with the deep dive material
20:16:06 <ildikov> hoping that no one will mess it up before the training :)
20:16:16 <ildikov> or well, not drastically at least
20:17:00 <ildikov> plz check the training-guides patches and let's get them merged quickly
20:17:09 <ildikov> if nothing else, then let's move on
20:17:10 <smcginnis> If not, it can be a lesson for them in "collaboration". :)
20:17:30 <diablo_rojo> smcginnis, :)
20:17:31 <ildikov> smcginnis: :)
20:17:58 <ildikov> #topic Projects/areas to cover during the training
20:18:11 <ildikov> #link https://etherpad.openstack.org/p/boston-upstream-institute-presenters
20:19:25 <ildikov> so I added there numbers to see how many people we have confirmed for each area
20:19:43 <ildikov> compute, containers and networking are the most popular ones
20:20:28 <jungleboyj> :-(  Need more storage peeps.
20:20:34 <ildikov> we have a few projects not really covered, we can get those guys and girls together and teach them things by picking an area from those we have coverage for
20:20:36 <spotz_> ha!
20:20:37 <diablo_rojo> Containers people are really needed
20:20:54 <spotz_> inc0 never got back with his flights
20:20:59 <ildikov> spotz_: did you finally find someone for containers?
20:21:02 <diablo_rojo> jungleboyj, you and smcginnis will be there so that is something :)
20:21:17 <jungleboyj> :-)
20:21:19 <spotz_> ildikov: still need his flights
20:21:24 <ildikov> spotz_: do you want me to go and ask or can you follow up?
20:21:26 <jungleboyj> We will convert people
20:21:31 <smcginnis> :)
20:21:41 <spotz_> either or
20:21:56 <trevormc> we should have one person from AT&T that can work on containers. He's just been busy.
20:22:03 <diablo_rojo> is xing going? She could help cover Manila and Cinder too
20:22:04 <trevormc> s/work/help with
20:22:21 <jungleboyj> diablo_rojo:  She is local.  She could come down.
20:22:23 <diablo_rojo> trevormc, will they be coming to the summit/be available Sunday?
20:22:37 <spotz_> diablo_rojo: She lives there, isn't planning on coming in until Sunday
20:22:41 <jungleboyj> We have vkmc  on Manila though and I got tdasilva for Swift.
20:22:48 <trevormc> diablo_rojo: They should be.
20:22:58 <ildikov> diablo_rojo: vkmc is coming too
20:23:15 <jungleboyj> diablo_rojo:  I mean we needed more people wanting to learn about storage.  :-)
20:23:22 <diablo_rojo> Ah
20:23:23 <ildikov> jungleboyj: +1
20:23:45 <ildikov> let's try not to have that many more mentors in the room than students :)
20:24:01 <jungleboyj> ildikov: Exactly!  ;_0
20:24:04 <jungleboyj> ;-)
20:24:09 <ildikov> :)
20:24:29 <mlavalle> trevormc: 6 interested in Neutron :-)
20:24:43 <trevormc> good not too many!
20:24:43 <diablo_rojo> trevormc, if you can drag them along that would be awesome :)
20:24:45 <ildikov> so we can try to convert the people who didn't say which area they are interested in and a few more for which projects we don't have coverage
20:24:54 <marst> ildikov: I'll be happy to be a student. Especially when Jay is around.
20:25:02 <ildikov> so we might have 10 new storage people by the end of the day :)
20:25:17 <jungleboyj> ildikov:  +2
20:25:37 <ildikov> marst: haha, teach by example, how to be a student :)
20:26:09 <ildikov> trevormc: will that AT&T person be around during the weekend?
20:26:27 <trevormc> ildikov: yeah he should be there at least for Sunday.
20:26:30 <trevormc> as a mentor
20:26:49 <trevormc> i'll confirm with him and get back to you if not.
20:26:57 <ildikov> trevormc: we have Brandon on the wiki with Helm
20:27:36 <ildikov> I don't know whether he's your contact or someone else
20:27:42 <ildikov> but either case it would be great if you can confirm
20:27:48 <spotz_> We could just grab people as they check-in to hotels and ask what projects they're on:)
20:28:01 <diablo_rojo> spotz_, lol
20:28:02 <ildikov> as Saturday is more of a generic part Sunday would be more than enough
20:28:08 <trevormc> ildikov: oh, I wasn't aware brandon was going. Larry should be there for Kolla, thats what was listed in the etherpad when we met in Atlanta.
20:28:13 <ildikov> spotz_: lol :)
20:28:13 <diablo_rojo> ildikov, +1
20:28:43 <ildikov> trevormc: I don't know whether he's coming, he signed up to the team only, not for Boston
20:28:54 <ildikov> trevormc: was just wondering who's your person :)
20:29:42 <trevormc> haha ok. Larry should be attending from what Im aware of there hasn't been any changes
20:29:46 <ildikov> trevormc: let's sync up after the meeting and see who we might have around
20:29:58 <trevormc> ok
20:30:05 <ildikov> trevormc: thanks!
20:31:06 <ildikov> we have a few double booked slots for the presentations
20:31:47 <smcginnis> Tag team?
20:32:03 <ildikov> I haven't seen people around for this meeting, so we will figure out during the week whether we pick someone or those will be slots with two presenters
20:32:07 <jungleboyj> whooomp there it is!
20:32:27 <smcginnis> What's the plan for that? One or two people presenting, the rest of the mentors available in the room to help answer questions?
20:32:41 <ildikov> smcginnis: we have exercises for all blocks
20:32:59 <ildikov> mentors should help with those
20:33:28 <ildikov> and having at least one mentor sitting at each table should also help with synchronizing who's finished and which group needs more time
20:33:37 <smcginnis> Perfect
20:33:43 <ildikov> and also answer questions if any
20:33:54 <ildikov> people were quite active on IRC during the Barcelona training
20:34:03 <ildikov> so a few of us should keep an eye on that too
20:34:11 <kmARC> (hah, bc it was configured on their VM ;-) )
20:34:25 <ildikov> kmARC: and in Boston it will be too :)
20:34:40 <ildikov> kmARC: so the patch is up to move the dev env VM setup after the intros
20:35:03 <ildikov> the floor will be yours, I will not add that to the sign up etherpad to ensure it's all yours ;)
20:36:28 <ildikov> kmARC: so as a summary, thanks again for putting together and updating and optimizing the VM image! :)
20:36:56 <kmARC> No problem, I enjoyed procrastinating on my real job and play with my pet project :-D
20:37:12 <ildikov> does anyone have questions for the exercises or any of the blocks?
20:37:16 <ildikov> kmARC: :)
20:37:56 <spotz_> I need to see where we actually are:)
20:38:08 <ildikov> spotz_: +1
20:38:14 <diablo_rojo> It might be a good idea for everyone to just go through all the slides so we are all familiar with whats there and are prepared to answer questions
20:38:36 <ildikov> #action ALL to check the latest version of the material: https://docs.openstack.org/upstream-training/
20:38:37 <jungleboyj> diablo_rojo:  ++  That is on my agenda
20:39:00 <ildikov> so as diablo_rojo said, plz!!!
20:39:12 <jungleboyj> ildikov:  If we do that we are bound to find issues, should we push up patches with fixes?
20:39:23 <ildikov> ianychoi: BTW, do you know how to update the logo on the training webpage to the new one?
20:39:35 <ildikov> ianychoi: I mean I couldn't find where to do it :)
20:39:57 <ildikov> jungleboyj: yes, push fixes please
20:40:08 <jungleboyj> ildikov:  Ok.  Will do.
20:40:11 <ianychoi> ildikov, which page? https://docs.openstack.org/upstream-training/ ?
20:40:12 <ildikov> jungleboyj: I would say fix only typos and things that are fundamentally wrong
20:40:23 <ildikov> polishing can come after we're done with the training
20:40:28 <jungleboyj> ildikov:  Of course.  Wasn't thinking of any content changes.
20:40:30 <smcginnis> +1
20:40:33 <ildikov> ianychoi: yep
20:40:34 <ianychoi> ildikov, slide logos are updated by you :)
20:40:40 <jungleboyj> Bugs only.  ;-)
20:40:54 <diablo_rojo> ianychoi, she is talking about the webpage I think
20:40:57 <ildikov> ianychoi: I meant the logo on the web page, the left top corner
20:41:04 <diablo_rojo> ianychoi, we already updated the slides :)
20:41:07 <ianychoi> ildikov, I see. openstackdocstheme might need to be updated . I will see it :)
20:41:36 <ildikov> ianychoi: oh, so that's a per project/page thing, I can try my best with it too
20:42:28 <ildikov> jungleboyj: smcginnis: do you want to talk about your deep dive idea fro the mail thread?
20:43:07 <jungleboyj> ildikov: Sure.
20:43:11 <ildikov> s/fro/for/
20:43:25 <ildikov> hmm no, s/fro/from/ :)
20:43:30 <smcginnis> :)
20:43:35 <jungleboyj> We are going to have a broken version of Cinder.
20:43:36 <ildikov> hate Mondays... :)
20:44:16 <jungleboyj> We had the idea of just putting a copy of Cinder up there for people to pull down to avoid having to do patching, but if you think everyone should be comfortable with apply a patch, we can just go that route.
20:44:38 <jungleboyj> This is for the deep dive with some broken code.
20:44:53 <ildikov> I think we can risk that who doesn't know how to do that we or the fellow students can teach them
20:45:03 <ildikov> but that's my two cents
20:45:21 <jungleboyj> ildikov:  Ok, we can go that route to be consistent with others then.
20:45:27 <smcginnis> It does sound like we will have enough help there that if a student has trouble, we should be able to spend time with them to get them going.
20:45:35 <ildikov> on the other hand, if we use the Sandbox repo that code might be way more broken than how you originally broke it
20:45:41 <ianychoi> ildikov, https://review.openstack.org/#/c/406450/ was settled but I need to more investigate whether the new theme was released or not.
20:45:51 <jungleboyj> ildikov:  Sounds like a good challenge.  ;-)
20:45:54 <jungleboyj> smcginnis:  ++
20:46:01 <ildikov> ianychoi: cool, thanks for checking
20:46:18 <ildikov> ianychoi: I just realized that the docs page has the new logo already, but the training page does not
20:46:36 <smcginnis> Must need to point to a new theme name?
20:46:44 <ildikov> smcginnis: yep, and I also think that it can be a good experience for students to help each other out
20:47:04 <smcginnis> +1
20:47:06 <ildikov> can make them more confident with things that are new to them if there are other things they can help each other with
20:47:11 <smcginnis> Teaching always helps with learning.
20:47:22 <ildikov> smcginnis: +1
20:47:28 <jungleboyj> Indeed.  Have learned a lot that way.
20:48:19 <ildikov> :)
20:48:27 <ianychoi> ildikov, aha but no actual documentations yet I got it :)
20:48:49 <ildikov> so it seems we will go with the patches and not the full code
20:49:45 <jungleboyj> ildikov:  Yes, that is fine.
20:50:00 <ildikov> trevormc: mlavalle: are you preparing some code breaking exercises as well?
20:50:08 <ildikov> jungleboyj: cool, tnx
20:50:20 <mlavalle> ildikov: yes
20:50:40 <ildikov> mlavalle: great, tnx
20:51:00 <ildikov> mlavalle: did anything come up that would be beneficial to discuss with the group here?
20:51:26 <ildikov> mlavalle: I mean with the preparation/brainstorming/etc
20:51:44 <mlavalle> ildikov: no, we are good. I am also almost done with my presentation / exercises for the on-boarding room
20:52:19 <ildikov> mlavalle: wow, sounds pretty good!
20:52:34 <ildikov> mlavalle: unintentionally I always have things for the last minute :/
20:52:52 <mlavalle> ildikov: np
20:52:56 <jungleboyj> smcginnis:  And I are working on putting together info that builds upon upstream-institute with Cinder specific details.
20:53:17 <ildikov> jungleboyj: for the on boarding room?
20:53:23 <smcginnis> Yep
20:53:38 <jungleboyj> ildikov: Yep
20:53:40 <ildikov> cool!
20:54:14 <ildikov> you can always re-use what we have for the training with those who didn't attend that
20:54:32 <ildikov> so having things built on top of it is a good idea IMHO
20:54:51 <smcginnis> I think we are going to recap the upstream training, then get into Cinder specific things.
20:55:01 <jungleboyj> ildikov:  What he said
20:55:09 <smcginnis> :)
20:55:18 <ildikov> at least you also have some extra things for advanced students, you can never know who shows up to the training :)
20:55:29 <jungleboyj> ildikov: Right.
20:55:33 <ildikov> smcginnis: sounds pretty good!
20:55:37 <jungleboyj> That was our thought.
20:55:39 <smcginnis> Exactly. I think we will have to just go with the flow and see how the audience turns out.
20:55:48 <smcginnis> 5 minutes
20:56:00 <ildikov> yep, pretty tough to get prepared for everyone
20:56:26 <ildikov> we should encourage the projects to have their on boarding room things available somewhere publicly
20:56:37 <smcginnis> Oh, that's not a bad idea.
20:56:45 <ildikov> so we could pick them up for the training if we need material for areas
20:56:45 <smcginnis> Would be good to link to it off of our project wiki pages.
20:56:52 <jungleboyj> Yeah ...
20:56:54 <smcginnis> Good idea
20:56:56 <ildikov> and vice versa
20:57:13 <ildikov> smcginnis: coolio, I will reach out to the projects then :)
20:57:28 <ildikov> smcginnis: jungleboyj: I guess I can count on you for Cinder :)
20:57:42 <ildikov> so we have 3 more minutes
20:57:43 <jungleboyj> ildikov:  We got you covered
20:58:05 <ildikov> is there anything I forgot, or any questions or comments from anyone to discuss?
20:59:08 <smcginnis> Probably. :)
20:59:22 <ildikov> smcginnis: thanks, that helps :)
20:59:34 <jungleboyj> smcginnis:  That wasn't very nice.
20:59:41 <ildikov> then see everyone in Boston soon!
20:59:48 <smcginnis> I meant it in the nicest way! :]
20:59:55 <ildikov> keep on checking your mailboxes and hang out on the team channel!
20:59:58 <jungleboyj> :-)  Looking forward to it!
21:00:09 <ianychoi> See all you at Boston!
21:00:14 <ildikov> safe travels everyone!!!
21:00:17 <ildikov> #endmeeting