14:01:20 <gothicmindfood> #startmeeting openstack-swg
14:01:21 <openstack> Meeting started Thu Jan 19 14:01:20 2017 UTC and is due to finish in 60 minutes.  The chair is gothicmindfood. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:25 <openstack> The meeting name has been set to 'openstack_swg'
14:01:37 <johnthetubaguy> o/
14:01:42 <gothicmindfood> I am in the noisiest coffeshop ever
14:01:53 * gothicmindfood is thankful for IRC meetings
14:02:13 <gothicmindfood> shall we cover our action items for last week?
14:02:17 <gothicmindfood> err - two weeks ago?
14:02:35 <gothicmindfood> #topic review/recap action items
14:02:40 * johnthetubaguy hates video conferencing with noise cancelling headphones, it doesn't work
14:02:54 <gothicmindfood> #link http://eavesdrop.openstack.org/meetings/openstack_swg/2016/openstack_swg.2016-11-08-15.04.html
14:03:00 <gothicmindfood> for those who want a quick link to see those
14:03:31 <gothicmindfood> oh no, that's a super old one
14:03:40 <fungi> you might want this year
14:03:55 <fungi> but history is fun too ;)
14:03:58 <gothicmindfood> #link http://eavesdrop.openstack.org/meetings/openstack_swg/2017/openstack_swg.2017-01-05-14.01.html
14:04:21 <gothicmindfood> I guess I need an action to close all of my action/meeting summary tabs from 2016 :)
14:04:52 <gothicmindfood> so the first two were mine
14:05:13 <gothicmindfood> finalizing logistics has been interesting, so a couple notes there:
14:05:16 <johnthetubaguy> so I have failed to attend the TC due to a combination of illness, and rehearsals, and it being a 9pm meeting :( but sent out things on email
14:05:47 <gothicmindfood> 1) the Foundation has agreed to fund the April 10 training costs, so attendees will only need to cover their own travel (like last year)
14:06:02 <EmilienM> can we book flights and hotel?
14:06:30 <gothicmindfood> EmilienM: I'd wait just a second - I'm going to say mid-February for booking if that's okay?
14:06:39 <EmilienM> it is
14:06:44 <gothicmindfood> EmilienM: awesome :)
14:07:21 <gothicmindfood> the next steps for leadership training are for me to confirm a list of attendees, finalize the specific dates the week of April 10th with those people, and then open up the remaining seats to the community
14:07:34 <gothicmindfood> that will all likely happen in February.
14:07:48 <gothicmindfood> so 2) is that the Foundation is interested in funding a day long visioning session
14:08:10 <gothicmindfood> however, ttx and I have been discussing how crazy-over-scheduled folks will be at the PTG
14:08:25 <gothicmindfood> and we are loathe to exclude people just because they're leading sessions they need to lead
14:08:54 <gothicmindfood> my understanding is there's a potential for a TC & Board get together after the PTG
14:08:56 * fungi wonders if it should be tacked onto the two-day tc/board powwow
14:08:59 <fungi> yeah, that
14:09:01 <gothicmindfood> yeah
14:09:01 <johnthetubaguy> so the joint board/tc meeting that coming up, could we fund an extra day there?
14:09:04 <johnthetubaguy> yeah
14:09:04 <ttx> I fear we'll have facilitation in a room with 4 people
14:09:35 <ttx> +1 to tacking to something already existing
14:09:44 <ttx> becase the next months are madness
14:09:46 <ttx> +u
14:09:51 <EmilienM> yes +1 too, too much travels otherwise
14:09:58 <johnthetubaguy> now I can't see me getting budge to attend that meeting, but thats a different battle
14:10:25 <gothicmindfood> so we're looking into adding a day to that, but I haven't heard about dates confirmed so we're a little on hold there until we do
14:10:39 <EmilienM> backup plan: videoconference?
14:10:52 <gothicmindfood> johnthetubaguy: is it possible that getting funding gets easier if you say the TC is going to plan the vision of what OpenStack will be there?
14:11:02 <gothicmindfood> but also EmilienM is right - videoconference would be great.
14:11:04 <ttx> Last time I looked Boston the week of March 6th still led
14:11:18 <gothicmindfood> also, it's important to keep in mind we'll likely come out with a draft that will be edited a LOT before Boston
14:11:39 <ttx> -1 to using location names to describe events thanks to Boston overloading
14:11:47 <johnthetubaguy> gothicmindfood: unsure, sadly
14:11:58 <gothicmindfood> ttx: hahaha. Yes. I will refrain from that in the future now
14:12:21 <ttx> Event Codename: The Kraken
14:12:22 <gothicmindfood> johnthetubaguy: okay. we'll do everything we can to be inclusive if you can't make it.
14:12:52 <johnthetubaguy> did we want to try something like two weeks after the PTG on videoconference?
14:12:56 <EmilienM> gothicmindfood: if we pick VideoConference, I can offer Bluejeans (with my Red Hat account) - it scales very well, and features are awesome; just fyi.
14:13:39 <gothicmindfood> You know - I'm going to go ask the ZingTrain folks about whether they've ever done it via videoconference.
14:13:40 <fungi> or if we pick conference call, we already have pbx.openstack.org for sip and dial-in
14:13:51 <gothicmindfood> I personally have never done an 8 hour videoconference
14:13:56 <gothicmindfood> and it sounds kind of terrible
14:14:00 <ttx> it probably is
14:14:16 <gothicmindfood> but I will ask them to see how they've accomodated such things in the past to investigate that option
14:14:18 <fungi> i have done 8+hour conference calls, and i can say that's plenty terrible
14:14:59 <gothicmindfood> #action gothicmindfood to find out about remote options for vision facilitation
14:15:05 <EmilienM> like I said, it's a backup plan, we need to consider not everyone wants/can travel (budget or family reasons)
14:15:29 <johnthetubaguy> fungi: honestly, where possible, faces makes a big difference
14:16:01 <johnthetubaguy> yeah, 8 hour conference calls suck, I would say at a minimum, two 4 hour stints would be better
14:16:05 * EmilienM would make the trip FWIW
14:16:16 <johnthetubaguy> also, no groups of folks joining together from a room
14:16:49 <gothicmindfood> I'm not sure how structured the facilitation is around actually being in a room, though, so I just need to check on whether that's even a thing that's possible
14:16:55 <fungi> proper telepresence facilities that bridge two remote conference rooms aren't that bad. i've had good experiences there but it's very expensive
14:17:12 <gothicmindfood> one plus is that if I'm there, I can act on behalf of anyone who's remote as my only job, since I don't really have a ton of opinions on the content of the vision
14:17:34 <johnthetubaguy> fungi: yeah, that can work
14:17:37 <EmilienM> fungi: Red Hat has bluejeans accounts for employees, we could use it, in case.
14:18:12 <gothicmindfood> ok - it sounds like we're all in favor of this *not* being at the PTG and trying to find another time
14:18:25 <gothicmindfood> we'll continue to look into remote options for either part of the group or all of it.
14:18:32 * fungi finds brady-bunch-style videoconferencing just as bad as voice-only, but maybe that's just me
14:18:42 <gothicmindfood> my next action item was to look up some visions and get links for folks. I only could find two, but I'm still searching
14:18:46 <ttx> Well I think that's athing we can have /out/ of the PTG week and at this stage I think everythingf that can happen elsewhere should
14:18:46 <EmilienM> it sounds like next time we should organize a 2 weeks event :-) PTG + the rest
14:18:50 <johnthetubaguy> it was the all remote option that seemed interesting to me, the half and half never really works for me
14:19:26 <gothicmindfood> part of the problem is that a lot of companies keep detailed visions as proprietary and don't want to publish them
14:19:35 <gothicmindfood> so a lot of "vision statements" read more like "mission statements"
14:19:47 <gothicmindfood> #link https://etherpad.openstack.org/p/AtlantaPTG-SWG-TCVision
14:19:48 <jroll> fungi: some of our non-native-english contributors have told me they prefer video because body language and such helps get the right meaning of their words across
14:20:05 <gothicmindfood> I put some of the vision links I did find at the bottom of that etherpad ^^
14:20:24 <gothicmindfood> I'll keep adding as I get more to share
14:20:24 <EmilienM> jroll: that's true
14:20:29 <ttx> yes, I would be useless through videconf
14:20:52 <ttx> you need to se my hands to understand wth I'm trying to say
14:21:15 <gothicmindfood> ttx: just hold them up high and be more dramatic!
14:21:16 <gothicmindfood> :)
14:21:19 <fungi> jroll: interesting point. i'd never heard that, but i can see it being the case
14:21:21 <ttx> for 8 hours ?
14:21:32 <gothicmindfood> ttx: you'll have to train for leading up to that long, I'm sure.
14:21:56 <fungi> jazzercise to the rescue
14:21:57 <alexismonville> remote and visioning seems really hard :)
14:21:58 <johnthetubaguy> jroll: honestly I find the same thing, even as a native speaker, but not as extreme I guess
14:22:22 <gothicmindfood> ttx: I'm assuming bringing up vision facilitation at open discussion at the TC meeting happened?
14:22:28 * gothicmindfood hasn't trolled logs this week yet
14:23:00 <fungi> as someone who maintains nearly all his personal relationships and conversations through text media, i'm mostly blind to intonation and facial expressions/body language
14:23:10 <ttx> gothicmindfood: johnthetubaguy mentioned it in a thread instead
14:23:26 <gothicmindfood> ah cool.
14:23:55 <ttx> fungi: you use more subtle signals like absence or presence of final punctuation.
14:24:05 <fungi> so true
14:24:11 <fungi> this thread?
14:24:15 <fungi> #link http://lists.openstack.org/pipermail/openstack-tc/2017-January/001316.html
14:24:36 <ttx> "thread" might be an overstatement but yes
14:24:44 <jroll> gothicmindfood: nice links, those are the ones we went over in training, yeah?
14:24:53 <gothicmindfood> jroll: yup
14:24:54 <fungi> and the dev message linked from it i guess...
14:24:58 <fungi> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/109575.html
14:25:14 <gothicmindfood> thanks for those fungi :)
14:25:36 <fungi> np
14:25:46 <gothicmindfood> awesome. So that's our action items
14:27:34 <gothicmindfood> I wanted to talk a bit about the Pike Summit in Boston and what our plans might be for there, esp. since the CFP is closing soon-ish
14:27:42 <gothicmindfood> does anyone else have any topics they need to cover before that?
14:28:27 <ttx> no
14:28:49 <gothicmindfood> #topic Pike (Boston) Summit plans for SWG
14:29:23 <gothicmindfood> okay - so, we should also write a vision for this, but first I wanted to get feedback on what we might want to get done there before I start drafting my (80 bajillionth) vision
14:30:11 <gothicmindfood> which reminds me - since we're also no longer doing a vision draft at the PTG, we probably want to rethink our session at the PTG. but we can talk about that in a sec
14:30:30 <gothicmindfood> does it still seem realistic that we could have a draft to the community of the TC Vision by the time May rolls around?
14:30:48 * jroll is unsure if he'll even be at the forum
14:30:48 <gothicmindfood> if we wait to facilitate until March, that still gives us a couple of months
14:31:05 * johnthetubaguy has similar worries to jroll
14:31:13 <gothicmindfood> jroll: yeah, I think one of the first things we should assume is that not a ton of people will be there
14:31:19 <gothicmindfood> from the -dev world anyhow
14:32:05 <gothicmindfood> but we will have produced this vision, and does the (theoretical) list of people who *will* be there matter in terms of presenting that vision?
14:32:33 <jroll> probably? hopefully?
14:32:43 <jroll> guess it depends who shows up :)
14:32:45 <gothicmindfood> I'm definitely on the hopefully side :)
14:33:04 * alexismonville will probably be able to join this time as he lives in boston :p
14:33:15 <jroll> and, well, do users/ops care about the TC vision, or just the overall openstack vision?
14:33:27 <gothicmindfood> I think they'll care about it
14:34:04 <johnthetubaguy> depends whats in it, planing to create an openstack vision might be the main news that interests them, maybe?
14:34:27 <gothicmindfood> I guess this deadline thing re: CFP could focus us in on things - do we think presenting something in the context of the panel makes sense, or is this better as a team presentation/slide talk?
14:35:34 <gothicmindfood> I'm happy to write the most vague things in the submission because frankly I think we won't know exactly how best to present the content until we have it
14:35:42 <jroll> I think a talk could be interesting - present the vision and what it might mean for the next <timespan>
14:35:51 <gothicmindfood> but I'm still unsure about whether panels or presentations are best here.
14:36:01 <fungi> yeah, my employer isn't going to let me skip the summit/forum without a really good reason, so i expect to be there if help is needed
14:36:07 <gothicmindfood> jroll: dyou think a talk would give enough room for lots of feedback from the audience?
14:36:23 <gothicmindfood> or whether we need that?
14:36:31 <jroll> start with a big grand "imagine you're at the T forum, in <imaginary location>, and blah blah "
14:36:37 <gothicmindfood> hahaha
14:36:43 <gothicmindfood> yeah, there is a storytelling element to it
14:36:47 <jroll> gothicmindfood: you could leave room for a long Q&A
14:36:55 <fungi> write the presentation in vision tense
14:36:55 <jroll> and specifically ask for feedback as well
14:36:57 <fungi> heh
14:36:59 <gothicmindfood> okay. So maybe a talk, but a half-time one so there's plenty of Q&A
14:37:00 <jroll> questions/comments and answer
14:37:12 <gothicmindfood> cool.
14:37:13 * jroll thinks we need morgan freeman's voice doing this talk
14:37:15 <gothicmindfood> alright
14:37:16 <gothicmindfood> hahaha
14:37:36 <gothicmindfood> so, while I am also uncertain about funding to go to Boston, I'll go ahead and submit this
14:37:55 <fungi> we could probably get patrick warburton. he's always eager for work ;)
14:37:56 <gothicmindfood> if for some reason I can't go, it's totally okay to pass it off to whoever on the TC or SWG can I think
14:38:10 <jroll> so I guess the half-time talk thing is kind of a cross between a talk and a panel, 20 minutes of each
14:38:14 <jroll> which could be fun
14:39:00 <gothicmindfood> #action gothicmindfood to write Pike Summit submission for a presentation on the TC's vision
14:39:08 * fungi loves panel format anyway
14:39:14 <gothicmindfood> I love panels too
14:39:24 <gothicmindfood> we can always turn it into one
14:39:35 <jroll> indeed
14:40:34 <gothicmindfood> anything else with an SWG-theme we could do at the pike summit, besides presenting the vision?
14:41:40 * gothicmindfood is so focused on PTG stuff it's hard to think about what Pike will be like
14:41:56 <persia> Better.
14:41:56 <fungi> there was some discussion of mini-leadership-training tips/tricks for community leaders, though that maybe shoud wait until more of us are on the same page about that kind of stuff i guess
14:42:18 <gothicmindfood> fungi: yeah, I'd love some more workshop-focused stuff that we could sponsor
14:42:55 <fungi> pike forum seems soon, queens forum maybe
14:43:04 <gothicmindfood> fungi: ++
14:43:21 <gothicmindfood> okay - so I think we're settled with the pike stuff we need at the moment
14:43:34 <gothicmindfood> #topic PTG vision revisit
14:43:50 <gothicmindfood> #link https://etherpad.openstack.org/p/AtlantaPTG-SWG
14:44:29 <gothicmindfood> so we have this vision written and some of it can still apply, though we should probably get more specific
14:45:19 * gothicmindfood is going to update so that it's clear we're not going to do vision facilitation at the PTG now
14:46:01 <johnthetubaguy> so if we don't the vision facilitation, what do we want to do instead?
14:46:42 <gothicmindfood> well, my initial plan before there was interest in doing the full vision there, was to have sessions introducing some of the concepts from leadership training
14:47:21 <gothicmindfood> which include stuff about visioning, stuff about principles/culture, servant leadership, and potentially change management
14:48:12 <gothicmindfood> that's just a list off the top of my head though - anyone have any other ideas?
14:49:03 <gothicmindfood> the idea for smaller sessions per concept came from the interest that was at our cross project session at the ocata summit
14:49:14 <gothicmindfood> a lot of people were really curious about what servant leadership was, for example
14:50:16 <johnthetubaguy> do we know if they will be there for that day at the PTG?
14:50:21 <johnthetubaguy> and in the SWG room
14:51:03 <gothicmindfood> johnthetubaguy: it's unclear to me who will be at the SWG sessions, but if we take Monday, I imagine we're risking some of the folks who are arriving later not being able to attend
14:51:33 <gothicmindfood> ttx: Monday is infra/release and which other cross-project days?
14:51:51 <ttx> gothicmindfood: see https://wiki.openstack.org/wiki/PTG/Pike/Etherpads
14:52:50 <gothicmindfood> oh wow. That's a lot of people.
14:53:02 <ttx> it's always a lot of people
14:53:32 <ttx> We could try to place our day on the Friday, but it's a bit late to try to change
14:53:35 <gothicmindfood> ttx: truer words have never been spoken
14:54:02 <ttx> I probably won't be able to attend the whole day in the SWG room tbh
14:54:06 <gothicmindfood> well - I'm comfortable staying with Monday, but I think the question is what can we do that's useful that day for the portion of the community that might be able to attend
14:54:17 <ttx> especially if I end up having to retake RelMgt PTLship
14:54:19 <jroll> yeah, I'll likely be bouncing around as well
14:54:38 <gothicmindfood> that's why I was thinking of breaking up the time into smaller themes
14:54:43 <ttx> we could say "only in the morning" and try to get more people at the same time
14:55:15 <ttx> we could say afternoon is open door complaints day
14:55:30 <ttx> like have a governance issue you would like solved, come complain to COlette
14:55:34 <gothicmindfood> haha. "therapy hour, hosted by gothicmindfood"
14:56:04 <ttx> you'll need some speaker to play relaxing music
14:56:16 <gothicmindfood> I think I need to do some reaching out to folks to see what they might like to see
14:56:36 <persia> If the morning "more people at the same shorter time" period was also used for organisation, if people have compatible schedules, some folk could start some subtasks for the ML later in the week.
14:56:39 <gothicmindfood> can I ask everyone to have a think about this and brainstorm in the etherpad with the vision - even if it's just sentence fragments/ideas?
14:57:04 <ttx> personally I'd like us to make /some/ progress on one of the initiatives. A bi-weekly meeting doesn't trigger that much momentum forward
14:57:19 <ttx> so if we need F2F to make progress, let's try to make some at the PTG
14:57:20 <gothicmindfood> I will too, and I'll also start maybe a -dev list ask of folks to see what they might be interested in
14:57:33 <gothicmindfood> ttx: agreed
14:57:38 <johnthetubaguy> ttx: +1 thats my preference, decide what to move forward
14:57:51 <gothicmindfood> ok - so a planning session for the next months with the SWG
14:58:00 <ttx> I would do a couple of hours brainstorm on the TC vision
14:58:06 <johnthetubaguy> well, and progress, resolve things in person
14:58:34 <gothicmindfood> okay - these are all great ideas! I will get to the etherpad and the mailing list to discuss in the next week
14:58:35 <ttx> currently it's going a bit in every direction so we are stalled
14:58:49 <ttx> with limited ideas on how to make progress
14:59:22 <gothicmindfood> oh a quick FYI and link, btw, superuser wrote up the SWG:
14:59:27 <gothicmindfood> #link http://superuser.openstack.org/articles/openstack-stewardship-working-group/
14:59:35 <ttx> that said it's the type of exercise that works best in distraction-free setting, and with so many things running at the same time on Monday we will be distracted
14:59:52 <johnthetubaguy> well, no progress now the facilitating doesn't have a date, I was assuming we pause for the facilitation really
15:00:01 <gothicmindfood> johnthetubaguy: for the vision, yes
15:00:08 <gothicmindfood> but there are other things we can start to get to work on
15:00:15 <gothicmindfood> okay - we're at time
15:00:23 <gothicmindfood> let's take this to #openstack-swg
15:00:31 <gothicmindfood> #endmeeting