20:00:36 <harlowja> #startmeeting openstack-state-management
20:00:37 <openstack> Meeting started Thu Mar 13 20:00:36 2014 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:40 <openstack> The meeting name has been set to 'openstack_state_management'
20:00:46 <iv_m> hi there
20:00:56 <harlowja> hey
20:00:56 <harlowja> https://wiki.openstack.org/wiki/Meetings/StateManagement
20:01:14 <harlowja> don't think much of an agenda, just people coding and reviewing, nothing to urgent to talk about i think
20:01:22 <harlowja> so maybe can just keep it short
20:01:24 <changbl> hey
20:01:30 <harlowja> changbl hey
20:01:34 <harlowja> for the exception stufss
20:01:57 <harlowja> maybe thats a good small topic
20:02:13 <harlowja> https://review.openstack.org/#/c/80372/
20:02:43 <changbl> i checked nova's exceptions
20:02:43 <harlowja> changbl is the part about why throw various exceptions over other exceptions the problem?
20:02:53 <harlowja> k
20:03:26 <changbl> their exceptions are groups under prefix, for example, exception InvalidInput is subclass of exception Invalid
20:03:37 <changbl> making it easier to code write/read
20:04:12 <harlowja> sure, seems like we could do a little bit of adjustment as well if we want
20:04:23 <changbl> yes, that would make it easier
20:04:43 <harlowja> maybe the following groups
20:04:49 <harlowja> 1. storage
20:04:51 <harlowja> 2. jobs
20:05:13 <harlowja> 3. InvariantViolation (for any kind of generic invariant being violated)
20:05:51 <harlowja> some of the other ones like NotFound or AlreadyExists seem ok to be seperate
20:06:06 <harlowja> possibly ConnectionFailure also
20:06:40 <changbl> sounds good
20:07:06 <harlowja> CorrelatedFailure is think is just to connect a exception to another exception, WrappedFailure is similar (wrapping many failures)
20:07:22 <harlowja> anyway changbl  do u want to try that restructuring?
20:07:46 <harlowja> hopefully this doesn't break to many peoples :-/
20:07:50 <changbl> harlowja, maybe you do it and i will review?
20:08:10 <harlowja> ok
20:08:18 <changbl> as long as we don't change too many names:)
20:08:23 <harlowja> sure
20:08:30 <harlowja> will try not to :)
20:09:09 <changbl> sounds good. let's move on
20:09:18 <harlowja> k
20:09:55 <harlowja> #topic 0.2 reviews
20:10:02 <harlowja> this isn't to much of a topic
20:10:08 <harlowja> most of the reviews are just being reviewed :-P
20:10:25 <harlowja> https://review.openstack.org/#/q/status:open+project:openstack/taskflow,n,z
20:10:31 <harlowja> so lets just keep on reviewing :)
20:11:05 <harlowja> #topic cinder/glance requirements gathering
20:11:18 <harlowja> so this is going slowly afaik, but going nonetheless
20:11:20 <harlowja> #link https://etherpad.openstack.org/p/taskflow-cinder
20:11:29 <harlowja> i also started #link https://etherpad.openstack.org/p/taskflow-glance
20:11:40 <harlowja> hopefully can meet up with the glance folks on IRC soon
20:12:13 <changbl> harlowja, schedule a meeting with them sometime?
20:12:20 <harlowja> yup, working on it :)
20:12:23 <changbl> +1
20:12:37 <harlowja> minimeeting WIP :)
20:13:00 <harlowja> anyways, so keep on doing that
20:13:24 <harlowja> *so will keep on working on that
20:13:48 <harlowja> thats about all the topics i had, anyone have any need for new use-cases
20:13:53 <harlowja> or anything to open-discuss
20:13:57 <harlowja> if not, quick meeting :)
20:14:56 <harlowja> goinng once
20:15:44 <harlowja> twice
20:15:46 <tinoue> hi
20:15:51 <harlowja> hi there
20:16:07 <tinoue> i have a question
20:16:10 <harlowja> tinoue sure
20:16:19 <tinoue> Do you have a task-management session in Atlanta?
20:16:37 <harlowja> tinoue speaker session or design session?
20:16:45 <harlowja> *different types of sessions
20:16:50 <tinoue> design session!
20:17:17 <harlowja> i haven't put any up yet, but i think we should
20:17:22 <harlowja> seems like http://summit.openstack.org/ is open
20:17:29 <harlowja> so good idea tinoue lets do that
20:17:44 <harlowja> i did like 3 or 4 last time, more are welcome
20:17:54 <harlowja> especially if others want to do them ;)
20:18:03 <tinoue> ok
20:18:36 <harlowja> so maybe we can all start thinking about good design sessions ideas
20:18:38 <harlowja> +2 to that :)
20:18:55 <harlowja> tinoue thx for reminding
20:19:19 <tinoue> :)
20:20:06 <harlowja> #action harlowja changbl iv_m + others think of design session ideas
20:21:05 <harlowja> cool, anything else to discuss?
20:21:23 <changbl> do we need to propose/register design sessions?
20:23:35 <harlowja> changbl i think its just a launchpad id
20:23:46 <harlowja> which i think u already have
20:23:55 <harlowja> i don't remember it being any other special registration
20:24:31 <changbl> harlowja, ok
20:24:41 <harlowja> sweet
20:24:54 <harlowja> we can also put the ideas on an etherpad before summit to that page if we want
20:26:34 <harlowja> either works, u can revise the submissions to summit.openstack.org afterwards afaik
20:29:02 <harlowja> k
20:29:04 <harlowja> lets see
20:29:11 <harlowja> anything else for folks :)
20:30:16 <harlowja> going once
20:31:49 <harlowja> going twice
20:34:04 <harlowja> going thrice
20:34:24 <harlowja> ok dokie, thx for coming folks
20:34:30 <harlowja> #endmeeting