20:00:09 <harlowja> #startmeeting openstack-state-management
20:00:10 <openstack> Meeting started Thu Feb 27 20:00:09 2014 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:13 <openstack> The meeting name has been set to 'openstack_state_management'
20:00:22 <harlowja> hi folks, anyone interested in meeting today :)
20:00:33 <harlowja> agenda @ http://tinyurl.com/a52eyhe
20:01:03 <iv_m> hi there
20:01:14 <harlowja> hi hi
20:02:20 <changbl> hello
20:02:24 <harlowja> hi changbl
20:02:29 <iv_m> hi changbl
20:03:09 <harlowja> how's it going folks
20:03:38 <iv_m> it goes, which means it's not bad
20:03:51 <changbl> not bad, filed a travel request to go to atlanta openstack summit
20:04:02 <harlowja> changbl cool
20:04:28 <harlowja> i beleive anastaisa is skiing so, she'll i guess miss out on the fun
20:04:58 <iv_m> ya, she's on vacations until monday
20:05:05 <harlowja> k
20:05:18 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting
20:05:25 <harlowja> sooo lets see here, likely can be a quick one :)
20:05:48 <harlowja> #topic last-action-items
20:05:55 <harlowja> i don't there were any right?
20:06:06 <harlowja> i had a good vacation :-P
20:06:10 <harlowja> skiing also, lol
20:06:47 <iv_m> #nick akarpinska
20:07:02 <iv_m> #action akarpinska have good vacation and get back l)
20:07:11 <harlowja> +1
20:07:15 <harlowja> no vote needed, ha
20:07:26 <harlowja> #topic 0.2
20:07:54 <harlowja> so for this one, zookeeper stuff went in, so that means newness, worker stuff went in (i've been messing around with it)
20:08:12 <harlowja> and i think once anastaisia gets back the retry/redo/ controlling stuff will go in
20:08:18 <harlowja> https://etherpad.openstack.org/p/TaskFlow-0.2.0
20:08:21 <harlowja> #link https://etherpad.openstack.org/p/TaskFlow-0.2.0
20:08:44 <harlowja> i am thinking we could do a ML post for each one of these features, explaning it, summarizing it, showing example
20:08:47 <harlowja> what do u guys think
20:08:59 <harlowja> i beleive they are cool enough to each have its own neat post
20:09:10 <changbl> sounds good
20:09:13 <iv_m> +1
20:09:38 <harlowja> might as well inform everyone of the awesomeness, lol
20:10:30 <harlowja> what else, i think there are a few fixes/adjustments that are going through the pipeline right now
20:11:04 <harlowja> iv_m do u think stanislav will have the ability to have the engine inquire what the workers have for 'capabilities' for 0.2, or maybe later?
20:11:17 <harlowja> thats the only pain that i saw right now
20:12:15 <iv_m> that depends on what design decisions we finally come to
20:12:18 <harlowja> k
20:12:25 <iv_m> he already have some simple code that works
20:12:28 <iv_m> *has
20:12:28 <harlowja> i guess post 0.2 then?
20:12:44 <harlowja> 0.2.1 or something
20:13:57 <harlowja> lets do that i think, doesn't seem like its critical for 0.2
20:14:27 <iv_m> yes, it does not look critical
20:14:44 <harlowja> changbl i can give u a simple MQ example if u want to try it, sorta neat
20:15:16 <iv_m> let's see if we can finish that in time for 0.2.0, but if we will not that's ok
20:15:23 <harlowja> http://paste.openstack.org/show/70354/ was one that i was messing around with :)
20:15:25 <changbl> harlowja, MQ example?
20:15:35 <harlowja> *sorry worker example (which uses a MQ)
20:16:09 <harlowja> if u want to try it out
20:16:57 <changbl> i am fine. why don't you put it under examples?
20:17:03 <changbl> examples/
20:17:04 <harlowja> changbl will likely do that :)
20:17:05 <iv_m> we also have pretty nice examples in master
20:17:07 <iv_m> https://github.com/openstack/taskflow/tree/master/taskflow/examples/worker_based
20:17:19 <harlowja> yup, some other ones
20:17:41 <harlowja> iv_m i can startup a little ML post about the worker stuff, maybe all of us can adjust it and then can finally send it
20:17:45 <iv_m> they can use mq with proper cmdline arguments
20:18:02 <iv_m> harlowja, sounds good
20:18:06 <harlowja> cool
20:18:20 <harlowja> #action harlowja draft ML post for workers and jobboard
20:19:04 <harlowja> k, lets see, guess we'll aim for 0.2 in a short while
20:19:16 <harlowja> after anastasia gets back, get that stuff in, then decide
20:19:33 <harlowja> alright , next hoepfully quick topic
20:19:40 <harlowja> #topic oslo-meetings
20:19:56 <harlowja> so i'm gonna try to attend the oslo IRC meeting tommorow, see how that goes
20:20:10 <harlowja> i am still wondering (i think we talked about it before) about if we should just join that meeting
20:20:26 <harlowja> #link https://wiki.openstack.org/wiki/Meetings#Oslo_Team_meeting
20:20:37 <harlowja> chair is dhellmann  not mark
20:20:38 <iv_m> it's a pitty that i can't attend oslo meetings
20:20:55 <harlowja> ya, 1400 utc will be tough for me also :-P
20:21:26 <harlowja> will see if i can remember to wakeup, lol
20:22:02 <harlowja> i'll report back, maybe just useful to collapse these 2 meetings since our meeting doesn't usually last to long
20:22:47 <harlowja> our updates haven't been to big, i think oslo irc is more of like a on-demand meeting anyway
20:22:49 <harlowja> anyways, lets see
20:23:39 <harlowja> #action harlowja report back on oslo!
20:23:54 <harlowja> #topic 0.3
20:23:59 <harlowja> so this one is an interesting one
20:24:14 <harlowja> it seems like we are realitevly stabilizing
20:24:30 <harlowja> but i could see the lock management feature being useful in 0.3
20:24:42 <harlowja> if we want to do that of course
20:24:55 <harlowja> or instead of 0.3 we can just all spend lots of time integrating
20:25:04 <harlowja> and evangelizing...
20:25:31 <harlowja> what do u guys think?
20:26:40 <changbl> can you say more on the lock management feature?
20:27:29 <harlowja> sure, so i think in a simple explanation, cinder, especially has resources that they don't want to be simulatenously worked on by workflows
20:27:58 <harlowja> so an idea i had was to allow for someway to specify that a task/flow acquires and releases locks on given resources before executing
20:28:11 <harlowja> which then creates a need for some type of lock management system
20:28:28 <harlowja> now idk if https://review.openstack.org/#/c/71167/ is the right way to go, but it could be
20:29:10 <iv_m> as for 0.3, i think we can have 0.2.x releases as new features come in, until we'll need to do a really big breaking change -- and i'm not currently seeing any big breaking changes coming after Anastasia's work gets in
20:30:09 <changbl> cinder right now use file as lock, so if cinder want to use taskflow's lock manager, will that change a lot of cinder's code?
20:31:21 <harlowja> changbl i am hoping it doesn't change alot, i would expect our lock manager to also be compatible with file locks if we see this is the way to achieve compatiblity until something better (zookeeper locks) can be used
20:32:10 <harlowja> iv_m the only change that could cause issues is if we want to rename taskdetails to atomdetails, or do more restructuring around that code
20:32:13 <changbl> i hope it won't change too much of existing openstack code
20:32:56 <changbl> btw, how is the integration process with cinder, nova, etc? i feel taskflow is being more and more mature, but the integration process is slow
20:33:14 <harlowja> yup, integration is always slow
20:33:58 <harlowja> i think it could require more people to help integration, of course, i'll do it also when i can, it just requires lots of slow work :)
20:34:03 <harlowja> and stamina, lol
20:34:20 <harlowja> and communication....
20:34:37 <changbl> harlowja, let me know if you need help on integration work, i can help a bit
20:34:47 <harlowja> sure, where do u want to tackle changbl  ;)
20:35:00 <changbl> impl
20:35:11 <changbl> cinder? or nova ?
20:35:15 <harlowja> i think there was some nova work, but it appears to have stalled (not enough time from nova folks to review it, or look at it)
20:35:44 <harlowja> changbl cinder is a good idea
20:35:57 <harlowja> changbl i think when anastaisia gets back we can all get an update from her on current status of that
20:36:05 <harlowja> and can maybe all jump-in there
20:36:13 <changbl> harlowja, ok
20:36:31 <harlowja> cool, lets do that
20:36:48 <harlowja> iv_m sound reasonable? do u know if alex is still fighting the nova fight?
20:37:32 <iv_m> at least he's not planning to give up
20:37:59 <harlowja> changbl lets get a dump from alex on how thats going i guess also
20:38:07 <changbl> harlowja, one thing is that demand always drives supply, so while the integration goes on, we can have more feedback and ideas on how to improve taskflow, instead of developing it alone separately on our own.
20:38:07 <harlowja> seems good to figure out how its all going from everyone
20:38:18 <harlowja> changbl agreed, i think we are at a good state for that
20:38:42 <changbl> harlowja, ok
20:38:57 <harlowja> iv_m cool, lets get everyone together outside meeting and see if we can have a mini-meeting about the current integration, what/how/where/help needed... and see how we can all help out
20:39:12 <harlowja> and then fix all the things :-P
20:40:16 <harlowja> changbl i think the cinder folks are this week having a hangout session as there mid-cycle meetup, i dropped in, should probably drop in again
20:40:43 <harlowja> jgriffith the hangout is still happening right?
20:40:52 <changbl> harlowja, hope we can get more feedback from them.
20:41:04 <harlowja> sure, they were deep into driver stuff when i joined :-P
20:41:08 <jgriffith> harlowja: yesterday was last day IIRC
20:41:13 <harlowja> oh noes, lol
20:41:14 <harlowja> crap
20:41:20 <jgriffith> 24-26
20:41:25 <harlowja> kk, np
20:41:34 <jgriffith> or else I"m just MIA :)
20:41:42 <harlowja> ;)
20:42:19 <harlowja> jgriffith anyways, just to catch u up, think we are going to regroup a little, figure out cinder work + taskflow, seem how we can all help here, and get in touch with u guys :)
20:42:40 <harlowja> i think thingee will be in sunnyvale y! next week so can chat with him to
20:42:53 * harlowja we are hosting tripleo/ironic meetup
20:42:56 <jgriffith> harlowja: sounds good
20:42:57 <harlowja> we == y!
20:43:23 <harlowja> cool beans, thx jgriffith
20:43:32 <jgriffith> harlowja: my pleasure ;)
20:43:59 <harlowja> k, lets see if anything else left to open-dicuss about
20:44:03 <harlowja> #topic open-discuss
20:44:12 <harlowja> if not can end short
20:44:35 <iv_m> i have couple of new blueprints i want to mention
20:44:38 <harlowja> changbl thx for bringing focus back on integration, needs to happen more than it is :)
20:44:43 <harlowja> iv_m cool, whats up
20:45:21 <changbl> harlowja, np
20:45:46 <iv_m> #link https://blueprints.launchpad.net/taskflow/+spec/persistence-uris is the first one, just a small neat feature
20:47:12 <harlowja> ah, iv_m seems like a nice helper to allow that
20:47:31 <harlowja> the conf thing can be a pain to have to make dicts :-P
20:48:08 <iv_m> if u agree it worth having please approve and i'll implement that real quick ;)
20:48:14 <harlowja> k
20:48:25 <harlowja> ok dokie
20:48:33 <harlowja> pressed the appropriate buttons, lol
20:48:40 <iv_m> thx harlowja
20:48:43 <harlowja> ;) np
20:49:05 <iv_m> also, we now have docs published under openstack manuals
20:49:13 <iv_m> #link http://docs.openstack.org/developer/taskflow/ <-- here
20:49:32 <harlowja> oh ya, woot
20:49:38 <iv_m> and #link http://docs.openstack.org/developer/openstack-projects.html has a link there
20:49:47 <harlowja> nice
20:49:49 <harlowja> +2
20:50:14 <harlowja> iv_m the developer docs come from https://github.com/openstack/taskflow/tree/master/doc/source right?
20:50:19 <harlowja> or do they come from the code, or both?
20:50:21 <changbl> nice, +2
20:50:37 <harlowja> seems like https://github.com/openstack/taskflow/tree/master/doc/source is sorta empty files, but then they get populated?
20:51:41 <iv_m> u mention module or class or whatever in https://github.com/openstack/taskflow/tree/master/doc/source via special macros, and then sphinx does its magic to generate some stuff from code and docstrings
20:51:58 <harlowja> kk, i'll have to look into that
20:52:38 <iv_m> also, some words in addition to reference will be nice to have
20:52:56 <harlowja> is there a tool that generates those special macro files, i was thinking something like javadoc which generates the whole thing, not needing special macro files
20:53:03 <harlowja> but i guess this is just sphinx stuff
20:54:05 <iv_m> you can generate the reference for the whole taskflow modules recursively, but i think the result is a but ugly and hardly usable
20:54:16 <harlowja> k, np
20:54:24 * harlowja not sure what the best approach is
20:54:35 <harlowja> seems like no matter is a good oppurtunity to shift around our docs if we want
20:54:49 <harlowja> some of https://wiki.openstack.org/TaskFlow could probably be in developer docs and vice-versa
20:55:24 <iv_m> .. so we (me and a-gorodnev) decided that it's better to hand-pick some modules and/or classes and organise them into nice docs structure
20:56:05 <harlowja> all good, looking at other developer docs there, it doesn't seem like there is agreement on what should/shouldn't be there
20:56:14 <iv_m> for farther sphinx docs improvements, i filed a bp #link https://blueprints.launchpad.net/taskflow/+spec/sphinx-docs
20:56:27 <harlowja> ah, thx iv_m
20:56:40 <harlowja> wondering how much we should move over though
20:56:57 <harlowja> k, will look over bp
20:57:46 <harlowja> iv_m i guess we can close https://blueprints.launchpad.net/taskflow/+spec/distributed-celery now i think to
20:57:56 <harlowja> ole celery
20:58:30 <harlowja> anyways, anything else, times almost up?
20:59:14 <iv_m> not from me
20:59:19 <changbl> i am fine
20:59:21 <harlowja> cool, thx iv_m changbl
20:59:38 <harlowja> lets regroup maybe tuesday after anatstasia gets back and we can chat with all the involved folks about integration
20:59:47 <harlowja> see if we can find a common time to do so
20:59:52 <harlowja> #endmeeting