20:01:16 <harlowja> #startmeeting openstack-state-management
20:01:17 <openstack> Meeting started Thu Feb  6 20:01:16 2014 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:21 <openstack> The meeting name has been set to 'openstack_state_management'
20:01:34 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting
20:01:45 <harlowja> anyone around today (if not, short meeting, ha)
20:02:38 <iv_m> hi there
20:02:42 <harlowja> iv_m howdy
20:03:09 * harlowja waits a few minutes for others
20:04:30 <harlowja> ok, guess might be short meeting
20:04:30 <harlowja> haha
20:04:41 <harlowja> #topic last-action-items
20:04:44 <harlowja> #link http://eavesdrop.openstack.org/meetings/state_management/2014/state_management.2014-01-30-20.00.html
20:05:03 <harlowja> so oslo transition will happen this weekend, or early next week
20:05:13 <harlowja> it will mean reviews will have to be reposted
20:05:16 <dhellmann> scheduled for 20:00 UTC tomorrow
20:05:27 <harlowja> thx dhellmann
20:06:22 <harlowja> hopefully thats not to much of a pain, but just something to be aware of (likely involving adding a new git remote...)
20:07:10 <harlowja> iv_m any progress on the writeup for reversion/retry strategies?
20:07:27 <iv_m> not yet, sorry
20:07:35 <harlowja> np
20:08:14 <harlowja> k, not many other action items
20:08:20 <harlowja> #topic taskflow 0.1.3
20:08:35 <harlowja> so the reason for this is a unicode problem in 0.1.2
20:08:43 <changbl> hey guys
20:08:47 <harlowja> hi changbl
20:09:03 <harlowja> #link https://etherpad.openstack.org/p/TaskFlow-0.1.3
20:09:11 <harlowja> i think we are ok to release that
20:09:20 <iv_m> ya
20:09:25 <iv_m> looks like we are ready
20:09:27 <changbl> great
20:09:28 <harlowja> k, i'll do that shortly
20:09:36 <harlowja> after meeting /lunch
20:09:50 <harlowja> then i think 2.0 we can merge in after move to oslo
20:09:54 <harlowja> 0.2
20:09:57 <harlowja> not 2.0, lol
20:10:00 <changbl> 2.0 :)
20:10:04 <harlowja> oops
20:10:38 <harlowja> if we adopt the firefox/chrome versioning scheme we should be at 10.0 already ,lol
20:11:01 <harlowja> i was also thinking about a 0.1.3 tag and a stable/0.1 branch?
20:11:08 <harlowja> just incase this happens again :-P
20:11:37 <harlowja> since after 0.2 code starts coming in, not gonna be easy to do small releases of 0.1
20:11:40 <harlowja> *if we need to
20:11:46 <iv_m> i think we should choose lazy approach and branch it when that happens again, if ever
20:11:56 <harlowja> ok
20:12:05 <harlowja> i'm fine with that to
20:12:41 <akarpinska1> hi
20:12:53 <iv_m> also, we might want to enforce some policy for bugfixes -- to know for sure what needs to be backported for stable branch when/if we make one
20:12:54 <harlowja> k, after https://review.openstack.org/#/c/71362/ goes into the incubator, we can use that instead of our mini-version
20:13:07 <harlowja> iv_m sure, what where u thinking?
20:13:09 <harlowja> hi akarpinska1
20:13:54 <iv_m> i was thinking of smth like '-1 all real bugfixes unless there is launchpad bug and it is reffered from commit message'
20:13:57 <harlowja> i was hoping stable would just be for tiny stuff (like some unicode stuff we missed somehow)
20:14:09 <harlowja> iv_m thats fair
20:14:33 <harlowja> sounds good to me
20:15:35 <harlowja> k, so next release
20:15:38 <harlowja> #topic 0.2 release
20:15:58 <harlowja> so this one i think we all know whats going into it, nothing unexpected afaik
20:16:08 <harlowja> just lets merge things after move to oslo
20:16:35 <harlowja> i'm also thinking we should put a release notes on ML
20:16:42 <harlowja> *some type of release notes
20:17:30 <iv_m> sure
20:17:39 <harlowja> iv_m maybe for each release we should follow the pattern @ https://etherpad.openstack.org/p/TaskFlow-0.1.3
20:17:42 <harlowja> that one seems nice
20:17:57 <harlowja> make a https://etherpad.openstack.org/p/TaskFlow-0.2.0 for example
20:18:07 <harlowja> with whats new, what changed ...
20:18:21 <changbl> when to have 0.2?
20:18:21 <iv_m> sounds good
20:18:28 <harlowja> changbl ah that question :)
20:18:46 <harlowja> #action harlowja start https://etherpad.openstack.org/p/TaskFlow-0.2.0
20:19:00 <harlowja> changbl i think the goal is next week or the week after
20:19:08 <changbl> ok, that is quick
20:19:13 <changbl> very soon
20:19:20 <harlowja> well we can change that :-P
20:19:34 <harlowja> 0.1.3 wasn't supposed to exist, lol (more of a patch release)
20:20:05 <harlowja> changbl do u think we should wait more?
20:20:19 <harlowja> i can see a nice to have being more examples for 0.2.0
20:20:28 <harlowja> that would help show to people the new features
20:20:39 * harlowja always likes more examples :-P
20:22:00 <changbl> harlowja, depends on what to achieve in 0.2:)
20:22:19 <harlowja> well i think its composed of the following
20:22:31 <harlowja> * jobboard reference impl (ready for people to start trying it out)
20:22:45 <harlowja> * remote workers
20:22:56 <harlowja> * retry controlling that akarpinska1  is working on
20:23:21 <harlowja> + any other bug fixes
20:23:31 <harlowja> your zookeeper backend will be in 0.1.3 (since it merged)
20:24:35 <changbl> i think probably more time is needed to nail down all above TODOs.
20:25:01 <harlowja> agreed, i think changbl  its mostly review time though and documentation and examples
20:25:25 <harlowja> hopefully those don't take to long
20:25:33 <changbl> review take time...
20:25:54 <harlowja> ya, np, no rush there :)
20:26:05 <harlowja> if it takes more time to review, thats fine
20:27:04 <harlowja> we can revisit release date to, just seems like ~2weeks should be able to review, document, make examples (and all that)
20:27:10 <harlowja> if not, we can change to >2weeks
20:28:03 <harlowja> sound fine?
20:28:05 <changbl> harlowja, yes
20:28:08 <harlowja> k
20:28:19 <harlowja> #topic cinder-integration-process
20:28:31 <harlowja> so this one is connected to http://lists.openstack.org/pipermail/openstack-dev/2014-February/026184.html
20:28:47 <harlowja> i just wanted to see how we can improve there (along with others and the cinder work)
20:29:06 <changbl> John G mentioned persistence is wanted right?
20:29:12 <harlowja> changbl ya
20:29:23 <changbl> we'd get persistence ready for cinder
20:29:39 <changbl> seems they really like persistence from taskflow
20:29:41 <harlowja> changbl i am thinking so, i need to see if i can get the nttdata folks to jump in
20:30:09 <harlowja> akarpinska1 do u see any major issues doing this, it will likely change a little bit how they run there workflows (its split across 3 components still)
20:30:33 <harlowja> i imagine the simplest approach is to add persistence in the 3 places (is it the same logbook, not sure)
20:30:50 <changbl> which 3 places?
20:30:55 <akarpinska1> I started to move common parts to separate tasks
20:30:58 <harlowja> changbl also i think part of the improvement that was desired, is to make sure that all the refactoring that was happening was well understood
20:31:11 <changbl> harlowja, yes
20:31:14 <harlowja> changbl api node, scheduler node, volume node
20:31:18 <akarpinska1> when I finish with retries I'll finish it
20:31:43 <harlowja> akarpinska1 lets also see if we can get the ntt folks to jump in, they seem willing and able
20:32:15 <akarpinska1> now we can give some recommendations about the coding style for flows, but the most important part is a persistence, I think
20:32:16 <harlowja> some of these ideas i wrote up and have updated @ https://etherpad.openstack.org/p/cinder-taskflow-persistence
20:32:28 <harlowja> akarpinska1 agreed, even the basic persistence model they would benefit from
20:32:39 <harlowja> and that i think would then unblock these other reviews (once they see what it means)
20:33:55 <harlowja> i'll try to catch the nttdata folks, see if they want to take ownership of this (or i can work with them to make it happen), just want to make sure they are visible and communicating the changes they are doing
20:34:12 <harlowja> and the overall plan (which i think was confusing some of the cinder folks, thus the above ML email)
20:34:17 <changbl> harlowja, rohit and another folk from nttdata?
20:34:54 <harlowja> changbl i think abhishek (and a couple other folks)
20:35:04 <changbl> harlowja, ok
20:35:20 <harlowja> rohit (who used to be doing some orchestration work) i think went to another company (unless its a different rohit u are thinking)
20:35:37 <changbl> oh, we mean the same rohit:)
20:35:41 <harlowja> k
20:36:20 <harlowja> #action harlowja engage cinder folks, nttdata folks to get some movement on persistence writeups,ideas...
20:36:53 <harlowja> the other thing that cinder wants to gain from taskflow is there state consistency issues
20:37:00 <harlowja> *is to resolve there state-consistency issues
20:37:37 <harlowja> i think there will be a feb cinder mid-cycle meetup where everyone will try to figure out what to do here, i'll try to be there if its in the bay area
20:38:23 <harlowja> not so easy to nail down what it means, is it resource consistency problems, race conditions on manipulating resources, other....
20:38:49 <harlowja> jgriffith has the location for this been finalized yet (so that i can try to go :))
20:38:57 <harlowja> *this == cinder mid-cycle meetup
20:39:34 <harlowja> anyways i'll followup on that, anyone that wants to attend to help please join ;)
20:39:45 <harlowja> akarpinska1 ^^ ;)
20:40:17 <akarpinska1> k
20:40:54 <harlowja> #action harlowja determine when is the cinder meetup so that taskflow people can jump on phone, in person...
20:41:01 <harlowja> #topic new use-cases
20:41:35 <harlowja> any new things that people are thinking about that we should have (that we don't)
20:41:45 <harlowja> if not i guess we can just jump into open-discuss
20:42:05 <harlowja> 5
20:42:10 <harlowja> 4
20:42:17 <changbl> sold:)
20:42:17 <harlowja> 3
20:42:21 <ccrouch> http://lists.openstack.org/pipermail/openstack-dev/2014-February/026403.html
20:42:22 <harlowja> we have  winner
20:42:42 <changbl> just kidding:)
20:42:46 <changbl> go on
20:42:50 <ccrouch> anything relevant in sdakes message there?
20:42:55 <harlowja> ccrouch interesting
20:43:04 <ccrouch> i.e. integration with Heat
20:43:13 * harlowja reading
20:44:03 <ccrouch> its a *big* thread, but thats the part that seemed most relevant to taskflow
20:45:08 <harlowja> hmmm, so partially that seems to be suggesting a workflow service right, which to me brings into the picture what mistral is
20:45:22 <harlowja> although there has been much discussion about heat using taskflow
20:45:44 <harlowja> *which changes alot of how heat runs (for better or worse)
20:46:19 <harlowja> although the mistral dsl seems to be turning into a 'full-fledged programming language'
20:46:59 <ccrouch> (2:45:23 PM) harlowja: although there has been much discussion about heat using taskflow
20:46:59 <ccrouch> i will go and try and find that
20:47:02 <harlowja> ccrouch i've been working with the mistral folks on using taskflow, there initial prototype still isn't using taskflow but i think they want to
20:47:21 <harlowja> ccrouch http://icehousedesignsummit.sched.org/event/ced7d22ac4c037f102b3cf3ade553104#.UvP00fY71ro
20:47:26 <harlowja> i think there was a etherpad somewhere
20:47:53 <harlowja> ccrouch https://etherpad.openstack.org/p/icehouse-summit-heat-workflow
20:48:19 <harlowja> the problem with changing heat was the coroutine style in heat makes it really hard to alter/change it to something else (something say that uses remote workers)
20:48:29 <harlowja> i'm all for bringing the question up again
20:49:51 <harlowja> from the HK summit i think the conclusion was that heat needed to do some refactoring before changing how it ran was even possible
20:50:01 <harlowja> *which was also desired to fix there scaling bottleneck
20:50:22 <harlowja> and they wanted taskflow to have a remote-worker model (now @ https://review.openstack.org/#/c/63155/)
20:50:35 <ccrouch> harlowja: ok, i can trying poking sdake about where this is at, if you would be receptive on your side to pushing the "workflow" ball down the field with heat
20:50:54 * harlowja unsure what that exactly means :)
20:51:08 <harlowja> the pushing the workflow ball down the field to heat :)
20:51:36 <ccrouch> that folks won;t say "too busy doing cinder integration, sorry cant talk" :-)
20:51:48 <harlowja> oh, sure, i'm always up for talking :)
20:52:02 <harlowja> *unless i'm in mad crazy programming mode, lol
20:52:24 <harlowja> ccrouch sounds good, lets start this conversation up with sdake (and any others)
20:52:30 <harlowja> and see what happens
20:52:33 <ccrouch> ok i'll see where sdake is at
20:52:34 <ccrouch> +1
20:52:40 <harlowja> cool, thx much
20:53:51 <harlowja> alright final topic
20:53:54 <harlowja> #topic open-discuss
20:54:09 <harlowja> sooo the only thing that i have is to get more input on https://etherpad.openstack.org/p/taskflow-atlanta-speaker-ideas :)
20:54:15 <harlowja> so that we can start filing little speaker abstracts
20:54:27 <harlowja> 'Hurry, the deadline to submit is February 14, 2014.  '
20:54:54 <harlowja> so start adding in anything that might be cool to show
20:54:56 <harlowja> or talk about
20:54:57 <harlowja> or...
20:56:07 <harlowja> anyways, that all i got
20:57:08 <harlowja> anybody else, if not we can end :-P
20:57:12 <harlowja> 5
20:57:22 <harlowja> 4
20:57:29 <harlowja> 3.1
20:57:35 <harlowja> 2
20:57:39 <harlowja> 0.5
20:57:42 <harlowja> 0.0
20:57:43 <harlowja> boom
20:57:48 <harlowja> thanks for coming again folks
20:57:59 <harlowja> more excitement always found in #openstack-state-management
20:58:02 <harlowja> #endmeeting