15:02:08 <TravT> #startmeeting openstack search
15:02:09 <openstack> Meeting started Thu Feb 11 15:02:08 2016 UTC and is due to finish in 60 minutes.  The chair is TravT. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:12 <openstack> The meeting name has been set to 'openstack_search'
15:02:25 <rosmaita> sjmc7: looks like everyone ganged up on you last night and -1'd your spec patch
15:02:30 <TravT> haha
15:02:36 <TravT> i had to jump on the band wagon
15:02:42 <sjmc7> hey
15:02:49 <nikhil> o/
15:02:54 <TravT> o/
15:02:55 <sjmc7> rosmaita: it was heartbreaking
15:03:12 <RickA-HP> o/
15:03:37 <TravT> okey-dokey.
15:03:49 <TravT> i didn't put together a big agenda today.
15:04:11 <sjmc7> i did have something which i now can’t remember. perhaps my mind will be jogged
15:04:20 <TravT> because i thought we should look over the current release and talk some priorities
15:04:52 <TravT> as usual, it is here though: https://etherpad.openstack.org/p/search-team-meeting-agenda
15:05:08 <TravT> so you can add or bring it up during the meeting
15:05:44 <TravT> General updates is that we are closing in on the end of mitaka 3 which you all already knew
15:06:24 <TravT> I did just remember one item for discussion and added to agenda
15:06:38 <TravT> #topic searchlight panel
15:07:18 <TravT> Interestingly enough, I've been contacted twice in the last two weeks from people wanting to install searchlight and the horizon panel.
15:07:34 <TravT> last one appeared to be somebody wanting it for liberty
15:08:03 <TravT> which left us in a not great spot, because it obviously wasn't merged to master
15:08:08 <TravT> and it wasn't its own repo
15:08:28 <nikhil> oops
15:08:39 <TravT> it exists as a patch on horizon.
15:09:22 <TravT> so, i'm still very much trying to get it in shape for horizon mitaka, but the reality is that its a longshot to land on horizon master for mitaka.
15:09:55 <TravT> i still think it may be best to be on horizon master, but if needed we should do a searchlight-dashboard / searchlight-ui repo
15:10:09 <TravT> so we have something we can tag with mitaka and be deployable.
15:10:58 <TravT> my question is this: should i proactively put up a patch for a searchlight-dashboard repo now?
15:11:17 <sjmc7> TravT: given horizon’s been moving stuff out rather than in, i think that’d be a good idea for now
15:11:25 <sjmc7> until we have a good case for making it a core piece
15:11:46 <TravT> ultimately i think we have a good case for making it core and many horizon cores agree.
15:11:52 <sjmc7> yeah, i agree
15:12:16 <sjmc7> but i’ve heard from many they want to see it have broader use before that happens
15:12:29 <TravT> i think that if we miss horizon master in mitaka, that it'll be tough to get a repo created in time for mitaka tagging
15:13:11 <TravT> but i still have to keep it as a patch on horizon master until its parent patch lands on master.
15:13:37 <sjmc7> having separate repos for horizon is a well-established pattern, so i don’t see a problem
15:13:42 <sjmc7> ultimately it’d be much nicer to be in core
15:13:53 <TravT> okay, so i'm going to request a new repo so we at least have it
15:14:19 <TravT> and we might swap it over from being a patch on master to the repo right at the end of mitaka.
15:14:50 <TravT> okay?  rosmaita nikhil RickA-HP?
15:15:06 <RickA-HP> TravT: I agree with creating the new repo now.
15:15:27 <sjmc7> good with me. and im sure with david :)
15:15:40 <RickA-HP> It will put us on the path to success if we don't make Horizon core.
15:15:44 <TravT> yeah, david and i had a long conversation about it.
15:16:08 <TravT> he likes it for horizon core, but thought a separate repo as backup / interim plan makes sense
15:16:31 <rosmaita> i don't have an opinion on this, don't know much about horizon politics
15:16:40 <rosmaita> but the discussion so far makes sense to me
15:17:12 <TravT> horizon team has generally been supportive, but the priority backlog for horizon is pretty big with several things higher on the list
15:18:20 <TravT> with a dashboard repo, it has become standard to make the service core team and the horizon core team cores on the repo.
15:18:41 <TravT> in some cases, additional people are added as cores.
15:18:49 <TravT> for example, magnum did that
15:19:17 <TravT> so initially, i'd make searchlight core and horizon core team have rights.
15:19:36 <nikhil> == rosmaita
15:20:08 <TravT> okay, i'll work on getting that going over the next several days
15:20:28 <TravT> #agreed Create a searchlight-dashboard repo as a backup plan to searchlight landing on mitaka horizon master
15:20:38 <TravT> i think that's how it works... i don't know
15:20:59 <TravT> #topic Newton summit session
15:21:19 <TravT> sjmc7 and I submitted a project update session to the summit.
15:21:43 * TravT needs to find a link
15:22:18 <TravT> sjmc7 do you have it?
15:22:24 <sjmc7> looking
15:22:37 <sjmc7> talki amongst yourselves
15:22:54 <sjmc7> https://www.openstack.org/summit/austin-2016/vote-for-speakers/presentation/7561
15:23:17 <TravT> ok, anyway, if you are so inclined, voting for it might help it
15:23:32 <sjmc7> and hopefully we won’t have to bellow over the marketplace this time
15:24:34 <TravT> #topic blueprints - end of mitaka priorities
15:24:52 <TravT> https://blueprints.launchpad.net/searchlight
15:25:34 <TravT> sjmc7, do we have anything left on index-level-role-separation
15:25:59 <sjmc7> there’s a bug against the designate plugins around it with a patch up, but the core code is done
15:26:23 <TravT> ok, then we'll leave it not marked as complete
15:26:27 <sjmc7> aww :(
15:26:37 <TravT> so close!
15:27:27 <sjmc7> the deletion-journal stuff i think will be much simpler after digging up the barely documented feature elasticsearch has (and again, i think rosmaita tried to bring this up and i didn’t pay enough attention, so apologies)
15:28:07 <TravT> +1 to rosmaita
15:28:31 <TravT> sjmc7: i think you can mark es-deletion-journal as something besides unknown delivery now, right?
15:28:36 <sjmc7> yes
15:29:08 <sjmc7> i can’t edit it :(
15:29:13 <sjmc7> ah, there it is
15:29:31 <TravT> RickA-HP: i just marked zero downtime indexing as approved (since spec went through)
15:29:42 <TravT> can you change delivery to appropriate status?
15:30:04 <RickA-HP> TravT: Sure. As an update, the code is written.
15:30:05 <sjmc7> per-resource-type-control i think will not be tremendously difficult now the role separation is in
15:30:12 <sjmc7> i’m saving it for a rainy afternoon
15:30:22 <RickA-HP> I'm in the middle of testing and I still need to write more unit tests.
15:30:28 <TravT> yes, i think we will need it in mitaka
15:30:48 <TravT> when i discussed searchlight in the horizon irc meeting yesterday, "permissions" was one of the questions raised
15:31:09 <sjmc7> ok. i’ll maybe talk to you about specifics
15:31:18 <TravT> richard asked if we'd addressed the permissions issues we talked about in tokyo.
15:31:19 <sjmc7> i don’t want to get too deep into a complicated hole
15:31:33 <TravT> sure, my brain isn't yet firing on all cylinders this morning
15:31:49 <TravT> so later in the day would be better
15:31:52 <TravT> ;)
15:32:25 <TravT> steve, i think this bp is actually done. it appears to overlap with role base documents spec  https://blueprints.launchpad.net/searchlight/+spec/nova-server-config-admin-properties
15:32:33 <sjmc7> woo-hoo!
15:32:41 <TravT> i can mark it superseded if you agree
15:32:46 <sjmc7> yes
15:33:01 <sjmc7> freebie blueprint!
15:33:10 <TravT> woot!
15:34:16 <TravT> ok, so other than pre resource type policy control, i contend that we really need cinder and neutron plugins for mitaka.
15:34:29 <TravT> we need to fill out the core openstack services.
15:34:39 <sjmc7> i looked at cinder yesterday
15:34:54 <sjmc7> and i think the existing notifications are sufficient for something without hitting the API all the time
15:35:05 <sjmc7> neutron i’m waiting for the parent/child patch to land
15:35:21 <TravT> okay, i saw lakshmiS added comments on that one last night
15:35:36 <sjmc7> yep. the data model is more complicated for neutron
15:36:08 <TravT> yeah, i've been trying to psych myself up to learn it enough to provide some review on it
15:36:11 <sjmc7> but i think i can put up a first stab for discussion
15:36:59 <TravT> if we get a cinder plugin patch up
15:37:07 <TravT> maybe duncan could still get the notification side up
15:37:11 <TravT> on cinder
15:37:31 <sjmc7> yep. i’m intending to work on both today or tomorrow
15:38:03 <sjmc7> the versioning patch is probably the most crucial one now
15:38:19 <sjmc7> it has the potential to introduce unforseen bugs
15:38:29 <sjmc7> so it’d be good to get as much testing time as possible
15:39:04 <TravT> well, looks like just waiting for another patch set from lei
15:39:15 <TravT> https://review.openstack.org/#/c/255751/
15:39:48 <sjmc7> yeah, it’s gone back and forth a bit. timezones make it more difficult
15:40:30 <TravT> nikhil, have you had any time to look at zuul functional tests?
15:42:33 <TravT> maybe he stepped away
15:43:49 <TravT> i still would like to see swift get closer to reality, but that's probably something to look to get worked out for the summit... maybe we should have put up a session on searching swift...
15:44:10 * TravT :( just realized we probably did miss the boat on that one...
15:44:27 <sjmc7> maybe the IBM guys will be doing it again :)
15:44:36 <TravT> we really should have done that!
15:44:54 <TravT> we'll have to propose it as a design session with swift perhaps
15:45:07 <TravT> walk in with working code.
15:45:32 <TravT> anyway, i don't have any other big topics for the week
15:45:39 <TravT> #topic open discussion
15:45:41 <sjmc7> i remembered something i had
15:46:30 <sjmc7> i am still worried about hitting the nova API. i wondered about not listening to state change notificaitons, or at least making it optional
15:46:47 <sjmc7> power events spawn at least 4 notifications
15:47:07 <sjmc7> the transitionary ones don’t seem that crucial for us to pick up
15:47:13 <RickA-HP> sjmc7: Are we able to filter out notifications?
15:47:20 <TravT> oh, actually, we talked about putting in some smarter logic there as well...
15:47:28 <sjmc7> RickA-HP: yeah, we can choose which ones
15:47:39 <sjmc7> i’m thinking a config option
15:47:44 <TravT> maybe we should only react to final state
15:47:55 <sjmc7> i have a strong concern that on a big install, hammering the API on state change is gonna be bad news
15:48:02 <TravT> yes - config option would be good.
15:48:12 <sjmc7> if we can get more info into the notifications next cycle we can do better
15:48:25 <sjmc7> ok. i’ll put up a BP. i can’t remember the other thing
15:49:11 <TravT> i haven't gone back to see if nova actually implemented any of that notification discussion that i attended at the summit
15:49:33 <sjmc7> i haven’t looked for a while. i’ll take another look
15:49:38 <TravT> if they did, then they were going to put full data into notification, but it would just be the raw data
15:49:45 <TravT> not looking like the API output
15:49:53 <TravT> but we could transform it
15:50:10 <sjmc7> yep
15:50:21 <sjmc7> i’l ltake a look. something for the summit, definitely
15:50:28 <TravT> I had asked about them giving a transform library and they were basically like "oh man, no way, not how tangled up the code is"
15:50:44 <sjmc7> :D
15:51:14 <TravT> if they did that, it would be pretty awesome...
15:51:31 <TravT> okay, anything else for today?
15:51:54 <TravT> i think we'll have yingjun back next week.
15:51:56 <sjmc7> nope. reviews on the versioning patch
15:51:58 <TravT> he was out this week on holiday
15:52:26 <TravT> all right, thanks!
15:52:51 <TravT> #endmeeting