13:01:26 <jasondotstar> #startmeeting openstack-salt
13:01:27 <openstack> Meeting started Tue Mar 29 13:01:26 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:30 <openstack> The meeting name has been set to 'openstack_salt'
13:01:39 <jasondotstar> #topic roll call
13:01:42 <jasondotstar> o/
13:04:30 <jasondotstar> hmmm. none of our folks are here atm. /me checks...
13:04:58 <liqw> o/
13:05:55 <genunix> o/
13:06:05 <jasondotstar> there we go
13:06:10 <jasondotstar> hi all
13:06:18 <genunix> hello :-)
13:06:36 <jasondotstar> shall we get going?
13:06:39 <jasondotstar> #topic Introduction
13:06:57 <jasondotstar> This meeting is for the openstack-salt team
13:07:04 <jasondotstar> If you're interested in contributing to the discussion, please join #openstack-salt
13:07:53 <jasondotstar> our meeting time has changed. Meetings are weekly on Tuesdays *now* at 1300UTC here in #openstack-meeting-4
13:08:35 <jasondotstar> hopefully this will better accommodate our global team members in the far east :-)
13:08:55 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
13:09:05 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
13:09:27 <jasondotstar> any questions or comments on this?
13:09:41 <jasondotstar> genunix, liqw - you think this works better for you?
13:11:39 <jasondotstar> ok guess we don't have comments on this, let's move on
13:11:47 <jasondotstar> #topic Review past action items
13:11:52 <genunix> yes much better :-)
13:12:07 <jasondotstar> genunix to continue researching openstack packaging
13:12:33 <jasondotstar> anything on this?
13:13:56 <genunix> nothing :-(
13:14:07 <jasondotstar> ok
13:14:21 <jasondotstar> so.... perhaps we should review what the goal is with this task
13:14:43 <jasondotstar> what are we packaging up.....
13:14:44 <jasondotstar> ?
13:15:05 <jasondotstar> let's talk through it a little more, that will help me figure out where I (and others) can help
13:15:22 <jasondotstar> genunix: can you give us a breakdown of what we want to see here?
13:16:11 <genunix> jasondotstar: Yes, we need to investigate how openstack packaging is done first
13:16:42 <genunix> jasondotstar: I mean for Debian-based distros + RPM (that was supposed to be investigated by ali afaik)
13:17:24 <genunix> I have some idea how it's probably going to be done, but I would like to find someone from OS packaging team to discuss
13:17:40 <jasondotstar> ok
13:17:48 <jasondotstar> this should probably be captured in a blueprint
13:17:54 <jasondotstar> or a spec
13:17:56 <genunix> yes
13:18:03 <jasondotstar> generally what we want to do
13:18:06 <jasondotstar> have folks review it
13:18:37 <genunix> + I would also like to think about packaging,resp. getting rest of our formulas into Debian as well
13:18:47 <genunix> not just openstack-related
13:20:02 <jasondotstar> +1
13:20:14 <jasondotstar> that's something we can discuss more too
13:21:30 <jasondotstar> so who should write up the blueprint
13:21:30 <jasondotstar> ?
13:22:08 <jasondotstar> genunix: if you want to start the spec
13:22:25 <jasondotstar> we can of course edit it... add, remove, modify, etc.
13:22:31 <jasondotstar> until it's about where we want it to be
13:22:37 <jasondotstar> agreed?
13:23:35 <genunix> ok
13:23:52 <jasondotstar> cool.
13:24:18 <jasondotstar> #action genunix to start the RPM packaging spec
13:24:32 <jasondotstar> anything else on the RPM packaging topic?
13:24:38 <genunix> where's ali btw?
13:24:44 <jasondotstar> hmmm... i dunno
13:24:47 <genunix> he wanted to participate on RPM stuff
13:24:50 <jasondotstar> iceyao isn't around either
13:25:07 <genunix> because I am more interested in Debian which has higher priority. RPM is nice to have for me.
13:25:36 <jasondotstar> genunix: +1. I'd like to get into packaging more myself
13:25:44 <jasondotstar> I'll ping you afterwards to talk about both
13:25:56 <jasondotstar> but I can assist with the RPM packaging efforts as well.
13:26:35 <jasondotstar> I assume that our target is Newton
13:26:46 <jasondotstar> but we can discuss that a bit more later
13:26:52 <jasondotstar> let's move on
13:27:07 <jasondotstar> jasondotstar to attend the RPM-packaging team meeting
13:27:22 <jasondotstar> so I attended the meeting, though I showed up a bit late
13:27:35 <jasondotstar> if you guys want to take a look at what was discussed here's a link:
13:27:50 <jasondotstar> #link http://eavesdrop.openstack.org/meetings/rpm_packaging/2016/rpm_packaging.2016-03-24-13.04.log.html
13:28:32 <jasondotstar> the meeting was rather short
13:28:47 <jasondotstar> but most of what they discussed was around creating a stable/mitaka branch
13:29:22 <genunix> ok, I will check
13:29:46 <jasondotstar> they will also be at summit
13:30:43 <jasondotstar> but they are facing similar facility issues as far as finding a room
13:31:07 <jasondotstar> I can reach out to dirk and talk to him about what we're doing - dirk is one of the leads in that group
13:31:51 <jasondotstar> #action jasondotstar to reach out to dirk (RPM-packaging team) to discuss RPM packaging
13:32:04 <jasondotstar> ok any other items here?
13:32:15 <jasondotstar> is newt around?
13:32:21 <jasondotstar> we're missing a couple folks today
13:32:23 <jasondotstar> :-)
13:33:31 <jasondotstar> ok next topic
13:33:46 <jasondotstar> jasondotstar to research building RPMs using the openstack-ci
13:33:50 <genunix> yes, day after easter :)
13:33:54 <jasondotstar> so this one is IN-PROGRESS
13:34:00 <jasondotstar> genunix: +1 that's true.
13:34:18 <jasondotstar> as it relates to the other stuff we've been talking about...
13:34:34 <jasondotstar> and the last one on the list is:
13:34:38 <jasondotstar> cznewt to follow up on DVR networking and the neutron salt formula with OVS support ready
13:35:31 <jasondotstar> he's not around so, I will move these last two up to next week's agenda
13:35:50 <jasondotstar> #action jasondotstar to continue researching the RPM build process using the openstack-ci
13:36:12 <jasondotstar> #action cznewt to follow up on DVR networking and the neutron salt formula with OVS support
13:36:29 <jasondotstar> ok any other lingering items to discuss from previous meetings?
13:36:40 <jasondotstar> genunix: dude, it's just me and you today :-P
13:38:54 <jasondotstar> #topic Today's Agenda
13:39:08 <jasondotstar> genunix: you have anything to bring up?
13:42:06 <jasondotstar> looks like we might have arif-ali joining us here shortly....
13:43:28 <arif-ali> hi
13:44:04 <jasondotstar> hi arif-ali
13:44:18 <jasondotstar> so we were talking earlier about RPM packaging
13:44:47 <arif-ali> didn't get far, tbh, and there was some ideas over the past few weeks of using openstack CI
13:45:14 <arif-ali> we just need to understand exactly, how we want to to go ahead, and then we can channel the right places to get it going
13:46:02 <arif-ali> if it's RDO, then I can go through that route, and I had preliminarily done some work, but hadn't submitted anything
13:46:03 <jasondotstar> right.
13:46:10 <jasondotstar> we spoke around writing up a spec
13:46:18 <jasondotstar> just to capture what we want to do on this
13:46:31 <jasondotstar> genunix volunteered to start the spec
13:46:38 <arif-ali> sure, ok
13:46:48 <jasondotstar> and i assume that we should get your help to finish defining it
13:47:05 <arif-ali> I am happy to assist, where needed
13:47:12 <jasondotstar> \o/ cool
13:50:18 <jasondotstar> ok
13:50:34 <jasondotstar> sorry guys, I'm actually talking to dirk now from the RPM  packaging team
13:50:46 <jasondotstar> told him who we were, what we are trying to do, etc.
13:51:02 <jasondotstar> so.... that's all i have for us today
13:51:51 <jasondotstar> is there anything else that the team wants to discuss? are we set for summit?
13:53:13 <genunix> I think that's all for today :-)
13:53:22 <jasondotstar> sounds good
13:53:30 <genunix> as almost nobody seems to be here :-)
13:53:40 <jasondotstar> if nothing else I think we can close out. yeah, light day today
13:53:52 <jasondotstar> we can continue talking in #openstack-salt if needed
13:53:56 <jasondotstar> thanks all
13:54:00 <jasondotstar> #endmeeting