16:08:45 <cznewt> #startmeeting openstack-salt
16:08:46 <openstack> Meeting started Tue Mar  8 16:08:45 2016 UTC and is due to finish in 60 minutes.  The chair is cznewt. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:08:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:08:50 <openstack> The meeting name has been set to 'openstack_salt'
16:10:27 <cznewt> #topic roll call
16:10:34 <cznewt> o/
16:11:12 <liqw> o/
16:11:41 <cznewt> #topic Introduction
16:12:12 <cznewt> This meeting for the openstack-salt team
16:12:12 <iceyao> hi
16:12:25 <cznewt> if you're interested in contributing to the discussion, please join #openstack-salt
16:12:33 <cznewt> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
16:12:41 <cznewt> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
16:12:47 <cznewt> iceyao: hello
16:13:33 <cznewt> #topic Review past action items
16:14:38 <cznewt> we'll go though items from last meeting, but as most of the members have gone away for today's meeting we'll go to todays issues
16:15:13 <cznewt> genunix tlo continue researching openstack packaging
16:16:39 <cznewt> genunix is way is away fot this week, will forward to next week's meeting
16:16:45 <cznewt> #action genunix to continue researching openstack packaging
16:17:08 <cznewt> next topic Research building RPMs using the openstack-ci
16:17:50 <cznewt> any news?
16:19:06 <cznewt> arif-ali is not present either, postponing till next week's meeting
16:19:26 <cznewt> #action Continue to research building RPMs using the openstack-ci
16:19:42 <cznewt> Research big tent.  Determine which of our salt-formula-* projects should fall under the big tent umbrella, and which of the more host-generic formulas should be pushed up to the salt community
16:20:33 <cznewt> this is being handled, we trying to reach salt community on this
16:21:32 <cznewt> topic, but the problem is that most of the presented formulas already exist in the salt community
16:21:54 <cznewt> I'll give resolution when we have some answers
16:22:08 <cznewt> talk to the  -infra team about using the openstack ci pipeline for building RPMs and more discussion needed on testing the RH stack
16:22:33 <cznewt> Any update on this?
16:23:00 <cznewt> If not we'll move to today's agenda
16:23:02 <cznewt> #topic Today's Agenda
16:23:08 <liqw> for those who are willing to test openstack-salt formulas and heat stack.. we still provide http://openstack-salt.tcpcloud.eu/develop/quickstart-heat.html
16:24:44 <cznewt> iceyao: hello, can you introduce yourself, today's meeting is a little undermanned, as snow has fallen in czech :)
16:27:02 <iceyao> I'm from 99cloud and I major in devops now
16:28:03 <cznewt> Do you at 99 deploy openstack using salt, or plan on to it?
16:28:56 <cznewt> I have some news about heat deployment labs
16:28:58 <iceyao> yeah, using salt deploy openstack now
16:29:25 <cznewt> We have the labs single/cluster ready and tested
16:29:26 <iceyao> Only on Centos7
16:29:53 <iceyao> cznewt: I can test it
16:30:04 <cznewt> for ubntu for now, but the redhat based is ready but not tested
16:30:34 <cznewt> yes, I can give you the password to the lab, so you can deploy the stack to start testing
16:30:51 <cznewt> the steps are covered in temporary documentations
16:31:06 <cznewt> #link http://openstack-salt.tcpcloud.eu/develop/quickstart-heat.html
16:31:38 <cznewt> iceyao: what version do you deploy / what networking?
16:31:53 <cznewt> at your production deploys
16:32:14 <iceyao> Liberty
16:33:31 <iceyao> cznewt: I found that doc using heat to deploy
16:33:59 <iceyao> it can deploy on baremental centos os ?
16:35:11 <cznewt> yes, if you setup the minions in the same way as in the heat-based lab
16:35:34 <cznewt> this is something we would like to have tested
16:36:06 <cznewt> we can give you support if you want to proceed testing on bare metal servers
16:36:09 <iceyao> I see
16:36:45 <cznewt> the setup is centos7 nodes, cluster or single deploy you'll try?
16:37:23 <iceyao> I'll try aio first
16:38:18 <cznewt> and about networking, what plugin do you use? vanilla or some vendor SDN?
16:38:37 <iceyao> use ovs now
16:39:18 <cznewt> #action iceyao to test the centos aio deployment
16:41:24 <iceyao> Does it suppourt ovs or linux bridge ?
16:41:49 <cznewt> We'll the support for ovs is a little outdated now, but you're welcome to make it up-2-date
16:42:02 <Tux_> +1
16:42:22 <Tux_> I would like to see ovs work as well
16:44:04 <cznewt> #action get the neutron formula with OVS support ready
16:45:04 <cznewt> I'll get ready the ticket on launchpad, the OVS support is must have
16:46:19 <cznewt> iceyao: when do you plan on testing the aio setup?
16:46:42 <cznewt> the current setup works with opencontrail networking
16:47:34 <iceyao> this week.
16:48:14 <iceyao> I may need your help , I'm not familiar with opencontrail
16:48:29 <liqw> iceyao: if you look at http://openstack-salt.tcpcloud.eu/develop/quickstart-heat.html#testing-lab-at-tcp-cloud there's 'Openstack-salt single setup' which are 3 nodes. maybe it's easier to do the first test on virtual environment (lab).
16:49:28 <cznewt> yes, the only thing that we'll need to be fixed for centos deloyment is the repository definition
16:49:35 <iceyao> liqw: thanks
16:50:10 <cznewt> for now it supports the ubuntu cloud archive repos
16:50:51 <iceyao> how can I do for repository definition?
16:51:37 <cznewt> iceyao: we'll get the repo setup ready tomorrow with the heat stack, so it's testable in heat setup
16:52:37 <cznewt> iceyao: we are getting short on time, we'll continue to discuss this further on #openstack-salt channel
16:53:01 <iceyao> ok
16:53:11 <cznewt> #action prepare the repositories for redhat deployments
16:54:04 <cznewt> iceyao: do you have spare time to get the ovs support in salt formulas fixed?
16:55:06 <iceyao> I try my best
16:56:05 <Tux_> +1
16:57:28 <cznewt> #action look at getting OVS networking working
16:57:47 <iceyao> Can you modify the meeting time next ? I live in Asia/ShangHai
16:58:59 <cznewt> well, we have already us/europe members
16:59:07 <cznewt> what time is it for you?
16:59:46 <cznewt> the time is up we'll continue at openstack-salt
16:59:57 <cznewt> #endmeeting