16:00:50 <jasondotstar> #startmeeting openstack-salt
16:00:51 <openstack> Meeting started Tue Feb 16 16:00:50 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:54 <openstack> The meeting name has been set to 'openstack_salt'
16:01:00 <jasondotstar> #topic roll call
16:01:02 <jasondotstar> o/
16:05:46 <jasondotstar> ok moving on
16:06:02 <jasondotstar> #topic Introduction
16:06:07 <jasondotstar> This meeting for the openstack-salt team
16:06:18 <jasondotstar> if you're interested in contributing to the discussion, please join #openstack-salt
16:06:45 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
16:07:03 <jasondotstar> #link https://wiki.openstack.org/wiki/Meetings/openstack-salt
16:07:50 <jasondotstar> #topic Review past action items
16:07:58 <jasondotstar> let's see who's around
16:08:32 <jasondotstar> genunix to continue openstack packaging research
16:08:59 <genunix> yes, unfortunately no progress. Except for proceeding with redhat packaging.
16:09:23 <jasondotstar> ok
16:09:41 <jasondotstar> #action genunix to continue openstack packaging research
16:09:58 <jasondotstar> we've got a new team member who's also looking into RDO packaging as well
16:10:26 <genunix> yes! :-)
16:10:46 <jasondotstar> and I've offered to help. I want to get back into building packages
16:11:23 <jasondotstar> ok next one:
16:11:37 <jasondotstar> jasondotstar to look at the integration of launchpad with our repos (bug triage, tracking, etc.) *important*
16:11:54 <jasondotstar> ok so here's some documentation that details how to go about this:
16:12:08 <jasondotstar> #link http://docs.openstack.org/infra/manual/creators.html#set-up-launchpad
16:12:24 <jasondotstar> basically this explains the process
16:13:03 <jasondotstar> I can work with cznewt
16:13:27 <jasondotstar> to ensure that we follow the LP process and setup the LP projects and groups correctly
16:14:17 <jasondotstar> #action jasondotstar to begin working on the launchpad integration (enlisting help from cznewt)
16:14:26 <jasondotstar> any comments or questions on this?
16:15:38 <jasondotstar> ok moving on
16:15:59 <jasondotstar> cznewt to look at beaker gates and how to fold a similar process into the salt workflow
16:17:24 <jasondotstar> cznewt: any news here?
16:19:54 <jasondotstar> ok let's move on
16:20:15 <jasondotstar> cznewt get the first cloud based labs for openstack-salt testing fully operational
16:20:30 <jasondotstar> we'll carry both of these fwd until we hear back from cznewt
16:21:03 <genunix> cznewt is probably still teaching on salt workshop
16:21:03 <jasondotstar> #action cznewt to look at beaker gates and how to fold in a similar process into the openstack-salt workflow
16:21:43 <jasondotstar> #action cznewt to work on getting the cloud-based labs for openstack-salt testing fully operational
16:22:11 <jasondotstar> ok there was an open item regarding our engagement with the broader salt community
16:22:22 <jasondotstar> to continue to engage the salt community regarding our standardizing dependencies, packaging, versioning, and testing
16:22:25 <genunix> yes, my mailing list post is still with no response
16:22:32 <jasondotstar> genunix: +1
16:22:34 <genunix> It would be great if someone could ping it
16:22:49 <jasondotstar> do we have any contacts there
16:22:56 <jasondotstar> besides Nitin Madhok?
16:23:15 <jasondotstar> I've had no luck reaching out to him in the past
16:23:15 <genunix> #link https://groups.google.com/forum/#!searchin/salt-users/pytloun/salt-users/v3PQDfRgtmk/8toLNeGVCAAJ
16:23:41 <jasondotstar> genunix: thx for the link
16:23:56 <jasondotstar> let's keep our eye on it; see if we can get someone to respond
16:24:38 <jasondotstar> #action continue monitoring the salt mailing list for a response
16:24:40 <genunix> maybe at lest something like "Great work, I also wonder how to package..." just to get some attention :-)
16:24:54 <jasondotstar> genunix: +1
16:25:34 <jasondotstar> next: jasondotstar to complete local dev testing setup
16:26:08 <jasondotstar> so following the process for setting up a local dev environment via vagrant works
16:26:37 <jasondotstar> should I publish my test results? blog post? wiki?
16:26:41 <jasondotstar> what would you guys suggest?
16:27:01 <genunix> both would be great imo
16:27:06 <jasondotstar> #link http://openstack-salt.tcpcloud.eu/develop/quickstart-vagrant.html
16:27:13 <jasondotstar> those are the instructions
16:27:30 <genunix> blog post could possibly get some more people to openstack-salt
16:27:37 <jasondotstar> but what I'll do is post a blog entry that illustrates it
16:27:45 <jasondotstar> my blog is on the openstack planet
16:28:18 <jasondotstar> #action jasondotstar to write a blog post that illustrates how to setup the openstack-salt local dev environment
16:28:31 <jasondotstar> anything else on this one?
16:28:47 <genunix> we will surely share your blog post on tcpcloud.eu and our channels
16:29:45 <jasondotstar> nice!
16:29:51 <jasondotstar> ok
16:29:56 <jasondotstar> next one:
16:30:13 <jasondotstar> jasondotstar to work on pruning the salt formula projects underneath the stackforge/ namespace
16:30:39 <jasondotstar> k so this one still needs work
16:30:52 <jasondotstar> but there was some guidance given to use from the -infra team
16:31:19 <jasondotstar> as we know, we've got competing repos
16:31:35 <jasondotstar> some in the stackforge/ namespace
16:31:49 <jasondotstar> and the ones we've been iterating against lately in the openstack/ namepace
16:32:18 <jasondotstar> the ones in the stackforge/ namespace are old and basically defunct
16:32:22 <jasondotstar> Best solution is to push a commit deleting all files and adding a readme with a note that the head^1 commit is teh last state of the repo pre-retirement, then locking down the gerrit acl to read-only for it
16:32:42 <jasondotstar> since we cannot delete those repos directly.
16:32:57 <jasondotstar> this is the suggestion from the -infra team
16:33:31 <genunix> Ok, it sounds fine
16:33:32 <jasondotstar> on the meeting agenda etherpad, i listed out all of the stackforge/ repos
16:33:54 <jasondotstar> basically we go through this list
16:34:29 <jasondotstar> and do this for each repo.
16:34:47 <jasondotstar> we can divide an conquer this
16:35:11 <jasondotstar> or one of us can simply work on it. either way I'll take the action to coordinat
16:35:15 <jasondotstar> *coordinate it
16:35:59 <jasondotstar> #action jasondotstar to coordinate 'sunsetting' of the salt formula repos under the stackforge/ namespace
16:36:47 <jasondotstar> any other thoughts on this?
16:37:48 <jasondotstar> if not that basically rounds out the action items from our last meeting
16:38:05 <jasondotstar> #topic Today's Agenda
16:38:28 <jasondotstar> ok
16:38:30 <jasondotstar> RedHat packaging/config
16:38:58 <jasondotstar> that's on the list, does someone here want to kick off this discussion?
16:39:44 <jasondotstar> genunix: did you put this topic on the agenda?
16:40:15 <genunix> no, didn't
16:40:26 <jasondotstar> ok I'm thinking that it was our newest member
16:41:31 <jasondotstar> well, the idea is around providing RPMs
16:41:44 <genunix> we are working on rhel support in formulas and arif-ali made some first spec file for building RPMs.
16:41:53 <jasondotstar> i remember cznewt saying that the RPM-based stuff needed some love.
16:42:13 <jasondotstar> i saw a couple commits on that
16:42:27 <genunix> #link https://review.openstack.org/280606
16:42:55 <genunix> Yes, there already was some basic rhel support, but not maintained.
16:43:02 <jasondotstar> gotcha
16:43:07 <jasondotstar> how were you guys testing
16:43:08 <jasondotstar> ?
16:43:21 <genunix> some fixes are also needed in formulas not yet under openstack big tent
16:43:23 <jasondotstar> were you building and installing the packages in a test environment?
16:43:29 <genunix> #link https://docs.google.com/spreadsheets/d/12d0GcnlIIFpg4439jWL_bRqaGeLzzIG6nCkjCNDo45w/edit?usp=sharing
16:43:48 <genunix> Yes, clustered setup, everything on CentOS 7
16:44:48 <jasondotstar> oh
16:44:49 <jasondotstar> nice
16:44:50 <jasondotstar> ok
16:44:59 <genunix> formulas are not delivered by packages but using git clone (at least until we have RPMs)
16:45:34 <jasondotstar> +1
16:46:50 <jasondotstar> so we'll have to figure out gating
16:46:56 <jasondotstar> that actually builds the packages too
16:47:33 <jasondotstar> just to ensure that the spec files work
16:47:38 <jasondotstar> i think we're doing linting now
16:47:53 <jasondotstar> but we've got to fold in the other project gates
16:48:01 <genunix> yes, something like that, just rendering sls with specific pillars
16:48:07 <jasondotstar> right
16:48:31 <jasondotstar> do we merge these in prior to having them testing via a gate?
16:48:45 <jasondotstar> s/testing/tested
16:49:26 <jasondotstar> that's something we can noodle on I guess
16:49:47 <arif-ali> The spec files don't necessarily need to be imported into the projects, and would be in the openstack-packaging project, then we can utilise the CentOS delorean for packaging
16:50:01 <arif-ali> that is my understanding
16:50:12 <jasondotstar> +1
16:50:22 <genunix> it would be great
16:51:19 <jasondotstar> the review that's up there now
16:51:39 <jasondotstar> is adding the .spec to the salt-formula-* project though
16:51:55 <arif-ali> I just need to find where the tarballed packages will be for the salt formalas, then it can track these down
16:51:58 <jasondotstar> should we add those to openstack-packaging instead
16:51:58 <jasondotstar> ?
16:52:29 <arif-ali> yeah, that can possibly be discarded, and create new projects under openstack-packaging
16:52:48 <jasondotstar> #action arif-ali to confirm where the tarballed pkgs for the openstack salt formulas should be hosted
16:53:25 <jasondotstar> we should confirm that.... can you take that one, arif-ali?
16:54:29 <arif-ali> so the other spec files that they have, expect them to be at http://tarballs.openstack.org/<project_name>
16:54:36 <jasondotstar> #action arif-ali to confirm the appropriate location for the openstack-salt spec files
16:54:54 <jasondotstar> yea that looks like the right place
16:55:47 <jasondotstar> ok any other thoughts on the RPM-based packaging work?
16:56:07 <jasondotstar> if not, we'll open up the last five minutes for open discussion
16:56:40 <jasondotstar> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
16:57:22 <jasondotstar> genunix: sorry, i didn't realize that cznewt was teaching a salt workshop
16:58:42 <jasondotstar> is there anything else that we should bring up?
16:58:56 <jasondotstar> we good?
16:58:59 <jasondotstar> :-)
16:59:22 <genunix> I think it's all :)
16:59:43 <jasondotstar> cool. thanks team - cznewt, genunix, arif-ali
16:59:50 <jasondotstar> until next week.
16:59:59 <jasondotstar> we'll talk in chan.
17:00:03 <jasondotstar> #endmeeting