23:19:59 <seongsoocho> #startmeeting openstack_i18n_meeting
23:19:59 <opendevmeet> Meeting started Wed Apr  3 23:19:59 2024 UTC and is due to finish in 60 minutes.  The chair is seongsoocho. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:19:59 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:19:59 <opendevmeet> The meeting name has been set to 'openstack_i18n_meeting'
23:20:14 <seongsoocho> Okay
23:20:22 <ianychoi> Thank you
23:20:36 <ianychoi> #link https://www.openstack.org/software/openstack-caracal/
23:20:46 <ianychoi> Caracal is officially released!!
23:21:15 <ianychoi> Thank you for all the contributions i18n team
23:21:39 <seongsoocho> yay!!
23:21:56 <seongsoocho> #link https://www.openstack.org/software/openstack-caracal/
23:22:07 <ianychoi> I see at least seongsoocho ‘s name on the contributor list :p
23:22:55 <ianychoi> I have some updates/discussion points today but seongsoocho you can start first :)
23:25:50 <seongsoocho> ( oh sorry. I had a phone call..)
23:26:26 <ianychoi> No worries
23:28:06 <seongsoocho> Actually, I've been busy with other things from the last meeting until now, so I don't have anything to share.  Reflecting rosmaita's opinion, I'mnow changing from calling the API directly to using the weblate python library.
23:28:27 <rosmaita> i hope that's a good move!
23:28:44 <ianychoi> I commented on the review yesterday morning - have u seen this with any chance?
23:29:03 <ianychoi> Hi rosmaita !
23:29:07 <rosmaita> hello!
23:29:23 <seongsoocho> I haven't seen your comment yet. I'll check it out.
23:30:37 <seongsoocho> I'd like to show Ian a demo first, but I'll contact you separately.
23:31:00 <ianychoi> #link https://review.opendev.org/c/openstack/i18n/+/896306
23:32:02 <ianychoi> As i believe that during last release cycle, the code migration from zanata was to re-write zanata api code into weblate api code
23:33:24 <ianychoi> So i think it will be a great idea if we merge this as-is with small improvement (currently the code is not working), discuss wlc library usage during ptg, and revise the code
23:34:11 <tonyb> I agree, working first "optimal" later.
23:34:23 <seongsoocho> sounds great.
23:34:58 <seongsoocho> It's not working, but you're saying we should merge it first as a small improvement, right?
23:35:53 <ianychoi> Almost yes :p I am not saying as should - instead, I wanna say that reviewing under the context that the patch was proposed 6 months ago is also a good idea
23:36:37 <ianychoi> My initial point on the review was stat items on zanata vs. weblate, which was addressed through the meeting about one months ago
23:36:47 <seongsoocho> okay
23:37:07 <ianychoi> My second point on the review was the compatibility of API under Weblate current version - 5.4 and I see that the work is in progress on another patch
23:38:02 <ianychoi> So far, seems that Weblate - wlc library is much better than Zanata. Zanata did not have SDK and zanata-cli did not support translate stat APIs
23:39:00 <ianychoi> rosmaita: Your thoughts would be also highly appreciated
23:39:04 <ianychoi> (And hi tonyb!)
23:39:29 * tonyb waves :)
23:41:26 <ianychoi> Or we can discuss during the upcoming PTG
23:41:45 <rosmaita> ianychoi: i am ok with doing something quick now that moves us along, given that we are committed to improving it later
23:42:06 <ianychoi> (Sorry seongsoocho but it will be great if you set the next topic as ptg-discussion)
23:42:11 <ianychoi> Thank you rosmaita !
23:42:21 <seongsoocho> #topic ptg-discussion
23:42:27 <ianychoi> Thank you
23:42:48 <ianychoi> Some agendas I am thinking now for upcoming PTG is...
23:43:29 <ianychoi> 1. Moving forward on open reviews for i18n: at least, there are several pending items on openstack/i18n repo
23:44:34 <ianychoi> 2. openstack/i18n repository structure discussion to embrace the use of weblate - wlc library on tools/weblate and others including the addition of tox environment and corresponding requirements.txt
23:45:39 <ianychoi> 3. Pilot work progress discussion on governance translation support on weblate platform
23:46:32 <ianychoi> 4. Overall feasible migration plan discussion to sunset translate.openstack.org earlier than zanata.translate.org
23:47:33 <ianychoi> I will itemnize and enumerate into PTG Etherpad
23:47:35 <ianychoi> #link https://etherpad.opendev.org/p/apr2024-ptg-i18n
23:48:24 <ianychoi> I maybe something missing.. sharing any discussion topics on upcoming PTG via here or Etherpad would be great
23:49:22 <seongsoocho> Thank you for setting up the ptg agenda.
23:49:36 <ianychoi> #action ianychoi and others will post discussion topics on I18n PTG Etherpad
23:49:43 <ianychoi> seongsoocho: np :)
23:50:23 <ianychoi> For meeting rooms with dates & times, seongsoocho how many hours would like to block according to your survey? Thank you for the survey
23:50:44 <ianychoi> I am additionally check the availability and will book 1-2 more PTG rooms
23:51:25 <ianychoi> #action seongsoocho will block PTG rooms within 13-16 UTC on Fri 12
23:51:31 <seongsoocho> 12th Apr. 1300~1500UTC. 2hrs
23:51:42 <seongsoocho> oh 1600 ok
23:51:53 <ianychoi> #action ianychoi will block additional PTG rooms per more availability
23:53:11 <ianychoi> And not sure whether I can assign a small time slot on openstack-tc discussion for i18n topics.
23:55:43 <ianychoi> Let's see it and hopefully we can make fun during the upcoming PTG including i18n team :)
23:57:11 <ianychoi> If there is no more topics or open items to be discussed, I think that would be all regarding today meeting!
23:57:11 <seongsoocho> I am in Vietnam next week to participate in FOSSAsia. UTC-7 is an ambiguous time for PTG. But I'm so excited.
23:57:34 <seongsoocho> nothing from my side.
23:57:52 <ianychoi> I miss OpenStack Vietnam user group members :)
23:58:23 <ianychoi> Safe travel seongsoocho !
23:58:24 <seongsoocho> me.too.. THen I will close today's meeting
23:58:28 <seongsoocho> thanks!
23:58:34 <seongsoocho> #endmeeting