14:22:22 <eumel8> #startmeeting OpenStack I18n Meeting
14:22:22 <openstack> Meeting started Thu Jan 18 14:22:22 2018 UTC and is due to finish in 60 minutes.  The chair is eumel8. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:22:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:22:25 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
14:22:30 <eumel8> wah
14:22:30 <eumel8> :)
14:22:37 <jpich> woohoo :)
14:22:56 <eumel8> Welcome to the I18n team meeting
14:23:19 <ianychoi> :)
14:23:27 <eumel8> #info next week will be no meeting due my longer business trip
14:23:46 <ianychoi> Oh enjoy your trip :)
14:24:13 <eumel8> partly, it's a "must-attend" event from the management ;)
14:24:33 <eumel8> #topic translate-dev.openstack.org with Zanata 4.3.3 for tests available
14:24:37 <eumel8> first topic
14:25:00 <eumel8> since few days we have Zanata 4.3.3 on stage in translate-dev.o.o
14:25:24 <eumel8> the database was cleared and my new registration was sucessful (after some email issues)
14:25:55 <eumel8> I uploaded a project and some translation files, but tested not so much things
14:26:26 <eumel8> anyone else on the dev platform?
14:26:30 <ianychoi> "Service unavailable" now on https://openstackid-dev.openstack.org/accounts/user/login
14:26:39 <ianychoi> Oh it works again :)
14:27:31 <jftalta> indeed !
14:27:36 <eumel8> maybe sleeping database connection
14:27:46 <jftalta> I've just signed up...
14:28:03 <ianychoi> eumel8, "grey-listing of the confirmation email" in https://review.openstack.org/#/c/531736/ means that there is no recipient from "Zanata registration" e-mails?
14:29:30 <jftalta> I just received the account activation email and I've activated my account :-)
14:29:42 <eumel8> sender adress verification. If your email provider has some kind of feature, there is a problem because noreply@openstack.org gives a user unknown error
14:30:14 <eumel8> jftalta: yeah, you have a bad email provider ;)
14:30:54 <eumel8> don't no if there still discussions on the infra team to reconfigure the adress to /dev/null.
14:31:05 <ianychoi> Hmm, it is difficult to figure out current status on ianw's comment.
14:31:06 <jftalta> yes, a friend of mine, his name is Goo...something ;-)
14:31:12 <eumel8> Or we use another sender adress, we can configure this
14:31:32 <eumel8> jftalta: brave friend ;)
14:32:22 <ianychoi> Hmm, then should we use different sender e-mail address?
14:33:12 <eumel8> ianychoi: something else without user unknown. I don't know if this was a problem in the past. This is not specific to the new Zanata version.
14:34:59 <ianychoi> Hmm...
14:35:41 <ianychoi> I now confirm that it happened from Zanata 3.7.3 to 3.9.6 upgrade..
14:36:04 <ianychoi> From my seeing on my received e-mails from noreply@openstack.org
14:36:39 <eumel8> I have no idea which address we should use instead
14:37:06 <eumel8> zanata@openstack.org and then routing the adress to ...
14:38:58 <ianychoi> Let's ask to Zanata development team
14:40:27 <eumel8> sorry, but this is not specfic to Zanata
14:40:45 <eumel8> look here: #link https://en.wikipedia.org/wiki/Callback_verification
14:41:36 <eumel8> some people use this feature and sometimes it makes sense. On the other hand some kind of emails get lost, like in this case
14:42:31 <ianychoi> eumel8, I confirm that noreply@openstack.org was used from Zanata 3.7.3 and at that time recipient e-mail address was written. However, after upgrading to Zanata 3.9.6, it disappeared.
14:43:03 <eumel8> I would talk to the infra team. Maybe there are still some solutions in use.
14:43:47 <ianychoi> Okay
14:44:02 <eumel8> #action eumel8 will talk to the infra team to change the sender address in Zanata.
14:44:21 <eumel8> at least we need 2 addresses for dev and the  prod server
14:45:12 <eumel8> okay, we have still time for tests. I would start Zanata live upgrade after Release date.
14:45:52 <eumel8> maybe we get a new order to translate User Survey but this is not deciced yet.
14:46:11 <ianychoi> eumel8, https://git.openstack.org/cgit/openstack-infra/system-config/tree/manifests/site.pp#n1739 is the pointer I think
14:46:28 <eumel8> if yes, we would have some additional work and shift the Zanata upgrade after that.
14:47:08 <jftalta> we will have to warn the users (i.e. translators/reviewers) before to deploy on the Prod platform
14:47:19 <ianychoi> Agreed
14:47:44 <eumel8> ianychoi: yes, but you can change this: https://translate-dev.openstack.org/admin/server_configuration?dswid=-3777
14:47:59 <ianychoi> eumel8, yes of course
14:48:11 <eumel8> jftalta: yes, better we solve the issue.
14:48:33 <eumel8> ianychoi: what about the "dead button" in user settings?
14:48:41 <ianychoi> dead button?
14:48:56 <eumel8> "remove connection"
14:49:08 <eumel8> you mentioned this earlier
14:49:13 <ianychoi> I am scared on the button.
14:49:21 <eumel8> I know :)
14:49:30 <eumel8> you klick this and you're dead :)
14:49:43 <ianychoi> If I click the button, I think I cannot access translate-dev.o.o again
14:49:47 <eumel8> openid url will deleted in zanata database
14:50:11 <jftalta> :-(
14:50:26 <ianychoi> Yeah then nobody would help on this issue
14:50:28 <eumel8> ianychoi: you can register new, but an admin must remove your old user and I think this removes all your stats
14:51:15 <ianychoi> eumel8, unfortunately I cannot do it because I now have only one account in OpenStack Foundation.
14:51:39 <ianychoi> Even I register new account in openstack.org, this new account will not be synced with openstackid-dev
14:52:04 <eumel8> ianychoi: doesn't care. I tested it (remove connection) and after that a new registration form on zanata will start with your openid account
14:52:26 <eumel8> but you cant't use the old username in zanata because it's still in the database
14:52:56 <ianychoi> eumel8, ?? I already registered my account in translate-dev.o.o and I can access now
14:52:57 <eumel8> ianychoi: no, no new openstackid account. You can use the same.
14:53:14 <ianychoi> Since the database was cleared :)
14:53:56 <eumel8> ianychoi: yes, if you klick "remove connection" in zanata user settings, the openid url will deleted for your account in zanata dababase
14:54:13 <eumel8> all other data are still there and it works untill you need a new login
14:55:50 <ianychoi> Hmm
14:56:17 <eumel8> in a hard case, somebody could insert the openid url in database, but for daily work it's not possible
14:56:54 <ianychoi> Infra team can insert openid column manually but I think it is not a good idea
14:56:56 <eumel8> I didn't tested yahoo and fedora openid. I don't know what happen if you add more connections there
14:57:07 <ianychoi> Neither do I
14:57:44 <eumel8> uncertain if this is a bug or a feature
14:57:47 <ianychoi> I think it would be so nice if there is some settings in Administration menu which controls the visibility of openid section in users' settings
14:59:14 <eumel8> singleopenid is configured. But the other openid providers are still in the user settings.
14:59:38 <eumel8> if multiopenid is configured, then you have the options also on login and registration
15:00:43 <eumel8> admin should be able to configure openid url for user
15:01:18 <eumel8> but I'm not sure if we should wait for the feature or go on with the upgrade in prod
15:02:01 <ianychoi> eumel8, http://eavesdrop.openstack.org/irclogs/%23openstack-i18n/%23openstack-i18n.2017-12-06.log.html#t2017-12-06T01:20:24
15:02:20 <ianychoi> That is what I briefly discussed with pahuang about a month ago.
15:04:29 <eumel8> alright
15:04:35 <eumel8> thx for sharing
15:04:59 <eumel8> then I think we should move on with the upgrade in prod
15:05:11 <eumel8> we have the right version as zip file
15:05:43 <eumel8> I reworked the puppet module with war files but this is untested and duplicates the work for all
15:05:56 <eumel8> so we can update the puppet module later
15:06:21 <ianychoi> Good... thanks a lot for your on-going progress!
15:06:43 <eumel8> #link https://review.openstack.org/#/c/531809/
15:07:03 <eumel8> ^^ that's for the module upgrade
15:07:29 <eumel8> so, let's move on with the topics
15:08:11 <ianychoi> okay
15:08:20 <eumel8> #topic PTL election for Rocky
15:08:36 <eumel8> #link https://governance.openstack.org/election/
15:09:01 <jftalta> when will it occur ?
15:09:23 <eumel8> my time as PTL is nearly over. the next PTL election is in 2 weeks
15:09:42 <eumel8> nomination starts 01/29
15:09:47 <jftalta> time flies...
15:09:55 <eumel8> till 02/07
15:11:08 <eumel8> I'm still with you but if anyone is interested in Rocky PTL I would strong support this.
15:12:21 <eumel8> I didn't reached all goals in Queens and would focus the work a little bit more to our main work in Rocky.
15:12:24 <jftalta> on my part, I'm still supporting you
15:13:45 <ianychoi> Unfortunately it is so difficult for me to attend to next Dublin PTG. IMO it would be so nice if Rocky PTL will go to the PTG.
15:13:46 <jftalta> and yes, you need extra time to achieve the goals
15:14:19 <ianychoi> Surely, I would like to support all I18n activities :)
15:14:53 <eumel8> thx, I think we have great European teams in France, Germany, Russia ... but there are still some blind fields on the map and I would try this summer to cach more people for our team
15:15:39 <ianychoi> Sounds so great!
15:16:52 <eumel8> the next PTG will be in North America and I will not be there. because it's to much travel. Maybe we plan a virtual meetup instead. Some teams are doing this also for this cycle.
15:17:16 <eumel8> s/to/too/g
15:18:06 <ianychoi> jftalta, are you planning some travels on PTG or Summits this year?
15:18:07 <jftalta> sounds good
15:18:23 <jftalta> yes I do. Vancouver summity
15:18:28 <jftalta> *summit*
15:18:34 <ianychoi> Wow :)
15:19:02 <eumel8> I'm also booked for Vancouver
15:19:12 <jftalta> great :-)
15:19:20 <eumel8> switch topic
15:19:23 <eumel8> #topic: CFP Vancouver Summit
15:19:44 <eumel8> maybe the hour is over and the bot will end the meeting
15:20:10 <ianychoi> eumel8, the bot will not automatically terminate the meeting as far as I know.
15:21:23 <eumel8> CfP is open for Vancouver. I submitted a talk about community work and I18n technique. If someone is interested to join, then let me know.
15:22:01 <eumel8> unfortunatelly I can't share the proposal
15:24:16 <jpich> Good luck :)
15:24:27 <ianychoi> Good luck too! :)
15:24:45 <jftalta> do you need some help ?...
15:25:24 <ianychoi> How about jpich? R u also planning to attend to PTG or Summits? (Surely you will definitely go to Dublin PTG.)
15:25:26 <eumel8> jftalta: thx, maybe re-use some slides from Boston
15:25:36 <jftalta> ok
15:25:47 <ianychoi> Reusing is so nice :)
15:26:08 <jpich> ianychoi: Dublin PTG should be ok, yes :-] I have conflicting travel during Vancouver so I won't be going there
15:26:12 <jpich> also it's very far
15:26:27 <eumel8> jpich goes to the Dublin PTG? You make jokes!
15:26:29 <jpich> especially compared to Dublin ;)
15:26:54 <ianychoi> jpich, I see then Berlin would be more comfortable to u than Vancouver :)
15:27:12 <jpich> Yeah, I hope I can go to Berlin but it's too early to tell
15:27:21 <ianychoi> jpich, okay :)
15:27:28 <jpich> :)
15:27:38 <ianychoi> eumel8, haha :)
15:27:44 <jpich> any good timing for you and PTGs/upcoming Summits, ianychoi?
15:28:04 <eumel8> it seems in Dublin we are also a bit outside like in Denver.
15:28:39 <jpich> A bit yeah. I think it's not as bad though, and public transport is better
15:28:58 <eumel8> but it's Ireland, if you are on the country side, you will see the ocean
15:29:14 <ianychoi> jpich, Dublin PTG is so difficult for me. For others, unfortunately I cannot tell right now. But, I really want to go to Berlin to see eumel8's country :)
15:29:37 <eumel8> jpich: btw. you have trains? Maybe we will miss it...
15:30:45 <eumel8> ianychoi: you can drive by car here > 200 km/h
15:31:01 <jpich> eumel8: There's a couple of train stations within walking distances yeah. Plenty of buses too - that's how I'll be coming :)
15:31:02 <ianychoi> eumel8, Oh LoL :)
15:31:13 <jpich> ianychoi: Hope you can make it to Berlin! :)
15:31:38 <ianychoi> jpich, I hope so - thank u :)
15:32:06 <eumel8> ianchoi: but don't expect too much, it's not the best time to travel in November
15:32:17 <jftalta> I'll be in Berlin to
15:32:50 <ianychoi> eumel8, I can count numbers in German hehe :)
15:33:14 <jftalta> eins, zwei, drei, vier, funf, ....
15:33:15 <eumel8> jftalta: great! We started to organize the Summit last week so all attendees have a good feeling here
15:33:33 <jpich> Nice
15:33:40 <eumel8> you have to change keyboard layout ;)
15:33:54 <jftalta> yes !
15:34:06 <jftalta> fünf
15:34:13 <eumel8> ++
15:34:14 <ianychoi> Haha
15:34:24 <eumel8> a can approve this ;)
15:35:12 <eumel8> so, no problems with order drinks
15:36:05 <eumel8> I switch the topic
15:36:07 <eumel8> #topic: Queens Release translattion phase
15:36:34 <jftalta> a major topic...
15:36:47 <eumel8> let's look in the plan: #link https://releases.openstack.org/queens/schedule.html
15:37:25 <eumel8> scrolling down, down, down ...
15:37:37 <eumel8> soft string freeze starts next week Monday
15:38:10 <jftalta> yes. R-5
15:38:28 <eumel8> ianychoi: When you expect stable branching? In RC-1?
15:38:47 <ianychoi> (Looking)
15:39:24 <jpich> As usual, tripleo-ui is cycle-trailing and will start freezing a couple of weeks later... Also master branch translations are still broken, there are patches to help but we have to solve some general CI issues on the project first!
15:39:26 <jpich> (Working on it!)
15:40:43 <ianychoi> eumel8, yes but On Soft StringFreeze, encouraging translations on master branch first would be nice I think
15:41:07 <eumel8> jpich: thx
15:41:13 <ianychoi> since the time between RC1 and final RC are rather short
15:42:05 <ianychoi> jpich, just plz tell me or eumel8 after finally fixing this issue - we might need to re-fill out translation result from translation memory since translation source is currently empty on tripleo-ui
15:42:35 <jpich> ianychoi: Yes, I will reply to that thread and ping you both when it's finally resolved. Thanks for that, I'm relieved we can recover them!
15:42:56 <ianychoi> jpich, power of Zanata :)
15:43:01 <eumel8> ianychoi: alright, I will scan dev mailing list for infos and ask robcresswell, our valuable customer :)
15:43:04 <jpich> zanata++ :)
15:44:19 <ianychoi> eumel8, yep and also discussing with current Horizon PTL is good I think :)
15:44:30 <eumel8> ianychoi, jpich: tripleo-ui -> easy going, easy to translate
15:44:59 <jpich> Small mercies
15:45:44 <eumel8> ianychoi: of course. and after that trying to search new zuul jobs for sync the new branches ;)
15:46:13 <ianychoi> eumel8 is so great I18n PTL! :)
15:46:38 <eumel8> thx :)
15:46:49 <eumel8> #topic Open Discussion
15:47:17 <eumel8> so, there are more open discussions between the normal topics
15:47:30 <jftalta> It's getting late, I have to leave you...
15:47:37 <eumel8> but it was a very good meeting :)
15:47:51 <ianychoi> jftalta, have a good dinner :)
15:47:51 <eumel8> thx jftalta, have a nice evening
15:48:20 <jftalta> dinner, evening... no, just back to work !
15:48:30 <jftalta> ahaha
15:48:43 <ianychoi> jftalta, haha see u!
15:48:51 <jftalta> see u !
15:49:04 <jftalta> goodbye all !
15:49:37 <eumel8> alright, if there are no more topics, then thx to all for attending
15:50:13 <ianychoi> eumel8, are you planning to more deploy playbooks in openstack/i18n repo?
15:51:36 <eumel8> ianychoi: I think so, there is an URI module in Ansible which is good to work on APIs and I believe we will use Zanata API more in the future.
15:52:30 <eumel8> ianychoi: and sorry for my limited Python skills, but I wasn't able to write the stats script in this language.
15:53:58 <ianychoi> eumel8, now I have two more idea on that: 1) That idea looks nice if the playbooks will be integrated with Zuul jobs later to automate I18n stuff and u will guide more to me and other I18n team members and 2) Then I think adding a virtualenv for tox would be a good idea like http://git.openstack.org/cgit/openstack/openstack-ansible/tree/tox.ini#n100
15:55:40 <ianychoi> In my opinion, using playbooks is intended to automate jobs, not for scripting purposes. For scripting purposes, I think using shell script or Python would be much better for maintainability.
15:55:45 <eumel8> ianychoi: thx for the link. That makes really sense. And of course, integrating this kind of jobs in Zuul is also possible.
15:57:54 <ianychoi> #link https://docs.openstack.org/i18n/latest/tools.html
15:58:03 <eumel8> ianychoi: I can guide you in Ansible, of course, but I try also to understand Zuul jobs to test them locally or repair them when it's broken. But this takes time for understanding.
15:58:45 <ianychoi> "pip install -r test-requirements.txt" is better than describing specific versions in a document. From this idea, I found that sample in openstack-ansible repository.
15:59:23 <ianychoi> And like "tox -e venv -- python ./tools/zanata/zanata_stats.py " :)
15:59:46 <ianychoi> I simply installed "apt install ansible" but it seems that it installs so old ansible version.
15:59:57 <eumel8> ok, have to look into
16:00:19 <ianychoi> I think "pip install ansible" is better :)
16:00:51 <eumel8> just wondering about < 2.0 version. I won't ask which OS version you have installed ;)
16:01:44 <ianychoi> I am using Ubuntu 16.04 LTS and I now tell that installing with apt will result so old Ansible version.
16:02:07 <eumel8> mhmm, strange
16:02:44 <ianychoi> But on tox.ini in openstack-ansible repo, it seems that ansible version is specified as requirement and controlled by pip I think
16:02:53 <eumel8> 2.0.0.2-2 - indeed
16:03:41 <ianychoi> "ansible-playbook 2.0.0.2
16:03:42 <ianychoi> "
16:03:50 <ianychoi> but I saw the error unfortunately
16:04:47 <ianychoi> No more on open discussions from me
16:05:12 <eumel8> thx
16:05:19 <eumel8> #endmeeting