13:00:29 <Daisy> #startmeeting OpenStack I18n Meeting
13:00:30 <openstack> Meeting started Thu Feb 18 13:00:29 2016 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:34 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
13:00:39 <eumel8> hi ho
13:00:44 <Daisy> Hi, eumel8
13:00:52 <jftalta> #openstack-meeting
13:00:58 <Daisy> jftalta: Welcome
13:01:04 <ianychoi_phone> Hi!
13:01:04 <eumel8> Hi Daisy
13:01:05 <jftalta> Hello
13:01:05 <katomo> Hi, Daisy, eumel8
13:01:20 <eumel8> Hi katomo
13:01:21 <doug-fish> hi all
13:01:25 <katomo> hi jftalta ianychoi_phone
13:01:27 <Daisy> Great. It looks like we have all people here.
13:01:37 <Daisy> Then let's start.
13:01:39 <katomo> hi doug-fish
13:01:50 <Daisy> #topic Follow up with translation check website
13:02:21 <ujuc> hi
13:02:25 <Daisy> eumel8: can you describe the status of this work ?
13:02:52 <Daisy> I was a week away and I'm a little lost.
13:02:52 <katomo> hi ujuc
13:02:56 <eumel8> yes, review is starting. we're in the 2nd round. Fixed some issues, awaiting response drom infra team
13:03:09 <eumel8> from
13:03:21 <Daisy> Thank you.
13:03:33 <doug-fish> that's great! do you have a link to the patch?
13:03:35 <Daisy> Are there anything left that we can help ?
13:03:35 <katomo> great
13:04:08 <eumel8> maybe we can ask for more support from infra if they have time
13:04:08 <Daisy> doug-fish: https://review.openstack.org/#/q/owner:f.kloeker%2540telekom.de+status:open
13:04:23 <Daisy> What kind of support ?
13:04:26 <doug-fish> thx
13:04:29 <Daisy> quick response, maybe . :)
13:05:19 <eumel8> for review
13:05:52 <Daisy> ok. I will talk with pleia2 to see if she can spend more time with us.
13:06:13 <eumel8> thx
13:06:14 <ujuc> hi katomo :)
13:06:32 <Daisy> Anything else ? eumel8
13:07:04 <eumel8> no, I think we're in a final stadium
13:07:19 <Daisy> Thank you, eumel8.
13:07:27 <Daisy> Let's move to next topic then.
13:07:32 <Daisy> #topic Get ready for Mitaka translation
13:08:20 <Daisy> According to the Mitaka schedule, string freeze will happen in first week of March
13:08:47 <Daisy> I hope we could have a discussion here to figure out a TODO list before we start Mitaka translation.
13:09:15 <Daisy> I mean, we get ourselves ready for Mitaka translation.
13:09:38 <Daisy> Something in my mind.
13:09:40 <eumel8> priority list on Zanate should be updated
13:09:44 <katomo> okay
13:09:51 <katomo> yep
13:09:52 <Daisy> eumel8: Exactly.
13:10:00 <jftalta> yep
13:10:03 <Daisy> 1. Priority list on Zanata
13:10:18 <ujuc> ok
13:10:45 <katomo> I'll take
13:10:59 <Daisy> Thank you, katomo
13:11:01 <katomo> #action katomo email priority list on Zanata
13:12:39 <Daisy> 2. Use a clear communication method, even local language communication.
13:12:43 <katomo> anything else?
13:13:09 <katomo> good point
13:13:24 <Daisy> I think we use a clear unique communication method this time.
13:13:28 <Daisy> I perfer IRC.
13:13:45 <Daisy> If you need, we could create special IRC channel for different language team.
13:14:01 <Daisy> If you don't need, we use openstack-i18n to communicate any problems we meet during translation.
13:14:26 <doug-fish> It would be great if the language teams documented their preferred communication tool - is that done already?
13:14:42 <jftalta> a special IRC channel for each language team is a good idea
13:15:26 <eumel8> for small team it's not necessary
13:15:36 <Daisy> katomo, ujuc, ianychoi_phone: thoughts ?
13:15:54 <katomo> I think special channel is a good idea
13:16:22 <katomo> however, we japanese team has own Gitter chat room
13:17:02 <Daisy> katomo: do you think you will change to IRC or continue to use Gitter chat room ?
13:17:06 <ianychoi_phone> Me and ujuc encourages Korean people to use #openstack-ko channel, but few one uses it.
13:17:32 <Daisy> either we use a unique method, or we document clearly.
13:18:07 <eumel8> there is a special team page in i18n wiki. you can provide your favorite communication channel there.
13:18:14 <Daisy> Because after we start the busy translation, I hope each language team could have a good communication way.
13:18:34 <Daisy> good point, eumel8.
13:19:24 <ujuc> no. we team not using irc...
13:19:59 <Daisy> ujuc: what communication method do you use ?
13:20:17 <ujuc> slack and offline meeting :)
13:20:24 <ujuc> an facebook :0
13:20:33 <Daisy> ujuc: I think it's not good to use offline meeting. :)
13:20:48 <doug-fish> Daisy - I'm not sure if you shared that we will have IBM translators participating significantly in the translation of Mitaka (I guess if you haven't I just did) ...
13:21:06 <ujuc> yab...
13:21:10 <doug-fish> I'd like to be able to easily direct them to their proper language team communication channels so they can work cooperatively
13:21:13 <Daisy> doug-fish: No, you go ahead.
13:21:57 <doug-fish> we will have IBM translators participating significantly in the translation of Mitaka
13:21:59 <doug-fish> :-)
13:22:31 <doug-fish> we expect to cover the languages and components that we have previously contributed via batch updates
13:22:40 <doug-fish> I hope we don't have any more batch updates
13:23:16 <doug-fish> These are experienced and skilled translators, but they aren't necessarily familiar with OpenStack, our tools, or processes
13:24:09 <doug-fish> I'm working with Daisy to prepare some education to help make sure they are effective ... and again, back to my original question, what's a good way to get them engaged with their language teams?
13:26:02 <Daisy> :)
13:26:47 <eumel8> In Zanata you find only nicks and names in language groups
13:27:28 <Daisy> Before, IBM translated downstream and then contributed upstream in batch. This time, they want to use the correct way - working directly with us and following community process.
13:27:41 <katomo> Japanese team welcome IBM translators join our gitter room.
13:27:59 <Daisy> The good thing is we will have more resources and cover more components.
13:28:14 <Daisy> The bad thing is they are new comers and need our guidances.
13:28:31 <Daisy> Sorry, not the bad thing. I use a wrong word.
13:28:40 <Daisy> The disadvantage. :)
13:28:41 <katomo> :)
13:28:48 <jftalta> ;)
13:29:07 <katomo> we need new comers any time, and welcome.
13:29:21 <eumel8> IBM guys are welcome, yes
13:29:31 <Daisy> so this time, we must use a open and clearly defined communication way, which could allow new comers in different time locale to join us easily.
13:29:38 <jftalta> welcome in the french team too
13:29:59 <Daisy> Thank you for the kindness, team.
13:30:13 <doug-fish> yes thank you. I'm very excited about this participation.
13:30:22 <ianychoi_phone> :)
13:31:57 <eumel8> french team has also a wiki page, I saw. This should be the central information point for each language team in each language.
13:32:17 <eumel8> contact addresses are also there
13:32:33 <katomo> japanese team has, too.
13:33:05 <doug-fish> are the links off of https://wiki.openstack.org/wiki/I18nTeam the pages you are referring to?
13:33:12 <ujuc> korea team has, too :)
13:33:19 <eumel8> so, it's standard :)
13:33:29 <doug-fish> good - that makes things much easier!
13:33:39 <eumel8> i.e. https://wiki.openstack.org/wiki/I18nTeam/team/fr
13:34:00 <katomo> doug-fish: yes, linked from there "in Japanse :)"
13:34:16 <eumel8> de - we haven't. I will contact our team lead.
13:34:16 <katomo> #link https://wiki.openstack.org/wiki/I18nTeam/team/ja
13:34:37 <doug-fish> excellent
13:36:42 <Daisy> doug-fish: can you tell us more detail about your plan ? for example, how many translators, which projects do you want to cover and which languages ?
13:37:01 <doug-fish> sure
13:37:17 <ianychoi_phone> #link https://wiki.openstack.org/wiki/I18nTeam/team/ko_KR
13:37:25 <doug-fish> The languages and components are exactly the same set that we have contributed via batch before
13:37:40 <Daisy> Will you send people to translate Horizon ?
13:38:03 <doug-fish> yes some - mostly because I want to make sure they are interacting with the translation teams
13:38:47 <doug-fish> It seems that there are about 4 people involved from each translation center ... but I am guessing that's probably one project manager, one people manager, and two people who will actually be translating
13:38:55 <Daisy> I still don't know how many Horizon plugin will be covered in this release.
13:39:44 <doug-fish> The only plugin we are thinking about is the neutron-lbaas-dashboard, but it's not ready for translation yet
13:40:08 <doug-fish> We do have a need to translate many of the services that the team hasn't normally covered
13:40:24 <doug-fish> Ceilometer Cinder Glance Heat Keystone Neutron Nova and Swift
13:40:28 <Daisy> doug-fish: I hope that IBM could make Horizon the last priority after they translate other components.
13:40:41 <doug-fish> understood
13:41:01 <doug-fish> What are the current plans for Nova?
13:41:10 <Daisy> no plan, actually.
13:41:38 <Daisy> Actually, from the experience of last time translation, I don't think community translators want to translate back-end messages.
13:41:38 <doug-fish> I expect the IBM translators will need to handle then
13:42:01 <Daisy> so if IBM want to translate back-end messages, IBM do.
13:42:10 <doug-fish> ok
13:42:44 <Daisy> For horizon, it's open for all people. I think community translators will make it first priority.
13:42:48 <katomo> Daisy: agree
13:43:10 <doug-fish> Languages I expect to have IBM translators for: de es  fr  it  ja  ko_KR  pt_BR  ru  zh_CN  zh_TW
13:43:25 <jftalta> Horizon still remains a priority for the french team
13:43:46 <Daisy> Thank you, jftalta
13:44:43 <doug-fish> Daisy - I'm still thinking about priorities for the IBM translators ... I'd like to have them translate a small number of messages in Horizon to make sure their work gets reviewed and they are working in a manner consistent with the community.
13:44:47 <doug-fish> Do you think that's okay?
13:46:06 <eumel8> doug-fish: maybe you guys can also help translating Release Notes, because it's not ATC related
13:46:12 <eumel8> #link https://wiki.openstack.org/wiki/ReleaseNotes/Liberty
13:46:22 <jftalta> doug-fish: good idea, imho
13:46:46 <katomo> doug-fish: good idea
13:47:07 <jftalta> And this will be a way for them to increase their OpenStack knowledge.
13:47:10 <doug-fish> eumel8: surprisingly, I may not be able to ask them to do that ... but I'll look into it a bit more
13:47:33 <doug-fish> jftalta: yes, exactly
13:47:35 <katomo> eumel8: we have new reno tools, not a wiki, which doesn't have traslation feature AFAIK.
13:48:14 <eumel8> ah, ok
13:49:17 <Daisy> doug-fish: If IBM translators follow the TM and glossary, read the guidances ( if some language teams have ), IBM translators will work in a consistent manner, in theory.
13:49:33 <katomo> #action katomo contact reno team to ask whether reno has translation feature
13:49:56 <doug-fish> Daisy: understood. But sometimes theory !== reality.
13:50:06 <Daisy> doug-fish: exactly.
13:50:07 <eumel8> thx, katomo
13:50:22 <katomo> :)
13:50:34 <jftalta> Theory ? Don't know this country ;)
13:50:52 <doug-fish> ha!
13:51:08 <doug-fish> Reality is sometimes a foreign place as well.
13:51:47 <jftalta> yes, unfortunately
13:52:31 <doug-fish> So again, please let me know if this participation is not working well for any language team. It will be very new for our translators and I want to help make sure it is handled well.
13:52:58 <katomo> thanks
13:53:16 <Daisy> So I will make sure each language team have a clear communication method documented.
13:53:50 <Daisy> What else we need to do before we start Mitaka translation ?
13:54:27 <katomo> may be nothing
13:54:33 <katomo> #action Daisy make sure each language team have a clear communication method documented
13:54:42 <Daisy> Thank you, katomo
13:54:57 <Daisy> #open discussion
13:55:03 <Daisy> #topic open discussions
13:55:05 <eumel8> Glossary management? Are there some progress?
13:55:18 <Daisy> Good point, eumel8.
13:55:25 <eumel8> I think it's also important for new translators
13:55:38 <Daisy> Yes.
13:55:42 <katomo> yeah
13:56:21 <Daisy> do you agree we send patches to i18n repo directly to update the glossary ?
13:56:33 <jftalta> Glossary is a true issue, for sure
13:57:11 <ujuc> um..
13:57:33 <katomo> I'm okay as work around at now
13:57:42 <jftalta> We need a way to share and update the local language glossary in an efficient manner
13:58:11 <Daisy> These are what we have.
13:58:13 <Daisy> http://git.openstack.org/cgit/openstack/i18n/tree/i18n/locale
13:58:57 <katomo> jftalta: agree, but it seems to need looooooong discussion
13:59:23 <Daisy> I remember Zanata will provide glossary editor feature in some version, I forget the number.
13:59:30 <jftalta> katomo: really ?
13:59:36 <Daisy> I forget the version number.
13:59:47 <katomo> Daisy and amotoki tried at once, but not complete.
14:00:19 <Daisy> I'm looking forward to this feature which can give an easy way to edit glossaries.
14:00:33 <jftalta> daisy: ok. And what could be the git workflow ?
14:00:45 <eumel8> I think it's to discuss in the language team and then we come together in next meeting
14:00:52 <eumel8> because ... time is over :)
14:01:14 <Daisy> jftalta: if you have any updates to glossaries, send a patch to update your po file.
14:01:22 <Daisy> ok, eumel8.
14:01:29 <Daisy> Let's close it soon.
14:01:31 <jftalta> daisy: ok, got it.
14:01:42 <Daisy> Thank you guys for attending.
14:01:51 <Daisy> We have a good discussion today.
14:02:05 <eumel8> thanks all
14:02:07 <Daisy> I will close the meeting then.
14:02:10 <Daisy> #endmeeting