07:00:18 <Daisy> #startmeeting OpenStack I18n Meeting
07:00:19 <openstack> Meeting started Thu Sep  5 07:00:18 2013 UTC and is due to finish in 60 minutes.  The chair is Daisy. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:23 <openstack> The meeting name has been set to 'openstack_i18n_meeting'
07:00:34 <Daisy> Hello, everyone.
07:00:36 <Daisy> Who are there?
07:00:42 <ujuc> Hi~
07:00:50 <Daisy> I see ujuc . Nice to meet you, ujuc!
07:00:50 <ujuc> :)
07:01:03 <jpich> Hello, Daisy
07:01:03 <ujuc> :))
07:01:05 * Fdot is here \o_
07:01:12 <Daisy> Hi, jpich !
07:01:17 <Daisy> Hi, Fdot !
07:01:18 <ujuc> HI, jpich!
07:01:26 <Fdot> Hello Daisy !
07:01:29 <Daisy> jpich is from Horizon team. Welcome !
07:01:29 <ujuc> Hi, Fdot :) z
07:01:49 <Daisy> We haven't been talking for a long time.
07:01:54 <Daisy> Three weeks passed.
07:02:11 <Daisy> because last month had 5 Thursday.
07:02:17 <Daisy> ok. Let's start.
07:02:30 <Daisy> #topic Action items from the last meeting
07:02:48 <Daisy> we have only one action item last meeting.
07:02:48 <Daisy> Daisy to continue to track the glossary and source language issue.
07:03:06 <Daisy> It's done. I have reported the updates to you through emails.
07:03:18 <Daisy> Fdot: all the glossaries have been imported.
07:03:32 <Fdot> Daisy : That's a great news :)
07:03:32 <Daisy> I did it by program, not manually.
07:03:35 <Fdot> Thanks a lot :)
07:03:48 <ujuc> Thanks~~~~ :), Fdot
07:04:16 <Daisy> we will move to the major topic today.
07:04:17 <Daisy> #topic Horizon I18n version release process
07:04:30 <Daisy> https://wiki.openstack.org/wiki/Havana_Release_Schedule
07:04:43 <Daisy> This is the release schedule of Havana.
07:04:55 <Daisy> The translation and translation test progress need to match Havana release.
07:05:13 <Daisy> Since it's the first release after i18n team setting up, I don't want to cover a big scope and set up a big goal.
07:05:28 <Daisy> So I will set our goal as "help to deliever high quality of internationalized Horizon in Havana.".
07:05:41 <Daisy> We will not cover messages tranlation this time, because of two reasons: (1) user facing message and log message are not separated. (2) the team are not ready enough to do such a big workload of message translation and test.
07:06:07 <Daisy> Horizion I18n will be the first project we make in OpenStack.
07:06:20 <Daisy> Next release, we may cover user facing messages and a few more projects.
07:06:24 <Daisy> agree ?
07:06:48 <Daisy> comments ?
07:07:08 <jpich> Sounds good to me :)
07:07:18 <ujuc> agree~~ :)
07:07:45 <Daisy> Fdot ?
07:07:54 <Fdot> agree
07:07:56 <Fdot> :)
07:07:59 <Daisy> thanks.
07:08:05 <Daisy> Then let's discuss about the timelines.
07:08:18 <Daisy> Sep 4 is the string frozen date. But I think we cannot assume 100% frozen.
07:08:49 <Daisy> So I will work together with Horizon team to update po files weekly till the end of release.
07:08:55 <Daisy> jpich: your opinion?
07:09:17 <jpich> Daisy: There are a few issues in the gates at the moment and patches are slow to merge, so I think the cut might be made later today when all approved patches are merged
07:09:24 <Daisy> jpich: can Horizon team to make sure each patch that changes strings will run message generation scripts?
07:09:39 <jpich> Daisy: We'll pay attention to it, yes
07:09:48 <Daisy> thanks.
07:09:54 <jpich> And avoid string changes unless they are really necessary
07:10:16 <Daisy> Again, I will check the syncronization weekly. If I find not syncronized, I will upload patch.
07:10:29 <jpich> Daisy: I just remembered something, do you know if django_openstack_auth is on Transifex?
07:10:35 <jpich> It contains the strings for the Horizon login page
07:10:38 <Daisy> jpich: when will all approved patches being merged?
07:10:42 <jpich> https://github.com/openstack/django_openstack_auth/blob/master/openstack_auth/locale/en/LC_MESSAGES/django.po
07:11:00 <Daisy> I don't see django_openstack_auth.
07:11:07 <Daisy> Is it a separate project ?
07:11:30 <jpich> Daisy: Hopefully today, it's unclear because a bug is slowing down the gate. I can let you know when it is completed
07:11:32 <jpich> Yes, it is
07:12:02 <Daisy> if so, we need to add this project. Is diango_openstack_auth being used by only Horizon?
07:12:18 <jpich> Yes
07:12:18 <Daisy> If it is only used by Horizon, can we add it to Horizon project ?
07:12:32 <jpich> That would make sense to me, yes
07:12:36 <Daisy> we can add a new resource to Horizon project.
07:12:38 <Daisy> good.
07:12:41 <jpich> Great! Thanks
07:12:47 <Daisy> Then the first to item:
07:13:03 <Daisy> #action Daisy to add diango_openstack_auth to Transifex.
07:13:24 <Daisy> ok. Let's continue.
07:13:29 <Steff00> hello
07:13:36 <Daisy> Hello, Steff00 !
07:13:40 <Daisy> Fdot is there.
07:13:45 <ujuc> Hi, Steff00!
07:14:01 <Daisy> We are talking about the release plan of Horizon I18n now.
07:14:06 <Daisy> Sep 26th is the first release candidate. There will be 3 release candiates till the formal release. I will do a translated strings downloading and merging back to code repository two days before each release candidate. That is Sep 24th, Nov 1nd and Nov 8th.
07:14:26 <Daisy> How do you think about it, jpich ?
07:15:39 <jpich> Daisy: I'm not sure about the November dates, the release will be on October 17th
07:15:51 <Daisy> right.
07:15:58 <Daisy> https://wiki.openstack.org/wiki/Havana_Release_Schedule
07:16:02 <Daisy> Look at this table.
07:16:05 <ujuc> Oct 1, Oot 8?
07:16:20 <Daisy> I don't understand release manage clearly. I just see this table.
07:16:25 <jpich> We can keep updating after the release of course (there will be a stable release one month after the release)
07:17:13 <jpich> Daisy: The release candidates will be made over 3 weeks, from the 26th to 17th at the latest. There will be a RC1 for sure, but RC2 / RC3 will only happen if needed (e.g. serious bug fixes needed)
07:17:32 <Daisy> Thanks for the information. very helpful.
07:17:40 <Daisy> So we need a merge before RC1.
07:17:45 <jpich> Agreed
07:18:08 <Daisy> How can I know the exact RC1 date?
07:18:35 <jpich> I would say Sept 26th based on the wiki
07:18:52 <Daisy> OK. I will do a merge at Sep 24th.
07:19:10 <Daisy> in order to leave enough time for the review and merge process.
07:19:29 <jpich> Makes sense
07:19:38 <Daisy> In Sep 24, I will check the Transifex to see which langauges are ready to be merged. The languages who finish 100% translation and 100% review are ready to merge.
07:20:00 <ujuc> OK~
07:20:07 <Daisy> so "100% translation and 100% review" are the conditions of merging into code repository.
07:20:28 <Daisy> we need to have different people working as reviewer and translators, to ensure the quality.
07:20:47 <Daisy> Before merge, I will send email to mailing list to ask for oppositions for merging these languages. If no oppositions, I will do the merge.
07:20:59 <Daisy> Any comments? Any suggestions? Any oppositions?
07:21:31 <Daisy> Fdot and Steff00 : are you team have difficulties to finish the translation and review before Sep 24?
07:21:38 <Daisy> only Horizon.
07:21:40 <ujuc> yes~
07:22:08 <Daisy> ujuc: do you have difficulties ?
07:22:13 <Fdot> Daisy I don't see any difficulties ;)
07:22:16 <ujuc> no~
07:22:18 <ujuc> no~
07:22:25 <Fdot> For translation it is going to be fine
07:22:38 <Fdot> maybe the review will take more time ;à
07:22:39 <Fdot> ;)
07:22:45 <Daisy> thanks. Only horizon is not a big workload, I think. I see many languages have reach 70%.
07:23:10 <Daisy> I also want to do the translation test. The goal of translation test is to verify if the strings in UI are correctly displayed and translated.
07:23:30 <Daisy> Of course, we want test in all langauges environment, but we may not have so many resources.
07:23:45 <Daisy> So we need pick out at least two languages and do the test. If horizon in these two langauges runs well, we can assume it's ok for other languages.
07:24:12 <Daisy> The translation test should be done several days before the first release candidate, in order to get enough time to fix bugs if we find important bugs while testing.
07:24:26 <Daisy> So I will set the target date to finish the test by Sep 20th.
07:24:43 <Daisy> I can raise my hand to offer Horizon test in Chinese. Can I get another volunteer to do the test?
07:25:17 <Daisy> no ?
07:25:46 <jpich> Maybe people can ask their teams if someone is interested in doing it
07:26:03 <Daisy> I can publish this question to mail list to see if I can get another tester.
07:26:06 <Fdot> Agree \o_ :)
07:26:11 <Daisy> :))
07:26:28 <Daisy> #action Daisy to get another tester for Horizon I18n.
07:26:50 <Fdot> I am not sure but in Cloudwatt team we probably have someone who will be able to do it in French
07:26:59 <Fdot> I will forward him your e-mail ;)
07:27:06 <Fdot> it will be easier
07:27:07 <Daisy> thanks, Fdot .
07:27:47 <Daisy> I have expressed all my thoughts about horizon I18n release plan.
07:27:56 <Daisy> any questions? comments?
07:28:08 <Fdot> #action Fdot is going to see with the Cloudwatt horizon team if they can help on testing the french translation with Daisy
07:28:21 <Daisy> Thanks, Fdot .
07:28:32 <Fdot> Daisy just one question about the glossary
07:28:33 <Daisy> jpich: do you have any concerns?
07:28:43 <Fdot> is it possible to add the french language
07:28:51 <Daisy> yes, it is.
07:29:05 <jpich> Daisy: Nope, that sounds great, thanks! I'd also like to mention from my experience last release, we're flexible enough with RCs so if people find a serious translation bug after RC1 we can fix it and do a RC2
07:29:05 <Fdot> so we will be able to upstream what we have already translate with steff00
07:29:16 <Fdot> I don't see it :(
07:29:32 <Daisy> Fdot: you can go to a certain project, for example, Horizon, click on the "view glossary", and select your language.  Then you can define the translation of glossary in your own language.
07:29:50 * Fdot is testing :)
07:30:09 <Daisy> thanks for your information, jpich .
07:30:32 <Daisy> It's my first time to experience OpenStack release.
07:30:43 <jpich> It'll be fun :-)
07:30:49 <ujuc> ;)
07:30:51 <Daisy> sure it will.
07:31:12 <Daisy> then we move to next topic.
07:31:21 <Daisy> #topic Translated document publish process
07:31:35 <Daisy> The job to build Ja ops is in the Jenkins, although it haven't run successfully.
07:31:46 <Daisy> https://jenkins.openstack.org/view/Openstack-manuals/job/openstack-operations-guide-ja/
07:32:49 <Daisy> But I don't know the progress with website patch.
07:33:01 <Daisy> Akihiro is working on it. But I guess, he should be very busy recently.
07:33:18 <Daisy> so I will track the progress offline by email.
07:33:32 <Daisy> #action Daisy to track the progress of ja document website.
07:34:25 <Daisy> http://summit.openstack.org/
07:34:49 <Daisy> Anne Gentle registerred a proposal here to discuss about the translated document publish process.
07:35:04 <Daisy> who will attend the summit in HongKong this time?
07:35:50 <Fdot> Daisy unfortunatly not me :(
07:35:57 <Daisy> sorry to hear that.
07:36:10 <Fdot> Too many works
07:36:14 <Daisy> Fdot: are there any people from French translation team will join the summit?
07:36:26 <ujuc> not me..... :(
07:36:53 <jpich> I'll be attending
07:37:03 <Fdot> Daisy : there will be some people from Cloudwatt which are helping me on the translation
07:37:16 <Daisy> good, jpich. We can meet there then.
07:37:17 <Fdot> so they will be in charge to represent me ;)
07:37:37 <Daisy> Great, Fdot. I'm sure there will be some sessions related with I18n.
07:37:51 <Daisy> I hope to see some people there.
07:37:58 <ujuc> ^_^ b
07:37:58 <uvirtbot> ujuc: Error: "_^" is not a valid command.
07:38:12 <ujuc> (^_^) b
07:38:35 <Daisy> ok. I think I have finished the things I want to address.
07:38:48 <Daisy> #topic Open discussion
07:39:17 <Fdot> Daisy Just test the glossary
07:39:23 <Daisy> does it work?
07:39:24 <Fdot> It rocks ! \o/
07:39:29 <Fdot> Thanks a lot
07:39:43 <Fdot> I have started to upstream what we have already done
07:39:55 <Daisy> Great !
07:40:08 <Fdot> It is going to be very helpfull for our team
07:40:14 <Daisy> Maybe I can provide you the cvs file, you update the cvs file, and I can try to upload.
07:40:19 <Daisy> That will be easier for you.
07:40:31 <Daisy> Is it helpful ?
07:40:35 <Fdot> Oh yes ! It could be very nice
07:40:39 <Fdot> and quicker :)
07:40:50 <Daisy> good. Then we do it offline.
07:41:00 <Daisy> #action Daisy to send the cvs file to Fdot
07:41:07 <Fdot> Thanks a lot :)
07:41:19 <Daisy> welcome ! I'd like to do anything I can help.
07:41:29 <Daisy> anything else ?
07:41:49 <Daisy> no ?
07:42:00 <Fdot> Ok for me :)
07:42:12 <Daisy> then I will close the meeting and you can go back to your busy work. :))
07:42:15 <ujuc> :)
07:42:20 <Daisy> Thank you all for attending.
07:42:35 <jpich> Thanks
07:42:43 <Daisy> we will touch offline.
07:42:45 <Daisy> #endmeeting