15:00:15 <srwilkers> #startmeeting openstack-helm
15:00:16 <openstack> Meeting started Tue May 28 15:00:15 2019 UTC and is due to finish in 60 minutes.  The chair is srwilkers. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:20 <openstack> The meeting name has been set to 'openstack_helm'
15:00:39 <howell> o/
15:00:46 <srwilkers> hey everyone -- let's give it a few minutes for others to roll in
15:00:55 <jsuchome> o/
15:01:09 <srwilkers> agenda pad is here: https://etherpad.openstack.org/p/openstack-helm-meeting-2019-05-28
15:01:12 <srwilkers> sorry it came late
15:01:25 <srwilkers> feel free to throw anything on there -- let's give it til 5 past
15:02:55 <evrardjp> o/
15:03:04 <mattmceuen> o/
15:03:49 <jayahn> o/
15:04:12 <cheng1__> o/
15:04:25 <gagehugo> o/
15:05:13 <srwilkers> okay - it's 5 past
15:05:19 <georgk> hi
15:05:40 <srwilkers> i know we got the etherpad out late -- at  the moment, i'm not seeing any items on the agenda
15:06:05 <srwilkers> so i suppose we can free style this one a bit -- are there any pressing items anyone would like to discuss today?
15:06:32 <evrardjp> if none, we can wrap this one very early
15:06:36 <jsuchome> itxaka has someting, afaik
15:06:39 <jayahn> i would like to discuss about meeting time, but probably for next week.
15:06:40 <evrardjp> I guess we have pending reviews?
15:06:41 <georgk> I'd like to ask for a workflow +1 on this one
15:06:52 <georgk> https://review.opendev.org/#/c/659581/
15:06:58 <itxaka> o/
15:07:01 <jayahn> it seems like there are three parties from asian region, skt, intel china, samsung
15:07:02 <georgk> thanks! :-)
15:07:20 <evrardjp> srwilkers: you see the result, everyone comes with some info :p
15:07:34 <srwilkers> georgk: done
15:07:40 <srwilkers> hey itxaka
15:07:49 <itxaka> o/
15:07:57 <georgk> srwilkers: thank you very much!
15:08:07 <jsuchome> jayahn: would it make sense to create a poll?
15:08:13 <itxaka> a bit late sorry about that
15:08:21 <evrardjp> What I want to raise, is the fact that LOCI builds are broken nowadays, but I am on the fixes, so it will unlock the image building pipelines in osh-images.
15:08:54 <evrardjp> so, sorry for brokenness, due to external factors basically.
15:09:07 <srwilkers> evrardjp: thanks for tackling that
15:09:21 <jayahn> jsuchome: probably yes. :) but, we were considering two options; having two meeting in a day (12 hour apart each other) vs. adjusting the current meeting time slightly preferable for asian region.
15:09:44 <evrardjp> FYI we can already mark patches as +w, we'll just need rechecks when the time arises
15:10:04 <jayahn> and evrardjp: suggested leveraging office hours.
15:10:35 <srwilkers> evrardjp: sounds good
15:10:40 <jayahn> so we probably need to gather which option is preferable among those, then go for a poll
15:10:43 <evrardjp> jayahn: I said that in a certain context, assuming mindset changes, and work on the ML too .
15:10:59 <evrardjp> what I want to add, is that this decision should be recorded on eavesdrop's agenda.
15:11:00 <jayahn> evrardjp: yeap. that was an important part of it.
15:11:01 <evrardjp> sorry
15:11:08 <evrardjp> on eavesdrop's ics file.
15:11:28 <evrardjp> in other words, here: http://eavesdrop.openstack.org/#OpenStack-Helm_Team_Meeting :p
15:11:37 <srwilkers> jayahn: i think a poll's a good idea -- i think this discussion would benefit from having a quorum of cores and the PTL present, but unfortunately we don't have that today
15:13:05 <jayahn> srwilkers: yeap, I agree. so probably for the next week
15:13:06 <evrardjp> I think it's not only about cores, but about where the community is... You don't have cores in Asia, yet, there are ppl in asia which want to speak to the OSH community leaders
15:13:37 <evrardjp> it's not only to them to do the effort (else you will not grow the community)
15:13:42 <itxaka> agreed on that ^^^
15:13:48 <evrardjp> I believe if there is a poll, it should be to the majority
15:13:58 <jayahn> however, i really want to have somewhat active discussion on these options, and how we address issues.
15:14:01 <srwilkers> evrardjp: im not saying it's only about cores, but discussing moving the meeting time and adjusting the quantity of meetings would benefit from their opinions and input before we can action on it
15:14:12 <jayahn> evrarjdp: describes better than me. :)
15:14:22 <evrardjp> ofc, when it comes to the decision on WHEN to run it, because cores are running the show, then it matters what they decide
15:14:44 <evrardjp> but at least they will have a "global" informed decision
15:14:52 <evrardjp> srwilkers: agreed :)
15:15:43 <evrardjp> jayahn: I am confused, wasn't there a poll recently though?
15:16:04 <evrardjp> sorry if I am mistaken, but we talked about it, at least
15:16:05 <jayahn> evrardjp: nope, no poll so far.
15:16:08 <evrardjp> ok
15:16:15 <evrardjp> sorry, my mind is confused :)
15:16:25 <jayahn> there was poll at airship though.
15:17:48 <jayahn> so, there is a bit more complexity here, since osh meeting time should align with airship. (technically speaking, osh does not need to have a strong dependency on ariship, but in reality, there are lots of people working for both projects)
15:19:53 <srwilkers> i dont disagree, but this is also where challenges arise with the proposed two meeting option
15:20:28 <srwilkers> from my perspective anyway
15:20:44 <jayahn> fyi, the sole reason I am asking for time changes, to encourage people in my region to come to the meeting by giving a better time than midnight.
15:22:05 <evrardjp> I don't have something to add there, I think a poll is fair
15:22:18 <srwilkers> i'll ping portdirect and get him to get the poll sent out asap so we can get a path forward here hopefully
15:22:22 <evrardjp> there is one more core too, so it might impact the team availability
15:22:28 <evrardjp> positively*
15:22:34 <evrardjp> srwilkers: thanks!
15:22:35 <srwilkers> yep
15:23:04 <jayahn> srwilkers: thansk
15:23:59 <srwilkers> anything else in regards to the meeting time topic?
15:25:23 <jayahn> I can better present what I think via written (like email) than real-time discussion. therefore, I will also writhe something before the meting about this. :)
15:25:45 <srwilkers> sounds good
15:26:04 <evrardjp> thanks jayahn
15:26:21 <evrardjp> I know it's not easy to speak when it's not your native language
15:26:42 <srwilkers> #action srwilkers to bug portdirect about sending poll wrt meeting times as soon as feasible
15:28:20 <srwilkers> alright, going to move on here
15:28:39 <srwilkers> #topic rbd pool app names:
15:28:44 <srwilkers> itxaka: floors yours
15:28:51 <itxaka> yep
15:29:36 <itxaka> so basically whats in there, a change to allow changing the app name for a ceph pool
15:30:40 <itxaka> as I dont have much experience with ceph pool/apps, especially in the context of helm was hoping someone may be able to comment on that, any side issues that could come from not having the default names and so on
15:31:17 <srwilkers> that's a good question -- unfortunately one i don't have an answer readily available for
15:31:21 <itxaka> as fas as I could see, that should not change anything, but someone more knowledgeable on that may have a different opinion
15:31:51 <evrardjp> at least the question is asked :)
15:31:58 <itxaka> so consider this a cry for help for those ceph masters in the community :D
15:32:47 <mattmceuen> itxaka are you thinking of changing the name in a live site, or just deploying with a different name?
15:32:49 <jsuchome> I'm just surprised someone would need to modify this, for given component (e.g. glance) ... but I am not expert either
15:33:14 <itxaka> deploying with different name!
15:33:28 <itxaka> I would not tackle changing on a live site, that would be terrible
15:33:35 <mattmceuen> +1 :D
15:33:51 <cheng1__> itxaka, what's the benefit of allowing customized pool names?
15:34:17 <itxaka> plus with the current script it wont be able to change it becuase you need to pass an override flag to remove the old app and set the new one
15:34:33 <jsuchome> it's not pool names AFAIU (those are already customizable)
15:34:42 <jsuchome> it's the app name that's supposed to use certain pool
15:34:46 <itxaka> cheng1__, its app names inside the pool
15:34:47 <jsuchome> (correct me if I'm wrong)
15:35:21 <itxaka> I guess the same as in the pool name, configuration from the user, I guess it could have more impact on the ceph administration part
15:38:22 <itxaka> nothing more from me regarding this, if anyone is interested in more comments or discussing this, please see both of the patch sent and we can talk in there
15:38:29 <itxaka> srwilkers, ok for me to move on
15:38:30 <srwilkers> sounds good itxaka
15:38:49 <srwilkers> any other topics before we move on to requests for reviews?
15:40:04 <srwilkers> #topic reviews
15:40:10 <srwilkers> https://review.opendev.org/660544
15:40:10 <srwilkers> https://review.opendev.org/#/c/659615/
15:40:11 <srwilkers> https://review.opendev.org/#/c/655426/
15:41:03 <srwilkers> any others to list here?
15:41:31 <itxaka> yay periodic building of images!
15:41:48 <srwilkers> :)
15:41:58 <srwilkers> #topic roundtable
15:42:18 <srwilkers> i know this whole meeting has been a round table discussion more or less, but i figured i'd open it up anyway
15:42:20 <srwilkers> also
15:42:49 <srwilkers> i didn't see any follow up on the mailing list thread, but i just wanted to say welcome to the core reviewers team itxaka :)
15:42:59 <itxaka> yay \o/
15:43:30 <jayahn> Congratulations !
15:43:34 <mattmceuen> Yes welcome!!
15:43:45 <srwilkers> any other items before we wrap it up?
15:44:44 <jayahn> https://review.opendev.org/#/c/660572/
15:44:44 <jayahn> https://review.opendev.org/#/c/659993/
15:44:44 <jayahn> https://review.opendev.org/#/c/659732/
15:44:48 <jayahn> pls :)
15:44:59 <evrardjp> congrats!
15:45:37 <jayahn> and this https://review.opendev.org/#/c/660695/
15:46:12 <srwilkers> thanks jayahn
15:46:23 <mattmceuen> Also: https://review.opendev.org/#/c/644388/ - HA Postgres
15:46:35 <mattmceuen> please and thank you :)
15:47:55 <srwilkers> alright everyone, thanks for coming today.  chat with you all in the normal osh channel
15:47:58 <srwilkers> #endmeeting