14:59:36 <mattmceuen> #startmeeting openstack-helm
14:59:37 <openstack> Meeting started Tue Feb  6 14:59:36 2018 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:40 <openstack> The meeting name has been set to 'openstack_helm'
14:59:54 <mattmceuen> #topic rollcall
15:00:06 <srwilkers> \m/
15:00:08 <jayahn> o/
15:00:12 <portdirect> ᕕ(⌐■_■)ᕗ ♪♬
15:00:17 <mattmceuen> https://etherpad.openstack.org/p/openstack-helm-meeting-2018-02-06 <- agenda
15:00:18 <lamt_> o/
15:01:03 <gmmaha> o/
15:01:30 <icolwell> o/
15:01:33 <d|k> o/
15:02:14 <mattmceuen> #topic Office Hours: The Final Chapter
15:02:30 * srwilkers thinks it was Colonel Mustard with the candlestick again
15:02:42 <alanmeadows> o/
15:02:45 <mattmceuen> Thanks everyone who volunteered potential office hours in the survey
15:03:13 <mattmceuen> I gathered the results, and for the most part, there were three different hours in a normal week that captured most folks.  I added them into the agenda if you want to take a look.
15:04:28 <mattmceuen> There were a couple of folks that didn't fit in and had their own hours.  I'd like to
15:04:28 <mattmceuen> 1. call the first three blocks the offical office hours for OSH
15:04:28 <mattmceuen> 2. see whether the two other folks (v1k0d3n and lrensing) are able to make any of those
15:04:28 <mattmceuen> 3. if not, they'll have to have their own office hours :)
15:05:15 <mattmceuen> Friday 4pm UTC, Tuesday 2pm UTC, Tuesday 10pm UTC would be the office hours
15:05:44 <mattmceuen> (Tuesday 8am and 4pm CST, Friday 10am CST)
15:05:55 <mattmceuen> Any concerns with that approach?
15:06:22 * portdirect wonders how many meetings will cut into 9-5 slots :trollface:
15:06:51 * mattmceuen gavels
15:06:54 <portdirect> works for me :)
15:07:08 <mattmceuen> I'll post on the wiki and send out an email on the list.  Thanks all!
15:07:38 <mattmceuen> #topic Discuss roadmap for OpenStack supported versions in OSH
15:07:55 <jayahn> that is a topic for ptg discussion, i guess.
15:08:22 <jayahn> I already put this topic in ptg agenda, unless someone has some answer on this at this moment
15:08:38 <mattmceuen> We def should discuss at PTG, but I thought we could at least put down a few thoughts in prep since not everyone will be there
15:09:01 <portdirect> On that point, I'd like to attend via video if possible
15:09:24 <jayahn> as long as i remember, the cut-off condition was "a reasonalbly good working gating".
15:09:42 <jayahn> portdirect: you are not coming to Dublin?
15:10:12 <portdirect> ++ to you point jayahn, and  we need to do it - though I think the time to do this is after the fabled 1.0 release, which encompases the gating
15:10:21 <srwilkers> portdirect: i wasn't kidding when i said id bring my ipad and just run some sort of video conference on it so we can take you everywhere
15:10:25 <mattmceuen> not an answer jayahn :)  but the critical path in my mind is:
15:10:25 <mattmceuen> 1. someone creates non-voting gates for ocata
15:10:25 <mattmceuen> 2. when we are comfortable with the gates, we make ocata gates voting
15:10:25 <mattmceuen> 3. at some point after that (post 1.0) we switch default images to ocata
15:10:25 <mattmceuen> 4. at some point when noone cares about newton, we deprecate newton gates
15:10:33 <mattmceuen> agree?
15:10:44 <portdirect> jayahn: visa fun means its very unlikely I'll be in dublin
15:11:01 * jayahn is really sad
15:11:09 <jayahn> newton is already O
15:11:10 <portdirect> mattmceuen: that looks on point to me
15:11:11 <jayahn> EOL
15:11:29 <jayahn> we probably better to move on Ocata as soon as possible.
15:11:40 <mattmceuen> I think we should start the process asap
15:11:42 <jayahn> even Ocata EOL is Feb 26
15:12:10 <mattmceuen> as long as we have newton + ocata voting gates, the question of which is the default set of images is more academic imo
15:12:27 <mattmceuen> jayahn - agree, and at PTG I want to talk post-Ocata! :)
15:12:41 <portdirect> master or bust!
15:12:49 <srwilkers> portdirect: !
15:12:53 <mattmceuen> at the end of the day we need voting gates for the releases we care about as a community
15:13:11 <portdirect> and can get the clearance to put time into
15:13:27 <alanmeadows> there is also new gating required for validating upgrade success
15:13:42 <alanmeadows> without this, the addition isn't worth much
15:13:46 <portdirect> ++
15:14:45 <mattmceuen> jayahn is that enough on the topic to tide you over till PTG discussion? :)
15:14:58 <jayahn> Do we want to put "upgrade success" as mandantory option to move on to the next version? I probably want to define further on what is upgrade success.
15:15:20 <mattmceuen> I think we do
15:15:36 <mattmceuen> upgrade success being a gated thing too
15:15:52 <alanmeadows> at some point, we have to make a small leap in order to have two releases we can demonstrate  upgrade success
15:17:59 <alanmeadows> has anyone given thought to how multiple releases would be served up to the community? OSH stable releases that are not tied to OpenStack and can support any image past or present? How do they elect an OS version? Manifests? Branches for OS versions? Many options each with their own benefits and costs
15:18:23 <portdirect> I'd be in favor of the manifests approach
15:18:28 <jayahn> demonstrating upgrade success will be not that difficult, especially from newton to ocata, if we limit to so called "openstack core services", and if it is okay for existing VMs sometimes to reboot due to libvirt upgrade.
15:18:41 <jayahn> i'd be in favor of the manifests approach as well
15:18:42 <portdirect> untill that breaks, and we *need* to create a new branch
15:19:14 <portdirect> that way each branch could suport a range of osh versions ie "newton-x" "x-y" etc
15:19:22 <mattmceuen> Also in favor of manifests approach as long as it doesn't get too branch-y in the code (which to date has been the case)
15:19:25 <alanmeadows> To avoid having to maintain "life long backwards compatibility" have we thought ... exactly @portdirect
15:19:49 <alanmeadows> I would say that would help alleviate some of the pain if we look at this over time
15:19:54 <alanmeadows> 1.0 supports "newton and ocata"
15:19:56 <mattmceuen> portdirect: was thinking the same about supporting ranges of OS versions in each OSH version
15:20:02 <mattmceuen> +1
15:20:03 <alanmeadows> 2.0 supports "ocata and pike"
15:20:04 <alanmeadows> so on...
15:20:36 <portdirect> I'd be mvoe up for 1.0.0 - newton and ocata, 1.1.0 ...
15:21:08 <alanmeadows> sure, just fabricating some numbers
15:21:10 <jayahn> we know some of ocata stuff breaks newton. :)
15:21:47 <jayahn> anyway, i agree on having ranges per a version.
15:21:51 <alanmeadows> it seems a healthy target though
15:21:57 <alanmeadows> is one OSH release supporting at least two versions
15:22:10 <alanmeadows> that way you can upgrade without touching charts
15:22:22 <portdirect> ^ I think this is a fundamental requirement
15:22:41 <mattmceuen> Having OS version ranges will allow us to deprecate any feature-toggle-type stuff needed to support multiple versions in a reasoned way
15:23:04 <mattmceuen> Which is one concern I had with "support all OS versions in a single branch"
15:23:22 <mattmceuen> cool
15:23:37 <mattmceuen> We can keep ironing out details @ the PTG
15:23:46 <mattmceuen> now watch me segue, segue, watch me segueway
15:23:51 <portdirect> we should also formalise the toggles
15:24:00 * portdirect so things like this are sane: https://review.openstack.org/#/c/531893/
15:24:22 <mattmceuen> Thanks for the reference portdirect
15:24:42 <mattmceuen> Should we target that for a spec?  Normalized feature toggles?
15:25:02 <portdirect> yes
15:25:22 <mattmceuen> #action Make a spec for normalized feature toggles
15:25:43 <mattmceuen> #topic PTG schedule
15:25:48 <alanmeadows> Everyone should get their interns on normalization -- charts like barbican still missing basics like node selector targeting for jobs
15:26:01 <portdirect> ++ to that
15:26:03 <alanmeadows> the fundamentals should be consistent everywhere at this point
15:26:05 <mattmceuen> rally the interns!
15:26:27 <portdirect> I was gonna make anothe sweep though this weekend, but an army of people would make lite work of it
15:26:45 <alanmeadows> its a great way to force an introduction :)
15:27:08 <mattmceuen> Identification of low-hanging fruit -- another thing I wanted to talk about at the PTG :) at this rate we'll have a light agenda
15:27:45 <mattmceuen> #topic PTG schedule redoux
15:28:05 <mattmceuen> We were originally scheduled for Monday and Tuesday of the PTG, now we're Thursday and Friday
15:28:49 <mattmceuen> This will allow us to branch out into more of the relevant cross-team meetings on M/T (edge, k8s sig, ..) that are important to OSH, while also allowing Wednesday to spend any time in other project team meetings as needed
15:29:27 <jayahn> so we are flying in Dublin on Monday, will be available from Tuesday for any kind of meeting. let us know if there is any cross-team meeting we need to attend as openstack-helm project member
15:29:33 <mattmceuen> Note that technically we get our room halfway through Thursday, so we probably want to grab an overflow room for the first half of Thursday
15:29:39 <mattmceuen> Perfect!
15:30:12 <mattmceuen> https://docs.google.com/spreadsheets/d/e/2PACX-1vRmqAAQZA1rIzlNJpVp-X60-z6jMn_95BKWtf0csGT9LkDharY-mppI25KjiuRasmK413MxXcoSU7ki/pubhtml?gid=1374855307&single=true
15:30:23 <mattmceuen> ^ the schedule in case anyone doesn't have it
15:31:08 <mattmceuen> ok
15:31:14 <mattmceuen> now it's going to get real
15:31:18 <mattmceuen> #topic Team Mascot
15:31:56 <mattmceuen> So  as  an official project we are entitled to have the Foundation draw us a cute animal as our official  logo/mascot!
15:32:06 <mattmceuen> There are two things I want to accomplish for that today
15:32:11 <jayahn> should it be animal?
15:32:34 <mattmceuen> It has to be something natural iirc from the rules - so doesn't have to be an animal perhaps, but can't be a semi truck
15:32:48 <mattmceuen> 1. let's share some  initial suggestions
15:33:02 <mattmceuen> 2. let's decide how as a team we'll decide
15:33:13 <srwilkers> oh, now we're talking the important stuff
15:33:27 <mattmceuen> I know portdirect is very passionate on this topic
15:33:35 <mattmceuen> you get the floor pete
15:33:47 <alanmeadows> http://ipfactly.com/wp-content/uploads/2015/02/Sphynx-kitten.jpg
15:33:49 <portdirect> 2. like the graceful ratel we will come to a consensus
15:34:12 <portdirect> I'd like to propose the Ratel at our team mascott
15:34:26 <srwilkers> seconded
15:34:35 <portdirect> its a hardy, flexible and robust animal
15:34:44 <portdirect> much like openstack-helm (developers)
15:35:02 <portdirect> also it just doesn't care about node failure
15:35:20 <jayahn> looking at google translation now
15:35:20 <portdirect> and keeps on serving up apis
15:35:24 <mattmceuen> If you are unfamiliar with the Ratel https://en.wikipedia.org/wiki/Honey_badger
15:35:33 <srwilkers> finally
15:35:40 <srwilkers> thank you for linking something with its proper name
15:35:45 <portdirect> mattmceuen: https://en.wikipedia.org/wiki/Ratel
15:36:02 <gmmaha> portdirect: thanks for saving me a google search
15:36:39 <srwilkers> alanmeadows: id be open to a sphinx kitten, only if they draw you sitting in a chair with one, staring menacingly
15:37:00 <mattmceuen> thank you portdirect, my mistake
15:37:05 <portdirect> ;)
15:37:42 <mattmceuen> I would propose in addition the Marine Otter https://en.wikipedia.org/wiki/Marine_otter
15:37:56 <alanmeadows> :)
15:38:03 <mattmceuen> It is small and efficient
15:38:20 <mattmceuen> It is the only otter that lives exclusively in marine regions
15:38:30 <mattmceuen> It is related to the Ratel and is essentially the Ratel of the sea
15:38:30 <jayahn> personally, i am leaning toward marine otter
15:38:45 <d|k> +1
15:38:58 <srwilkers> the ratel is the ratel of the sea, because it doesnt care about water
15:39:01 <srwilkers> it just jumps in
15:39:51 <portdirect> srwilkers: you are correct
15:39:59 <alanmeadows> Is there already a penguin? https://en.wikipedia.org/wiki/Emperor_penguin
15:40:03 <mattmceuen> I propose we sit on it today and let folks make a careful and well-reasoned decision on this important choice
15:40:13 <srwilkers> also, dont want a marine otter being confused with the karbor mascot (beaver), tail be damned
15:40:18 <alanmeadows> because... I like being emperor
15:40:38 <portdirect> I think voting should be weighted by commits
15:40:42 <mattmceuen> fair point alanmeadows.  maybe you can embrace and extend that mascot
15:40:58 <mattmceuen> let's vote on that idea portdirect
15:40:59 <gmmaha> so we are not going to try the semi-truck? :P
15:41:56 <jayahn> https://leeromao.artstation.com/projects/gBPK
15:42:08 <jayahn> popeye at the helm :)
15:42:14 <mattmceuen> oh my!
15:42:35 <mattmceuen> the spinach tatoo is a nice touch
15:42:48 <mattmceuen> Any other candidates before we change topics, and reconvene next week?
15:42:55 <alanmeadows> jayahn: now thats a mascot
15:43:10 <alanmeadows> "OpenStack-Helm: We will crush you."
15:43:32 <jayahn> :) with armada
15:43:37 <mattmceuen> lol
15:43:41 <srwilkers> oh my
15:44:47 <mattmceuen> #topic PS Needing Reviews
15:44:56 <mattmceuen> https://review.openstack.org/#/c/535699/ - Use ceph-admin-keyring to execute storage_init script in Cinder.
15:44:56 <mattmceuen> https://review.openstack.org/#/c/501961/ - Ironic chart and gate scripts
15:44:56 <mattmceuen> https://review.openstack.org/#/c/536215/ - Will be getting tidied today, but this is now very close to what we will push upstream to ceph-helm
15:44:56 <mattmceuen> https://review.openstack.org/#/c/538419/ - Add template for Fluent logging index
15:45:16 <mattmceuen> Other PS we need to get on the collective radar?
15:45:26 <mattmceuen> Or comments on the above
15:46:18 <portdirect> I'll check out the cinder ps today
15:46:28 <portdirect> looks good at 1st parse
15:46:42 <jayahn> thanks
15:46:50 <mattmceuen> awesome
15:47:15 <portdirect> feeback on the ceph stuff would be really appreated
15:47:30 <portdirect> as soon it will be moving out of our direct control
15:47:37 <portdirect> as it moves to ceph-helm
15:47:44 <mattmceuen> good point
15:48:14 <portdirect> once this is merged, I'll spit the chart into one for each function
15:48:15 <gmmaha> portdirect: will check it out today as soon i am done testing the loopback create on fedora which isn't playing nice
15:48:28 <portdirect> nice - cheers gmmaha
15:48:44 <portdirect> you have a link to the ps your working on?
15:49:01 <gmmaha> portdirect: https://review.openstack.org/#/c/539019
15:49:11 <gmmaha> the one renis authored.
15:49:46 <portdirect> nice - I'll check that out for sure
15:50:12 <mattmceuen> thanks gmmaha portdirect - really looking forward to that one
15:50:14 <portdirect> I'f its not changed too much since the original work it should not have too much trouble on fedora, as that was done on f26
15:50:41 <gmmaha> portdirect: it used to work on fedora 27, but somehitng seems to have chnaged in the os and now it doesxnt'
15:50:51 <gmmaha> chasing that down to see what happened there
15:51:37 <mattmceuen> Alright - changing topics
15:51:43 <mattmceuen> #topic Topics for future meetings
15:52:03 <mattmceuen> I have one, bringing it up now to get the gears turning:  storyboard is coming to town
15:52:43 <mattmceuen> The foundation has done a successful test migration of OSH to storyboard away from launchpad
15:52:59 <mattmceuen> I've been poking around and have some thought, but just early ones
15:53:23 <mattmceuen> We can discuss next time, but if anyone is interested in digging in and taking point, I have resources/info I can share
15:54:15 <mattmceuen> #topic Roundtable Discussion
15:54:24 <mattmceuen> 5 minutes left; anything else team?
15:56:57 <mattmceuen> Alright  - adjourned
15:57:01 * mattmceuen gavels again
15:57:08 <mattmceuen> #endmeeting