14:54:20 <zhipeng> #startmeeting openstack-cyborg
14:54:21 <openstack> Meeting started Wed Sep 27 14:54:20 2017 UTC and is due to finish in 60 minutes.  The chair is zhipeng. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:54:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:54:25 <openstack> The meeting name has been set to 'openstack_cyborg'
14:54:49 <zhipeng> shit where is our meetbot ?
14:55:14 <zhipeng> ah here it is
14:55:40 <zhipeng> luckily it didn't catch the s word ...
14:56:16 <zhipeng> #topic Official Project Application Status Report
14:56:45 <zhipeng> #link https://review.openstack.org/#/c/504940/
14:56:59 <zhipeng> we have 8 TC voted =1
14:57:26 <zhipeng> which means we already approached majority since there are 12 TC in total
14:57:33 <jkilpatr> great
14:57:47 <zhipeng> so the only thing left is technicality for the procedure
14:58:00 <zhipeng> again this the recognition of the team's great work
14:58:07 <jkilpatr> cool, we only have one review open right now, so I think we need to decide goals for the next sprint and get started.
14:58:56 <zhipeng> I think we should just stick to the plan we made in denver
14:59:27 <zhipeng> #topic patch discussion: https://review.openstack.org/#/q/project:openstack/cyborg+status:open
14:59:37 <jkilpatr> I thought that was just start api interaction work?
15:00:02 <zhipeng> jkilpatr for the nova integration we could just modify Roman's spec patch
15:00:24 <zhipeng> we have two priorities right ?
15:00:41 <zhipeng> the other one is to get generic driver working on a real backend
15:00:50 <zhipeng> so that we have an E2E capability for queens
15:02:02 <jkilpatr> I need to review Romans patch again.
15:02:12 <zhipeng> yes we need to redo that
15:02:45 <zhipeng> i think we could focus on the nova one and crushil focus on the driver-backend thing
15:04:35 <zhipeng> while we could have other people focusing on non-priority stuff they want to contribute
15:05:32 <jkilpatr> that sounds like a plan to me, we need to plan out and then implement the nova workflow there are a couple of obvious places where nova doesn't do what we need so we need to put in specs to them.
15:05:38 <jkilpatr> specifically live addition of pci devices to the whitelist etc
15:08:03 <zhipeng> yep
15:08:22 <zhipeng> hotplug was the consesus back in denver I remember
15:08:32 <zhipeng> that we want to support for queens
15:08:34 <zhipeng> with Nova
15:12:12 <zhipeng> okey then
15:12:32 <zhipeng> #action jkilpatr and howard will be the prime on nova integration
15:12:56 <zhipeng> #action crushil will be the prime on generic driver functioning for real backend
15:20:52 <jkilpatr> is crushil not around today?
15:22:04 <zhipeng> he was here
15:29:31 <jkilpatr> so should we just patch ontop of the cyborg nova interaction patch?
15:29:46 <zhipeng> yep
15:29:55 <zhipeng> just switch the owner
15:36:52 <zhipeng> crushil you still around ?
15:39:51 <zhipeng> so other than the nova spec
15:40:06 <zhipeng> plz help review the other one on spdk support
15:40:30 <zhipeng> #link https://review.openstack.org/498690
15:40:37 <zhipeng> #info spdk driver spec
15:41:07 <zhipeng> so the author comes from my team working on spdk
15:41:37 <zhipeng> the main thing I think would be the new interfaces introduced to the generic driver
15:41:41 <zhipeng> the common ones
15:42:08 <zhipeng> if that is ok, then the spec should be of few problems. All is left would be just implementation
15:43:57 <zhipeng> crushil_ was just talk about the spdk driver spec
15:44:33 <crushil_> I know. I am connected via two devices
15:44:51 <zhipeng> ah gr8t
15:45:15 <crushil_> I have been reviewing it and will continue to review it over this week
15:45:28 <zhipeng> gr8t ! thx :)
15:45:46 <zhipeng> jkilpatr plz help review if you got time as well
15:49:18 <zhipeng> #topic AoB
15:49:34 <zhipeng> shall we submit forum topics for Sydney ?
15:49:47 <crushil_> We can
15:49:55 <crushil_> zhipeng Are you going?
15:50:02 <zhipeng> i plan to
15:50:16 <zhipeng> not sure if I could get the visa in time is the issue
15:50:21 <zhipeng> i mean i get the budget
15:51:17 <crushil_> Why don't you get the Visa done now?
15:52:29 <zhipeng> coz i need to travel for OSS EU in mid Oct
15:52:39 <zhipeng> i'm waiting for the visa for that now actually
15:52:50 <zhipeng> the timing is just really tricky
15:52:55 <crushil_> It's online last time I saw
15:53:06 <zhipeng> not for China :(
15:53:14 <zhipeng> we have to prep a lot of paper works
15:56:57 <crushil_> Ohh
15:57:42 <crushil_> Well even for Chinese citizens living in the US, it's online I believe
15:58:50 <zhipeng> lol
15:59:06 <zhipeng> i habe to color photocopy my passport for some reason
15:59:34 <zhipeng> just give you a sense of the obstacles i'm overcoming ...
16:01:26 <zhipeng> ok gonna end the meeting now
16:01:28 <zhipeng> #endmeeting