23:03:56 <reed> #startmeeting openstack-community
23:03:57 <openstack> Meeting started Wed Jul 31 23:03:56 2013 UTC and is due to finish in 60 minutes.  The chair is reed. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:03:58 <fifieldt> unfortunately I have yet to automate all the things of my workload, and so much going on :)
23:03:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:04:01 <openstack> The meeting name has been set to 'openstack_community'
23:04:25 <reed> #topic action items from last meeting
23:04:36 <reed> #info there was none :)
23:04:45 <fifieldt> brilliant
23:04:55 <fifieldt> #link https://wiki.openstack.org/wiki/Meetings/Community
23:05:02 <reed> #topic pending issues https://bugs.launchpad.net/openstack-community
23:06:01 <reed> so, the Bitergia folks are working on a new version of the dashboard
23:06:05 <fifieldt> cool
23:06:10 <reed> it's deployed, based on bootstrap
23:06:17 <reed> it allows more flexibility to move things around
23:06:52 <reed> they have removed the link to the "top things" from the navigation bar
23:06:59 <fifieldt> ok
23:07:05 <reed> so we don't have one page that looks like a race
23:07:23 <reed> there are more improvements to be made but I believe they require a much longer conversation with them
23:07:47 <fifieldt> right, ok
23:07:50 <reed> Bitergia submitted a talk to Hong Kong, they have ideas to discuss
23:08:03 <fifieldt> cool!
23:08:25 <reed> zagile is also working on the fixes assigned to them, they'll submit a talk too
23:08:33 <fifieldt> yay
23:09:13 <reed> on Ask also I've had a meeting with Evgeny, closed some bugs and updated others today
23:09:20 <fifieldt> I noticed that
23:09:22 <fifieldt> good progress
23:09:29 <reed> any specific question on the pending issues?
23:09:52 <fifieldt> mm
23:10:02 <reed> I have one:
23:10:19 <fifieldt> yes?
23:10:44 <reed> we'll have Evgeny, Zagile and Bitergia and Tipit work on projects in an 'agile' fashion
23:11:08 <reed> with stories and points attached to issues to solve and features
23:11:16 <fifieldt> aye
23:11:20 <reed> to build a workplan and generate a SOW
23:11:36 <reed> I'd like that whole plan/process to be visible
23:11:43 <reed> what tools do we have for that?
23:11:58 <reed> maybe this is a question for the #infra team
23:12:07 <fifieldt> right now, just blueprints and bugs are all we've got
23:12:09 <fifieldt> and the wiki :)
23:12:13 <fifieldt> and etherpad
23:12:25 <fifieldt> we can target blueprints to milestones
23:12:30 <reed> oh, sure... blueprints may be enough
23:12:30 <russellb> don't think we have anything better than launchpad for project tracking right now
23:12:33 <fifieldt> and bugs to blueoruints
23:12:45 <fifieldt> but
23:12:47 <reed> and milestones...
23:12:49 <fifieldt> keep in mind the access control issues
23:13:01 <reed> explain
23:13:06 <fifieldt> you'll probably need to make them admins of the community project
23:13:17 <fifieldt> as only certain roles are able to target blueprints and assign milestyones
23:13:22 <fifieldt> not sure of the exact permissions required
23:13:24 <reed> ok, makes sense
23:13:26 <fifieldt> but it's not very fine-grained
23:13:45 <reed> #action reed to investigate using blueprints and milestones to manage development projects
23:14:15 <reed> something else?
23:14:45 <fifieldt> I'm ok so far - got a good response from evgeny on my query about 'sorting by view'
23:14:53 <fifieldt> but I guess it will take time to implement
23:15:06 * reed subscribing to that bug
23:15:14 * fifieldt gets all spam :D
23:16:26 <reed> makes sense
23:16:39 <reed> it's one of the projects I'd like to have Evgeny work on: reporting tools
23:16:53 <fifieldt> cool
23:17:23 <reed> next topic?
23:17:40 <fifieldt> sure
23:17:41 <reed> #topic  progress report of projects: Ask in Chinese, User Group Portal
23:17:57 <reed> ok, so Ask in Chinese is quite ready to go live
23:18:05 <reed> the site itself works
23:18:09 <reed> the search itself works
23:18:21 <reed> the UI is only 60% or so translated
23:18:43 <fifieldt> want to push the button?
23:19:03 <reed> I'd say "ship it"
23:19:09 <fifieldt> what's the latency like from translations getting into askbot transifex to being deployed on ask.openstack.org/zh ?
23:19:15 <fifieldt> ship it :)
23:19:20 <reed> we'll need a few minutes downtime
23:20:23 <reed> I'm asking Evgeny about that, not sure
23:20:31 <reed> I'd assume around a week
23:20:32 <fifieldt> kk
23:21:41 <reed> I assume also that he can automate that in the future
23:21:47 <fifieldt> that's probably a good idea
23:21:57 <fifieldt> more rewarding if you see your translation on the site sooner
23:21:58 <fifieldt> :)
23:22:39 <reed> yeah, once a week is a plausible timeframe says Evgeny
23:22:45 <fifieldt> kewl'
23:23:31 <reed> about the user/community group portal: contract is signed
23:23:54 <fifieldt> congratulations!
23:24:19 <reed> kickoff meeting is tomorrow at 23:00 CEDT with Marton, Todd and me
23:24:26 <reed> are you able to join it?
23:24:31 <reed> (if you want to)
23:24:36 <fifieldt> looking at timezone now
23:24:51 <reed> it's about 2 hours before this
23:25:13 <fifieldt> tomorrow = Thursday?
23:25:16 <fifieldt> yeah, 7am
23:25:21 <fifieldt> I should be able to do that
23:25:25 <fifieldt> thanks to jet lag :D
23:25:34 <fifieldt> skype, irc, ...
23:25:35 <fifieldt> ?
23:25:49 <reed> skype
23:25:59 <fifieldt> ok
23:26:07 <fifieldt> I'll wake up and you can patch me in :)(
23:26:12 <reed> ok
23:26:42 <reed> this completes my overview
23:27:11 <fifieldt> ok
23:27:46 <reed> #topic various
23:28:03 <reed> there was something that annegentle mentioned to me but I don't remember it now
23:28:16 <fifieldt> It might be in my email, but I've not caught up yet :s
23:28:20 <reed> meanwhile: the migration to the mailing list is complete
23:28:25 <reed> no, it was on IRC
23:28:31 * fifieldt pops champagne
23:28:42 <fifieldt> oh - wiki page obsolescence
23:28:53 <fifieldt> We now have an "obsolete" namespace
23:29:00 <fifieldt> that any user can use to move dead pages to
23:29:12 <fifieldt> need to figure out the best way to use that and communicate it
23:29:38 <reed> right
23:29:54 <reed> other thing: we have a new policy for the blog
23:30:12 <reed> #action reed to write down the new policy for the blog and communicate it
23:31:02 <fifieldt> #action reed to comment on fifieldt's email titled "Dealing with Out of Date wiki pages" ;)
23:31:12 <reed> #info we're going to restrict access to the openstack blog to openstack foundation staff and promote the use of planet for everything else since planet is featured on the homepage http://openstack.org anyway
23:31:56 <fifieldt> reed, was annegentle's topic "integrating doc comments with ask"?
23:32:17 <reed> maybe... that's a good topic
23:32:25 <reed> i forgot to ask Evgeny about that
23:33:16 <fifieldt> np
23:34:08 <reed> #action reed to investigate further how to use askbot widgets, find examples of other sites using them, etc
23:35:29 <reed> something else?
23:35:52 <fifieldt> not that comes to mind right now
23:35:57 <fifieldt> there;s the trystack survey
23:36:04 <fifieldt> but I think this needs to go on for another couple of weeks
23:36:06 <fifieldt> only 20 responses so far
23:37:15 <reed> I'm wondering if we should try to promote it in other ways  too
23:37:25 <fifieldt> how would you think, reed?
23:37:30 <reed> not sure...
23:37:39 <fifieldt> any way I can think of doesn't hit those facebook users :s
23:37:46 <reed> yeah ...
23:39:14 <reed> so, lets wait a bit more
23:39:19 <fifieldt> ok
23:39:34 <fifieldt> I am also going to try and arrange a meeting with trystack admins
23:39:38 <fifieldt> so we can find out who is involved
23:39:41 <fifieldt> and how it's being run :)
23:39:50 <reed> oh, maybe we can send an email to the general list saying 'go to facebook and respond to the survey'
23:40:01 <reed> without revealing the liknk to the survey itself
23:40:22 * fifieldt has a feeling this will just generate new users ...
23:40:49 <fifieldt> which isn't necessarily something we want to do right now ... given the recent downtime, I guess :s
23:41:33 <reed> fifieldt, better risk that than have the survey sit there capturing .3% of members
23:41:44 <fifieldt> I disagree :)
23:41:46 <reed> I don't approve new members anyway
23:42:18 <fifieldt> I really worry about the negative experience of people - especially if they are using OpenStack for the first time
23:42:40 <reed> I hear you... so a message that simply says:
23:43:57 <reed> we're collecting feedback from current trystack users. Go to the facebook group <link> and fill in the survey please to help us decide the future direction of the project.
23:44:07 <fifieldt> yeah, I feel uncomfortable with that
23:44:12 <fifieldt> since it's still promoting trystack
23:44:21 <reed> if people are not members, we don't let them join
23:44:22 <fifieldt> other idea:
23:44:29 <fifieldt> add the link to the trystack dashboard
23:44:44 <fifieldt> the survey has actually already had a result -
23:44:51 <reed> makes sense
23:44:57 <fifieldt> we know that people are not engaged with the trystack community group
23:45:15 <reed> where is my 'not surprised' face?
23:45:17 <reed> :)
23:45:19 <fifieldt> :)
23:45:46 <fifieldt> I think stopping accepting new users is not our decision to make right now - we're not running trystack
23:46:17 <reed> anyway, I'm not sure that sending an email to 8k people on the general list linking to a facebook group would result in 'promotion' of trystack
23:46:29 <reed> i think the risk is low compared to the advantage of getting more feedback
23:46:36 <fifieldt> I disagree :)
23:46:39 <reed> we're admins though :)
23:46:51 <fifieldt> I think that if ten more people have a bad OpenStack experience due to trystack, that's too many
23:46:54 <reed> and we can discuss this with the others
23:47:36 <fifieldt> which is why I want to have a meeting with the admins as soon as we can
23:47:39 <reed> if you're that concerned we should just close it then
23:47:48 <reed> I get 2/3 new requests to join every day
23:47:59 <fifieldt> I am that concerned
23:48:05 <reed> or suggest that we close it :)
23:48:19 <reed> ok, lets postpone this discussion until you talk to the admins
23:49:01 <reed> other things to discuss?
23:49:01 <fifieldt> kmewl
23:49:30 <fifieldt> hmm, not yet :D
23:50:05 <reed> #info the migration of General mailing list is almost done. Need to migrate archives. The mail server is a bit slow, delays to delivery are to be expected. The infra team is working on fine tuning exim.
23:51:05 <reed> #info trystack survey still going on on Facebook group. Will wait more time to capture more responses.
23:51:26 <reed> #action fifieldt to have a meeting with trystack admins
23:51:42 <reed> i think we're done for this week
23:51:52 <reed> #endmeeting