23:10:11 <fifieldt> #startmeeting OpenStack Community
23:10:12 <openstack> Meeting started Wed Jun 26 23:10:11 2013 UTC.  The chair is fifieldt. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:10:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:10:15 <openstack> The meeting name has been set to 'openstack_community'
23:10:16 * sarob_ waving yes
23:10:28 <sarob_> no reed?
23:10:33 <fifieldt> he's well asleep
23:10:37 <fifieldt> currently in italy
23:10:45 <sarob_> tough break
23:10:50 <fifieldt> indeed :)
23:10:57 <annegentle> yeah night time for him
23:11:07 <fifieldt> Just to quickly run through the action items from the past meeting
23:11:13 * fifieldt evgeny_ to work on bug 1172076 (reed, 23:24:56)
23:11:19 <fifieldt> Ongoing - still shows:
23:11:20 <fifieldt> $ openssl s_client -showcerts -connect ask.openstack.org:443
23:11:20 <fifieldt> Verify return code: 21 (unable to verify the first certificate)
23:11:28 * fifieldt reed to send a request to Chinese User Groups to help translate askbot GUI (reed, 23:35:01) <-- done
23:11:45 * fifieldt fifieldt to summarise conversation with Everett about helping developers consuming OpenStack (reed, 00:18:59) <-- ongoing, has branched out into many discussions
23:12:10 <fifieldt> any queries about those annegentle, sarob_?
23:12:41 <annegentle> nope
23:12:47 <fifieldt> cool
23:12:55 <annegentle> doh lost sarob looks like
23:13:00 <fifieldt> dammnn
23:13:10 <annegentle> And another californian!
23:13:18 <fifieldt> ah california :)
23:13:18 <sarob> hmm
23:13:31 <fifieldt> any queries about those action items sarob?
23:13:42 <sarob> tx at heart
23:14:05 <sarob> no questions
23:14:16 <fifieldt> #topic evaluate pending issues from the bug tracker
23:14:20 <fifieldt> #info https://bugs.launchpad.net/openstack-community
23:14:49 <fifieldt> normally at this point we'd ask evgeny, our tame askbot developer, to give an update on the bugs assigned to that team
23:15:17 <fifieldt> but it doesn't look like any have been completed since last tgime
23:15:35 <fifieldt> also: annegentle, sarob - feel free to spam bugs to that tracker regarding the community tools
23:15:47 <fifieldt> sans openstack.org website
23:15:47 <annegentle> fifieldt: yeah looking/browsing now
23:16:06 <sarob> yeah, like https://bugs.launchpad.net/openstack-community/+bug/1099887
23:16:16 <annegentle> fifieldt: I don't know if you've seen it, but https://bugs.launchpad.net/openstack-org has openstack.org website issues
23:16:30 <fifieldt> yup, I'm an active contributor there now I have write access to the CMS :)
23:16:50 <fifieldt> indeed, sarob
23:16:59 <fifieldt> so the plan is to create a 'user portal'
23:17:04 <sarob> its not really a bug, rather blueprint
23:17:06 <sarob> right
23:17:12 <fifieldt> which will have many features
23:17:31 <sarob> righto
23:17:31 <fifieldt> and reed has been scoping the funding and methods to do that out with mark recently
23:17:41 <fifieldt> but it's slow going
23:17:50 <annegentle> I lost my write access to silverstripe, reed was looking into it
23:17:53 <sarob> bugs tracking as features, or just side effect
23:18:16 <fifieldt> yeah, since this is just a small team at the moment it doesn't use blueprints
23:18:18 <fifieldt> maybe it should?
23:18:33 <fifieldt> would you like more visibility of what's going on future roadmap wise?
23:18:38 <fifieldt> blueprints work for that well, yes...
23:19:04 <sarob> reed created one for the portal
23:19:09 <fifieldt> #info https://blueprints.launchpad.net/openstack-community/+spec/community-portal
23:19:20 <sarob> right
23:19:31 <fifieldt> ok, let me do this:
23:19:43 <sarob> i created two new ones based on reed conversation last week
23:19:53 <sarob> linking into the portal
23:19:53 <fifieldt> #action fifieldt to talk to reed about use of blueprints, and making 'large' community plans roadmap more visible
23:19:58 <fifieldt> cool
23:20:03 <sarob> okay
23:20:21 <fifieldt> anything else on the launchpad time, while we're at it?
23:20:44 <fifieldt> ok then
23:20:49 <fifieldt> #topic  how to help developers consuming API
23:21:12 <fifieldt> so I had a chat with everett, dianne via email, reed, and annegentle about this
23:21:18 <fifieldt> and also other people in the foundation
23:21:41 <fifieldt> analysed the current poor (say, nonexistent) treatment of SDKs on openstack.org
23:21:56 <fifieldt> and started writing up some stuff to replace the current "getting started" page
23:22:40 <fifieldt> the foundation team is meeting at OSCON for a workshop, and one idea we had was to look at the getting started page and smash out some content so that it's accessible for all types of people in the community
23:23:21 <fifieldt> of course, annegentle, we'll also need to look at http://docs.openstack.org/ and make sure it's pristine as it can be for developers
23:23:31 * annegentle nods
23:23:33 <fifieldt> I'm thinking we need pretty icons, thoughts? :)
23:23:51 * annegentle just found bootstrap's icons yesterday
23:23:57 <fifieldt> :D
23:24:16 <sarob> would like be like clearer steps for learning openstack
23:24:26 <fifieldt> indeed
23:24:35 <sarob> and/or provide more options
23:24:49 <annegentle> could you redesign api.openstack.org?
23:25:21 <fifieldt> it's a nice domain name :) I think we have two types of developer
23:25:40 <fifieldt> one type uses the API directly, - our own coders, people writing SDKs, other hardcore people
23:25:46 <fifieldt> the other type relies on libraries and SDKs
23:25:52 <fifieldt> and that's actually a greater number of people
23:26:06 <fifieldt> so we need to make sure we deal with both very well
23:26:27 <sarob> me thinks as instruction gets
23:26:27 <annegentle> agreed on all
23:26:50 <sarob> deeper then expose more details
23:26:58 <sarob> beyond just using api
23:27:16 <sarob> n00bs get confused
23:27:27 <fifieldt> so, providing actual examples, sarob?
23:27:32 <fifieldt> with a tangible use case to follow
23:27:35 <sarob> def
23:27:55 <fifieldt> sounds good to me
23:28:01 <sarob> we need to make tiers of material
23:28:11 <annegentle> I think Diane's user guides are going that direction with your guidance fifieldt
23:28:21 <annegentle> Dashboard > CLI > API > SDK
23:28:28 <sarob> right
23:28:33 <fifieldt> indeed, I need to get back to her  on those - sobusybusy
23:28:52 <sarob> so how can the efforts around training
23:29:05 <sarob> be spun into
23:29:25 <sarob> cause nobody wants stale, dub material
23:29:30 <fifieldt> hehe, indeed
23:29:32 <sarob> dup that is
23:29:46 <annegentle> dubstep is awesome tho
23:30:56 <sarob> so i created this bp https://blueprints.launchpad.net/openstack-manuals/+spec/training-manuals
23:31:18 <sarob> its meant to create those tiers
23:31:26 <sarob> tie into the docs
23:31:38 <sarob> and the getting started stuff
23:31:52 <fifieldt> I agree with creating training content, but my understanding is that this is a contentious board-level issue right now :|
23:31:54 <sarob> sfbay user group is working on it
23:31:57 * annegentle reads
23:32:13 <sarob> well, we are not talking about certs
23:32:26 <sarob> just creating material
23:32:46 <annegentle> sarob: what's the tie in to refstack exactly?
23:32:47 <sarob> foundation board will debate certs, def, etc
23:33:20 <sarob> the idea being that to provide examples and scenarios
23:33:25 <fifieldt> Of course it's always fine to create, but I think it's naive to assume people wouldn't get up in arms, so I'm just going to take a light touch :)
23:33:38 <sarob> we need an archetype
23:34:09 <sarob> thats me light touch
23:34:29 <fifieldt> cool
23:34:35 <fifieldt> so what's our action item here?
23:34:39 <fifieldt> share more widely
23:34:41 <fifieldt> ask for people?
23:34:53 <fifieldt> read & feedback?
23:34:56 <sarob> well started with api
23:35:55 <annegentle> sarob: reading more to try to figure out refstack tie-in
23:36:04 <sarob> roger that
23:37:13 <sarob> refstack would be reference stack, debate about whats in, what to call it, etc
23:37:33 <annegentle> sarob: my understanding of refstack is a test suite
23:37:35 <annegentle> more or less
23:38:00 <fifieldt> in this case: a way to have a defined openstack install, without using vendor Product X?
23:38:02 * sarob putting my user commuity hat on
23:38:08 <annegentle> sarob: but I do like the idea of real trainees getting real cloud experiences, but they're going to want it for free?
23:38:25 <sarob> thats def part of it
23:38:30 <annegentle> #link https://etherpad.openstack.org/RefStackBlueprint
23:38:32 <sarob> crowdsourced training
23:38:33 <annegentle> that was the link
23:38:45 <sarob> right
23:38:57 * fifieldt supports the free part and thinks usergroups around the world can deliver training material should it be available
23:39:28 <sarob> testing based on refstack, the ins and outs
23:39:37 <annegentle> sarob: so the training is for cloud users
23:39:39 <sarob> continue to be debated
23:39:53 <annegentle> sarob: the Dash > CLI > API > SDK range of users
23:40:03 <sarob> very similar
23:40:05 <annegentle> I mean that as a question, is that the range of abilities?
23:40:15 <sarob> start easy
23:40:26 <sarob> going to an architect/devops
23:40:30 <annegentle> sarob: sure if that's what you're seeing as demand
23:40:50 <sarob> demand is all over the place
23:41:04 <sarob> but they need to start somewhere
23:41:20 <annegentle> sarob: sure
23:41:30 <annegentle> sarob: just have to prioritize somewhat :)
23:41:47 <sarob> if it is selfpaced then np
23:41:48 <annegentle> sarob: to me, refstack is more about API > SDK
23:42:21 <sarob> true, i was just stating that the training is intended to teach the core of openstack
23:42:28 <sarob> not get into the weeds
23:43:15 <sarob> refstack will evenually explain / def the core of openstack
23:43:29 <sarob> through the tests
23:43:30 <annegentle> sarob: ok got it
23:43:38 <annegentle> sarob: that helped, thanks
23:43:50 <sarob> ;)
23:44:00 <fifieldt> indeed
23:44:03 <sarob> so api teach
23:44:40 <sarob> can we mold this topic into the broader training materials plus docs?
23:44:51 <sarob> as part of community
23:45:00 <fifieldt> #topic training material, documentation
23:45:01 <sarob> or massive super overload
23:45:12 <sarob> :)
23:45:18 <fifieldt> ;)
23:45:40 <fifieldt> you won't get argument from annegentle or I regarding words on paper, I think :)
23:45:44 <annegentle> right!
23:45:59 <sarob> words are our friends
23:46:23 <annegentle> One idea I see coming out of these etherpads is an appendix on certain manuals that offers training materials - objectives, labs?
23:46:40 <sarob> thats the idea
23:47:05 <sarob> was thinking that could keep the docs as
23:47:14 <annegentle> sarob: what's unfortunate is that our restructure may gut the compute admin manual and the blueprint fifieldt wrote up for restructuring the doc gets rid of the admin manuals... we're still doing content analysis on it
23:47:38 <fifieldt> indeed
23:47:39 <annegentle> #link https://wiki.openstack.org/wiki/Blueprint-restructure-documentation
23:47:39 <sarob> yeah
23:48:09 <annegentle> well, actually, the Compute Admin manual gets rolled into an OpenStack Admin manual -- so it would still work
23:48:29 <annegentle> fifieldt: Diane and Nick Chase and I just talked about it this week and Nick's going to write an outline
23:48:31 <sarob> yeah, i think its not the end of the world
23:48:38 <annegentle> sarob: so it still works for training needs
23:48:39 <fifieldt> sweet
23:48:58 <fifieldt> but yeah, sarob, if there's some content you like in there
23:48:59 <annegentle> sarob: have you seen the Couch to OpenStack webinar series? Can't help but think there's something to that organizational approach
23:49:06 <fifieldt> earmark it soon and communicate it
23:49:12 <fifieldt> because the scope is being reduced :)
23:49:21 <sarob> we could just thinking about how to break down the training structure to follow the docs structure
23:49:22 <annegentle> #link http://openstack.prov12n.com/vbrownbag-podcast-couch-to-openstack/
23:49:35 <annegentle> fifieldt: for which?
23:49:46 <fifieldt> I'd say for the compute admin manual especially
23:49:47 <sarob> hmm, nope. i chk it out
23:49:57 <annegentle> fifieldt: the way I explained it to Nick this week is we're tacking towards a point like a sailboat :)
23:49:57 <sarob> not couch to 5k
23:50:16 <annegentle> fifieldt: correcting direction as we discover
23:50:17 <fifieldt> sure, annegentle :)
23:50:22 <fifieldt> indeed
23:50:36 <fifieldt> but I think practically, this means some of the content from compute admin will disappear
23:50:38 <sarob> hmm, interesting idea
23:50:56 <fifieldt> hence the note to earmark things that might be working in case we miss them off the side of the boat in a tack :)
23:51:10 <sarob> so getting back to content
23:51:10 <annegentle> fifieldt: yeah I think the scoping is for "what goes with a release as official docs"
23:51:42 <annegentle> sarob: and I don't think that training materials can be scoped in "released" docs (which is also a starting discussion with the programs discussion)
23:51:47 <annegentle> ah too many tie ins today sorry
23:52:07 <sarob> sure i get that
23:52:18 <fifieldt> perhaps, unless someone else writes them, and it brings billions of contributors annegentle ?  :)
23:52:26 * sarob looking forward
23:52:42 * sarob on the bow
23:52:47 <fifieldt> hehehe
23:52:50 <fifieldt> metaphor win!
23:53:03 <annegentle> sarob: land ho!
23:53:18 * sarob falls overboard and gets prowed
23:53:20 <annegentle> fifieldt: just drawing imaginary lines
23:53:33 <annegentle> esp. since there's a mention of refstack in the room :)
23:53:40 <fifieldt> aye!
23:53:49 <fifieldt> or is that aye aye
23:53:50 <fifieldt> :)
23:53:56 <annegentle> or arrrr matey
23:53:57 <sarob> what homework
23:54:18 <sarob> sfbay hackathon is tomorrow night
23:54:19 <annegentle> sarob: you have done a good job getting up to speed on doc processes/tools
23:54:26 <sarob> :)
23:54:43 <fifieldt> +1
23:54:45 <annegentle> sarob: so that's excellent. I would like to know if people generally have an idea of how training material is usually written with objectives and such
23:54:46 <sarob> i gots to teach me peoples
23:54:48 <annegentle> is that what they want?
23:55:23 <sarob> now that we getting more of a crowd
23:55:29 <sarob> and yurs input
23:55:50 <sarob> im going to get some of my university friends
23:55:52 <annegentle> I guess I'd like more definition from your group too -- what's the audience, be specific. Do you need slide decks? questions? if there's stuff not covered in the manuals, will they add it as manuals or as a training add on
23:56:00 <sarob> and other user groups to chime in
23:56:13 <sarob> roger that
23:56:19 <annegentle> sarob: yes, I like that. Trainers are a really unique bunch.
23:56:34 <annegentle> sarob: and how much lab equip would be assumed/acquired?
23:56:41 <annegentle> sarob: audience, tasks, equipment.
23:56:46 <sarob> universities are already creating their own materials
23:56:53 <sarob> details
23:56:55 <sarob> right
23:57:25 <sarob> i going tap in to that gusher
23:57:37 <annegentle> fifieldt: do you have a sense of the audience yourself? students? new to cloud? IT warriors?
23:58:24 <fifieldt> indeed
23:58:39 <fifieldt> up until recently I was also creating an OpenStack course for a university
23:58:43 <sarob> i will start surveys through meetup for the user groups
23:58:49 <fifieldt> and I have many thoughts on training
23:58:55 * fifieldt is a trainer
23:59:13 <sarob> those involved peoples are the ones to tap first,
23:59:20 <annegentle> "target population"
23:59:26 * sarob you think so?
23:59:47 * sarob too
23:59:55 <annegentle> then "task analysis" and "course objectives"
00:00:01 <annegentle> anyway... those are the details
00:00:05 <annegentle> to fill in
00:00:14 <sarob> sean like
00:00:54 <sarob> you will get a few more doc contributors
00:01:14 <annegentle> cool
00:01:18 <sarob> cause that is the first thing im teaching the user group working on the training
00:01:25 <fifieldt> :)
00:01:27 <annegentle> yeah you guys are doing great
00:01:35 <annegentle> really, really good stuff here!
00:02:00 <fifieldt> +2
00:02:15 <sarob> so can you noodle on how to keep us from dupin stuff
00:02:28 <sarob> as the docs get mashed
00:03:12 <annegentle> sarob: yeah been doin that, if you'll forgive another cheesey metaphor, we've got the patient on the operating table with the guts hanging out while we reorg
00:03:34 * sarob arrgghhh
00:03:44 <sarob> right
00:04:09 <fifieldt> and we're fitting a permanent pacemaker, and replacing the lungs with machines
00:04:24 <sarob> im meaning from the creating training materials based on the docs
00:04:57 <fifieldt> the docs won't be stable for a few months, is my guess
00:05:00 <sarob> if the operations training needs materials from multi locations
00:05:29 <sarob> best way to stitch together
00:05:31 <annegentle> sarob: I think we're just saying, the admin manual may be a different beast, divided in to an admin user guide and config ref
00:05:40 <sarob> roger that
00:05:56 <annegentle> sarob: and it won't be titled "Compute" only
00:06:24 <sarob> the training will be more like assoc, ops, dev, devops
00:06:44 <sarob> with subsection specialities
00:07:11 <annegentle> sarob: yeah taht's why the audience, task, and objectives will help with matching
00:07:23 <sarob> 3rd dimension
00:07:45 <sarob> i will add those attrib in
00:08:00 <annegentle> sarob: awesome
00:08:07 <fifieldt> we're overtime for the meeting - any objections if I end the recording now?
00:08:27 <sarob> nope, thanks for your time
00:08:31 <fifieldt> #endmeeting