15:33:24 <markvan> #startmeeting OpenStack Chef
15:33:24 <openstack> Meeting started Thu Feb 19 15:33:24 2015 UTC and is due to finish in 60 minutes.  The chair is markvan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:33:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:33:28 <openstack> The meeting name has been set to 'openstack_chef'
15:33:55 <markvan> topics for today:  juno update, notes from JJ, open discussion
15:34:07 <markvan> other big topics?
15:35:03 <sc`> interesting that testing-stack's berksfile is happy, while openstack-chef-repo is not, even though they appear mostly identical
15:36:24 <markvan> yup, somethings wrong. I have not had time to dig much yet. and now we have this new openssl/postgresql issue.
15:37:27 <sc`> at least chefdk is back to being happy after purging my system of rvm
15:38:12 <markvan> ah good.  adding a topic for Berks dependencies
15:38:22 <markvan> #topic Juno update
15:38:41 <markvan> #link  https://groups.google.com/forum/#!topic/opscode-chef-openstack/VGOoOOEOpwg
15:39:05 <markvan> I updated the list of whereI think were at for Juno.  It's getting close.
15:39:47 <markvan> Just a couple of patches and possibly looking at the mariadb support.
15:40:26 <markvan> Big step will be changing the repo to the new testing suite.
15:40:50 <markvan> Any comments on remaining must have Juno work?
15:40:54 <sc`> does openstack-chef-repo officially have an expiration date?
15:41:01 <sc`> ^yet
15:41:49 <markvan> The idea was to branch off the existing repo and replace with testing suite.  Timeframe was "any day now"
15:41:58 <sc`> gotcha
15:42:20 <markvan> so folks could still use that branched version and make changes to it while getting used to the new suite.
15:43:58 <cmluciano> It seems like MySQL is working on centos with jj's patches, wondering if we are still a go on implementing the Mariadb support also.
15:45:04 <sc`> I know mariadb is being specifically targeted for rhel7, but how about percona?
15:45:25 <sc`> probably a "nice to have" more than anything
15:45:30 <markvan> cmluciano: good question.  From our teams view, we want to use the platform native database, and that would be mariadb for centos/redhat7.  So, I for one would vote to get that support in as the default/native
15:45:30 <markvan> path
15:47:42 <markvan> to clarify, for redhat 7, I would like to see mariadb support as the default.  for centos, whatever works well is good for me.
15:48:01 <markvan> I don't know much about percona
15:48:35 <sc`> this is new. aio_nova fails in the vagrant initialization. you guys using vagrant 1.6 or 1.7 with testing-stack by chance?
15:49:12 <markvan> 1.7.2
15:49:52 <markvan> When I get a chance today, I'll try out JJ patches for centos 7.
15:50:04 <markvan> #topic JJ notes on the testing repo
15:50:19 <markvan> ok, so long story short, AIO-nova works with CentOS7
15:50:19 <markvan> testing stack is back in a good state
15:50:19 <markvan> mysql v6 is working with Ubuntu 14.04
15:50:19 <markvan> both multi and AIO
15:50:19 <markvan> I’ve started investigating a ceph testing stack
15:50:21 <markvan> in turn having to learn ceph...
15:50:23 <markvan> markvan: yeah. trashed berksfile.lock, ./cookbooks and ~/.berkshelf/cookbooks. gist is here: https://gist.github.com/scassiba/e314ae40eaa4494d1d0c
15:50:26 <markvan> shits cool, but i need to get in the correct mind set
15:50:28 <markvan> the reviews need a little love, we have some stale code
15:50:30 <markvan> i have and am ready for the stable/juno branch, i started writing some notes on it
15:50:32 <markvan> https://wiki.openstack.org/wiki/OpenstackChefStablebranchCreateNotes
15:50:34 <markvan> as soon as we decied what SHA is stable/juno we can easily create it
15:50:37 <markvan> i’d like some more +1s and confirmations that https://github.com/jjasghar/chef-openstack-testing-stack/pull/33 is good
15:50:39 <markvan> and also like someone to spot check the multi-nova issue and see if you can recreate: https://gist.github.com/jjasghar/4d2d184fa23b2575815a
15:50:45 <markvan> quotes from JJ ^^^  to log in meeting minutes
15:51:24 <sc`> I'll update my vagrant to latest and see what's good
15:52:26 <markvan> If we get good testing results with U14 with multi and aio, and use his patch to also get aio wth centos 7, I think with that level we should go ahead and replace the current repo with this.
15:53:05 <markvan> and objections?
15:53:29 <sc`> +1, but users will need to be patently aware of how the changes affect them. openstack-chef-repo doesn't spin up vms and such
15:54:15 <sc`> ideally they'll less README.md, but still :)
15:54:22 <markvan> sc`: good point.  That's why branching off the current repo is important.  I guess we can add some addition intro words in the readme
15:54:24 <cmluciano> +1, I think a note about deprecation in the readme is a good start
15:55:24 <markvan> #action add some words to repo Readme about new vs old  - markvan
15:56:15 <markvan> #topic Berks issues
15:57:06 <markvan> There is a new one based upon a the new 3.x of the openssl cookbook released yesterday.  Name of library was changed and breaks the postgresql cookbook.
15:57:28 <markvan> I doc the issue and PR here: https://github.com/hw-cookbooks/postgresql/issues/225
15:58:08 <markvan> In addition, looks like we still have some other issue, maybe with the database cookbook v2  vs v4, but still digging into that one.
15:58:30 <markvan> (and I take blame for some of this, we all my cookbook version bumps)
15:58:38 <markvan> /we/with/
16:04:01 <markvan> I do see that common has apt at >= 2.6.1 and block has apt at >= 2.3.8
16:05:49 <sc`> smells like a lead
16:06:25 <markvan> and database shows 4.x in common, but only 2.x is coming up with block.  seems like one of those two is probaly the issue
16:06:39 <sc`> I know it's still not for several more weeks, but anyone attending chefconf this year?
16:06:55 <markvan> #topic chefconf
16:07:05 <markvan> as of right now, I'm not
16:08:06 <krtyyy> Any recommendation if it's worth the time? I see it's just down the road from me.
16:09:16 <markvan> I have never been, but heard is was good
16:10:06 <sc`> it's local to me, too. I've heard good things about it, but never had a chance to attend previously
16:11:20 <cmluciano> I would like to go
16:11:31 <krtyyy> I'll ping my boss and see what we have in the budget. I can probably justify it since the rest of my group went to Paris for the OS conference. I can bike to this one. ;-)
16:11:33 <cmluciano> I am def going to be at the operators meetup in march
16:13:54 <markvan> Any other topics, if not I'll end the meeting
16:14:40 <sc`> I got nothin'. go $local_and_or_regional_sports_team!
16:16:44 <markvan> #endmeeting