15:31:08 <markvan> #startmeeting Openstack-Chef
15:31:08 <openstack> Meeting started Thu Jan 29 15:31:08 2015 UTC and is due to finish in 60 minutes.  The chair is markvan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:31:12 <openstack> The meeting name has been set to 'openstack_chef'
15:32:42 <markvan> howdy all, just a short meeting today.  my topics are package updates and gates
15:32:56 <markvan> any other topics folks have for today?
15:34:21 <j^2> Nope
15:34:58 <markvan> #topic package updates
15:36:06 <markvan> So, just a quick note.  The issue we have with the current cookbook is that when a package gets updated (like in a service/fix release of base openstack),  the package resource will update the binary properly, but the service won't get restarted.
15:37:17 <markvan> Add a notify/subscribes between the package and the service seems like the right way to go, please checkout https://review.openstack.org/#/c/149152/ the new ironic cookbook as an example of what I think we need to do across the board (and in some of our dependencies)
15:39:40 <markvan> #topic gates
15:39:50 <openstackgerrit> Mark Vanderwiel proposed stackforge/cookbook-openstack-object-storage: Use keystone as default authenication  https://review.openstack.org/151002
15:41:59 <markvan> Another quick note. the current gates are using ruby 193 and calling the test commands.  The new gates approach is to use the rake files with chef dk on ubuntu 14.04.
15:42:53 <markvan> Please consider changing your dev env over to that such that we can all be on the same page for testing (and future CI integration tests https://github.com/jjasghar/chef-openstack-testing-stack)
15:43:04 <j^2> Yep
15:43:18 <markvan> #topic general discussion
15:43:39 <markvan> Anything else for now?
15:43:43 <j^2> We should official ly deprecate chef - repo like ceph
15:44:02 <markvan> #topic chef repo
15:44:07 <j^2> And push up testing stack
15:44:17 <j^2> I think its time
15:44:29 <markvan> Should we deprecate it or just branch it off and then push up?
15:44:55 <j^2> Wait for juno then push you mean?
15:45:49 <j^2> We need to remove chef-repo because I know its not supported, and replace with testing stack
15:46:09 <j^2> When is up for debate though
15:46:39 <markvan> humm, I guess we don't have to wait, we can push your part up now, so Juno is covered.  And maybe get more focus on using it (at least with U1404 to start with)
15:46:48 <j^2> Yep
15:47:29 <j^2> And then its official and not in my github name space
15:48:26 <j^2> But let me have a working session were it all works with you, offline then we can make the movements
15:48:30 <markvan> yes.  I know there was some work done on the current readme and instructions, so maybe we should consider cutting a quick branch as it stands today to preserve those in a reasonable manor.
15:49:00 <j^2> Cool I'm good with that
15:49:35 <j^2> OK, I'll be back in 30 odd mins :)
15:50:30 <markvan> #action Branch chef repo for pre-metal/juno, update chef repo with new testing suite  j^2
15:51:10 <markvan> #endmeeting