20:00:46 <j^2> #startmeeting openstack-chef
20:00:47 <openstack> Meeting started Thu Aug 14 20:00:46 2014 UTC and is due to finish in 60 minutes.  The chair is j^2. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:50 <openstack> The meeting name has been set to 'openstack_chef'
20:00:54 <j^2> Hey everyone!
20:01:05 <j^2> Here’s our Thursday IRC meeting
20:01:48 <j^2> Anyone around to check in and say hi?
20:02:07 <markvan> j^2: Howdy
20:02:25 <j^2> #topic General Discussion
20:02:41 <j^2> Is there anything specific anyone would like to bring up?
20:02:54 <j^2> I have 3 quick topics, but i’m opening it up to everyone frist
20:03:58 <carlp> I don't have anything
20:04:03 <carlp> so, what do you have?
20:04:09 <j^2> heh, that works :P
20:04:32 <j^2> #topic moving IRC meeting to friday
20:05:05 <markvan> friday morn is fine with me
20:05:28 <j^2> So Ionuț would like to have the IRC meeting moved to friday
20:06:23 <carlp> ok
20:08:05 <j^2> cool, so any other concerns or questions? obviously it’ll start next week not tomorrow beause that’s just redundant
20:09:08 <j^2> ok, cool, next topic
20:09:11 <mattray> don't conflict with the #chef-hacking meeting
20:09:36 <j^2> yeah we shouldn’t, it’s an hour before ours to the #chef-hacking :)
20:09:52 <j^2> #topic the gate jobs for both master and stable
20:10:08 <j^2> markvan: you have made some movement? issues? can you explain it for the group?
20:11:22 <j^2> #info mattray suggests we don’t conflict with the #chef-hacking meeting
20:12:33 <markvan> yup, the gate issue was merged just a bit ago.   We are trying to setup the gate to allow for Berks 3.x to be used in Master,  but 3.x deprecated some of the 2.x commands, so we needed to put in a check.
20:13:10 <j^2> is this something we can do programaticly per branch or per repo? where does this fix exactl?
20:13:12 <markvan> My first attempt failed, but with jklare's help, we're now back on track
20:14:02 <markvan> So, in working on this, I noticed our current gates are setup to cover all our branches, which means any change could break the stable branches.
20:14:12 <j^2> agreed
20:14:37 <j^2> #info our current gates cover all the branches which could break stable branches
20:14:37 <markvan> I asked out on infra, and it seems like we can have separate gate jobs for Master and then for Stables.
20:14:52 <j^2> oh nice
20:15:08 <markvan> I'll take a look into some examples and put together a blueprint to cover that change.
20:15:24 <j^2> a spec first right? ;)
20:15:39 <markvan> The other issue with messing with gates is that it's hard if not impossilbe to test it completely before pushing up a patch.
20:15:45 <markvan> yup spec
20:16:08 <j^2> #action markvan will write up a spec to split the branches gating jumps into master and stable
20:16:21 <markvan> we had our first patches merged  in over a week....yah!
20:16:56 <j^2> btw, the meeting commands are here: https://wiki.debian.org/MeetBot if anyone else wants to leverage them
20:17:11 <j^2> markvan: nice!
20:17:24 <markvan> And i would like to change the gate job for bundler to add the --retry option to allow for temp outages with installing gems.
20:17:41 <j^2> that seems like a great idea
20:18:22 <markvan> And with this latest gate update, jklare can continue to move toward getting our cookbooks up to using Berks 3.x.
20:20:08 <j^2> awesome, that’s great news
20:20:25 <openstackgerrit> Mark Vanderwiel proposed a change to stackforge/cookbook-openstack-dashboard: Update horizon local settings conf files for Juno  https://review.openstack.org/112050
20:20:42 <markvan> I think that the summary from  gate world
20:21:32 <j^2> awesome works for me
20:21:54 <openstackgerrit> Mark Vanderwiel proposed a change to stackforge/cookbook-openstack-dashboard: Need to be able to enable firewall and vpn in dashboard  https://review.openstack.org/108493
20:21:57 <j^2> #topic General Discussion/General Questions or Concerns
20:22:02 <carlp> Yes, great work Mark!
20:22:29 <j^2> I’m opening the floor up to anyone or anything we would like to discuss, please don’t hesitate
20:23:00 <markvan> I have several Juno pathch out there that are trying to get the cookbook up to speed with latest Juno conf file changes.  My intent was to get them in early in the cycle to set the stage for Juno.
20:23:37 <carlp> I'll try and spend some time reviewing it this weekend
20:23:38 <j^2> makes sense, this is to fix most/all of the conf file changes? or just get a “worknig viable product?"
20:23:47 <carlp> I'm swapmed until then :(
20:25:07 <markvan> Was trying to cover all the conf changes I could find.   In most cases the actual code changes are small, BUT I did try to sync with the latest conf file comments to make it easer to inspect nodes after converges.
20:25:40 <j^2> are you creating specs for the specific changes too?
20:26:03 <j^2> specs in the sense of tests
20:26:11 <carlp> A suggestion: If the options don't exist in a config file, defaults are taken. Maybe we should just strip out all the options we don't specifically set and go from there?
20:26:13 <markvan> Just straight up bugs for these initial changes....since there's very little logic changing.
20:26:14 <j^2> i don’t like how we have the word specs mean too things
20:26:37 <carlp> I know it means not seeing all the options in the files, but we could also move the default files to .orig or something...
20:27:30 <markvan> carlp: the new issue is that some of the base project now don't include sample conf files, so nothing to look at after an install.
20:28:00 <markvan> So, I did the gen sample conf and went from there, since that fairly easy to do once a release
20:28:14 <carlp> markvan: right, but putting a .orig or .sample file next to the generated one should be a lot less eork - no?
20:29:05 <j^2> and also that’ll give the ability to diff against them too if all the sudden something popped up
20:29:07 <carlp> That way we don't have to touch it at all, just update the .sample once a release and put a note in the generated one to check there for all the options
20:29:57 <markvan> k, I see your point.
20:30:33 <carlp> I'm not saying we have to, just a thought...
20:30:36 <markvan> I guess that would only really apply to the major conf files, as most of the others are fairly small and don't change much.
20:30:50 <carlp> yeah, agreed
20:31:07 <carlp> Hell, nova.conf has over 600 options in it. I bet we change like 20
20:31:34 <markvan> yeah, and then they deprecate and/or move them to other sections
20:31:56 <j^2> #info  update the .sample once a release and put a note in the generated one to check there for all the options,  that would only really apply to the major conf files, as most of the others are fairly small and don't change much.
20:32:49 <markvan> probably need a spec on this idea, to allow others to chime in.  But I think it's a good item to try to tackle in the future.
20:32:53 <xmltok> so it looks like launchpad has my ICLA now
20:33:19 <carlp> xmltok: yay!
20:33:29 <j^2> xmltok: nice!
20:33:55 <xmltok> yes, nice, it shows stuff signed from back in august so i guess it worked back then it was just crashing when rendering it back to me
20:34:16 <j^2> awesome, that’s great news
20:34:19 <markvan> btw, I have been working on forking that conf sample generator to instead generate Chef attributes and templates, that way we could have every option gen'd automatically (with a few exception.)
20:35:13 <markvan> At least that might help with trying to keep in sync with the base.
20:37:12 <markvan> New topic?   The Versioning spec?   We should try to get that initial one out and make mods as needed later.
20:37:14 <j^2> markvan: wouldnt that have some overhead to it? i don’t think that has a long term advantage. greated attributes aren’t much better i think it would cause some confustion?
20:38:48 <j^2> granted a sample generator should be a much larger conversation
20:38:49 <markvan> j^2: Yeah, still working out the details, but would be nice to be able to branch to "k" release and know ahead of time what conf values changed.
20:39:03 <j^2> maybe a spec ;)
20:39:36 <markvan> yup, but seems like something to explore to see if it could help us out as the base grows.
20:40:21 <j^2> sounds good
20:40:33 <j^2> #topic Versioning spec
20:40:49 <markvan> The other issue is that Chef templates don't handle [sections] very well right now. but that's another story.
20:40:57 <j^2> ok so we’ve attacked this spec every which way
20:41:25 <markvan> For Versioning spec, I took a shot with a bunch of updates....would like some feedback if the general idea is sound.
20:41:55 <j^2> https://review.openstack.org/#/c/110763/ is still the review?
20:42:39 <markvan> https://review.openstack.org/#/c/110728/ is the Versioning one.
20:42:45 <j^2> ah opps
20:42:48 <j^2> i’m glad i asked
20:43:11 <j^2> ha! i got my integration one conused
20:43:47 <j^2> #info https://review.openstack.org/#/c/110728/ is the Versioning spec review
20:44:32 <openstackgerrit> Mark Vanderwiel proposed a change to stackforge/cookbook-openstack-dashboard: Need to be able to enable firewall and vpn in dashboard  https://review.openstack.org/108493
20:45:04 <markvan> The net of the spec is, lock down Stable branches with locks and versions for every change,  and for Master, allow some minor changes to just require a ChangeLog entry.
20:45:31 <j^2> markvan: you’ve made some great changes with this. I need to read it deeper but man great job
20:45:35 <j^2> !m markvan
20:45:35 <[d__d]> You're doing good work, markvan!
20:45:35 <openstack> j^2: Error: "m" is not a valid command.
20:46:01 <j^2> i should convert that ! m command to os-chef-bot
20:46:24 <j^2> oh on that note, os-chef-bot now has this
20:46:26 <j^2> os-chef-bot: help
20:46:26 <os-chef-bot> please click here: http://tranquil-anchorage-9510.herokuapp.com/os-chef-bot/help
20:46:36 <j^2> you can click on it and recieve the commands he can do
20:46:53 <markvan> nice, I forget the cmds all the time....
20:47:00 <j^2> also, being that we have the openstack bot in this room, we are being logged in two locations
20:47:09 <j^2> the offical openstack one, and botbot.me
20:47:29 <j^2> http://eavesdrop.openstack.org/irclogs/%23openstack-chef/
20:47:36 <markvan> cool
20:47:41 <j^2> there is some redundancy to this, so i’d like to have a discussion about it
20:47:49 <j^2> the offical openstack is well openstack
20:48:08 <j^2> botbot.me is more the “opensource” channel logger, and has searching
20:48:13 <j^2> openstack doesnt
20:48:21 <j^2> i’m not sure _what_ is the correct answer
20:48:43 <j^2> though theres no harm in having them both
20:48:51 <j^2> i’d just ilke to through it out there to see what people thing
20:48:53 <j^2> think*
20:49:38 <markvan> I probably need reivew the output from each...then I can give better feedback.  both for now sounds like no issue
20:49:52 <j^2> agreed
20:49:59 <j^2> but i wanted to at least have it on the radar
20:50:25 <markvan> yup, as we improve our meetings...this will become more important
20:50:34 <j^2> that’s the goal :)
20:50:55 <j^2> i have to admit i am starting to dig the irc style
20:51:14 <j^2> we are all here anyway
20:51:29 <markvan> yeah, it's not to bad...if I coudl only type better
20:51:49 <markvan> next topic, the VPN spec  https://review.openstack.org/#/c/111145/
20:52:10 <j^2> #topic VPN spec
20:52:55 <markvan> This VPN spec has had some good comments and been updated to a point where I think it's pretty good.
20:53:16 <markvan> Just trying to make other aware of that if they're interested.
20:53:47 <markvan> #info VPN spec  https://review.openstack.org/#/c/111145/      Please review if interested
20:55:13 <j^2> awesome
20:55:30 <j^2> it seems like a great idea, but man, SSL :-/ i have trouble with basic networking :’(
20:56:14 <markvan> yeah, luckily it looks like this spec will be fairly straight forward recipe coding
20:57:09 <j^2> back to the conversation about integration testing :P
20:57:17 <markvan> sure
20:57:23 <j^2> #topic integration testing
20:57:53 <j^2> any thoughts on this? i personally have a POC when that glance issue is resolved
20:59:08 <j^2> galstrom_zzz: gave me a couple people to ping about the rackspace test suites, honestly i havent yet
20:59:41 <j^2> #action j^2 should ping the RS guys about the slaved jenkins machines
20:59:42 <markvan> I would really like to see this happen.   Whatever I can to help, just ask
20:59:54 <j^2> fix glance ;)
21:00:20 <markvan> yeah, I'm have it on my list to ping the core for that and ask what's going on.
21:01:23 <markvan> Seems like Nova added the auto covert to utf8 long ago...why with that exmaple should it take the other projects so long
21:08:00 <xmltok> oh you know what would be nice from a consumer of the cookbooks? tagged version numbers in the git repos
21:08:20 <j^2> cool everyone, thanks for being for this hour, again, we are going to move this to friday’s. I’ll send out some data to the ML
21:08:23 <j^2> #endmeeting