16:01:03 <spotz_> #startmeeting openstack_ansible_meeting
16:01:03 <openstack> Meeting started Thu Jun 29 16:01:03 2017 UTC and is due to finish in 60 minutes.  The chair is spotz_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:06 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:10 <andymccr> yeah!
16:01:11 <spotz_> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:01:17 <spotz_> #topic Roll Call
16:01:26 <andymccr> o/
16:01:35 <spotz_> He's only yeahing cause he has to run the meeting again next week while I'm showing the pony:)
16:01:48 <andymccr> hahahaha
16:01:56 <mgariepy> \o/
16:01:56 <andymccr> TIL about horse motels :D
16:02:41 <spotz_> We'll give folks a minute or 2 to wander in. It's mainly the andymccr show though cloudnull is the first thing:)
16:02:51 <cloudnull> o/
16:02:57 <spotz_> sweet!:)
16:03:22 <cloudnull> neither mhayden or i have worked on the spec, we're bad people.
16:03:25 <evrardjp> o/
16:03:26 <spotz_> #topic Previous Items - cloudnull doing the hyperconverge spec
16:03:31 <cloudnull> next topic
16:03:34 <spotz_> now you have to repeat!:)
16:03:42 <mhayden> confirmed, i'm turrible
16:03:57 <andymccr> sigh
16:03:58 <andymccr> :P
16:03:59 <andymccr> well
16:04:00 <andymccr> like i said
16:04:05 <andymccr> milestone 3 im gonna start ejecting stuff
16:04:09 <cloudnull> :'(
16:04:22 <spotz_> Bad cloudnull and mhayden!
16:04:23 <mhayden> s/ejecting/rejecting/
16:04:24 <andymccr> as we move to feature freeze, i might move it aside so you can re-imp
16:04:34 <andymccr> mhayden: haha no actually taking the stuff that was alreadyc hanged and ejecting it :P
16:04:37 <mhayden> when's the feature freeze date?
16:05:05 <andymccr> so for us
16:05:09 <andymccr> its aug 7-11th
16:05:10 <andymccr> https://releases.openstack.org/pike/schedule.html
16:05:26 <andymccr> but keep in mind that things get harder to merge as we get close to milestone3 (we already have some gate timing issues causing problems)
16:05:40 <andymccr> but that means you still have a month and a half or so
16:05:55 <spotz_> So get on it!
16:06:05 <andymccr> ^ better listen to spotz
16:06:16 <spotz_> :)
16:06:23 * cloudnull listening to spotz_
16:06:28 <andymccr> hahah good good
16:06:37 <andymccr> cloudnull: can we recarry that just to keep it on the agenda?
16:06:46 <cloudnull> sure
16:06:51 <andymccr> #action cloudnull doing the hyperconverge spec (and some work)
16:07:01 <spotz_> Moving on then
16:07:09 <spotz_> #topic Documentation changes
16:07:17 <spotz_> asettle: assuming that's you?
16:07:26 * asettle taps out
16:07:34 <andymccr> hahaha
16:07:37 <andymccr> so
16:07:41 <andymccr> the docs repos are changing!
16:07:41 <asettle> spotz_: you are liaison :) but andymccr is repping me today, because I'm hosting the docs meeting right now too
16:07:53 <spotz_> ahh cool:)
16:07:59 <andymccr> we have a little bit to do - not too much, since all our docs are in our repos
16:08:01 <andymccr> but there is a spec: http://specs.openstack.org/openstack/docs-specs/specs/pike/os-manuals-migration.html
16:08:22 <andymccr> we need to imp that, i think there is a sample patch that another project has, e.g.: https://review.openstack.org/#/c/478546/
16:08:31 <spotz_> #link http://specs.openstack.org/openstack/docs-specs/specs/pike/os-manuals-migration.html
16:08:40 <andymccr> thanks spotz_ :D forgot to link
16:08:48 <spotz_> #link https://review.openstack.org/#/c/478546/
16:08:58 <asettle> spotz_: has got this ;) thanks!
16:09:02 <andymccr> i think its pretty minimal for us, but was hoping somebody could take a stab at ensuring we're achieving that, obv asettle will be a point of contact
16:09:09 <spotz_> I'll take a look, might be able to work on it some next week while off and traveling
16:09:14 <andymccr> spotz_: awesome thanks a bunch!
16:09:36 <andymccr> so thats pretty much that one. but its somehting we have to get done to keep our docs up to date as they change i believe
16:10:11 <andymccr> again by milestone 3 i think it is - but that may actually be milestone 3 for the docs project which is 2 weeks before ours (jul24-28, so just under a month)
16:10:18 <evrardjp> oh ok
16:10:22 <evrardjp> thanks for the timeframe
16:11:02 <spotz_> Ok marked the dates down, I'll look at it after I finish my CFP for summit
16:11:10 <andymccr> thanks spotz_!
16:11:38 <spotz_> #action spotz look at the doc changes needed for OSA, will give andymccr an update for next meeting
16:11:45 <andymccr> ahh such good action items :D
16:11:49 <spotz_> :)
16:12:09 <spotz_> Or I'll join from the pony, but can't lead a meeting like that!
16:12:28 <andymccr> hahaha yeah no problem, i mean we can wait for the week after or just let us know outside of the meeting time
16:12:29 <spotz_> PTG - 11-15 September - Denver, Colorado
16:12:38 <spotz_> bah hang on
16:12:46 <evrardjp> topic ?
16:12:50 <evrardjp> :p
16:12:55 <andymccr> yes! SO another PTG update. just to say its coming up again, we have a room from Wed-Fri, but Mon-Tue are cross project and may be useful to some people
16:12:55 <spotz_> #topic PTG - 11 -15 September - Deniver, CO
16:13:03 <andymccr> its in Denver - keep it in mind, get your tickets!
16:13:05 <andymccr> yes! SO another PTG update. just to say its coming up again, we have a room from Wed-Fri, but Mon-Tue are cross project and may be useful to some people
16:13:08 <andymccr> will repeat that one :P
16:13:09 <spotz_> evrardjp: Yeah it sent vs putting it inline:(
16:13:11 <andymccr> but yeah just an update!
16:13:45 <spotz_> andymccr: Etherpad or too early?
16:13:52 <cloudnull> sadly i wont be at the PTG :'(
16:13:57 <spotz_> :(
16:13:57 <andymccr> spotz_: gonna call it too early right now. but we should think about that soonish i guess :)
16:14:22 <andymccr> cloudnull: i think your trip around Europe sounds better tbh :)
16:14:36 <cloudnull> hahaha, maybe :)
16:14:36 <spotz_> ooh I'll pick that one!:)
16:14:49 <spotz_> cloudnull does fun stuff on vaca
16:14:55 <evrardjp> I doubt I will be at the PTG too. Let's see.
16:15:12 <spotz_> I'm trying to get there, cross fingers
16:15:26 <andymccr> we'll get more details on that, but for now just try start planning to be there :P
16:15:44 <spotz_> Ok moving on
16:15:48 <spotz_> #topic Release Planning and Decisions
16:15:53 <spotz_> hrm that one worked:)
16:16:26 <andymccr> haha nice
16:16:36 <andymccr> i'll tag a release this week - thanks to evrardjp for doing the one while I was out.
16:17:04 <andymccr> and then like i said aug is milestone 3 for master
16:17:13 <andymccr> if there are any major issues let me know so i can include them in the release
16:17:36 <spotz_> So that brings us to....
16:17:41 <spotz_> #topic uWSGI/NGinx Blueprint: pending some changes (andmyccr)
16:18:16 <andymccr> i was out so i havnt updated it just yet, but hopefully i'll fix something up before next week to get some more comments
16:18:21 <andymccr> and again will ping - but yeah my bad i havnt progressed that
16:18:41 <mhayden> i like where this blueprint is going ;)
16:18:45 <spotz_> heheh
16:18:59 <andymccr> mhayden: i thought we were friends :(
16:19:06 <mhayden> uh oh
16:19:12 <evrardjp> :)
16:20:43 <spotz_> Ok moving on!:)
16:20:51 <spotz_> #topic OPen Discussion
16:21:33 <spotz_> And I've got one, cleaning up old reviews. we should go through them and either abandon or get them back on track. we're up to 3 pages of reviews a few from 2016
16:21:35 <odyssey4me> andymccr https://review.openstack.org/478836 should go in before we release ocata
16:21:53 <evrardjp> I've got one: SHould we cancel next week's bug triage?
16:22:09 <andymccr> odyssey4me: noted - thanks
16:22:18 <evrardjp> spotz_: I abandonned a few ones recently
16:22:28 <andymccr> evrardjp: yeah perhaps, i'll try run through them briefly - i did that while you were out last week i think
16:22:31 <evrardjp> but don't hesitate
16:22:40 <spotz_> evrardjp: I'd say yes cause I'll be driving and it's a holiday i the US
16:22:54 <xgerman_> I like to be a bid more pro-active instead of figuring out the gate crashed I am wondering if there is a way for people not in the weeds to get a heads up on breaking changes
16:22:54 <evrardjp> andymccr: oh great. but it's gonna be 4th of July so I don't expect any US guy
16:23:01 <andymccr> evrardjp: yeah true
16:23:06 <odyssey4me> ah, you make a good point evrardjp
16:23:12 <spotz_> odyssey4me: there were a few reviews you -1'd and commented and nothing happened after
16:23:19 <evrardjp> I am using guy because I don't know what's the plural man + woman term
16:23:21 <odyssey4me> xgerman_ yes, implement more testing - perhaps a periodic
16:23:31 <odyssey4me> then make sure you check the periodics daily
16:23:41 <andymccr> ahh xgerman_ - sorry i havnt responded to your mail yet (i was out the last few days), i will do today (i half wrote the response!) but yeah above.
16:23:48 <spotz_> evrardjp: No offense taken and asettle is in the other meeting and I don't think she'd be offended either
16:23:52 <xgerman_> thanks
16:24:09 <odyssey4me> spotz_ which reviews? I haven't seen any comments that need addressing?
16:24:28 <andymccr> i think the point is more that there are a tonne of old reviews
16:24:36 <asettle> spotz_: what what? :)
16:24:37 <evrardjp> andymccr: let's do the triage when we can, ad-hoc. if ppl want to raise bug, they can raise them on the chan
16:25:05 <asettle> Oh, no, I use 'guys' for men and women all the time
16:25:06 <spotz_> asettle: evrardjp using guys
16:25:14 <asettle> It's a pretty generic term. It's evolvedddd.
16:25:17 <asettle> At least, in my mind.
16:25:18 <spotz_> odyssey4me: looging in
16:25:20 <evrardjp> cool.
16:25:21 <asettle> Others don't see it as such
16:25:23 <asettle> ANWYAY NOT THE PLACE
16:25:26 <evrardjp> so
16:25:30 <evrardjp> for the old reviews
16:25:38 <evrardjp> I don't see a problem for abandonning them
16:25:55 <odyssey4me> we probably need to arrange some sort of hack day to address old reviews
16:26:00 <evrardjp> if they are like 6 months old, they are probably not relevant anymore
16:26:09 <spotz_> odyssey4me: one example https://review.openstack.org/#/c/388013/, the other one I was thinking was jmccrory -1 as the last thing
16:26:45 <odyssey4me> yeah https://review.openstack.org/#/q/I2eae414fba7ddfac44ad6f5125e08740dc7a80a2,n,z has notmoved in ages
16:26:48 <spotz_> But like this review from Travis is a year old https://review.openstack.org/#/c/342383/
16:27:23 <odyssey4me> that might even work now
16:27:33 <spotz_> I'm just thinking someone with the knowledge should maybe go through and abandon or mail the list or an either to get traction cause some might be too old to continue with
16:27:48 <odyssey4me> but yeah, we need time to actually evaluate and decide whether to achieve those goals or abandon them
16:28:05 <evrardjp> maybe we should put them in an etherpad, evaluate together in a hackday like odyssey4me suggested?
16:28:17 <spotz_> +2
16:28:29 <andymccr> sounds good to me
16:28:39 <spotz_> I don't think we have any bugs that old but we could do them at the same time too
16:28:49 <evrardjp> well we do
16:28:54 <spotz_> :(
16:28:57 <evrardjp> but they are now classified as opinion
16:29:11 <evrardjp> it's been a while I didn't move them though, so I am sorry
16:29:24 <evrardjp> #action evrardjp opinion bugs according to schedule
16:29:46 <spotz_> I just know I sometimes go looking for stuff and you never know if old bugs are still valid
16:30:14 <evrardjp> so if they are not opinion they are still "active"
16:30:14 <andymccr> agreed
16:30:36 <evrardjp> but it's not important, if you are looking into bug, the triage gives the importance of the bug
16:30:44 <spotz_> #action Schedule a hack day to go through old reviews and possibly bugs
16:30:54 <spotz_> :)
16:30:57 * mhayden will bring snacks
16:31:02 <andymccr> look at us adding all sorts of action items
16:31:11 <andymccr> mhayden: i just want some of those scotch brite sponges
16:31:12 <evrardjp> if it's low or wishlist, we can pretty much put that further in the back of our heads :)
16:31:28 <evrardjp> andymccr: mhayden ??
16:31:37 <evrardjp> sounds a nice private joke.
16:31:39 <spotz_> andymccr: You can't get them on amazon.co.uk?
16:31:44 <mhayden> evrardjp: gotta clean those bugs
16:31:49 <spotz_> ahh
16:31:50 <evrardjp> haha.
16:31:56 <mhayden> i print out the ansible tasks on paper and them rub them with soap and water
16:32:11 <evrardjp> I thought it was more a super timor thing.
16:32:17 <spotz_> I bet you hand write them...
16:32:36 <spotz_> Ok any more open discussion things?
16:32:37 <andymccr> scrub the bugs!
16:32:42 <andymccr> all good from my side
16:32:48 <evrardjp> mhayden: that's an expensive hobby, with the price of the ink
16:32:52 <spotz_> I can find more stuff for you....
16:32:57 <mhayden> evrardjp: double sided pages
16:33:02 <andymccr> or actually 1 thing
16:33:07 <spotz_> see:)
16:33:29 <andymccr> cloudnull wrote a blog about implementing nspawn with OSA - it would be cool if people could take a look (it links a review too) - i think its a cool concept
16:33:38 <andymccr> and id like some more eyes and people interested prior to the PTG
16:33:39 <andymccr> #link https://cloudnull.io/2017/06/nspawning-openstack-ansible/
16:33:52 <evrardjp> there is a review up for it
16:34:02 <cloudnull> ++
16:34:05 <cloudnull> :)
16:34:22 <andymccr> so we can have a meaningful discussion and actually move forward with it - we've been talking for a while (much like the dev mode stuff!) so i'd like to start executing on that one too.
16:34:23 <spotz_> :)
16:34:30 <evrardjp> cloudnull: I love the idea, but I'm gonna a pain, sorry in advance!
16:34:39 <cloudnull> I've also got some of those learnings being implemeted in our existing stack
16:34:41 <cloudnull> https://review.openstack.org/#/c/478561/
16:34:53 <cloudnull> evrardjp: ++ no worries
16:34:58 <spotz_> We can change it to what you like while he's traipsing about Europe if you come to PTG evrardjp!
16:35:30 <spotz_> #link https://review.openstack.org/#/c/478561/
16:35:33 <evrardjp> well if he is in Europe I'd be happy to invite him home for drinks. :D
16:35:49 <andymccr> evrardjp: haha yes exactly
16:36:05 <cloudnull> evrardjp: I may be in your home town
16:36:09 <cloudnull> still figuring that part out
16:36:13 <andymccr> plus thanks for the work and the blog post cloudnull - its really awesome imo
16:36:23 <evrardjp> thanks indeed
16:36:26 <cloudnull> thanks1
16:36:35 <spotz_> thanks2 :)
16:36:42 <cloudnull> I think it will open up some cool possibilities
16:37:25 <cloudnull> the WIP review is very incomplete
16:37:41 <andymccr> yeah im genuinely hoping to fix the community goals and then focus on looking at that
16:37:41 <cloudnull> and a role will be needed for nspawn host setup
16:37:47 <spotz_> We still have 23 minutes we can do it now!
16:38:20 <cloudnull> but all of the concepts are in the review so folks can see the things in one place.
16:39:34 <spotz_> ^ see link above:)
16:39:55 <evrardjp> cloudnull: great
16:40:13 <spotz_> Well I'm gonna release everyone back to their day. Pester cloudnull in the openstack-ansible channel:)
16:40:22 <spotz_> #end-meeting
16:40:24 <evrardjp> spotz_: ok
16:40:24 <cloudnull> ++
16:40:26 <cloudnull> cheers all
16:40:29 <evrardjp> bye all!
16:40:32 <spotz_> #endmeeting