16:03:14 <spotz> #startmeeting openstack_ansible_meeting
16:03:15 <openstack> Meeting started Thu May 25 16:03:14 2017 UTC and is due to finish in 60 minutes.  The chair is spotz. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:18 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:03:33 <spotz> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:03:50 <spotz> cloudnull, mattt, andymccr, d34dh0r53, hughsaunders, b3rnard0, palendae, Sam-I-Am, odyssey4me, serverascode, rromans, erikmwilson, mancdaz, _shaps_, BjoernT, claco, echiu, dstanek, jwagner, ayoung, prometheanfire, evrardjp, arbrandes, mhayden, scarlisle, luckyinva, ntt, javeriak, automagically, spotz, vdo, jmccrory, alextricity25, jasondotstar, admin0, michaelgugino, ametts, v1k0d3n,
16:03:50 <spotz> severion, bgmccollum, darrenc, JRobinson__, asettle, colinmcnamara, thorst, adreznec, eil397, qwang,nishpatwa_, cathrichardson, drifterza, sc68cal
16:03:59 <spotz> I'm all alone in meeting room 4!!!!
16:04:01 <andymccr> o/
16:04:09 <odyssey4me> o/
16:04:12 * mhayden toots
16:04:12 <asettle> o/
16:04:13 <spotz> wrong channel but I got people:)
16:04:13 <evrardjp> o/
16:04:22 <spotz> #topic Roll Call
16:04:27 <asettle> o/
16:05:04 <jmccrory> o/
16:05:19 <palendae> o/
16:05:28 <logan-> o/
16:05:40 <spotz> #topic Review action items from last week
16:05:54 <spotz> First item is andymccr to revert hyperconverge work
16:06:13 <andymccr> OK! so i havnt done that - mostly because cloudnull was interested in not doing that straight away and following up with a spec/upgrade path
16:06:21 <andymccr> cloudnull: you about?
16:06:36 <spotz> he might be with his dog:(
16:06:50 <andymccr> yeah :( ok lets re-add an action item
16:06:52 <mhayden> indeed :/
16:07:06 <andymccr> #action cloudnull to fix up upgrades/spec for hyperconverge path
16:07:24 <spotz> So second action item from last week was everybody to start investigating options for the PTG 11-15 September in Denver
16:08:03 <andymccr> yeah so - just a reminder :D
16:08:15 <andymccr> we can leave that out since its a running topic of discussion
16:08:15 <asettle> Consider me reminded
16:08:20 <andymccr> and see - its working!
16:08:25 <asettle> -.-
16:08:47 <spotz> heheh, we're gonna be quick at this rate:)
16:08:53 <spotz> #action everybody to start investigating options for the PTG 11-15 September in Denver
16:09:14 <spotz> So moving on to Topics for Discussion
16:09:21 <mhayden> road trip!
16:09:28 <spotz> #topic Developer mode changes
16:09:38 <andymccr> OK!
16:10:04 <andymccr> yay so i've put together some patches for the developer mode stuff - i'd love feedback logan- jmccrory looking at you: https://review.openstack.org/#/c/467604/
16:10:24 <andymccr> that is pretty much ready to go, but relies on a change to the individual role repos so we can set the precedence of the pip install: https://review.openstack.org/#/c/468028/ for example
16:10:55 <andymccr> so the second patch for nova doesnt change any functionality to nova (and is failing because of some other race condition im investigating now)
16:11:07 <andymccr> but it will allow us to set the local pip constraints as having the highest precedence
16:11:19 <andymccr> and once those merge + similar changes to other role repos, we will be done!
16:11:36 <odyssey4me> TIL that pip takes the first constraint if there are multiple provided that match the requirement
16:11:44 <andymccr> yeah :/ wishing it was the last :P
16:11:51 <logan-> cool will take a look
16:11:57 <andymccr> sweet :)
16:11:59 <andymccr> thats all really!
16:12:10 <spotz> Next up then...
16:12:15 <spotz> #topic PTG - 11-15 September - Denver, Colorado
16:12:22 <spotz> Hey we're back to road tripping:)
16:12:32 <andymccr> again - get planning! If you have any plans please start getting specs/etherpads/plans up somewhere that we can discuss
16:12:45 <andymccr> as we get closer i'll plan a bit more, its still quite a few months away so for now leaving it as is
16:13:31 <spotz> Another quick topic!
16:13:37 <andymccr> yeah :)
16:13:41 <spotz> #topic Release Planning and Decisions
16:13:45 <andymccr> releases!
16:14:01 <asettle> the hound!
16:14:21 <andymccr> :/
16:14:22 <andymccr> haha
16:14:27 <andymccr> ok so i'll be releasing teh end of this week
16:14:33 <andymccr> i have a SHA bump i need for nova ocata
16:14:39 <spotz> They're locked up except for Hippie, don't tell mudpuppy:)
16:15:01 <andymccr> other than that - as always let me know if there are critical changes you need in the next release
16:15:06 <andymccr> pike m2 is in like 2 weeks
16:15:19 <andymccr> that is all :D
16:15:29 <evrardjp> already?
16:15:32 <evrardjp> man that flies.
16:15:36 <spotz> So Blueprint work
16:15:43 <mhayden> yarly
16:15:49 <spotz> #topic uWSGI/NGinx
16:15:49 <andymccr> yaaaas
16:16:01 <spotz> #link  https://review.openstack.org/#/c/458595/
16:16:22 <andymccr> im reworking the patch to include all nova services, but i may simplify and use uwsgi only with no nginx. will update the spec and ask for feedback
16:16:32 <andymccr> that is all!!
16:16:42 <asettle> \o/
16:16:50 <spotz> #topic ELK Blueprint
16:17:12 <andymccr> d34dh0r53 asked me to create some repos - so i think he's finished his initial investigation - d34dh0r53 got an update?
16:17:57 <andymccr> guessing Dave isnt about :) so thats all there is for that one
16:18:18 <spotz> Ok last but not least...
16:18:22 <spotz> #topic Open discussion
16:19:15 <evrardjp> I have nothing to add that's not in recent merged commits :p
16:19:47 <odyssey4me> I'm busy doing some work with palendae to benchmark down time for minor and major upgrades.
16:19:59 <odyssey4me> We're pushing to get the benchmarks into the gates, just like we have for keystone.
16:20:04 <palendae> Yep
16:20:22 <palendae> Currently trying to figure out why the gate output isn't matching what I get when I manually run the role test for glance
16:20:26 <odyssey4me> The plan initially is just to get the tests in, but not make them fail the gate like the keystone one does.
16:20:39 <palendae> Once I have some of a pattern for glance, shouldn't be hard to get that implemented for everything else
16:20:43 <odyssey4me> Then once a service has proper rolling upgrades implemented in the role test we can flip that switch.
16:21:21 <odyssey4me> But because of this you can expect to see a flurry of patches to implement stages restarts and serialisation of rthe playbooks.
16:21:35 <odyssey4me> *staged restarts of services per role
16:21:47 <odyssey4me> *serialisation of the service install playbooks
16:22:36 <odyssey4me> the plan is to test the API through the upgrade, and the data plane (for the integrated build)
16:25:59 <andymccr> that sounds good to me
16:29:00 <spotz> sorry vet called.
16:29:05 <spotz> Anything else?
16:29:11 <andymccr> all good from my side!
16:29:17 <palendae> Don't think so
16:29:28 <spotz> #endmeeting