16:00:18 <andymccr> #startmeeting openstack_ansible_meeting
16:00:19 <openstack> Meeting started Thu May  4 16:00:18 2017 UTC and is due to finish in 60 minutes.  The chair is andymccr. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:23 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:25 <alextricity25> howdy
16:00:31 <andymccr> o/
16:00:31 <evrardjp> o/
16:01:04 <palendae> o/
16:01:10 <andymccr> give it a few minutes
16:02:02 <spotz> -o- not really here:)
16:02:18 <andymccr> #addchair evrardjp
16:02:25 <jmccrory> o/
16:02:52 <andymccr> #chair evrardjp
16:02:53 <openstack> Current chairs: andymccr evrardjp
16:02:55 <andymccr> there we go :D
16:03:02 <cloudnull> o/
16:03:03 <evrardjp> haha
16:03:29 <andymccr> ok! i think thats the majority of people - just as an fyi i need to run off in like 20 mins or so, there isnt much to cover but evrardjp is gonna finish up if we're not quite finished yet!
16:03:46 <andymccr> #topic Action items from last week
16:03:54 <andymccr> so we have 2 action items from last week
16:04:00 <andymccr> add spec for hyper-converge - mhayden cloudnull
16:04:09 <andymccr> with the summit coming up im guessing neither of you have had time
16:04:09 <asettle> o/ sorry am here
16:04:38 <evrardjp> I guess mhayden is busy with rh summit
16:04:42 <andymccr> I'll add that one back as an action item and we can follow up after the summit
16:04:43 <andymccr> yeah
16:04:44 <evrardjp> cloudnull: ?
16:04:49 <andymccr> #action add spec for hyper-converge - mhayden cloudnull
16:05:31 <andymccr> ok cloudnull isnt available :)
16:05:35 <andymccr> the only other action item was: volunteers to investigate py35 requirements
16:05:47 <evrardjp> I didn't got the chance to do it
16:05:53 <evrardjp> odyssey4me: told me he hasn't either
16:06:06 <andymccr> i think after the summit i'll have a bit more time so i can hopefully start working on that myself
16:06:25 <evrardjp> on top of that ansible under python3 now started to fail for me due to urlparse change
16:06:25 <andymccr> #action prod on the py35 requirements goal
16:06:33 <andymccr> hmm
16:06:43 <spotz> *pokes andymccr* sign up on etherpadif going to Boston....
16:06:47 <evrardjp> but I have to dig deeper into that later.
16:06:49 <andymccr> guess thats why we need testing at some point ;P
16:07:02 <andymccr> spotz: will get to that! summit talk coming up next!
16:07:15 <andymccr> lets move on! next up
16:07:16 <evrardjp> I think we covered AP
16:07:19 <evrardjp> yup!
16:07:23 <andymccr> #topic Summit next week in Boston!
16:07:32 <evrardjp> have fun! :p
16:07:45 <andymccr> ok so - as spotz said anybody going take a look at the etherpad link
16:07:47 <andymccr> #link https://etherpad.openstack.org/p/osa-summit-talks
16:08:04 <andymccr> add your details if you're keen to talk with the rest of the crew - there is a hangouts session up
16:08:14 <andymccr> we'll try do dinner/drinks and definitely catch up during the week
16:08:26 <andymccr> also if there are any sessions missing from the etherpad feel free to add
16:08:37 <spotz> Sunday night official outing, Thursday unofficial!
16:09:00 <andymccr> ^ this - looking forward to meeting some of you, and seeing familiar faces. should be great
16:09:25 <andymccr> OK SO - forward thinking - but i'll add this as an agenda item until the event :P
16:09:29 <andymccr> #topic PTG - 11-15 September - Denver, Colorado
16:09:46 <odyssey4me> o/
16:09:48 <andymccr> just to keep it in peoples minds - there really is no additional info at this point, but it's a good point to start arranging and planning
16:10:03 <evrardjp> #link https://upload.wikimedia.org/wikipedia/en/f/f3/Denver_the_Last_Dinosaur_title_card.jpg
16:10:11 <evrardjp> I'm not sorry.
16:10:12 <asettle> evrardjp: so relevant
16:10:14 <andymccr> hahaha
16:10:19 <spotz> heheh
16:10:21 <andymccr> im sure the PTG will be exactly like that!
16:10:41 <andymccr> ok so! moving on
16:10:43 <andymccr> #topic Release Planning and Decisions
16:11:11 <andymccr> OK SO! Ocata is on hold (for SHA bump) until reno  2.2.1 is released
16:11:15 <andymccr> #link https://review.openstack.org/#/c/462528/
16:11:34 <andymccr> theres nothingreally to do there, but once that merges we can push the SHA bump, and it should unblock any releasenote gates on master & stable/ocata
16:11:51 <andymccr> i'll still aim to do a release next week - especially for stable/newton
16:12:36 <andymccr> For pike the next milestone is the first week of June - so we have a bit of time til that happens, but it marks the end of projects being able to be added as part of the release
16:12:50 <andymccr> so if you have anything you want to get in for the final release it needs to be apart of m3. (june 05-09 will be m3)
16:13:30 <andymccr> anyway moving along :)
16:13:32 <andymccr> #topic uWSGI/NGinx Blueprint: https://review.openstack.org/#/c/458595/
16:13:55 <andymccr> I've refactored the uwsgi patch to make use of the other nova services (nova-api, nova-metadata) - its not working just yet - will fix that up
16:14:04 <andymccr> thanks for the feedback so far, i responded for the most part
16:14:33 <andymccr> lets keep that going - it'd be cool to discuss at the summit a bit and get a workable/agreed solution going.
16:15:51 <evrardjp> handlers are defined per play if that can help. Also you can define some of them in plays directly, not only in roles, I'll adapt my review
16:16:13 <andymccr> evrardjp: ok cool - lets discuss that and come up with a better method then. that sounds workable
16:16:48 <andymccr> evrardjp: i think practically its there - it just needs some tinkering (like the role dependency and other things) to bring it to the best possible outcome.
16:17:06 <andymccr> i also ran into a lint issue because im calling handlers from a role that has a lint issue
16:17:07 <evrardjp> Ok cool. Thanks for the spec!
16:17:19 <andymccr> trying to get that fixed upstream - but it may mean we have to come up with another method of doing this
16:17:32 <andymccr> or i need to dig into ignoring lint issues on handlers :P
16:17:40 <evrardjp> if you have a link to code that would be good
16:17:53 <evrardjp> well ignoring linting on an outside role could be fine for me
16:17:57 <evrardjp> it's outside our control
16:18:02 <andymccr> #link https://github.com/jdauphant/ansible-role-nginx/pull/140
16:18:12 <evrardjp> thanks.
16:18:13 <andymccr> evrardjp: agreed - but usually we ignore lint on the actual task by using the tag to ignore lint
16:18:21 <andymccr> im not sure how to ignore linters on the handler - although im sure there must be a way
16:18:31 <odyssey4me> andymccr same tag on the handler
16:18:42 <andymccr> odyssey4me: but we dont own the handler - and i cant tag the notify statement
16:18:47 <odyssey4me> ah
16:18:51 <odyssey4me> are we using listen?
16:18:56 <odyssey4me> no they're using listen
16:19:00 <odyssey4me> hmm, that's a fun one
16:19:37 <andymccr> yeah. im sure there's a way
16:19:39 <andymccr> just need tofigure that out
16:19:47 <andymccr> would be awesome to ignore linters on any roles that arent ours. without having to tag
16:20:02 <evrardjp> just tag it on the complete role
16:20:21 <evrardjp> in the play or the meta dependency :p
16:20:27 <andymccr> yeah well i think we'll change how we do that dep anyway
16:20:28 <evrardjp> well that's another conversation
16:20:43 <evrardjp> I mean that conversation is probably for a review instead of for the meeting
16:20:49 <andymccr> hahahaha yeah probably
16:20:58 <andymccr> i'll revise the spec after the summit and we can redo that!
16:20:59 <andymccr> anyway lastly!
16:21:02 <andymccr> #topic open discussion
16:22:01 <odyssey4me> nothing from me at this time - thanks for everyone pitching in to reviews
16:22:13 <odyssey4me> we're slowly getting more cross-repo testing functionality coming through
16:22:16 <andymccr> thanks for the work on that cross-repo testing odyssey4me! and the 2.3 fixes, and all the other stuff :P
16:22:30 <asettle> Also - can some of y'all take a wee looksie at my wee patch here: https://review.openstack.org/#/c/462477/
16:22:47 <andymccr> #link https://review.openstack.org/#/c/462477/
16:22:51 <andymccr> oh yes! that reminds me
16:22:54 <odyssey4me> the current stuff is focused on our own repositories, but I have some more WIP patches which are enabling cross-repo testing with ARA and will extend that to any openstack services
16:22:55 <spotz> asettle - pulled up and will review after meeting
16:23:00 <andymccr> the Ops guide is coming along nicely - so im told.
16:23:07 <asettle> Thanks spotz
16:23:12 <asettle> Yeah mate where'd you hear that awesome news andymccr ?
16:23:18 <asettle> :p
16:23:24 <asettle> We are very nearly done :P
16:23:29 <asettle> Anyway andymccr you gotta go flo
16:23:32 <andymccr> haha
16:23:41 <andymccr> if we could get reviews on the guide as a whole that'd be great
16:23:47 <andymccr> so if you have a chance to read through it please do!
16:23:48 <asettle> +2 to that
16:24:00 <andymccr> #link https://docs.openstack.org/developer/openstack-ansible/draft-operations-guide/index.html
16:24:08 <cloudnull> andymccr: sorry was afk , back now :)
16:24:09 <andymccr> file bugs, fix bugs, do the things
16:24:17 <odyssey4me> I'm still working through the atomic policy file changes too, which I see as a pre-requisite for the git-sourced config files... so I'm working through those over time and would appreciate reviews and/or help on those
16:24:19 <evrardjp> :)
16:24:21 <andymccr> haha cloudnull no worries - hyperconverge spec after summit si si? :)
16:24:27 <cloudnull> si si
16:24:28 <odyssey4me> the pattern is set, so anyone who feels like it can go for it
16:24:30 <andymccr> thanks!
16:24:32 <evrardjp> cool
16:24:55 <evrardjp> andymccr: jdauphant just merged your PR
16:25:00 <andymccr> evrardjp: nice!
16:25:05 <andymccr> wasnt mine - but yeh
16:25:07 <andymccr> thats quick response time
16:25:25 <andymccr> anymore for anymore?
16:25:33 <evrardjp> for anyone?
16:25:39 <evrardjp> I don't have anything to add.
16:26:04 <andymccr> in that case. thanks all - and looking forward to next week (for those who are going to be there)
16:26:15 <andymccr> #endmeeting