16:01:06 <spotz_> #startmeeting openstack_ansible_meeting
16:01:07 <openstack> Meeting started Thu Apr 27 16:01:06 2017 UTC and is due to finish in 60 minutes.  The chair is spotz_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:09 <odyssey4me> o/
16:01:11 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:21 <spotz_> agenda for reference
16:01:24 <spotz_> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:01:28 <evrardjp> woot :)
16:01:31 <evrardjp> thanks spotz_
16:01:36 <spotz_> #topic Roll Call
16:01:40 <asettle> o/
16:01:40 <odyssey4me> o/
16:01:42 <spotz_> \o/
16:01:51 <mgariepy> o/ for a couple minutes
16:01:54 <andymccr> o/
16:02:24 <spotz_> We kinda need mhayden and cloudnull they're first:)
16:02:37 <cloudnull> o/
16:02:49 <cloudnull> yo yo yo
16:02:53 <spotz_> While we're waiting if we want a hacking room go sign up for it andymccr:)
16:02:54 <cloudnull> hows it going ?
16:02:57 <spotz_> hey!
16:03:05 <andymccr> oh yeah i saw your email spotz_
16:03:08 <andymccr> is there an email about that?
16:03:10 <spotz_> Ok wwe'll do first item as cloudnull is here
16:03:11 <andymccr> i saw your irc msg rather
16:03:20 <logan-> o/
16:03:26 <spotz_> andymccr: dev list from Kendall
16:03:33 <andymccr> spotz_: will dig!
16:03:34 <spotz_> #topic add spec for hyper-converge - mhayden cloudnull
16:03:40 <spotz_> cloudnull: you're on
16:03:53 <cloudnull> I've not made a spec quite yet.
16:03:55 <cloudnull> :'(
16:03:56 * mhayden stumbles in
16:03:57 <cloudnull> i've failed
16:04:04 <andymccr> hahah
16:04:09 <andymccr> we can just add it again for next week!
16:04:11 <cloudnull> however I'd be happy to talk about it
16:04:17 <cloudnull> maybe at the end of the meeting
16:05:10 <andymccr> #action add spec for hyper-converge - mhayden cloudnull
16:05:23 <andymccr> we can talk about it at the end, but a spec would be useful :)
16:06:06 <mhayden> i'm sure we can tinker on one at the summit if it's not ready by then
16:06:46 <andymccr> mhayden: cool
16:07:01 <spotz_> Any thing else on this?
16:07:06 <andymccr> i think we're good on this!
16:07:29 <spotz_> #topic Everyone going to summit put your contact info on https://etherpad.openstack.org/p/osa-summit-talks
16:07:47 <spotz_> #link https://etherpad.openstack.org/p/osa-summit-talks
16:07:48 <andymccr> yeah so the summit is soon! ahh logan- gonna be there awesome :D
16:07:58 <logan-> :D
16:08:03 <asettle> logan-: MATE
16:08:04 <spotz_> Summit is in like 10 days
16:08:05 <asettle> YES
16:08:14 <asettle> Why are we so excieted about Logan? :p
16:08:16 <spotz_> I'll be there starting next Friday
16:08:28 <logan-> why not?????
16:08:29 <spotz_> And we need to do at least 1 outing!
16:08:48 <andymccr> the talks are on that etherpad too - I'd still ask for any help from OSA folks /w the onboarding session (9am on Tuesday, thanks to spotz_ for stealing that room!) and the ops feedback session (13:50 on Wednesday)
16:09:12 <evrardjp> logan-: :)
16:09:14 <spotz_> and a possible hacking room.... :)
16:09:16 <asettle> logan-: hahahha <3
16:09:24 <asettle> spotz_: anything but Monday! That's docs dinner
16:09:25 <evrardjp> why not asettle right? right?
16:09:26 <andymccr> yes and possible hacking room :P
16:09:32 <andymccr> i will check the schedule and ask based on when we are more free
16:09:35 <andymccr> maybe thursday is a good day for hacking
16:09:37 <asettle> evrardjp: hahhahahaa
16:10:12 <spotz_> Yeah docs is Monday, party is Tuesday and I have a work thing on Wednesday. So Sunday, thursday or friday? Or knowing us... all?:)
16:10:13 <evrardjp> I will miss you all guys. If that's english. or the other way around. Foreign language is hard.
16:10:40 <spotz_> I actually get to go to a work thing....:)
16:11:01 <asettle> evrardjp: :(
16:11:06 <asettle> That's english
16:11:09 <asettle> Mate. Taught you so well
16:11:11 <asettle> You just blend in now
16:11:13 <asettle> :p
16:11:19 <asettle> spotz_: should we do official dinner on the Thursday?
16:11:37 <spotz_> andymccr: I'll add my 2 panels to the ether cause they're both THursday
16:11:42 <andymccr> i think mgariepy will be gone by then - so if we could do it before then, that'd be best
16:11:49 <andymccr> spotz_: please do!
16:11:50 <spotz_> mgariepy is leaving on thursday:(
16:12:12 <spotz_> So I vote for Sunday and possibly thursday:)
16:12:18 <mgariepy> yeah, my hotel is full for the friday.
16:12:34 <spotz_> For thurday night you mean to stay?
16:12:37 <asettle> Bugger dude :(
16:13:02 <spotz_> Well if andymccr can take you for the night I can take asettle:)
16:13:08 <mgariepy> i'll ask the hotel when i get there but I don't think they have room.
16:13:16 <asettle> spotz_: BAHAHAHAHAHAH sWITCHING IS UP
16:13:23 <asettle> andymccr: you okay having mgariepy sleep next to you instead of me?
16:13:25 <asettle> I'll go snuggle spotz_
16:13:27 <andymccr> ok moving swiftly along :P
16:13:33 <spotz_> I don't think mudpuppy would approve me taking mgariepy:)
16:13:34 <asettle> spotz_: he's blushing
16:13:43 <asettle> Hahaha yeah spotz_ I think he might have something to say about it
16:14:14 <mgariepy> and i'll also miss my son so I might want to get back soonish
16:14:18 <spotz_> Ok so we'll shoot for Sunday and THursday, cause we actually like each other:)
16:14:18 <evrardjp> like you wouldn't asettle.
16:14:34 <andymccr> i think its a small enough group that we can organize at the venue
16:14:39 <asettle> evrardjp: hehehhehe
16:14:58 <asettle> mgariepy: we're a group of children. We'll make great substitutes for the week :p
16:15:06 <mgariepy> haha
16:15:09 <spotz_> andymccr: Yeah and like all the old stuff is only a 30 minute trip away so we can go somewhere cool
16:15:10 <evrardjp> andymccr: pay attention, experience proves group can expand like gaz.
16:15:30 <spotz_> evrardjp: asettle is good at controlling that:)
16:15:40 <spotz_> Moving on:)
16:15:43 <andymccr> si si!
16:15:44 <asettle> I just stand around and yell at people
16:15:45 <asettle> 10/10
16:15:46 <asettle> Sorry
16:15:49 <asettle> Distracting
16:15:49 <spotz_> #topic odyssey4me to investigate py35 requirements
16:15:53 <mgariepy> so i'm out now.
16:16:04 <evrardjp> haha. perfect timing? :p
16:16:07 <spotz_> While odyssey4me is talking I'll add my talks to the ether
16:16:12 <odyssey4me> unfortunately I haven't managed to do that just yet, but I hope to get to it this week coming
16:16:21 <andymccr> that was a bit of a voluntelling i believe
16:16:28 <asettle> Who did that
16:16:44 <evrardjp> odyssey4me: do you plan to test just the roles with python 3.5 or also ansible deploy ?
16:16:47 <andymccr> i'll add it again, but if anybody else has some time to help out on this, it would be good - i know odyssey4me has a lot of other things on the go.
16:17:10 <evrardjp> good idea andymccr
16:17:42 <odyssey4me> evrardjp the general plan is to at least get some py35 lint tests going, but also to add some jobs for ansible py35 testing
16:17:50 <evrardjp> k
16:17:51 <andymccr> #action volunteers to investigate py35 requirements
16:18:03 <odyssey4me> this will also mean we'd have to split the package lists for py2 vs p3
16:18:11 <andymccr> i think that should be ok
16:18:30 <odyssey4me> it'll be something that takes time over the next cycle I imagine
16:18:40 <andymccr> yeah
16:21:22 <andymccr> ok spotz_ i think we're good to move on!
16:21:30 <spotz_> andymccr: ready?
16:21:52 <spotz_> #topic New topics
16:21:53 <andymccr> si si
16:22:01 <spotz_> #topic Summit 8-11 May
16:22:07 <spotz_> cause I like topics:)
16:22:17 <andymccr> ok so i think we covered that one pretty much. since it was an action item anyway
16:22:22 <andymccr> but yeah summit! do the summit things.
16:22:39 <spotz_> And fill out the etherpad and come visit us!
16:22:43 <asettle> YAY :D
16:22:56 <spotz_> #topic PTG - 11-15 September - Denver, Colorado
16:23:23 <andymccr> ok so
16:23:24 <andymccr> its early
16:23:27 <spotz_> I will try to make PTG, submitted a talk for Open Source Summit the same week in LA
16:23:41 <andymccr> but - the PTG is coming up in September (its in Denver this time round)
16:23:53 <andymccr> so consider this an early doors notification to start planning for that!
16:24:11 <andymccr> Last PTG went really well (i thought), and it'd be great to have similar involvement
16:24:33 <spotz_> I'm trying!
16:25:07 <andymccr> so yeah that's all on the PTG - there'll be more info to follow
16:25:11 <spotz_> hehe
16:25:16 <andymccr> but right now just to say - i've said OSA will be there, and start planning!
16:25:44 <spotz_> My plan is to fly from one to the other if it works out
16:25:51 <spotz_> You're still up andymccr
16:25:55 <spotz_> #topic Release Planning and Decisions andymccr
16:26:05 <andymccr> i'll be doing a release tomorrow for Ocata/Newton
16:26:15 <andymccr> I've already performed a SHA bump to include the recent Keystone CVE fix
16:26:32 <andymccr> We'll be adding Designate back into the integrated build for master - and I'll perform a SHA bump for that tomorrow
16:26:41 <andymccr> as always - if there are any questions or anything that urgently needs to go in, let me know!
16:27:06 <andymccr> Mitaka will be EOL'd at some point, although we depend on other services, and at the moment i think there are some key ones (glance for example) who are considering holding off
16:27:09 <andymccr> so that may take some time.
16:27:10 <evrardjp> is designate fine now? Yesterday it wasn't not so sure about today. In master I mean.
16:27:22 <andymccr> evrardjp: the global requirements patches finally merged
16:27:31 <evrardjp> ok. cool
16:27:33 <andymccr> and i believe our gate for the actual role is working again
16:27:39 <andymccr> so yeah should be adding it back in!
16:27:40 <evrardjp> thanks for the info!
16:27:57 <spotz_> Anything else on releases?
16:28:11 <andymccr> nope! that is all :)
16:28:25 <spotz_> #topic Blueprint work
16:28:36 <spotz_> 3topic uWSGI/NGinx Blueprint: https://review.openstack.org/#/c/458595/
16:28:48 <spotz_> #link https://review.openstack.org/#/c/458595/
16:28:49 <andymccr> yay - so the blueprint is up
16:28:52 <spotz_> #topic uWSGI/NGinx Blueprint: https://review.openstack.org/#/c/458595/
16:29:00 <spotz_> fixed:)
16:29:07 <andymccr> thanks to mhayden for the response so far - more reviews required por favor :)
16:29:16 <mhayden> whee
16:29:34 <andymccr> i'd like to get a defined path so we can implement as the other services come up
16:29:37 <andymccr> we have a few that are ready to go
16:29:47 <andymccr> so once we have a pattern we can apply it and move on!
16:30:23 <spotz_> We like patterns:)
16:30:44 <spotz_> Anything else on the blueprint?
16:30:54 <andymccr> nope all good - asettle do you want ot talk about the ops guide?
16:31:01 <asettle> Ya!
16:31:07 <asettle> Actually, got me some goooood news
16:31:13 <spotz_> bad andymccrnot in the agenda!
16:31:18 <asettle> Yeah that guy.
16:31:25 <asettle> OKAY!
16:31:26 <asettle> So
16:31:27 <andymccr> spotz_: that one isnt my topic ;P
16:31:30 <andymccr> its a wiki - add your own asettle
16:31:32 <asettle> As you guys know, I like to harp on about documentation
16:31:35 <asettle> andymccr: omg how could you
16:31:38 <asettle> Sleep on the couch! :p
16:31:43 <spotz_> hehe
16:31:47 <asettle> For the folks at home, he just rolled his eyes
16:31:48 <asettle> OKAY
16:31:49 <asettle> So
16:31:49 <asettle> https://wiki.openstack.org/wiki/OpenStackAnsible#Documentation_planning
16:31:51 <asettle> #link https://wiki.openstack.org/wiki/OpenStackAnsible#Documentation_planning
16:31:53 <asettle> Sorry
16:31:59 <asettle> So, we've actually on track to finalise this by the summit
16:32:02 <asettle> Which is really exciting
16:32:15 <asettle> The Rackspace ops team have stepped up big time and are really keen to help out
16:32:21 <asettle> It won't be perfect, but we're pretty much done for context.
16:32:24 <asettle> Reviews, please, of course.
16:32:41 <asettle> But i'm actually going to write us up a blog about this in SuperUser and maybe even the RAX blog to publish our awesome work
16:32:41 <spotz_> They remembering to tag us?
16:33:01 <asettle> spotz_: should be
16:33:05 <asettle> There hasn't been a patch in a while
16:33:06 <asettle> but we're getting there
16:33:08 <spotz_> okie
16:33:10 <asettle> BjoernT is on it ;)
16:33:32 <andymccr> excellent
16:33:41 <asettle> Yep, anyway.
16:33:42 <asettle> HOORAY
16:33:46 <spotz_> Woot!
16:33:52 <BjoernT> I'm not the only one, other still need to contribute
16:34:00 <evrardjp> hehe
16:34:02 <spotz_> And that brings us to....
16:34:10 <spotz_> #topic Open Discussion!
16:34:48 <odyssey4me> nothing from me
16:34:52 <asettle> BjoernT: we know :) we're just joking.
16:34:53 <spotz_> We'll meet next week someone else will need to lead, but should we cancel the following meeting?
16:35:13 <andymccr> nothing from my side
16:35:31 <andymccr> spotz_: yeah - i think a large contingent will be at the summit - we'll skip that week
16:35:43 <asettle> Is the summit next week!?
16:35:50 <andymccr> asettle: week after
16:35:59 <andymccr> im guessing spotz_ is out next week though!
16:36:29 <asettle> Ah right!
16:36:31 <asettle> I was confused
16:36:33 <asettle> Dont' mind me
16:36:35 <spotz_> Any volunteers to lead next week? I'll be in Dallas
16:37:19 <andymccr> aww :(
16:37:23 <andymccr> well i can always do it :P
16:37:31 <spotz_> Woot!
16:37:44 <spotz_> Yeah flying to the office for a meeting then back so I can fly to Boston:)
16:38:19 <andymccr> enjoy!
16:38:22 <spotz_> mhayden: get your info on the ether, you can't hide from us
16:38:39 <mhayden> aah, multi-tasking between meetings
16:39:05 <spotz_> mhayden makes 7, anyone else going to Boston and want to hang with the cool crowd get on the etherpad!
16:39:24 <spotz_> And I think that's it?
16:39:50 <spotz_> Everyone gets 20 minutes back!
16:39:54 <spotz_> #endmeeting