16:04:08 <mhayden> #startmeeting openstack-ansible-meeting
16:04:09 <openstack> Meeting started Thu Apr 20 16:04:08 2017 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:13 <mhayden> #chair spotz major
16:04:13 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:04:14 <openstack> Warning: Nick not in channel: major
16:04:15 <openstack> Current chairs: major mhayden spotz
16:04:20 <spotz> hehe
16:04:27 <mhayden> #unchair major
16:04:27 <openstack> Current chairs: mhayden spotz
16:04:32 <mhayden> #topic Roll Call
16:04:36 * mhayden hands it off to spotz  ;)
16:04:42 <spotz> hehe, this is why I have issues!
16:04:57 <spotz> \o/
16:05:04 <spotz> Continue with roll call:)
16:05:12 <cloudnull> o/
16:05:19 <jmccrory> o/
16:05:20 <asettle> o/
16:05:22 * mhayden isn't running the meeting, but i can do typey typey as needed :P
16:05:35 <cathrichardson> o/
16:05:43 <evrardjp> o/
16:05:46 <andymccr> o/
16:06:04 <spotz> #topic Old Action Items andymccr to create spec for uwsgi/nginx changes
16:06:20 <andymccr> ok so! i will have that done today :P im literally finishing it up right now
16:06:32 <andymccr> so i will ping in #openstack-ansible at some point after the meeting
16:06:43 <spotz> Woot!
16:06:47 <asettle> \o/
16:06:55 <spotz> #topic Old Action Items andymccr create list of OSA related talks/sessions at the Summit
16:06:59 <andymccr> ok this one i have done!
16:07:05 <spotz> Cause it's the andymccr show:)
16:07:08 <spotz> Link?
16:07:11 <andymccr> #link https://etherpad.openstack.org/p/osa-summit-talks
16:07:18 <andymccr> if you have a talk and its not on there please feel free to add it!
16:07:25 <odyssey4me> o/
16:07:27 <andymccr> i did a search for ansible and OpenStack-Ansible and copied any over
16:07:41 <spotz> Mine aren't OSA but I'll be there:)
16:07:51 <andymccr> spotz: feel free to add them if you'd like!
16:07:56 <andymccr> oh. as a side note
16:08:19 <spotz> I think on the bottom of that ether, lets everyone add if you're going and contact info so we can try to hang at least once?
16:08:30 <andymccr> it would be super useful to have as many people as possible at the project onboarding session (tuesday lunch time) and the ops feedback (Wednesday just after lunch)
16:08:38 <asettle> andymccr: I should be there, I think
16:09:00 <spotz> I can be there Wednesday though might be late have to come from the lunch and learn
16:09:01 <andymccr> asettle: excellent :) im not sure i can answer all questions from operators by myself - and would be good to have a mix of everybody involved if possible
16:09:08 <andymccr> spotz: thanks!
16:09:12 <asettle> Yeah should be able to try and help
16:09:59 <spotz> I don't remember if we need emails or phone numbers?
16:10:12 <spotz> good call cloudnull
16:10:32 <cloudnull> ;)
16:10:48 <spotz> Last action item
16:10:51 <spotz> #topic Old Action Items https://review.openstack.org/#/c/454742/ reviews for logan-
16:11:09 <spotz> Pretty sure we did that no?
16:11:15 <andymccr> so i think this has some reviews - logan- do you need more, or is this looking good?
16:11:20 <andymccr> do you have enough to work on?
16:11:49 <logan-> yes good on it right now. i am working on some tests for it
16:11:53 <andymccr> sweet :)
16:11:55 <evrardjp> great
16:11:56 <logan-> thanks jmccrory for taking a stab last week
16:12:19 <jmccrory> np
16:12:28 <spotz> Sweet, see how much we rock!:)
16:12:34 <asettle> Hahahha
16:12:35 <asettle> \o/
16:12:40 <spotz> #topic OPNFV Cross Community CI (XCI), its relation to OSA and where we are now
16:12:47 <spotz> fdegir you here?
16:12:54 <evrardjp> or hwoarang
16:12:59 <andymccr> this might be a carry-over from last week - since we spoke about that i believe
16:13:11 <andymccr> but i didnt want to remove it incase we needed to talk more :)
16:13:22 <andymccr> but odyssey4me i know you did some work to help on this, you may be interested in the chat logs from last week!
16:13:25 <hwoarang> i am around but i thought fdegir talked about that last week
16:13:33 <evrardjp> ok
16:13:41 <odyssey4me> ah, thanks andymccr
16:13:42 <spotz> he did but Andy left it on the agenda....
16:13:43 <evrardjp> if you need extra help or anything, just ping
16:13:52 <andymccr> haha yes yes i take responsibility :P
16:13:52 <hwoarang> sure thank you evrardjp
16:13:54 <spotz> Bad andymccr
16:13:59 <odyssey4me> andymccr did you update the agenda yet?
16:14:01 <odyssey4me> :p
16:14:09 <spotz> he half did odyssey4me
16:14:14 <odyssey4me> I hear that the agenda should really get updated. :p
16:14:15 <andymccr> odyssey4me: see i left some tricks in to see if others were paying attention
16:14:22 <evrardjp> well there could have been updates
16:14:23 <andymccr> apprently they AREN'T :P
16:14:24 <odyssey4me> :)
16:14:35 <spotz> hehehe well moving on and back to andymccr
16:14:40 <evrardjp> don't be too harsh on andymccr, he is our benevolant dictator
16:14:41 <spotz> #topic Release Planning and Decisions
16:15:05 <andymccr> ok - next week is more releases - however it's mitaka EOL coming up
16:15:15 <andymccr> I've asked for our role repos to be EOL'd and to leave our main repo in place
16:15:28 <andymccr> the plan will be to SHA bump to point at mitaka-eol for roles and upstream projects and then mitaka-EOL the main openstack-ansible repo
16:15:42 <evrardjp> +1
16:15:54 <andymccr> other than that business as usual :) if anybody has anything specific to go in. let me know
16:15:59 <evrardjp> oh wait. Can't vote on intentions.
16:16:02 <evrardjp> :p
16:16:09 <andymccr> also the CVE fixes for Horizon & Nova are in the latest release for OSA
16:16:31 * mhayden pours one out for mitaka
16:16:36 <andymccr> hahaha yeah
16:16:38 <cloudnull> hahaha
16:16:51 <odyssey4me> alas, mitaka, it served us well
16:16:54 <mhayden> that was the first release where i broke less stuff
16:16:56 <andymccr> it did indeed
16:16:56 * mhayden sniffles
16:17:02 <mgariepy> lol
16:17:08 <spotz> hehehe
16:17:22 <spotz> #topic Blueprint work
16:17:51 <andymccr> so aside from the uWSGI bits i dont think we have much
16:17:59 <andymccr> asettle: we could get an updateon the docs ops guide?
16:18:00 <mhayden> monitorstack is moving along
16:18:24 <asettle> andymccr: sure. So we have a few more contributors rolling in from the Rackspace side.
16:18:34 <andymccr> mhayden: excellent, you may need ot ping for reviews since i'm not sure most ppl will be monitoring monitorstack (get it?)
16:18:37 <asettle> I'll be having a meeting with the ops team next week about what they're up to
16:18:45 <mhayden> andymccr: what you did there -- i see it
16:18:45 <asettle> I'll also be doing my best to plug it at the summit.
16:18:51 <spotz> andymccr: ha!
16:18:58 <mhayden> as an aside, the latest OpenStack user survey shows Ansible on top
16:18:59 <andymccr> asettle: excellent!
16:19:01 <asettle> Got a few new links here
16:19:05 <asettle> links - ugh, names
16:19:06 <mhayden> although it is broken into 3 pieces
16:19:08 <asettle> #link https://wiki.openstack.org/wiki/OpenStackAnsible#Documentation_planning
16:19:11 <andymccr> sweet !
16:19:12 <andymccr> moving along
16:19:24 <andymccr> nicely - i'd like to get that done for Pike
16:19:35 <andymccr> or at least moved to a point where its not "draft"
16:19:44 <asettle> Yeah, that should be on target.
16:19:54 <asettle> :)
16:20:06 <spotz> Any more blueprint talk?
16:20:17 <asettle> not from me :)
16:20:18 <andymccr> so we'll need to start talking about the py35 bits
16:20:33 <andymccr> and id really appreciate somebody trying to take that one on
16:21:30 <andymccr> i know you're all trying so hard to be the first to type "me" that you're falling off your chairs - but let me know if you'd be ok with helping out on that :)
16:21:52 <spotz> Have you seen my python code?:) Yeah so !me:)
16:22:02 <asettle> I wouldn't know python if it hit me in the face.
16:22:07 <asettle> Unless it's a snakey
16:22:10 <asettle> Then I got that!
16:22:24 <spotz> Who's not here.... Jimmy?:)
16:22:32 <andymccr> haha its ok we'll figure it out :)
16:22:36 <andymccr> but for now just to put it on the radar!
16:22:36 <asettle> jmccrory mgariepy cloudnull
16:22:40 <asettle> I'm super good at tagging people
16:22:42 <asettle> logan-:
16:22:45 <odyssey4me> andymccr we have very little python of our own, and last I asked and did a cursory look most of our stuff was already py35 compatible
16:22:53 <odyssey4me> it'd be good to have some sort of test to validate
16:22:57 <spotz> I can add translation code really well to python:)
16:23:02 <andymccr> odyssey4me: exactly - i dont think it'd be that hard
16:23:06 <cloudnull> woo hoo , i was tagged.
16:23:08 <mgariepy> i'm not good at python
16:23:10 <andymccr> odyssey4me: its pretty much testing and ensuring that the infra works properly.
16:23:25 <spotz> odyssey4me: I don't know I think you volunteered:)
16:23:31 <asettle> I think odyssey4me did
16:23:38 <asettle> #action odyssey4me to investigate py35 requirements
16:23:39 <jmccrory> is there a place to see how far along each openstack project is for py35?
16:23:41 <asettle> Phew, you're welcome andymccr
16:23:41 <odyssey4me> I seem to recall cloudnull going down the road of trying to make ansible run on py3
16:23:52 <cloudnull> andymccr: I did a py35 thing with the pip install role
16:23:54 <odyssey4me> but yeah, I'll happily take a look at adding some sort of py3 tests
16:23:57 <andymccr> jmccrory: im trying to find that out - for the uwsgi work too because its hard to keep track of that otherwise
16:23:58 <mgariepy> voluntold!
16:24:06 <cloudnull> thats a first step
16:24:15 <spotz> hehehe, we're so bad:) Hi-5 to asettle
16:24:18 <cloudnull> but i've not circled back on it
16:24:25 <asettle> spotz: NICE :D
16:24:37 <spotz> Well that leads us to....
16:24:45 <spotz> #topic Open Discussion
16:25:03 <evrardjp> 2.3. Great.
16:25:17 <evrardjp> That's all I had to say for today.
16:25:43 <mhayden> so there's been a topic of consolidating containers
16:25:45 <andymccr> evrardjp: hahaha yeah how are we with that? i know jmccrory was fixing it up a lot
16:25:49 <mhayden> as in, don't have heat-api and heat-engine
16:25:51 <mhayden> just put them into one
16:25:59 <cloudnull> also we merged the machinectl things
16:26:00 <mhayden> since if you lose the engine, the api is worthless
16:26:10 <cloudnull> which would be great for folks to beat on
16:26:41 <andymccr> mhayden: yeah i saw that - im concerned about upgrade paths
16:26:41 <jmccrory> andymccr patches are up for all integrated roles, most have merged by now
16:26:44 <evrardjp> andymccr: I didn't start patching. I think the discussion with jmccrory was pending. Then went to do different things.
16:26:58 <andymccr> mhayden: i think its a nice approach tbh.
16:26:59 <evrardjp> jmccrory: great. thanks.
16:27:12 <mgariepy> There is an issue when upgrading to newton from mitaka when having old stuff in /etc/openstack_deploy/env.d/
16:27:14 <cloudnull> mhayden: and I have a couple prs in flight for removing a few of our container groups and moving the services a combined container https://review.openstack.org/#/q/status:open+project:openstack/openstack-ansible+branch:master+topic:hyperconverged
16:27:25 <cloudnull> it'd be great to get some thoughts on that too
16:27:39 <cloudnull> oh.
16:27:40 <cloudnull> haha
16:27:41 <odyssey4me> the point of the multiple containers is to allow scale - it's not really anything to do with anything else
16:27:43 <cloudnull> what major said
16:27:43 <mhayden> also, on the nova side, we can combine scheduler/conductor/api together
16:28:04 <andymccr> cloudnull: mhayden: im personally in favour of it if we can fix the upgrade path up to work nicely
16:28:05 <odyssey4me> we could, as a default in OSA, have combined containers on a per project basis - as long as the functionality to split them out is still there
16:28:20 <mhayden> it might be nice to have env.d differences for hyperconverged, as andymccr mentioned
16:28:24 <mhayden> so someone could pick that option
16:28:30 <andymccr> yeah we could default to converged
16:28:34 <andymccr> per service
16:28:44 <spotz> I like the option path though might be hard to code
16:29:12 <odyssey4me> well, doing this would require a dynamic inventory change
16:29:26 <andymccr> odyssey4me: sure it would just require an env.d change
16:29:31 <andymccr> *surely
16:29:47 <odyssey4me> andymccr well, for one option yes - to have multiple pre-set options I don't think so
16:30:00 <odyssey4me> unless we provide a set of override files, but that gets messy
16:30:06 <andymccr> odyssey4me: i dont think it gets that messy
16:30:19 <andymccr> you have an env.d which has optional different env.d files per service to not converge
16:30:26 <odyssey4me> so, well, what's the purpose of doing this - what do we gain?
16:30:32 <cloudnull> so we have the scale groups already.
16:30:41 <andymccr> fewer containers really
16:30:42 <cloudnull> but they're largely un documented.
16:31:06 <odyssey4me> I think the documentation is on the way into the ops guide?
16:31:09 <cloudnull> so we could combine the defaults that we have already and then document how to scale each group
16:31:18 <cloudnull> ah.
16:31:22 <cloudnull> then we may already b eclose
16:32:04 <evrardjp> limitations of the inventory, again on the table.
16:32:14 <cloudnull> #link https://review.openstack.org/#/c/442091/
16:32:18 <cloudnull> ^RE py3 support
16:32:29 <andymccr> oh nice :)
16:32:31 <odyssey4me> well, to me there's limited value and it's a massive pain for upgrades - so unless we change the approach to how we work with containers I'd recommend against doing this
16:33:16 <andymccr> perhaps a spec would help illustrate the aims youre going for mhayden cloudnull?
16:33:16 <cloudnull> RE: py3 -- i need rhel help :)
16:33:34 <andymccr> that may be helpful
16:33:35 <spotz> mhayden: mgariepy ^
16:33:43 <odyssey4me> ie if we no longer need to ssh into containers, and no longer need to identify them as hosts, then we can change them around at will
16:34:43 <andymccr> cloudnull: mhayden would you be up for adding in a spec for that?
16:34:51 <mhayden> i could possibly do that
16:34:53 <cloudnull> I can try and crank out a spec
16:34:54 <andymccr> sweet :)
16:34:56 <cloudnull> or mhayden
16:35:01 <mhayden> cloudnull and i can collab
16:35:04 <andymccr> #action add spec for hyper-converge - mhayden cloudnull
16:35:08 <cloudnull> woot ! go team!
16:35:08 <mhayden> we are collabing a lot lately
16:35:11 <andymccr> hahah
16:35:13 <mhayden> YAY TEAM
16:35:17 <andymccr> ok so one other topic i want to bring up
16:35:24 <andymccr> the user survey came out. im following up on a few things.
16:35:28 <mhayden> Gartner is telling me that hyperconverged is where it's at
16:35:38 <andymccr> mhayden: is it bimodal though?
16:36:10 <andymccr> on the user survey - im following up around the way projects get listed as "projects" essentially, since ours isnt listed - i think that has a negative impact and i'd like to get that fixed
16:36:20 <andymccr> (for next time, since this one is done!)
16:36:26 <cloudnull> andymccr: I saw ansible is +9000 but osa is not listed. :'(
16:36:32 <andymccr> cloudnull: yeah basically thats the problem
16:36:50 <andymccr> there is also a projects section that includes some deployment projects but not others.
16:36:59 <cloudnull> ansible (LXC) - is, but i think that's a write in
16:37:07 <spotz> odyssey4me: andymccr - I think they just call us Ansible, and the reason I say that is the video of the new mascots
16:37:27 <cloudnull> spotz: link?
16:37:30 <andymccr> so im making some queries and hopefully asking the right ppl the right questions and hopefully we'll get something moving for next time!
16:37:45 <spotz> cloudnull: saw it on facebook but it was from sueruser let me look
16:38:26 <spotz> cloudnull: http://superuser.openstack.org/articles/openstack-project-mascots/
16:38:58 <spotz> Here we are listed as openstack-ansible though https://www.openstack.org/project-mascots
16:39:39 <cloudnull> ah i see in the video, we're "ANSIBLE"
16:39:51 <andymccr> either way the question wouldnt be that specific in the survey i think
16:39:56 <andymccr> but i think it shows we have good traction
16:39:59 <spotz> Yeah but on that second link we're openstack-ansible so who knows:(
16:40:03 <andymccr> either way - we just need to be in the right sections too :)
16:40:10 <evrardjp> WE ARE ANSIBLE. WOOT.
16:40:24 <andymccr> thats all i have for this week afaik :)
16:40:58 <spotz> Anyone have anything else?
16:41:23 <evrardjp> Nothing. Thanks spotz and everyone!
16:41:29 <spotz> #action Everyone going to summit put your contact info on https://etherpad.openstack.org/p/osa-summit-talks
16:41:47 <spotz> #endmeeting