16:00:33 <asettle> #startmeeting openstack_ansible_meeting
16:00:34 <openstack> Meeting started Thu Mar 30 16:00:33 2017 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:39 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:46 <andymccr> yay
16:00:47 <andymccr> o/
16:00:53 <xgerman> o/
16:00:58 <asettle> Good job team
16:01:02 <spotz> \o/
16:01:11 <evrardjp> o/
16:01:14 <asettle> Love to see you all here :)
16:01:15 <asettle> https://media.giphy.com/media/14urMYvFxIKEms/giphy.gif
16:01:19 <palendae> o/
16:01:20 <asettle> Oh c'mon gif
16:02:09 <asettle> #topic Roll call (just so we have it, although thanks everyone for already doing it)
16:02:15 <asettle> Omg I made that the whole topic hAHHAHAHAHAHAHAH
16:02:17 <asettle> *head desk*
16:02:24 <asettle> odyssey4me: I hear you, but I don't see you.
16:02:28 <andymccr> o/
16:02:59 <asettle> yes yes we get you andymccr :p
16:03:15 <asettle> I'll give it 2 more mins before we kick off the fun
16:03:26 <palendae> o/
16:04:10 <jmccrory> o/
16:04:13 <asettle> jmccrory: bout time
16:04:17 <asettle> slacker
16:04:22 <asettle> Where is logan-
16:04:25 * asettle taps foot
16:04:32 <logan-> o/
16:04:34 <andymccr> hahah
16:04:39 <logan-> :D
16:04:41 <asettle> That's right logan-
16:04:51 <asettle> odyssey4me: bro I see you typing commit messages.
16:05:03 <asettle> Okay let's rock it
16:05:05 <asettle> #topic Review action items from last week
16:05:12 <asettle> andymccr: did we have any?
16:05:17 <asettle> There's none in the agenda.
16:05:25 <andymccr> i was out for the last 2 meetings
16:05:28 <andymccr> so im guessing no :)
16:05:31 <asettle> Beautiful
16:05:41 <asettle> *dusts off hands*
16:05:45 <asettle> #topic Operations guide requires review
16:05:47 <evrardjp> I think there was none
16:05:51 <asettle> #link http://docs.openstack.org/developer/openstack-ansible/draft-operations-guide/index.html
16:05:54 <asettle> Yo homies, all review
16:06:03 <asettle> #action OSA TEAM TO REVIEW OR ALEX WILL BE UPSET
16:06:07 <asettle> Good action
16:06:10 <andymccr> asettle: didn't we have some offers to do that last time?
16:06:14 <andymccr> well it would've been 3 meetings ago
16:06:27 <andymccr> we should track that - i think people usually just need a prod to say "hey you were interested is that still the case here"
16:06:36 <evrardjp> well we skipped that part on previous meeting
16:06:47 <evrardjp> but I think this deserves # actions items
16:07:05 <asettle> evrardjp: make it so
16:07:06 <evrardjp> #action evrardjp work on the firewll for ops guide
16:07:11 <asettle> Gracias evrardjp :)
16:07:12 <evrardjp> haha already one :p
16:08:10 <asettle> andymccr: you want to go back to action items yo
16:08:16 <andymccr> yeah sorry i checked the logs
16:08:19 <asettle> *tsk*
16:08:24 <andymccr> i know im terrible
16:08:31 <asettle> #action Andy to actually update the meeting agenda each week
16:08:58 <andymccr> hahaha
16:08:59 <andymccr> yes yes
16:09:06 <andymccr> we had 2 action items
16:09:09 <andymccr> 1 was to unblock the gate
16:09:17 <andymccr> AFAIK this is a big tick - so thank you everybody for that help
16:09:25 <asettle> https://media.giphy.com/media/xb8zoHFCKU0Ra/giphy.gif
16:09:25 <andymccr> if that isn't the case let me know.
16:10:01 <andymccr> we have another action item which is for me to look into getting an onboarding room at the summit - i need to do that still
16:10:02 <andymccr> so
16:10:12 <andymccr> #action andymccr to look into getting an on-boarding room at the summit (carry-over)
16:10:22 <asettle> You can get a lunch room, email Kendal andymccr
16:10:24 <asettle> Kendall*
16:10:33 <asettle> On the dev list
16:10:36 <andymccr> sweet nice tip :)
16:10:42 <andymccr> and 2 other action items
16:10:43 <spotz> Try for Thursday if possible, so I can help:)
16:10:53 <andymccr> spotz: awesome will do - and thanks for the offer!
16:10:55 <asettle> Good idea :)
16:11:02 <andymccr> so last 2 action items: review https://review.openstack.org/#/c/445334/
16:11:05 <andymccr> thats another tick since its merged :P
16:11:22 <asettle> http://quotesblog.net/wp-content/uploads/2015/05/PuW18jf.gif
16:11:25 <andymccr> and one more which is a carry over
16:11:27 <asettle> Oh c'mon gif
16:11:38 <asettle> We'll go back to this since it worked: https://media.giphy.com/media/xb8zoHFCKU0Ra/giphy.gif
16:11:42 <andymccr> #action review https://review.openstack.org/#/c/447151 and talk about shared "osa community goals" for network integration best practices next week (useful for trove and octavia)
16:11:59 <andymccr> xgerman: have you spoken with kylek3h and some of the other people working on the trove role - if there is link over there?
16:12:14 <xgerman> we discussed it last week
16:12:14 <andymccr> ahh i see kylek3h is on that review already :) so magic is happening
16:12:26 <xgerman> at the meeting
16:12:29 <odyssey4me> :)
16:12:34 <andymccr> sweet :) xgerman do we need to talk more about that this week?
16:12:36 <xgerman> though reviews have been slow after last week
16:12:43 <andymccr> ok cool so another prod to get some reviews in
16:12:48 <xgerman> yep
16:13:02 <asettle> https://encrypted-tbn2.gstatic.com/images?q=tbn:ANd9GcT_PRvH1I6k2uI8IGJNdrVvGg0dAkRRs5bpZcyvsRgL9jb_d_kcyg
16:13:04 <asettle> Omg wh
16:13:08 <andymccr> ok so that is all the action items i believe
16:13:23 <asettle> https://media.giphy.com/media/m80Q4HTDNPFHq/giphy.gif
16:13:26 <asettle> OMG WHAT
16:13:30 <asettle> I should realy test these before the meeting
16:13:38 <andymccr> true story
16:13:58 <asettle> palendae: the next item is python naming, is this really still a thing?
16:14:07 <palendae> asettle: It is not
16:14:12 <asettle> REMOVE IT
16:14:14 <odyssey4me> nope - cleaning up the agenda is not really a strong point :p
16:14:16 * asettle slams gavel
16:14:25 <asettle> odyssey4me: periodic jobs?
16:14:33 <andymccr> i think we hav enew ones coming up
16:14:36 <odyssey4me> that can come off too
16:14:37 <asettle> Cause if it's not, imma rage quit.
16:14:38 <asettle> OH that's it
16:14:41 <asettle> You're all useless :p
16:14:46 <andymccr> no i mena
16:14:47 <odyssey4me> there are some new ones coming in
16:14:51 <andymccr> yeah ^ that
16:14:52 <odyssey4me> I should prod infra to merge them
16:14:55 <palendae> asettle: No argument from me
16:14:56 <asettle> #topic Periodic jobs
16:14:56 <asettle> odyssey4me:
16:15:06 <odyssey4me> #link https://review.openstack.org/449272
16:15:09 <odyssey4me> a whole bunch more
16:15:46 <asettle> MOre?
16:15:56 <andymccr> yeah the periodical work is great, so if we have more ideas around thigns we should be testing but aren't - lets discuss get them setup and move on!
16:16:19 <asettle> https://admin.mashable.com/wp-content/uploads/2013/07/excited-baby.gif
16:16:30 <asettle> ^^ a gif of me, moving on
16:16:30 <stevelle> heh
16:16:42 <asettle> #topic Moving to uWSGI/NGinx
16:16:42 <andymccr> odyssey4me: do we need anything else on periodicals or are we good/no more topic needed for next week?
16:16:43 <asettle> andymccr:
16:17:06 <andymccr> OK! so - I have proposed a WIP patch for using upstream NGinx and uWSGI for Nova placement: https://review.openstack.org/#/c/451425/
16:17:08 <andymccr> there is some discussion going on
16:17:20 <andymccr> so please review and comment and give thoughts/feedback
16:17:25 <andymccr> #action review and comment on https://review.openstack.org/#/c/451425/
16:17:43 <andymccr> this will then be used as the base of the pattern for our community goal around using wsgi apps everywhere
16:17:44 <asettle> #link https://review.openstack.org/#/c/451425/
16:17:51 <asettle> Ooohh Ahhhh
16:17:52 <asettle> Importento
16:17:54 <andymccr> so we need consensus on how that will go
16:18:19 <evrardjp> I think we all need a time to digest this before consensus can happen
16:18:23 <andymccr> evrardjp: agreed
16:18:32 <evrardjp> when do we take decision?
16:18:39 <evrardjp> next week's meeting?
16:18:47 <asettle> That seems reasonable.
16:18:48 <andymccr> evrardjp: there is no immediate rush, since half the projects don't support wsgi apps properly yet
16:18:52 <asettle> Okay :)
16:18:55 <andymccr> but once they are ready i'd like to start motoring through them
16:19:01 <andymccr> that said, i'd really like to get some reviews on that
16:19:25 <andymccr> so logan- jmccrory looking at you 2 :) and anybody else - this is an important change that is going to shape the arch/way we install services etc
16:19:25 <evrardjp> yea, and we can already think of cloudnull's ideas (or alternatives) because they are already technically doable
16:19:38 <andymccr> evrardjp: yeah agreed - that is literally a first pass, (or second since i reworked it today)
16:19:53 <andymccr> if it would help i will write a blueprint/spec about it and we can discuss whilst looking at that patch
16:19:54 <evrardjp> but yes, adding reverse proxying there in the mix or not
16:20:39 * asettle nods thoughtfully
16:20:43 <asettle> I agree.
16:20:53 <andymccr> ok cool :)
16:21:14 <asettle> Shall we move on?
16:21:20 <odyssey4me> yeah, as this is a change in architecture, I think it's important to have a spec to help us and others understand the motivations
16:21:25 <odyssey4me> and the decisions made
16:21:27 <andymccr> ok cool
16:21:33 <andymccr> #action andymccr to create spec for uwsgi/nginx changes
16:22:11 <andymccr> ok all good on this topic i think!
16:22:31 <asettle> You got it boss
16:22:33 <asettle> #topic Weekly meeting host!
16:22:42 <asettle> mhayden has abandoned us
16:22:44 <asettle> Because he hates you all
16:22:47 <asettle> ANd now we need a new meeting host
16:22:51 <andymccr> Ok so - mhayden has a meeting clash or the above might be more true :)
16:22:56 <asettle> ... it's the above andymccr
16:23:02 <asettle> Don't be lying to the children now
16:23:29 <asettle> evrardjp already is a champ and hosts our weekly bug triage
16:23:30 <andymccr> so if there is somebody who would be keen to get involved and start hosting the meetings on a weekly basis that would be awesome!
16:23:42 <asettle> It's not hard. Having a core be able to participate would be ideal.
16:23:56 <asettle> logan- jmccrory spotz odyssey4me mgariepy
16:24:40 * asettle sits, and waits.
16:24:49 <andymccr> or perhaps we should look at changing the meeting time - i know we've had this discussion before, but if the consensus is that this time doesnt work at all - for the majority of people. we should look to change it
16:24:50 <odyssey4me> :) I'd prefer to give someone else a chance.
16:25:03 <odyssey4me> I'm happy to rotate with someone though.
16:25:04 <asettle> odyssey4me: true, you've done your duties. You're honourably discharged.
16:25:41 <odyssey4me> meeting time change is fine for me, but would that be earlier or later
16:25:51 <jmccrory> time is rough for me, i'm catching commute near beginning or end depending on daylight savings time
16:26:06 <andymccr> odyssey4me: would have to figure it out based on when works for people
16:26:10 <asettle> Hmmm okay, maybe we should consider moving. But only on the basis there's more participation?
16:26:10 <andymccr> i think ^ is the key issue
16:26:22 <asettle> Like, I'm going to call it, there's no point in having meetings where andymccr odyssey4me and evrardjp chat to themselves.
16:26:32 <andymccr> yeah i think the key question is would another time work better for more people
16:26:32 <odyssey4me> we'd also have to identify which days there are meeting room slots available
16:26:40 <evrardjp> :)
16:26:41 <asettle> So, if it means more participation moving, I'm all for it.
16:26:48 <andymccr> or is there a better way to get work items discussed that is outside of meetings.
16:26:49 <asettle> odyssey4me: true, we would.
16:27:29 <asettle> andymccr: maybe its worth sending out to the OSA cores a poll?
16:27:42 <spotz> asettle I might be able to host, need to double check conflicts. Sorry was on phone with vets
16:27:43 <asettle> andymccr and odyssey4me - yo I get that it's easier to speak, but let's have this recorded please.
16:27:48 <asettle> spotz: no problem :)
16:27:52 <asettle> That would be cool, if you have no conflicts.
16:27:58 <odyssey4me> probably best to do a ML post with the details of time slot options
16:28:04 <andymccr> yeah lets try that
16:28:04 <evrardjp> +1
16:28:20 <andymccr> ok
16:28:22 <andymccr> i'll start that off
16:28:28 <asettle> Okay, andymccr action that please :)
16:28:46 <andymccr> #action andymccr to look into timeslots for meeting and poll the team to decide a best time
16:29:08 <asettle> *nods* like it
16:29:23 <andymccr> ok next!
16:29:39 <asettle> #topic Release Planning and Decisions
16:29:41 <asettle> andymccr: go go go
16:29:48 <andymccr> ok so releases will be going out this week, so tomorrow basically
16:30:01 <andymccr> i think we got in all the critical fixes that im aware of - but if there are any outstanding let me know
16:30:29 <xgerman> exit
16:30:37 <asettle> xgerman: yo yo IRC bro
16:30:40 <andymccr> we've done a minor version bump due to the change in repo server build
16:30:45 <xgerman> I know
16:30:48 <andymccr> but yeah.
16:31:20 <andymccr> that is all for releases :)
16:32:06 <asettle> Thanks andymccr :)
16:32:14 <asettle> #topic Blueprint work
16:32:21 <asettle> #link https://blueprints.launchpad.net/openstack-ansible/+spec/upgrade-testing
16:32:23 <asettle> andymccr:
16:32:28 <asettle> Upgrade testing for core roles in openstack-ansible
16:32:28 <andymccr> ok so
16:32:33 <andymccr> we are at the last step
16:32:35 <andymccr> just as an update
16:32:45 <andymccr> https://review.openstack.org/#/c/450198/ once that merges
16:32:52 <andymccr> we will have voting upgrade jobs on the core roles
16:33:04 <asettle> #link https://review.openstack.org/#/c/450198/
16:33:06 <andymccr> so that may be a pain at first :) btu they are passing as of now, so lets try keep it that way
16:33:25 <asettle> Sweet :)
16:33:31 <andymccr> that is all on that bp - but after that it's gonna be closed and all done :)
16:33:39 <asettle> Sweet as :)
16:33:47 <asettle> #topic Open discussion
16:36:03 <jmccrory> for upgrade jobs in those roles, is plan to add testing to see how long any downtime is as well?
16:36:27 <andymccr> jmccrory: id say yes if/when we start to implement the zero downtime upgrades per service
16:36:32 <andymccr> i think keystone is the only one right now
16:36:40 <andymccr> atm its more just a test that it works before and after
16:36:53 <jmccrory> ah right, not sure where other projects are with that
16:37:05 <andymccr> jmccrory: yeah i know cinder has some - they did a presentation at the ops midcycle
16:37:11 <andymccr> would be great to get some time to actually work on that
16:38:37 <odyssey4me> yeah, we ideally should try and implement the rolling upgrades for cinder and nova
16:38:47 <odyssey4me> and swift, although that might already be there
16:38:59 <odyssey4me> with those we can add the measurements
16:39:08 <stevelle> I'm hoping to start submitting reviews for glance zero-downtime upgrades during pike
16:39:33 <andymccr> hmm yeah i guess although in swift we can't do serial i think - which is the main issue with zero-downtime on restarting services
16:39:52 <palendae> andymccr: Cause of ring rebalancing?
16:40:19 <andymccr> palendae: yeah mostly because of the way we sync things - it means if all hosts haven't run certain tasks it'll fail
16:40:28 <andymccr> like it does an md5sum check on each hosts ring to make sure its good
16:40:36 <andymccr> and then does some checks - but if you serialise that the var doesnt exist
16:41:06 <andymccr> ideally need to rework that whole thing
16:41:15 <andymccr> whilst ensuring it still works properly :P
16:41:24 <palendae> Hm, yeah
16:41:26 <palendae> That'll be tricky
16:41:43 <palendae> And neutron routers have to shift around, too
16:41:55 <andymccr> yeah i think swift is easy from a tech perspective, hard from how we imp it perspective
16:41:59 <andymccr> neutron is just hard i imagine :D
16:42:14 <palendae> Yeah, until we enable l3ha it's gonna be annoying
16:42:32 <palendae> It was enabled, then turned off due to bugs, I don't know the current status
16:43:17 <odyssey4me> not really hard
16:43:19 * asettle nods sagely
16:43:20 <asettle> Mmhmm
16:43:43 <odyssey4me> just disable one agent, migrate the routers/networks, upgrade the disabled agent when they're done, then do the same for the other
16:44:03 <palendae> Anyway, sounds like odyssey4me's got it
16:44:37 <odyssey4me> the tools are all there
16:44:47 <andymccr> theoretically it will work perfectly :P
16:45:07 <odyssey4me> and we enable l3ha by default anyway, so it'll likely just work :p
16:45:21 <andymccr> ship it
16:45:30 <odyssey4me> for a real online migration without it there's a bit more orchestration that needs doing
16:46:49 <odyssey4me> anyway, are we done for the day?
16:46:57 <asettle> WE are
16:46:58 <andymccr> i believe so!
16:47:00 <andymccr> thanks all :)
16:47:09 <asettle> #endmeeting