16:00:05 <mhayden> #startmeeting openstack_ansible_meeting
16:00:05 <openstack> Meeting started Thu Feb  9 16:00:05 2017 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:09 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:14 <mhayden> #topic Roll Call
16:00:19 * mhayden woots
16:00:27 <mgariepy> o/
16:00:32 <crushil> \o
16:02:06 <cathrichardson> o/
16:02:56 <spotz> \o/
16:03:09 <xdaxdb> o/
16:03:25 <jmccrory> o/
16:03:33 <andymccr> o/
16:03:40 * mhayden will wait until :05 after
16:03:50 <asettle> \o/
16:03:52 <asettle> heyo
16:03:57 <asettle> Where yo gifs bro
16:04:11 <mhayden> asettle: it's been a week
16:04:44 <evrardjp> o?
16:04:47 <evrardjp> o/
16:05:05 <asettle> mhayden: *nods* understandable
16:05:14 <mhayden> alrighty, let's put the lime in the coconut
16:05:26 <mhayden> #topic Review action items from last week
16:05:45 <mhayden> it looks like we came through on andymccr's starred reviews! https://review.openstack.org/#/q/starredby:andrew-mccrae
16:05:52 <mhayden> andymccr: you're welcome
16:05:56 <andymccr> yes thank you! i didn't have to stay up too late on thursday :P
16:06:11 <mhayden> woot
16:06:22 <mhayden> moving right along
16:06:27 <mhayden> #topic Ops guide reviews - asettle
16:06:32 * mhayden hands it to asettle
16:06:43 <asettle> Helloooo
16:06:49 <stevelle> o/
16:06:55 <asettle> Currently up for review: https://review.openstack.org/#/c/431499/
16:06:59 <asettle> All those that know/understand rabbitmq
16:06:59 <asettle> Get on that
16:07:17 <asettle> Darren Carpenter from Rackspace has been providing us with content and we've been help write it down.
16:07:32 <asettle> Thanks to spotz for already looking :)
16:07:47 <asettle> If anyone else can help in sections, let us know: https://wiki.openstack.org/wiki/OpenStackAnsible#Documentation_planning
16:07:51 <asettle> SIgn up and write up :)
16:08:05 <mhayden> woot
16:08:10 <andymccr> yeah if any ops related people have some time to take on some of those would be massively appreciated
16:08:27 <asettle> I mean, Darren has been writing and dumping things into an etherpad
16:08:31 <asettle> No upstream experience necessary ;)
16:08:50 <asettle> Anyway, still rolling to Boston. Thanks mhayden :)
16:09:04 <mhayden> asettle: congrats on PTL, btw
16:09:11 <asettle> Thanks mhayden :)
16:09:15 <mhayden> #info congrats to asettle on docs PTL!
16:09:21 <asettle> Hahhahahah <3
16:09:29 <andymccr> isnt that like a #success ? :P
16:09:45 <mhayden> #action everyone congratulate asettle on becoming docs ptl
16:09:48 <mhayden> there, i did it ;)
16:09:50 <andymccr> hahaha
16:09:51 <mhayden> okay... moving along
16:09:59 <mhayden> #topic PTG - Feb 20-24 - andymccr
16:10:11 <andymccr> ok so same as the last few weeks - its like 2 weeks away now  - looking fwd to it.
16:10:22 <andymccr> if you're coming fill out the etherpad with any suggestions/ideas!
16:10:24 <odyssey4me> o/
16:10:31 <andymccr> #link https://etherpad.openstack.org/p/osa-ptg-pike
16:10:43 <asettle> So about htat, I don't know if I can make it over to the OSA ops session
16:10:49 <asettle> Cause i'll be between docs/security
16:11:05 <asettle> If someone could represent the efforts there, that would be helpful
16:11:23 <evrardjp> jmccrory: will be there, woot!
16:11:46 <jmccrory> evrardjp : finally got approval yesterday
16:11:50 <mhayden> yay
16:11:58 <evrardjp> I just saw you added your name, that's why :p
16:12:00 <mhayden> how about ol' automagically?
16:12:08 <andymccr> automgically cant make it :(
16:12:10 <evrardjp> that would be great
16:12:16 <evrardjp> and logan- ?
16:12:17 <mhayden> darn
16:12:25 <logan-> unlikely :/
16:12:36 <evrardjp> ok
16:12:59 <cloudnull> i'll be there. :)
16:13:10 <stevelle> nice
16:13:12 <evrardjp> wooot! add your name! :)
16:13:17 * cloudnull adding
16:14:03 <mhayden> if anyone isn't going to be there, feel free to toss some comments into the etherpad there with your thoughts, +1's, -1's, etc
16:14:30 <andymccr> ^ yes
16:14:44 <andymccr> and anything super important that you want discussed let me or somebody else know and i'd be happy to start a discussion if possible
16:15:34 <mhayden> i'll be at the Hilton up the street from the Sheraton
16:15:40 <mhayden> i think a few others will be there too
16:17:06 <mhayden> perhaps we could arrange a dinner or meetup for beverages?
16:17:32 * mhayden appoints jmccrory to lead our social committee :P
16:17:47 <odyssey4me> not sure what's happening with the PTG itself, but I'm guessing that nothing has been arranged - so mon night is the thing
16:18:00 <odyssey4me> some of us are staying for the whole week
16:18:06 <mhayden> we can always talk it over when we get there
16:18:13 <mhayden> i'll be around Mon/Tue only :/
16:18:19 <andymccr> im sure we will arrange somethings :)
16:18:27 <mhayden> okay, we're good on this i think
16:18:33 <mhayden> TO THE ETHERPAD!
16:18:42 <andymccr> rallying cry!
16:18:48 <mhayden> #topic New core reviewer -- andymccr
16:18:54 <mhayden> back to andymccr
16:19:20 <andymccr> yay!
16:19:24 <andymccr> so 2 in 2 weeks, which is kinda great
16:19:32 <andymccr> but mgariepy is now a core, since nobody objected
16:19:37 <evrardjp> yes!
16:19:41 <odyssey4me> huzzah!
16:19:41 <cloudnull> woot!
16:19:42 <evrardjp> this is great !
16:19:45 <mgariepy> yay :)
16:19:45 <mhayden> woot!
16:19:53 <odyssey4me> gratz mgariepy - and commisserations :p
16:19:59 <mhayden> #action everyone congratulate mgariepy on becoming a core reviewer!
16:20:03 <cloudnull> mgariepy: bring on the -2's :)
16:20:11 <andymccr> the CentOS work has been great and all the reviews too!
16:20:18 <cloudnull> ++
16:20:20 <mhayden> yeah, the centos work is much appreciated
16:20:24 <mhayden> as is the selinux work
16:20:27 <jmccrory> congrats
16:20:51 <mgariepy> thanks a lot guys :)
16:21:13 <mhayden> i remember when i walked uphill both ways to give a -2
16:21:18 * mhayden giggles
16:21:36 <mhayden> nice work, mgariepy  -- moving aloooong
16:21:44 <mhayden> #topic Release planning and decisions - andymccr
16:21:51 <mhayden> i hear we have some kind of release coming soon
16:21:56 <mhayden> rumor has it
16:22:00 <andymccr> ok so! we got rc1 out with the nova bits in!
16:22:09 <andymccr> we are working to fix everything up and thanks to everybody for the effort
16:22:18 <andymccr> with new branches and some instability around packages etc its a bit of a battle
16:22:22 <andymccr> but i think we're near the end of that
16:22:37 <andymccr> as an extra note, we have 2 extra weeks after final release date since we are cycle-trailing
16:23:10 <andymccr> mitaka will get a new release next week - but newton has stalled, im going to follow up with releases and stable branch team to find out if there is something we can do better to help get those releases through
16:23:30 <evrardjp> thanks andymccr
16:23:35 <asettle> Thanks :)
16:23:43 <andymccr> keep fixing the things in master and stable/ocata :)
16:23:45 <mhayden> ocata rc1 looks good on centos so far
16:23:53 <mhayden> my cluster is happy
16:24:03 <evrardjp> that's because setenforce 0
16:24:06 <andymccr> and i'll try do a stable/ocata bump once we have all the issues ironed out
16:24:11 <mgariepy> lol
16:24:16 <mhayden> evrardjp: actually, it's enforcing right now
16:24:23 <evrardjp> oh that's great news!
16:24:31 <odyssey4me> stop ruining our fun mhayden
16:24:34 <mhayden> sorry
16:24:41 <stevelle> that deserves some applause
16:24:46 <stevelle> really does
16:24:52 <evrardjp> wait to see the rules first :p
16:24:52 <mhayden> okay, andymccr -- anything we can do to help with releases?
16:25:11 <asettle> andymccr: do you have a starred list of patches again?
16:25:12 <andymccr> not really, just keep fixing the things like we have been and that'll be a massive help :)
16:25:12 <mhayden> #action everyone thank mhayden for ruining the selinux trolling fun
16:25:20 <asettle> Thanks mhayden
16:25:24 <evrardjp> thanks mhayden
16:25:28 <mgariepy> thanks a lot mhayden
16:25:30 <mhayden> #info Ocata RC1 is out
16:25:32 <andymccr> if only somebody had a "thanks" gif :P
16:25:44 <mhayden> #info We get 2 extra weeks after release for extra fixes since we're cycle-trailing
16:25:56 <xdaxdb> thanks to all you guys
16:26:06 <xdaxdb> err  *people
16:26:13 <spotz> hehe
16:26:33 <mhayden> i'm normally referred to as "that thing"
16:26:35 <mhayden> so it's okay
16:26:46 <mhayden> "that thing with the gifs"
16:26:47 <spotz> Por mhayden
16:26:51 <mhayden> "and the dad jokes"
16:27:04 <mhayden> #topic Open Floor
16:27:16 <mhayden> what else do we have?  blueprints? pre-ptg discussions?
16:27:42 <logan-> opinions on https://review.openstack.org/#/c/429779/ appreciated
16:27:49 <logan-> ceph is broken in ocata until we fix the enrollment workflow
16:27:52 <spotz> If anyone snags a code at PTG they're not going to use let me know
16:27:54 <mhayden> i'm interested in working with cloudnull to draft a spec for getting a formal monitoring role made out of his work in openstack-ansible-ops
16:28:11 <cloudnull> ++ i think this is a long time coming
16:28:23 <logan-> that is great
16:28:24 <cloudnull> It'd be great to formalize somet things
16:28:28 <andymccr> i would be in favour of this :)
16:28:40 <mhayden> would anyone want to form a little subgroup to talk about monitoring/metrics and use cases?
16:28:45 <andymccr> if you could spec that up before the ptf that would be awesome
16:28:50 <andymccr> ptg
16:28:56 <mhayden> andymccr: i think ol' cloudnull and i could do that
16:29:02 <andymccr> this is what i call TEAM
16:29:38 <mhayden> #action cloudnull and mhayden to draft up a spec for monitoring/metrics in OSA
16:30:13 <andymccr> ohh dang cloudnull - he's added an action item for you
16:30:33 <cloudnull> it just got real...
16:30:59 <cloudnull> https://www.youtube.com/watch?v=XQb3h0EEK8Y
16:31:15 <evrardjp> mhayden: for the metrics I think I'd be happy to relay some thoughts from outside rackspace
16:33:30 <andymccr> guessing mhayden put "last call on discussion" in the wrong channel? :P
16:33:37 <andymccr> but im guessing we are good for today!
16:33:45 <odyssey4me> and the action note :p
16:33:45 <evrardjp> I'm good.
16:33:53 <xdaxdb> I was planning on going to Boston in May, PTG sounds interesting though too
16:34:10 <evrardjp> well I'm not sure if that translate properly. I meant I have nothing to add.
16:34:15 <xdaxdb> I'm new to the scene trying to get more exposure
16:34:16 <andymccr> xdaxdb: for dev work the PTG is going to be more useful - there aren't any dev sessions at the summit afaik
16:34:21 <palendae> evrardjp: I understood it )
16:34:22 <asettle> xdaxdb: PTG is where it's at. It's where we'll go for planning :)
16:34:23 <evrardjp> xdaxdb: different targets I think
16:34:33 <andymccr> but if you're new to OpenStack and want to get more exposure the summits are great :)
16:34:38 <mhayden> now that i'm back in the right channel...
16:34:44 <evrardjp> palendae: \o/
16:34:44 <andymccr> mhayden: add the action item
16:35:05 <mhayden> #action everyone congratulate lbragstad on becoming keystone PTL!
16:35:06 <xdaxdb> I've been to a Red Hat summit and got really bored, would you say Boston is the same target audience?
16:35:11 <mhayden> but he's in #openstack-ansible, not here
16:36:00 <stevelle> xdaxdb: probably similar target
16:36:04 <mhayden> xdaxdb: this boston summit will be interesting -- it's the first time we've had one after a ptg
16:36:21 <xdaxdb> Not sure how much I can contribute I just want to listen to these meetings :)
16:36:42 <mhayden> i submitted a couple of talks for the summit in boston, so i may be there, who knows
16:36:57 <mhayden> my gut says that there will be much fewer technical people at the summits
16:37:05 <odyssey4me> xdaxdb the PTG is a project team planning for the next cycle's work, whereas the summit is where those who deploy the projects are able to give feedback
16:37:50 <xdaxdb> also its a place for vendors to shoot fish in a barrel I assume
16:37:51 <odyssey4me> they're staggered so that the feedback can be given ahead of the planning for the next cycle, and after the release so that deployers have time to actually try it all out
16:37:51 <spotz> mhayden I think you're right, I think folks will be there if their talks get in but not the numbers of tech folks when we had design meetings
16:38:08 <odyssey4me> yes, the summit is definitely the vendor thing
16:38:33 <spotz> I'm hoping they'll adjust things after this round
16:38:40 <xdaxdb> booking flight to ATL then
16:39:31 <spotz> Hey if we have any doc type things in ATL I'll try to atleast dial in on cloudnull or mhayden's phones:)
16:40:13 <mhayden> hah, we can figure out something possibly
16:40:17 <mhayden> even if it's one way
16:40:25 <mhayden> okay, 20 min left -- anything else today?
16:40:57 <mhayden> going once
16:41:05 <mhayden> going twice
16:41:09 <mhayden> thanks, everyone!
16:41:10 <spotz> woot gone
16:41:13 <mhayden> #endmeeting