16:00:57 <asettle> #startmeeting openstack_ansible_meeting
16:00:58 <openstack> Meeting started Thu Jan 19 16:00:57 2017 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:01 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:20 <asettle> #topic roll call
16:01:28 <cathrichardson> o/
16:01:28 <asettle> Hurr
16:01:30 <openstack> asettle: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:01:32 <asettle> STOP
16:01:34 <asettle> Hahaha
16:01:35 <asettle> Frick
16:01:36 <asettle> not my day today
16:01:39 <asettle> Hey cathrichardson :)
16:01:44 <rromans> .
16:01:44 <andymccr> o/`
16:01:45 <cathrichardson> :0
16:01:55 <cathrichardson> :)
16:01:56 <alextricity25> o/
16:02:00 <spotz> \o/
16:02:04 <automagically_> o/
16:02:17 <logan-> o/
16:02:19 <asettle> http://data.whicdn.com/images/82095776/large.gif
16:02:28 <asettle> Thanks team for all making it over ;)
16:02:40 <asettle> Give it a minute or so more.
16:03:24 <xgerman> o/
16:03:57 <evrardjp> hello
16:04:13 <odyssey4me> o/
16:04:17 <weezS> There should be applause
16:04:20 <odyssey4me> noddy badge for asettle :)
16:04:56 <asettle> Yeah wow, what a derp start to the meeting
16:04:59 <asettle> Sorry peoples
16:05:07 <asettle> Me today:
16:05:08 <asettle> https://68.media.tumblr.com/1171f60ff599233dd980af8438c49210/tumblr_n59mwmJx5J1t3gucoo1_500.gif
16:05:20 <asettle> Right, let's get this party started!
16:05:33 <asettle> #topic Review action items from last week
16:05:45 <asettle> I don't know if we had any...
16:05:46 <asettle> Let me double check
16:05:58 <asettle> Sorry, we do
16:06:03 <asettle> First action: Team to populate etherpad with ideas and discussion point for PTG
16:06:12 <asettle> Has everyone reviewed the etherpad for the PTG?
16:06:15 <asettle> #link https://etherpad.openstack.org/p/osa-ptg-pike
16:06:28 <asettle> Everyone that is attending - put your names down
16:06:32 <asettle> Any topics you want to talk about - put them down there too
16:06:37 <asettle> Who is attending the PTG?
16:06:38 <andymccr> ok so mhayden and asettle have added some. I need to add some too
16:07:04 <asettle> andymccr: that was an action item for you
16:07:06 <asettle> I can carry that one over
16:07:08 <andymccr> yeah please do
16:07:12 <asettle> #action andymccr to update PTG etherpad
16:07:31 <andymccr> just getting caught up in getting things ready for the release! I'll be on top of it after next week
16:07:38 <asettle> Next action item from last week, andymccr to close out the trusty-removal blueprint
16:07:40 <andymccr> also a reminder - it would be most appreciated if you could include blueprints
16:07:42 <asettle> Closed, andymccr ?
16:07:45 * automagically_ not attending the PTG
16:07:49 <andymccr> i removed it from the list - but i'll close it out
16:07:50 <asettle> automagically_: boo bro, boo :(
16:07:53 <odyssey4me> automagically_ :(
16:07:54 <asettle> andymccr: please close now :)
16:08:16 <asettle> Next action item from last week: team to review palendae 's spec
16:08:18 <asettle> #link https://review.openstack.org/#/c/419116/
16:08:23 <asettle> This appears to have *not* been reviewed.
16:08:34 <asettle> Could we get some eyes on this one please? automagically_ jmccrory evrardjp odyssey4me andymccr et al
16:09:06 <andymccr> i'll take a look but probably after next week
16:09:14 * automagically_ looking
16:09:15 <evrardjp> starred!
16:09:19 <andymccr> added myself as a reviewer
16:09:25 <asettle> Oh, me too ha
16:09:28 <asettle> okay, well thanks and thank you evrardjp
16:09:29 <asettle> :)
16:09:51 <asettle> Our last action item on the list was for the meeting host to include a new meeting section called "review my patch".
16:10:07 <asettle> I will add this section at the *end* of our meeting
16:10:16 <asettle> Hooray!
16:10:17 <asettle> https://68.media.tumblr.com/261733ff5718770535b28ebea028aa52/tumblr_mkqeob4BXl1s4xdz1o1_500.gif
16:10:19 <asettle> Moving along
16:10:30 <asettle> First topic
16:10:34 <asettle> #topic Operations guide
16:10:49 <asettle> All those that like and love a good operations guide, and have the time to review the doc, please see here: http://docs.openstack.org/developer/openstack-ansible/draft-operations-guide/index.html
16:11:41 * automagically_ doing so, and submitting patches as I go
16:11:45 <asettle> I have nothing more to say there unless anyone has any questions and comments? :)
16:11:47 <asettle> Thanks automagically_ !
16:11:50 <automagically_> Thanks all for the hard work on the ops guide
16:12:00 <automagically_> I’ve also asked some of my peers internally to review it
16:12:10 <asettle> automagically_: if you or anyone is able to provide ops experience to help build out some sections, that would be awesome!
16:12:15 <asettle> We're still looking for some things to be fleshed out
16:12:26 <asettle> You can see if any of your internals can help out on any of these topics: https://wiki.openstack.org/wiki/OpenStackAnsible#Documentation_planning
16:13:00 <automagically_> We’ll do what we can
16:13:07 <asettle> Thats' great :) thanks automagically_
16:13:21 <asettle> http://a.fod4.com/images/GifGuide/dancing/tumblr_lit5wdB6j21qcfba3o1_500.gif
16:13:26 <asettle> Excitable Alex!
16:13:33 <asettle> Next up:
16:13:43 <asettle> #topic PTG - Feb 20-24
16:13:48 <asettle> andymccr: got anything more to add here?
16:13:52 <andymccr> ok so - just keeping this as an ongoing topic really.
16:13:55 <asettle> To reiterate...
16:13:57 <asettle> #link https://etherpad.openstack.org/p/osa-ptg-pike
16:14:01 <andymccr> again its all about getting blueprints etc together for the etherpad ^
16:14:29 <andymccr> so yeah more just a reminder, will keep it up until the PTG happens :D
16:14:33 <asettle> Sweet!
16:14:43 <asettle> Does anyone know of anything they'd like to talk about at the summit but are too afraid to put on the etherpad?
16:15:33 <andymccr> if thats the case, feel free to msg me to talk about it.
16:15:38 <asettle> Cool :)
16:15:40 <asettle> Thanks andymccr
16:15:41 <andymccr> Also this applies to people who arent able to attend the PTG either
16:15:54 <andymccr> let me know and we can discuss and i'll do my best to represent/raise it
16:16:09 <asettle> Great idea :) thanks andymccr
16:16:33 <asettle> Next up
16:16:37 <asettle> #topic Release planning and decisions
16:16:42 <asettle> andymccr: this is you, o' PTL
16:16:54 <andymccr> ok
16:16:55 <andymccr> so!
16:16:59 <asettle> What's a hap-happening?
16:17:01 <andymccr> newton/mitaka releases went out today.
16:17:09 <andymccr> but more importantly, this is the last week of Ocata "feature" work.
16:17:22 <andymccr> i'll try do milestone 3 for Ocata mid week next week, to give us time to merge any patches that are important
16:17:40 <andymccr> but i want to raise a few that are ongoing and I'd like to see reviewed and merged if possible
16:18:02 <andymccr> #link https://review.openstack.org/#/c/409407/ logan- has a ceph patch up and its currently passing teh ceph experimental gate
16:18:06 <andymccr> so i think that should be able to go in
16:18:39 <andymccr> #link https://review.openstack.org/#/c/391524/ the dragonflow patch worked on by oanson and evrardjp pretty much all cycle - if that could be reviewed
16:19:02 <andymccr> and lastly i'll have a patch up to do nova-placement API which will be ready in time (hopefully) so i may ping some ppl tomorrow/monday for reviews
16:19:25 <asettle> Thanks andymccr :) I can reiterate those patches at the end of the meeting too
16:19:27 <andymccr> does anybody else have any other patches that need to go in?
16:19:39 <andymccr> or need reviews/help getting patches in?
16:19:52 <andymccr> let me know and i'll do my best to help move them along.
16:20:05 <asettle> +2 - will also try to help
16:20:58 <evrardjp> all my artifacts one :)
16:21:11 <evrardjp> so I'll probably give a link in the chan later
16:21:29 <logan-> working on dragonflow testing. now that the ansible thing is fixed I can build aios again so i'll hopefully have some info on whats still outstanding w/ that one today
16:21:30 <evrardjp> https://review.openstack.org/#/q/topic:artifacts
16:21:35 <asettle> evrardjp: thanks !
16:21:40 <evrardjp> #link https://review.openstack.org/#/q/topic:artifacts
16:21:57 <andymccr> there's only 1 there and its for stable/newton - are more coming evrardjp?
16:22:04 <evrardjp> yes :)
16:22:08 <andymccr> ok
16:22:13 <evrardjp> giving the generic url
16:22:24 <evrardjp> sorry thinking ahead :p
16:22:36 <evrardjp> but they gonna need some love!
16:22:39 <logan-> evrardjp: is the developer mode stuff needed in newton for any of your work?
16:23:17 <evrardjp> it is a certainly welcomed addition
16:24:01 <evrardjp> I'll evaluate this and maybe we could backport together if needed, and talk about it in the next community meeting?
16:24:34 <logan-> sure. i already forked & bp the ones I need because I wasn't sure if anyone upstream needs them bp. but I'm happy to handle proposing them if they'll be of any use
16:25:19 <evrardjp> we always need to be careful about the standard behavior, but as I said, I think it's a good addition
16:25:51 <evrardjp> thanks for this work btw :D
16:26:15 <asettle> Okay great, everyone ready to scoot on?
16:26:26 <logan-> yep!
16:26:34 <asettle> #topic Blueprint work
16:26:44 <asettle> #link https://blueprints.launchpad.net/openstack-ansible/+spec/security-rhel7-stig
16:26:49 <asettle> RHEL 7 STIG - mhayden
16:27:00 <asettle> I believe mhayden is indisposed. But the current status is still 'active development'
16:27:01 <mhayden> done!
16:27:02 <mhayden> next :)
16:27:02 <andymccr> marked as implemented
16:27:03 <asettle> OH HEY!
16:27:04 <andymccr> so done!
16:27:08 <andymccr> celebrations
16:27:10 <mhayden> put a fork in it
16:27:12 <mhayden> it's done
16:27:14 <mhayden> :)
16:27:17 <asettle> http://a.fod4.com/images/GifGuide/dancing/tumblr_lit5wdB6j21qcfba3o1_500.gif
16:27:18 <asettle> Excitement
16:27:45 <asettle> Okay, next up
16:27:51 <asettle> #link https://blueprints.launchpad.net/openstack-ansible/+spec/upgrade-testing
16:27:54 <asettle> Upgrade testing, andymccr
16:28:00 <andymccr> work is being done on the integrated upgrade build
16:28:17 <asettle> Boom boom
16:28:25 <asettle> Upgrades got nufin on andymccr
16:28:25 <asettle> https://s-media-cache-ak0.pinimg.com/originals/4d/bd/b3/4dbdb35c73eb21489b302c758b6d9784.gif
16:28:37 <evrardjp> that's a weird gif
16:28:39 <asettle> Been waiting all day to use that gif
16:28:47 <asettle> Worth it.
16:28:47 <evrardjp> I bet you were
16:28:49 <asettle> :p
16:28:54 <asettle> Any further update andymccr ?
16:28:58 <evrardjp> Could we stop 'though?
16:28:59 <andymccr> #link https://review.openstack.org/#/c/421295/
16:29:04 * automagically_ wishes he hadn’t viewed that gif
16:29:06 <andymccr> was just looking for the pr
16:29:19 <asettle> automagically_: you are *welcome*
16:29:20 <andymccr> but thats it for upgrade testing - thats pretty much the last thing
16:29:24 <andymccr> (and most important)
16:29:35 <asettle> Excellent :)
16:29:51 <asettle> And then the last blueprint
16:29:54 <asettle> #link https://blueprints.launchpad.net/openstack-ansible/+spec/create-ops-guide
16:30:00 <asettle> Operations guide - which we have already more or less discussed
16:30:04 <asettle> Active development, slow going.
16:30:10 <asettle> Needs reviews and contributors.
16:30:36 <asettle> Anyone have any other blueprints we have missed?
16:31:05 <asettle> To be fair, I see a fair few
16:31:06 <asettle> #link https://blueprints.launchpad.net/openstack-ansible
16:31:37 <andymccr> most are not active i believe
16:31:39 <asettle> odyssey4me - what's the update on the upgrade path from Mitaka to Newton? Can we close this?
16:31:41 <asettle> #link https://blueprints.launchpad.net/openstack-ansible/+spec/upgrade-mitaka-newton
16:31:55 <andymccr> we should audit those
16:32:08 <asettle> We really should.
16:32:18 <odyssey4me> asettle apparently mitaka->newton works
16:32:22 <asettle> odyssey4me: can close?
16:32:27 <odyssey4me> I don't know though - never tested it personally
16:32:36 <odyssey4me> IIRC jmccrory worked on that
16:33:42 <asettle> jmccrory: update?
16:34:25 <logan-> i'm hoping to get my dev cluster M->N by end of month so no input on that one from me yet
16:34:36 <asettle> OKay, thanks logan- - I'll leave that one open then
16:34:45 <asettle> @odyssey4me I have another you're assigned to. Update?
16:34:47 <asettle> #link https://review.openstack.org/#/
16:34:49 <asettle> DAMNIT
16:34:52 <asettle> https://blueprints.launchpad.net/openstack-ansible/+spec/gate-split
16:34:56 <asettle> I am so bad at this whole computer thing today
16:36:46 * asettle looks at the abandoned channel
16:36:49 <asettle> GUYS
16:37:04 <andymccr> haha
16:37:06 <andymccr> i think the best approach
16:37:06 <andymccr> is
16:37:08 <logan-> the ceph job uses a lot of foundational work from that but the bp itself is not ready to close. not much motivation to keep it moving along right now because it seems like we're doing good on gate times
16:37:29 <andymccr> leave the blueprints for now, we need to audit them, which doesnt necessarily need to be done now.
16:37:34 <asettle> Thanks logan- :)
16:37:50 <andymccr> i'll spend some time after next week pruning some of those and seeing what is/isnt meant to still be there
16:37:52 <andymccr> then we can follow up
16:38:00 <asettle> Sounds like a plan andymccr :)
16:38:18 <asettle> Okay, well, since you've all decided to return to your daily lives and this has become a dead zone. I'm calling it unless people have reviews
16:38:27 <asettle> #topic Open discussion and 'please review my patch' time
16:38:28 <odyssey4me> yeah, the gate split foundational work is actually done
16:38:36 <odyssey4me> it is now possible to have multiple scenarios
16:38:46 <odyssey4me> the ceph job is the first to use it
16:38:50 <asettle> You have got to be joking odyssey4me you have outrageously lame timing :p
16:39:06 <asettle> odyssey4me: should we close?
16:39:16 <odyssey4me> but yeah, andymccr we should probably chat about whether it needs to continue on from there is stay as-is
16:39:32 <andymccr> yeah i think thats one that probably needs more conversation in general
16:39:34 <odyssey4me> the urgency to actually split it is gone
16:39:37 <andymccr> but a lot of those are finished/done
16:39:41 <andymccr> so yeah
16:39:44 <asettle> That's good :)
16:39:49 <asettle> okay, well, andymccr that's in your hands for now
16:40:05 <andymccr> i'll add it to my post release check list
16:40:15 <asettle> I'll leave this open for 5 more minutes in case anyone has anything left before I close us out :)
16:40:54 <andymccr> can we get reviews on: https://review.openstack.org/#/c/422698/
16:40:58 <andymccr> its causing the integrated build to break
16:41:03 <asettle> #link https://review.openstack.org/#/c/422698/
16:41:04 <andymccr> as well as some role gates (ironic for example)
16:41:33 <odyssey4me> done
16:41:40 <andymccr> thanks!
16:42:27 <asettle> Anyone else with some reviews? :)
16:42:29 <asettle> evrardjp: ;)
16:42:54 <evrardjp> ahah not this time. I used it during "should appear in next release" :)
16:43:18 <asettle> Cool :) well, I'm just about good to close
16:43:23 <asettle> andymccr: all good in the hood>?
16:43:23 <evrardjp> thanks everyone!
16:43:31 <andymccr> asettle: one more gif for the road?
16:43:38 <asettle> It's liek you knew I was waiting
16:43:38 <asettle> http://31.media.tumblr.com/e252577812e9094520e44124f6b66b48/tumblr_ml07jxD1J31r1mr1po1_500.gif
16:43:50 <asettle> #worthit
16:43:54 <asettle> #endmeeting