16:08:05 <odyssey4me> #startmeeting OpenStack Ansible Meeting
16:08:05 <openstack> Meeting started Thu Jan 21 16:08:05 2016 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:08:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:08:08 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:10:21 <odyssey4me> Hello?
16:10:28 <automagically> Hello
16:10:30 <odyssey4me> #topic Agenda & rollcall
16:10:31 <mattt> \o
16:10:42 <dstanek> odyssey4me: you alway roll call in the other room :-P
16:10:44 <odyssey4me> sorry about the late start :/
16:10:51 <prometheanfire> o/
16:11:15 <spotz> o/
16:11:19 <odyssey4me> heh dstanek I do it there as not everyone sticks around in this room
16:11:38 <jmccrory> hello
16:11:50 <cloudnull> presente
16:11:57 <mcarden> .
16:12:09 <KLevenstein> o/
16:12:16 <neillc> o/
16:12:38 <Bjoern> o/
16:12:52 <odyssey4me> Alright, welcome all. Apologies for the late start.
16:13:13 <b3rnard0> hello
16:13:24 <odyssey4me> Apologies too for not yet sending out the reminder and further details about the mid cycle. I'm still trying to get all that together.
16:13:34 <odyssey4me> Hopefully that'll be done by COB tomorrow.
16:13:44 <odyssey4me> #topic Mid-Cycle Meetup
16:14:06 <odyssey4me> For now - does anyone have any questions about the Ops Mid Cycle or OSA Mid Cycle?
16:14:17 <odyssey4me> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:14:47 <cloudnull> odyssey4me: am i correct in that the ops midcycle is in manchester and the osa will be at rax offices in LON  ?
16:15:06 <cloudnull> or all will be at the same venue ?
16:15:15 <odyssey4me> yes, that's correct - we have been invited to hold some sessions at the ops mid cycle too
16:15:33 <cloudnull> kk
16:15:44 <odyssey4me> I'm working with the organisers to secure a few sessions in a room there.
16:16:01 <cloudnull> nice
16:16:05 <odyssey4me> It does seem to be that there is a space issue, so I'll be working with them to see if we can sort that out.
16:16:46 <odyssey4me> I have asked for topics and provided an etherpad to propose topics - please add to the etherpad.
16:17:49 <odyssey4me> I'm looking for proposals - but I'm thinking that we'll likely do some dev docs to help new contributors, I think we need to discuss the dynamic inventory, and we should try to finalise the new roles for searchlight, ironic, designate, zaqar, etc. I'd like to also formulate and document some policies around when we do sha bumps, rabbit upgrades, etc. I',m not sure that we can fit that all in - we may have to
16:17:50 <odyssey4me> defer some to the summit.
16:17:51 <prometheanfire> the multi-os support linked is something I've been working on the groundwork for.
16:18:03 <prometheanfire> at least to add to the list of branches working on it
16:18:38 <odyssey4me> prometheanfire please add to the applicable etherpad so that everyone else is exposed to the work you're doing
16:19:06 <prometheanfire> sure, right now it's just disk-image-builder, but I plan on using the master-rhel branch to base my chanes off of
16:19:19 <odyssey4me> it'd be ideal if multi-os enablement work could be proposed directly to the repositories though, rather than in forks
16:19:24 <prometheanfire> need to get the rax-nova-agent to work first I think
16:19:37 <cloudnull> #link https://github.com/cloudnull/os-ansible-deployment/tree/master-rhel
16:19:50 <prometheanfire> it'll be done in a fork at first because it needs to be tested
16:19:57 <prometheanfire> it's a large change
16:20:03 <odyssey4me> ah, there's some high level stuff that needs to be done before anything that actually touches another OS comes into play
16:20:27 <odyssey4me> just the application of patterns to only use apt if the package manager is apt, for instance
16:20:34 <prometheanfire> ah
16:20:41 <odyssey4me> also to import vars that apply to the right OS
16:20:44 <prometheanfire> splitting into var files seems like a good idea
16:20:54 <odyssey4me> that can be done now, in tree without needing anything special
16:20:56 <cloudnull> with the seperatation of all of the roles that should be easier to do
16:21:06 <cloudnull> without impacting the main repo
16:21:10 <prometheanfire> right
16:21:19 <odyssey4me> once that's done, then systemd support needs to come into play
16:21:43 <prometheanfire> since the first pass is only host support what's in a container shouldn't matter at least at first
16:21:44 <odyssey4me> once that's in - then adding another OS will largely be simply adding var files and some task files for os-specific stuff if need be
16:22:33 <prometheanfire> right
16:22:52 <prometheanfire> odyssey4me: can the pre-work be fully colated so we can start work on it?
16:23:28 <odyssey4me> prometheanfire well, someone needs to volunteer to pull the interested parties together and put together a spec for a body of work
16:23:55 <odyssey4me> myself and cloudnull are maxed out right now
16:24:02 <prometheanfire> the main reason I haven't done the pre-work is because I don't know what it is
16:24:29 <odyssey4me> ok, perhaps we should specifically discuss this topic next week and put together a spec in an etherpad
16:24:45 <odyssey4me> happy with that?
16:25:11 <odyssey4me> ie next week thu we'll do a design workshop in the community meeting
16:25:11 <prometheanfire> yep, thanks :D
16:25:33 <odyssey4me> #action odyssey4me to facilitate a design discussion in next week's meeting for multi-os enablement
16:25:38 <odyssey4me> right
16:25:41 <odyssey4me> #topic Release Planning and Decisions
16:26:03 <odyssey4me> FYI to all, I tagged Liberty 12.0.4 and Kilo 11.2.8 earlier today after the pip fix patches merged.
16:26:25 <odyssey4me> That should help everyone get on with their lives, and we now have safeguards in place to reduce the risk of this happening again.
16:26:50 <cloudnull> ++ W00t!
16:27:10 <odyssey4me> Due to some very serious CVE's being released since the last Kilo SHA bump, I'm pushing to have a SHA bumpe merged today and will tag again immediately.
16:27:25 <odyssey4me> Kilo SHA bump: https://review.openstack.org/265491
16:27:50 <odyssey4me> the last Liberty bump missed the latest CVE fix, so I'll do the same for Liberty: https://review.openstack.org/270760
16:28:08 <odyssey4me> please review and vote accordingly - I'd like to tag tomorrow at the latest
16:28:09 <prometheanfire> so, 11.2.9?
16:28:20 <prometheanfire> and 12.0.5
16:29:00 <odyssey4me> 11.2.8 and 12.0.5
16:29:14 <odyssey4me> ah, I misspoke earlier - I released 11.2.7 - sorry about that
16:29:16 <cloudnull> odyssey4me:  because of those CVEs can we auto +w those patches? or do we have another core that can help shove the changes through ?
16:30:00 <odyssey4me> mattt / stevelle could you do the honours of providing a second vote?
16:30:21 <mattt> odyssey4me: i'll have a peek
16:30:28 <odyssey4me> thanks mattt
16:30:33 <cloudnull> + d34dh0r53 hughsaunders
16:31:15 <odyssey4me> #topic Open discussion
16:31:27 <odyssey4me> alright, we have time for anything anyone wants to raise
16:31:45 <spotz> One quick thing
16:32:05 <spotz> If your patch is a doc it's been real handy if you put Doc: on it so I can find it
16:32:21 <automagically> Ah, good to know
16:32:47 <spotz> Might even be good for bugs but I think most people bug it and fix it themselves
16:33:31 <odyssey4me> well, typically a bug has the bug/<number> topic
16:33:39 <automagically> spotz: 2 from me that I should have tagged as such: https://review.openstack.org/268266 and https://review.openstack.org/268231
16:33:41 <odyssey4me> it might be good to use some sort of topic tag for docs too
16:34:22 <spotz> Thanks automagically I'll get them after the meeting
16:34:50 <odyssey4me> good suggestion spotz :)
16:35:19 <odyssey4me> You may have noticed that we're having trouble merging patches into Master right now.
16:35:37 <odyssey4me> It seems that we're continually getting into something that seems like a race condition.
16:36:09 <odyssey4me> The tempest role tries to add a glance image. Glance returns that the image is in just fine, but glance_store is actually spitting errors out.
16:36:26 <odyssey4me> so the image that glance thinks is uploaded, is not
16:36:31 <stevelle> odyssey4me: I dont know much about the race condition yet. Is this related to running multiple Keystones at all?
16:36:32 <odyssey4me> so the tempest run fails
16:37:00 <automagically> newb hereā€¦.and the tempest run is part of the gate?
16:37:05 <odyssey4me> stevelle perhaps
16:37:21 <odyssey4me> automagically yes, tempest does a functional test of our build after the ansible build is complete
16:37:24 <mattt> stevelle: i was wondering that today actually
16:37:29 <odyssey4me> it's how we know that what we've built actually works
16:37:34 <automagically> Thx
16:38:31 <stevelle> in-memory caching in a load-balanced app, perhaps mattt?
16:38:34 <odyssey4me> stevelle I've tried reducing the galera & rabbit affinities down, but that got the same result. Perhaps I should reduce the keystone affinities too.
16:39:30 <odyssey4me> Alright, I think that's a discussion we should take to the channel afterwards. I wanted to raise awareness and solicit help.
16:41:35 <odyssey4me> good pointer stevelle - as this is only happenning in master, we could be seeing an upstream change in behaviour/defaults
16:44:07 <odyssey4me> any other topics, questions or thoughts?
16:47:51 <odyssey4me> alright, we're done then
16:48:02 <odyssey4me> thank you all for your time - have a great day!
16:48:06 <odyssey4me> #endmeeting