16:01:24 <odyssey4me> #startmeeting OpenStack Ansible Meeting
16:01:24 <openstack> Meeting started Thu Oct 15 16:01:24 2015 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:28 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:32 <Sam-I-Am> yo
16:01:33 <d34dh0r53> o/
16:01:44 <odyssey4me> #topic Agenda & rollcall
16:02:26 <Sam-I-Am> yo, again
16:02:55 <prometheanfire> o/
16:03:05 <palendae> 'lo
16:03:16 <b3rnard0> hola
16:04:19 <odyssey4me> howdy all
16:04:32 <odyssey4me> shall we get on it, or are we waiting for anyone else
16:04:49 <odyssey4me> cloudnull has sent apologies as he's not feeling well at all
16:05:08 <jasondotstar> o/
16:05:21 <odyssey4me> #topic Review action items from last week
16:05:30 <odyssey4me> #link http://eavesdrop.openstack.org/meetings/openstack_ansible_meeting/2015/openstack_ansible_meeting.2015-10-08-16.00.html
16:05:52 <odyssey4me> odyssey4me verify master has fix commited and change status of https://bugs.launchpad.net/openstack-ansible/trunk/+bug/1482756
16:05:52 <openstack> Launchpad bug 1482756 in openstack-ansible trunk "networking fails due to new ebtables-based arp spoofing protection" [High,Fix committed] - Assigned to Jesse Pretorius (jesse-pretorius)
16:06:04 <odyssey4me> that is done
16:06:41 <odyssey4me> the one final piece is https://review.openstack.org/234926
16:07:02 <odyssey4me> which is really just an update for neutron which allows Liberty's config to use the upstream default
16:07:19 <odyssey4me> next: mhayden update https://bugs.launchpad.net/openstack-ansible/+bug/1491440 with current status
16:07:19 <openstack> Launchpad bug 1491440 in openstack-ansible trunk "Restarting containers leads to 'dangling' veth interfaces" [Medium,In progress] - Assigned to Major Hayden (rackerhacker)
16:07:38 <odyssey4me> mhayden what's up with that? ;)
16:07:46 <Sam-I-Am> odyssey4me: in that neutron arp thing, did you add the ml2 extension?
16:07:46 <Apsu> Netlink is hard.
16:07:49 <Sam-I-Am> or plan to...
16:08:20 <odyssey4me> Sam-I-Am there is no need - the config template capability allows the deployer to set whatever they want
16:08:46 <odyssey4me> so the approach for Liberty+ is to use upstream defaults and deployers can override anything in any conf
16:08:49 <Sam-I-Am> in liberty, if you default to enabling arp spoof protection, you should also by default enable the port_security extension
16:09:11 <Sam-I-Am> never trust defaults in neutron config files, they're terrible
16:09:17 <odyssey4me> Sam-I-Am if that is done by default upstream, then it is how it will be for us
16:09:30 <odyssey4me> we don't use the config files - we rely on the code defaults
16:09:50 <odyssey4me> mhayden you around?
16:10:15 <odyssey4me> ok, that action item will have to carry
16:10:24 <odyssey4me> #action mhayden update https://bugs.launchpad.net/openstack-ansible/+bug/1491440 with current status
16:10:24 <openstack> Launchpad bug 1491440 in openstack-ansible trunk "Restarting containers leads to 'dangling' veth interfaces" [Medium,In progress] - Assigned to Major Hayden (rackerhacker)
16:10:33 <odyssey4me> next: jasondotstar work on https://bugs.launchpad.net/openstack-ansible/+bug/1469868
16:10:33 <openstack> Launchpad bug 1469868 in openstack-ansible "OpenStack Ansible Does Not Ship Glance Metadata Definitions" [Wishlist,Confirmed]
16:11:09 <odyssey4me> I see that this just came up in the channel
16:11:11 <jasondotstar> https://review.openstack.org/#/c/235425/ is under review - got some comments
16:11:14 <odyssey4me> #link https://review.openstack.org/235425
16:11:24 <odyssey4me> and I see that sigmavirus24 has already provided feedback
16:11:28 <jasondotstar> I'll make the adjustments accordingly
16:11:41 <sigmavirus24> Thanks jasondotstar
16:11:50 <sigmavirus24> You'll probably want with_items to make sure you find all locations =P
16:12:01 <jasondotstar> sigmavirus24: +1
16:12:15 <sigmavirus24> thanks for tackling that jasondotstar
16:12:19 <odyssey4me> ++
16:12:24 <jasondotstar> np, first one for the ansible team
16:12:26 <jasondotstar> :-)
16:12:33 <odyssey4me> alright, next
16:12:37 <odyssey4me> #topic Liberty Release Blueprints
16:13:06 <odyssey4me> there are still some WIP as shown in https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:13:20 <odyssey4me> as with the venv reviews
16:13:54 <odyssey4me> I'm hoping that we can get them finalised and merged by next week so that we can let it bake for a week before we release, which is planned for Firday.
16:13:57 <odyssey4me> *Friday
16:14:06 <odyssey4me> any questions or comments?
16:14:32 <odyssey4me> Note that the venv reviews are also a deliberable for the Liberty release.
16:17:46 <palendae> When is upstream's Libety release?
16:17:51 <odyssey4me> today
16:17:54 <palendae> Ah
16:18:24 <odyssey4me> #topic Mitaka Agenda
16:18:34 <odyssey4me> #link https://etherpad.openstack.org/p/openstack-ansible-mitaka-summit
16:18:43 <odyssey4me> so, we have two fishbowl sessions
16:19:21 <odyssey4me> one is http://sched.co/4Qed and the other is http://sched.co/4QbH
16:19:37 <odyssey4me> fishbowl sessions are named on the summit agenda and large rooms
16:20:05 <odyssey4me> we have several proposals in the etherpad
16:20:44 <odyssey4me> I'd like some input on which proposals are considered most important for a large public audience?
16:20:57 <odyssey4me> whether already proposed, or not
16:21:33 <palendae> I know the image-based deployment options have been coming up a lot internally
16:21:44 <palendae> Probably worth exploring
16:22:26 <odyssey4me> I'd like to make a call, then send out ML announcements with the etherpad links
16:23:07 <odyssey4me> I do agree that image-based deployments would be great to discuss. palendae are you still keen to moderate that?
16:23:33 <palendae> Sure; I don't really have an opinion myself, but I'd like to hear ideas
16:23:51 <palendae> I think the kolla team has insights to share
16:24:51 <odyssey4me> sure, I'm sure that many people do
16:25:00 <prometheanfire> they said they wanted to join my session but claim scheduling conflicts
16:25:10 <palendae> I think cloudnull, who's not here, had a few ideas from our side, but I think it's of general concern to operators
16:25:29 <odyssey4me> as moderator you'll need to prep with probing questions, some analysis of stuff you can find and will have to be clear about what outcome you want to see
16:26:01 <odyssey4me> yeah, cloudnull has already done some PoC work - and mhayden has some insights too
16:26:12 <odyssey4me> I've done a little testing too
16:26:19 <palendae> Alright, I can draft some questions. Is that etherpad a good place for now?
16:26:23 <odyssey4me> ok cool, so we'll announce that as one
16:26:25 <palendae> Or does that get on the official docs?
16:26:32 <palendae> Er, official schedule
16:26:44 <odyssey4me> I'll setup etherpads for these two sessions straight after the meeting
16:26:47 <palendae> Ok
16:26:55 <odyssey4me> and yes, it'll be very widely published
16:27:07 <palendae> The questions?
16:27:09 <palendae> Or the title?
16:27:44 <odyssey4me> the etherpad we use for that session - I'll setup one up, then rely on you to put a skeleton of some sort together on it
16:27:54 <palendae> Sure
16:28:01 <odyssey4me> I want to send it out to the ML next week monday at the latest
16:28:04 <palendae> Ok
16:28:14 <odyssey4me> that way people can already pose questions and notes
16:28:35 <palendae> Yep, fair
16:29:12 <odyssey4me> For the other session I'd like to invite feedback from anyone on how we're doing... but that seems a bit naf
16:29:35 <odyssey4me> So perhaps we should do a session on enabling multi OS support for openstack-ansible?
16:30:08 <palendae> That sounds like a good one
16:30:18 <stevelle> that seems like fit for a work session maybe
16:30:39 <stevelle> I am not sure if that benefits from fishbowl but
16:30:54 <stevelle> I don't really know, to say that again
16:31:35 <odyssey4me> yeah, I think it's been a broad interest and may bring in some fresh faces
16:32:06 <odyssey4me> then for the workroom slot, perhaps we should buckle down and discuss our lessons learned and how we can do better
16:32:31 <odyssey4me> how does that sound?
16:32:50 <stevelle> I was drawn to the idea of revisiting dynamic inventory
16:33:37 <odyssey4me> hmm, another option I just realised for the fishbowl session is to talk about upgrades
16:33:51 <odyssey4me> it'd be great to get a broad set of feedback for handling upgrades properly
16:34:03 <palendae> I know someone from CERN mentioned they wanted to talk about how they upgrade to every openstack release
16:34:13 <palendae> I want to ask them how they do that without disrupting business
16:34:21 <palendae> Or "work"
16:35:13 <palendae> Not sure if that's generally applicable or not. prometheanfire were you doing operator sessions?
16:35:33 <palendae> That audience would probably be interested
16:35:53 <prometheanfire> yes
16:36:00 <prometheanfire> https://etherpad.openstack.org/p/TYO-ops-infrastructure-containers
16:36:19 <prometheanfire> it's wednesday from 11:15 to 11:55
16:36:22 <palendae> Thanks
16:37:03 <prometheanfire> there are also other upgrades talks
16:37:04 <prometheanfire> https://etherpad.openstack.org/p/TYO-ops-upgrades
16:37:06 <odyssey4me> that's before our session - so it may be good to attend that, then come armed with that info for a discussion?
16:37:21 <prometheanfire> yes?
16:37:26 <prometheanfire> that a question?
16:38:00 <odyssey4me> yeah - I'm suggesting that perhaps we make or second fishbowl session (3:40 pm on wed) a workshop on upgrades
16:38:13 <prometheanfire> that sounds good
16:38:16 <odyssey4me> so the first one (at 2:50pm will be about image-based deployment)
16:38:34 <palendae> Ok
16:38:58 <odyssey4me> do we think those two topics are of a broad interest and useful to the project?
16:39:35 <palendae> I believe so
16:39:46 <palendae> Would like other opinions
16:39:46 <odyssey4me> great!
16:40:05 <odyssey4me> ok, then the work session at 5:30pm...
16:40:18 <palendae> Wonder if they have any documentaton on what video hook ups the rooms have
16:40:42 <prometheanfire> I'm gonna scope out at least my room before :P
16:40:55 <palendae> Yeah, I'd kind of like to know now, since I'm still waffling on what devices to take
16:40:57 <palendae> But that's a tangent
16:41:36 <odyssey4me> perhaps for the workroom slot we should take a look at dynamic inventory
16:41:57 <odyssey4me> it seems to be the greatest cause for confusion when new users are configuring OSA
16:42:11 <odyssey4me> and for developers trying to add functionality
16:43:19 <palendae> Do we want to discuss the Ansible community day at all?
16:43:24 <palendae> I think that's Tuesday?
16:43:26 <odyssey4me> I'd like to also do a sprint where we go through a role analysis and see how we can simplify how we build roles and set an improved pattern.
16:43:34 <odyssey4me> Ansible community day is Thu
16:43:39 <palendae> Ok
16:43:46 <odyssey4me> https://etherpad.openstack.org/p/ansible-collabday-mitaka-planning
16:43:51 <palendae> I know there were some topics like what needs to happen to move to Ansible 2.0
16:45:14 <odyssey4me> that's pretty much Ansible's gig - our attendance will be to listen mostly
16:45:24 <palendae> Sure
16:45:41 <palendae> More looking for things we might pitch as discussion topics
16:46:12 <odyssey4me> #action odyssey4me to setup summit etherpads
16:46:47 <odyssey4me> #action palendae to populate the Image-based deployments etherpad
16:47:20 <odyssey4me> #action odyssey4me to populate the upgrade session etherpad
16:47:40 <odyssey4me> #action odyssey4me to send ML announcements for the summit etherpads
16:47:49 <odyssey4me> am I missing anything?
16:49:41 <odyssey4me> #topic Open discussion
16:49:58 <odyssey4me> alright - is there anything else anyone wants to discuss, highlight or dance a jig about?
16:50:02 <stevelle> https://review.openstack.org/#/c/226621/
16:50:18 <stevelle> I want to highlight this for discussion
16:50:27 <odyssey4me> sure, go ahead
16:51:25 <stevelle> This is something that would be a fairly significant change to juno, and I wanted to recruit opinions in the form of reviews.
16:53:09 <odyssey4me> yeah, I'm not fond of the idea of that much change going into juno - that said it is simply an enabler and if enough people confirm that it doesn't break anything to merge it in, then I don't mind
16:53:37 <odyssey4me> my primary concern is not whether it does what it wants to do (ie if you enable https then it actually sets the endpoints, etc)
16:53:47 <odyssey4me> my primary concern is whether it breaks anything if you don't
16:54:49 <odyssey4me> from the gate check it appears not, but it definitely needs more actual testers as the juno testing is not as thorough as kilo+
16:56:53 <odyssey4me> any other opinions/views?
16:57:42 <palendae> I tested patchset 1, and got expected endpoints when not enabling it
16:57:47 <stevelle> If you don't have something to add right now but you can take a bit of time to consider it, please do this week.
16:57:48 <palendae> But that's been a while
17:00:01 <odyssey4me> ok, thanks everyone!
17:00:06 <odyssey4me> #endmeeting