16:00:51 <odyssey4me> #startmeeting OpenStack Ansible Meeting
16:00:51 <openstack> Meeting started Thu Jul 30 16:00:51 2015 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:55 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:15 <odyssey4me> #topic Agenda & rollcall
16:01:43 <prometheanfire> o/
16:01:49 <palendae> Here
16:02:10 <serverascode> o/
16:02:14 <phalmos> yup
16:02:17 <stevelle> o/
16:02:17 <d34dh0r53> \o/
16:02:21 <dstanek> o/ too!
16:02:37 <evrardjp> hello there
16:02:48 <odyssey4me> howdy all, and welcome
16:03:11 <miguelgrinberg> Hi
16:03:25 <odyssey4me> We have quite a lot to cover today, so we should get on with it. :)
16:03:35 <b3rnard0> hello
16:03:43 <odyssey4me> #topic Review action items from last week
16:04:17 <odyssey4me> action: VOTE: Voted on "Should we backort the new key distribution process?" Results are, Yes: 6 (cloudnull, 16:26:46)
16:04:30 <odyssey4me> as I recall, this was done
16:04:44 <odyssey4me> ie ACTION: backport https://review.openstack.org/#/c/205008/ https://review.openstack.org/#/c/205056/ and https://review.openstack.org/#/c/204996/ to kilo - someone (cloudnull, 16:27:25)
16:05:13 <odyssey4me> yep, it's all merged into master and kilo
16:05:34 <odyssey4me> carried actions:
16:05:39 * odyssey4me get a thread going on the mailing list surrounding issues with upgrading Kilo > Liberty - someone (cloudnull, 16:10:58)
16:06:16 <odyssey4me> can anyone volunteer to do this?
16:06:29 * sigmavirus24 will start writing the email no
16:06:30 <sigmavirus24> *now
16:06:44 <odyssey4me> thanks sigmavirus24
16:07:02 <odyssey4me> #action get a thread going on the mailing list surrounding issues with upgrading Kilo > Liberty  sigmavirus24
16:07:26 * odyssey4me add more hours to the day so sigmavirus24 can put together a POC for pip and epoch's (cloudnull, 16:07:08)
16:07:31 <sigmavirus24> carry that
16:07:35 <odyssey4me> hahaha, have you found more hours yet?
16:07:37 <sigmavirus24> But cloudnull and I have an idea
16:07:40 <sigmavirus24> odyssey4me: no I have not
16:07:54 <odyssey4me> we could do with more of those
16:08:01 <odyssey4me> ok
16:08:26 <odyssey4me> #action sigmavirus24 and cloudnull to put together a POC for pip and epoch's
16:08:50 <odyssey4me> does anyone mind if I skip Blueprints for now and move on to reviews?
16:09:27 <stevelle> no objection
16:09:33 <evrardjp> same
16:09:38 <odyssey4me> right, thanks
16:09:41 <odyssey4me> #link https://review.openstack.org/#/q/starredby:%22Jesse+Pretorius%22+project:stackforge/os-ansible-deployment,n,z
16:10:00 <odyssey4me> those are outstanding reviews for the upcoming milestones for release tomorrow
16:10:30 <odyssey4me> unfortunately openstack-ci has been a bit broken this week, so we really need to try and get reviews done asap to maximise the chance of merging them
16:10:45 <odyssey4me> are there any missing from the list?
16:11:00 <odyssey4me> #link https://launchpad.net/openstack-ansible/+milestone/11.1.0
16:11:08 <odyssey4me> #link https://launchpad.net/openstack-ansible/+milestone/10.1.11
16:11:41 <odyssey4me> considering those milestones, there are many patches that aren't yet 'in progress' - so can we select some that can slip to the next milestone please?
16:12:39 <odyssey4me> eg: https://bugs.launchpad.net/bugs/1424705 for juno is still looking for a backport volunteer and I don't see it getting done today? agreed?
16:12:40 <openstack> Launchpad bug 1424705 in openstack-ansible juno "tear apart the schedule for cron.daily/weeky/monthly " [Wishlist,Triaged]
16:14:02 <odyssey4me> also https://bugs.launchpad.net/bugs/1399383 for juno
16:14:03 <openstack> Launchpad bug 1399383 in openstack-ansible juno "General SSL support for all public endpoints including spice" [Wishlist,Confirmed]
16:14:13 <odyssey4me> and https://bugs.launchpad.net/bugs/1426371 for juno
16:14:14 <openstack> Launchpad bug 1426371 in openstack-ansible trunk "keystone_admin: cannot bind socket" [Low,In progress] - Assigned to Kevin Carter (kevin-carter)
16:14:24 <odyssey4me> and finally https://bugs.launchpad.net/bugs/1453276
16:14:25 <openstack> Launchpad bug 1453276 in openstack-ansible trunk "Additional Swift middleware not loaded in proxy server" [Medium,In progress] - Assigned to Julian Montez (jpmontez)
16:16:38 <odyssey4me> anything unassigned will shift to the next milestone - any objections?
16:17:17 <odyssey4me> palendae will you be able to get https://bugs.launchpad.net/bugs/1472702 done today, or shall we shift it to the next milestone?
16:17:18 <openstack> Launchpad bug 1472702 in openstack-ansible juno "Update elasticsearch and logstash to latest versions" [High,In progress] - Assigned to Nolan Brubaker (nolan-brubaker)
16:17:33 <palendae> odyssey4me: Shift to 10.1.12
16:17:51 <evrardjp> no objection
16:17:57 <prometheanfire> ditto
16:18:05 <d34dh0r53> +1
16:18:16 <palendae> RPC, the main consumers of Juno at this point, have been informed that's where it's going anyway
16:18:31 <odyssey4me> #action odyssey4me to move all unassigned juno bugs to the 10.1.12 milestone
16:18:44 <odyssey4me> ok, let's take a look at https://launchpad.net/openstack-ansible/+milestone/11.1.0
16:20:14 <odyssey4me> any objections to moving the unassigned and incomplete bugs that are wishlist/low to the next milestone?
16:20:46 <odyssey4me> by incomplete I mean not yet in progress
16:20:59 <prometheanfire> no objection
16:21:11 <palendae> None
16:21:13 <d34dh0r53> none
16:21:49 <odyssey4me> #action odyssey4me to move all unassigned and not yet 'in-progress' kilo bugs to the 11.1.1 milestone
16:22:36 <odyssey4me> sigmavirus24 I would guess that https://bugs.launchpad.net/bugs/1479131 should move along to the next milestone too considering that it's an upstream bug?
16:22:37 <openstack> Launchpad bug 1479131 in openstack-ansible trunk "Glance Cannot Be Configured to Make Swiftclient Authenticate Against Keystone v3" [High,In progress] - Assigned to Ian Cordasco (icordasc)
16:23:49 <sigmavirus24> odyssey4me: makes sense
16:24:15 <odyssey4me> ok, that covers most stuff - now back to the reviews in flight
16:24:17 <odyssey4me> https://review.openstack.org/#/q/starredby:%22Jesse+Pretorius%22+project:stackforge/os-ansible-deployment,n,z
16:24:57 <odyssey4me> those in the kilo branch are backports - d34dh0r53 palendae sigmavirus24 please check them briefly and vote accordingly
16:25:56 <sigmavirus24> Reminder: infra is under 7.5 hour backlog
16:26:02 <sigmavirus24> And they've asked people to not approve things if we can avoid it
16:26:10 <odyssey4me> https://review.openstack.org/181560 needs another vote
16:26:22 <sigmavirus24> so hold off on approving if you don't mind until tomorrow maybe when zuul isn't ready to croak
16:26:27 <odyssey4me> ok, then I think at least get the +2 done so that when the backlog is done we can +w?
16:26:32 <sigmavirus24> Yeah
16:26:52 <d34dh0r53> cool
16:27:00 <odyssey4me> non-cores, please review the patches and vote/comment - it helps the cores a lot when people do that
16:27:21 <d34dh0r53> +10000
16:27:41 <odyssey4me> special note for some reviews which are a little more complex
16:28:11 <odyssey4me> https://review.openstack.org/206575 is quite simple - it doesn't change defaults and just enables a horizon feature if horizon is pointed at a Keystone v3 endpoint
16:29:08 <sigmavirus24> odyssey4me: specifically when people comment with their vote
16:29:16 <sigmavirus24> A +1 is useless to me if they don't state how they reviewed the patch
16:29:21 <odyssey4me> https://review.openstack.org/194474 is a bit complex, but it actually works - the previous Keystone SSL enablement was a bit broken... this also enables Keystone to be SSL even when there's an SSL offloader like haproxy too
16:29:23 <odyssey4me> sigmavirus24 ++
16:29:56 <odyssey4me> a comment stating whether you reviewed the style, checked the syntax, actually ran a test, etc is very, very handy to know
16:30:06 <d34dh0r53> yes
16:30:16 * sigmavirus24 goes back to lurking
16:30:25 <miguelgrinberg> odyssey4me: have you tested the SSL patch combined with the SP? I have not
16:30:45 <evrardjp> note taken
16:31:23 <odyssey4me> https://review.openstack.org/194395 is a key blueprint review which adds the capability to configure Keystone as a federation service provider - it does not change anything for anyone who doesn't want that functionality... so please don't be afraid to approve it even though it's a pretty big patch set
16:31:39 <odyssey4me> this is a key blueprint for 11.1.0
16:32:06 <miguelgrinberg> odyssey4me: I tested this one it yesterday, both with SP enabled and disabled, no problems
16:32:28 <odyssey4me> https://review.openstack.org/195403 doesn't appear to work without further testing and figuring out - I move that this shifts to the next milestone? any objections?
16:34:56 <d34dh0r53> none
16:36:06 <odyssey4me> another key review for the 11.1.0 blueprints is https://review.openstack.org/201136
16:36:23 <odyssey4me> it's a final patch to enable a global swift cluster
16:36:45 <odyssey4me> stevelle you've been testing this patch - does it change anything for anyone only building a normal swift cluster?
16:37:06 <stevelle> no material changes to single-region builds
16:37:27 <stevelle> just have the setup and sync tasks split into two plays
16:37:56 <stevelle> os-swift-install  still runs everything
16:38:50 <odyssey4me> great, thanks - that's good to know
16:39:11 <odyssey4me> are there any questions from anyone regarding these reviews?
16:39:21 <odyssey4me> shall we give it 10 mins to look through them and vote?
16:44:15 <b3rnard0> well that's why you have these overlays like huboard/waffle.io
16:44:31 <b3rnard0> n/m ^^ on the above wrong window
16:44:39 <odyssey4me> lol b3rnard0
16:44:49 <odyssey4me> any questions?
16:45:07 <sigmavirus24> odyssey4me: we're not requiring people to vote right this second, right?
16:45:20 * sigmavirus24 is in another meeting and can't vote immediately with proper reviewing
16:45:26 <odyssey4me> sigmavirus24 I was hoping that people would take the time, given the captive audience. :)
16:45:39 <odyssey4me> ok, no worries - those who can please do
16:45:41 <odyssey4me> we need to move on
16:46:20 <odyssey4me> we have three new bugs raised which are on the agenda
16:46:26 <odyssey4me> phalmos ready?
16:46:31 <phalmos> sure
16:46:33 <odyssey4me> #link https://bugs.launchpad.net/openstack-ansible/+bug/1479473
16:46:34 <openstack> Launchpad bug 1479473 in openstack-ansible "Need log_slave_update enabled" [Undecided,New]
16:46:57 <phalmos> This came up when needing to restore the cinder.volumes table
16:47:21 <odyssey4me> I don't know enough about how galera works to comment. d34dh0r53 ?
16:47:25 <phalmos> The the LB choosing where to write in the cluster, the Binary logs can be spread across all nodes
16:47:47 <phalmos> enabling this means the slaves will also log to their binary logs
16:47:56 <odyssey4me> it makes sense to me and seems like a reasonable enhancement request
16:48:05 <d34dh0r53> looking now
16:48:29 <odyssey4me> it also seems like a pretty easy fix - shall we class this a wishlist item and target for the next point release?
16:48:52 <odyssey4me> it won't guarantee that it gets done, but it will put it up for discussion and anyone can pick it up and submit a review
16:48:59 <sigmavirus24> phalmos: what version are you using where you saw this?
16:49:09 <phalmos> 10.1.6
16:49:25 <sigmavirus24> so we'll need to backport this to juno and kilo odyssey4me
16:49:30 <sigmavirus24> can you target the series appropriately?
16:49:39 <odyssey4me> sigmavirus24 yup, added the series now
16:49:54 <d34dh0r53> I'm fine with this change, I think it will make recovery much easier, I've fixed two completely borked galera containers this week and I think this would have helped
16:50:08 <sigmavirus24> d34dh0r53: I'm sorry for your loss
16:50:14 <odyssey4me> hahaha
16:50:17 <d34dh0r53> lol
16:50:38 <sigmavirus24> shall we have a moment of silence for those two containers?
16:50:38 <odyssey4me> ok, I think we'll leave it as 'new' so that we can discuss it in more detail in tuesday's meeting
16:50:42 <odyssey4me> we can triage it properly then
16:50:57 <odyssey4me> next one
16:51:00 <odyssey4me> #link https://bugs.launchpad.net/openstack-ansible/+bug/1479484
16:51:01 <openstack> Launchpad bug 1479484 in openstack-ansible "server_id missing in my.cnf" [Undecided,New]
16:51:11 <d34dh0r53> sigmavirus24: send QE some scotch, they were their containers
16:51:12 <phalmos> This is required for replication
16:51:35 <phalmos> each node should have a unique ID in my.cnf
16:51:42 <sigmavirus24> phalmos: I bet you know more about galera now than you ever wanted
16:51:48 <odyssey4me> hmm, I know this is something needed in standard mysql replication but wasn't aware that MariaDB/Galera needed it
16:52:01 <phalmos> It became an issue when restoring
16:52:09 <evrardjp> sigmavirus24: hehe I hope he has fun !
16:52:10 <odyssey4me> I take it this was in the same installation?
16:52:18 <phalmos> yes, we had to create a new instance of mysql
16:52:27 <phalmos> in order to import the backed up db
16:52:35 <evrardjp> this is standard, I think we should have it
16:52:56 <odyssey4me> yeah, I think this should actually be classed as a bug - perhaps a medium bug?
16:53:57 <odyssey4me> any objections to that, or alternative suggestions?
16:54:05 <d34dh0r53> nope, medium is good
16:54:05 <phalmos> none from me
16:54:28 <odyssey4me> and finally
16:54:32 <odyssey4me> #link https://bugs.launchpad.net/openstack-ansible/+bug/1479486
16:54:34 <openstack> Launchpad bug 1479486 in openstack-ansible juno "Holland backup needs to backup localhost" [Undecided,New]
16:54:48 <phalmos> This goes with the binary logs
16:54:55 <odyssey4me> as I recall we don't carry holland in master/kilo so this is rightly marked as only juno
16:55:02 <phalmos> oh
16:55:10 <phalmos> what is doing the backup in Kilo?
16:55:15 <palendae> Correct.
16:55:25 <palendae> rpc-openstack installs Holland
16:55:29 <odyssey4me> that's up to the deployer, so for RPC that's in rpc-openstack in its own roles :)
16:55:36 <phalmos> roger
16:55:56 <odyssey4me> so I'll set this as wishlist along with the binary log thing - happy?
16:56:13 <phalmos> sure
16:57:02 <odyssey4me> alright - all happy - anything else?
16:57:11 <odyssey4me> we've got 5 mins for open discussion
16:58:18 <sigmavirus24> more like a minute by my count odyssey4me
16:58:23 <evrardjp> for which release is ceph supported planned? The one for tomorrow or the next one?
16:58:27 <sigmavirus24> just a thanks to phalmos for joining us
16:58:33 <sigmavirus24> evrardjp: probably not 11.1 (tomorrow)
16:58:48 <odyssey4me> alright, thank you all for your time
16:58:48 <sigmavirus24> evrardjp: maybe 11.2 if enough people can give us good feedback on it
16:58:48 <phalmos> Anytime
16:58:50 <palendae> evrardjp: I'm guessing 11.2
16:58:53 <odyssey4me> please remember to review!
16:59:02 <evrardjp> ok thanks everyone
16:59:03 <palendae> But like sigmavirus24, depends on how reviews go
16:59:08 <odyssey4me> discussions can continue in #openstack-ansible from now
16:59:16 <sigmavirus24> still have 45 sc
16:59:18 <sigmavirus24> =P
16:59:38 <b3rnard0> thanks for running the show, odyssey4me!
17:00:00 <odyssey4me> #endmeeting