16:01:40 <cloudnull> #startmeeting OpenStack Ansible Meeting
16:01:41 <openstack> Meeting started Thu Jul  2 16:01:40 2015 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:45 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:01:50 <Sam-I-Am> moo
16:01:52 <sigmavirus24> oom
16:01:54 <cloudnull> #topic Agenda & rollcall
16:01:59 <sigmavirus24> o/
16:02:01 <palendae> o/
16:02:02 <stevelle> o/
16:02:03 <alextricity> Hey
16:02:07 <TheIntern> o/
16:02:16 <Sam-I-Am> sigmavirus24: little-endian cow
16:02:17 <odyssey4me> o/
16:02:23 <alextricity> hah
16:02:31 <evrardjp> hello
16:02:35 <b3rnard0> howdy
16:02:51 <cloudnull> #topic Blueprints
16:03:15 <cloudnull> odyssey4me hughsaunders miguelgrinberg sigmavirus24 how goes the fed sp idp efforts ?
16:03:41 <cloudnull> #link https://blueprints.launchpad.net/openstack-ansible/+spec/keystone-federation
16:03:44 <cloudnull> #link https://blueprints.launchpad.net/openstack-ansible/+spec/keystone-sp-adfs-idp
16:03:50 <miguelgrinberg> cloudnull: idp is blocked on the keystone v3 module, but otherwise in good shape
16:03:52 <hughsaunders> cloudnull: ok... currently having some gating issues with getting the v3 update for keystone module in
16:03:54 <sigmavirus24> Keystone v3 module upgrades are soo close
16:03:55 <odyssey4me> So for those who don't know, we've been working on adding federation configuration to os-ansible-deployment. ^
16:04:34 <odyssey4me> We sent out a mail to the openstack-operators and openstack-dev mailing lists to request feedback on the first spec which is near ready.
16:05:08 <cloudnull> has there been any traction on that so far?
16:05:17 <hughsaunders> A few approving replies
16:05:22 <odyssey4me> We have working prototypes for both the keystone2keystone federation, and just today we managed to get the ADFS-keystone federation working too.
16:06:22 <odyssey4me> I'll spend tomorrow updating the two specs to refect what we've learned and to adjust the use-cases for the first as we've discovered that keystone in kilo is not ready to be a full IdP.
16:07:14 <cloudnull> ok
16:07:23 <odyssey4me> I've seen a few comments trickling in on the spec reviews, but we'd like more attention on that from everyone here if possible today before I iterate it tomorrow.
16:07:52 <cloudnull> Next up, ceilometer . #link https://review.openstack.org/#/c/173067
16:07:58 <cloudnull> alextricity: ^
16:08:24 <alextricity> It's ready for reviews. There was a merge conflict this morning so a new patch set was neede
16:08:26 <alextricity> needed*
16:08:53 <cloudnull> the patch as is LGTM . and now has doc dep thats following it
16:09:03 <alextricity> ^
16:09:04 <alextricity> #link https://review.openstack.org/#/c/198025/2
16:09:12 <odyssey4me> yeah, I've gone through it and it looks good from a code standpoint.
16:09:14 <cloudnull> i have it up and running on a few boxes and it works.
16:09:32 <alextricity> I've also done testing and metrics are reporting back normally
16:09:36 <odyssey4me> I'd like to see some testing feedback from anyone who has a gap to try it out.
16:09:38 <alextricity> The database connection looks good too
16:10:58 <cloudnull> thats all we have in the way of open bps being worked on .
16:11:06 <alextricity> I'll just need cloudnull and odyssey4me to give it another +1 with the new patch set
16:11:45 <cloudnull> #topic Open discussion
16:12:10 <cloudnull> to build up on what we were talking about last week .
16:12:14 <cloudnull> Defining the project mission - odyssey4me
16:12:36 <cloudnull> we now have a wiki page https://wiki.openstack.org/wiki/OpenStackAnsible
16:12:55 <cloudnull> and i've posted a WIP manifesto
16:12:58 <cloudnull> #link https://etherpad.openstack.org/p/openstack-ansible-manifesto
16:13:07 <cloudnull> that i'd like people to tear apart
16:13:17 <odyssey4me> cloudnull nice work!
16:14:03 <evrardjp> to avoid losing people over different wiki pages, I'd like to add a link of this new wiki page on the main repo documentation
16:14:05 <cloudnull> sometime in the next week or so i'd like to pul lthat out of the wiki and PR it to the main repo
16:14:18 <cloudnull> evrardjp: ++
16:14:38 <odyssey4me> cloudnull +1
16:15:38 <cloudnull> so lets chew on that for the next week or so.
16:15:53 <cloudnull> next:
16:15:57 <cloudnull> What is our roadmap like? Will making fernet tokens in keystone be an 11.1.0 feature? palendae
16:16:14 <cloudnull> we have https://launchpad.net/openstack-ansible/+milestone/11.1.0
16:16:14 <alextricity> nice! this manifesto answers all the questions that i've been asked about osad
16:16:38 <cloudnull> which is looking good so far.
16:16:40 <sigmavirus24> cloudnull: I think it should be an 11.1.0 feature
16:16:41 <palendae> cloudnull: That one's my bad, should have removed that after last week
16:16:54 <palendae> We already discussed it and I think it was agreed it's 11.1.0
16:17:15 <cloudnull> i know palendae, just building up on what we talked about.
16:17:20 <odyssey4me> cloudnull should we be targeting the federation blueprints for 11.1.0 too?
16:17:30 <palendae> cloudnull: Yep
16:17:43 <sigmavirus24> odyssey4me: if we can get them in shape for 11.1.0, why not?
16:17:45 <cloudnull> odyssey4me: do we think it will be ready for 11.1.0 ?
16:17:53 <cloudnull> if so i say yes
16:18:09 <cloudnull> if no then we'll do it for 11.2.0
16:18:10 <b3rnard0> is cloudnull asking for an estimate?
16:18:20 <sigmavirus24> b3rnard0: nope
16:18:22 <cloudnull> # /kick b3rnard0
16:18:22 <sigmavirus24> Just a guess
16:18:31 <palendae> guesstimate
16:18:35 <odyssey4me> cloudnull I think there's a fair chance that we'll be code ready - not necessarily docs ready
16:18:58 <odyssey4me> miguelgrinberg hughsaunders your thoughts?
16:19:10 <cloudnull> and odyssey4me version numbers are cheap, if it merges for master a day after we drop 11.1 im happy to rev to 11.2 within the next cycle.
16:19:27 <miguelgrinberg> when's 11.1.0?
16:19:40 <cloudnull> but if its ship shape for 11.1 then lets do it
16:19:42 <odyssey4me> how about we target for 11.1 and review in the final week before d day?
16:19:59 <cloudnull> ok
16:20:01 <cloudnull> fair
16:20:19 <odyssey4me> I don't recall us discussing the due date, by the way? Was that date chosen for any special reason?
16:20:33 <hughsaunders> gating not withstanding, I think we are quite close
16:20:50 <palendae> miguelgrinberg: https://launchpad.net/openstack-ansible/+milestone/11.1.0 says 17/7/2015
16:20:51 <cloudnull> it was chosen as being two weeks after the 11.0.4 drop
16:20:58 <miguelgrinberg> and besides, none of this is going to be enabled by default, so the normal use cases are safe
16:21:20 <miguelgrinberg> I think we can make it for the 17th, yes
16:21:23 <odyssey4me> miguelgrinberg true
16:21:42 <cloudnull> before we can target these items we need to target the specs, thus https://review.openstack.org/#/c/194147/ and https://review.openstack.org/#/c/194255/ need to be reviewed
16:21:46 <miguelgrinberg> wrost case we get federation bugs, which we fix for the next one
16:21:47 <cloudnull> so cores typie typie.
16:21:57 <palendae> you mean votie votie?
16:22:03 <sigmavirus24> no
16:22:06 <sigmavirus24> typie typie
16:22:15 <sigmavirus24> you need to give -1s with feedback
16:22:32 <odyssey4me> yup, I'll update the specs tomorrow based on feedback and lessons learned - hopefully we can do final votes on the specs next week
16:23:47 <cloudnull> #action odyssey4me to update the specs for federation.
16:24:25 <cloudnull> moving on.
16:24:39 <cloudnull> #topic Reviews
16:25:08 <cloudnull> 11.0.4 is coming soon we need the following items worked on https://review.openstack.org/#/q/starredby:cloudnull+status:open,n,z
16:25:39 <cloudnull> and if there are issues that need backports from https://launchpad.net/openstack-ansible/+milestone/11.0.4 we need to do that too
16:27:28 <cloudnull> the keystone fernet update needs love for master.
16:27:31 <cloudnull> #link https://review.openstack.org/#/c/195853/
16:28:11 <cloudnull> it looks like its been generaly accepted however we need another core to merge it.
16:28:32 <cloudnull> presently we're gating on a fernet token system that has a few issues, which are corrected by that patch.
16:30:05 <cloudnull> another review in need of some attention is https://review.openstack.org/#/c/181957/
16:30:14 <cloudnull> which is for ceph client support.
16:30:23 <cloudnull> svg: ^
16:30:48 <cloudnull> looks like svg is going to post a new review soon .
16:31:12 <cloudnull> but if we have folks with more ceph experience it would be great to get more reviews on that.
16:31:42 <cloudnull> most of this was mentioned on the ML
16:31:44 <cloudnull> #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/068362.html
16:31:57 <odyssey4me> yeah, I'd like to ask everyone reviewing that to also pay attention to the ceph-ansible playbooks - we don't need any clashes in variables between the two.
16:32:30 <cloudnull> ++
16:32:43 <cloudnull> #link https://github.com/ceph/ceph-ansible
16:34:03 <evrardjp> I agree, while I admit that it doesn't mean that ceph need to/will be deployed by ansible, so the importance of it could be reduced...
16:34:19 <palendae> Yeah, as about to ask
16:34:30 <palendae> Are we assuming that Ceph is deployed with ceph-ansible only?
16:34:43 <cloudnull> no,
16:34:52 <andymccr> i dont think its an assumption, but if you wanted to and the vars overlapped it could create difficulties
16:34:59 <cloudnull> we're simply assuming that there is a ceph cluster available.
16:35:15 <palendae> Or are you just asking to be sure we don't have duplicate variable names in case a deployer does use both?
16:35:22 <palendae> Ok andymccr, makes sense
16:35:30 <palendae> I misunderstood
16:36:22 <cloudnull> so anything else we want to mention regarding open reviews?
16:37:07 <cloudnull> moving on
16:37:09 <cloudnull> #topic Bugs
16:37:21 <cloudnull> do we have an open issues that we want to highlight and or work on ?
16:37:37 <cloudnull> #link https://bugs.launchpad.net/openstack-ansible
16:38:26 <cloudnull> we have 73 open issues, most of which are low/wishlist items so imo we're looking quite good
16:39:29 <cloudnull> BjoernT: nothing ?
16:39:35 <andymccr> yeh i think if you remove fix commited its 41 and most of those are assigned already
16:40:03 <cloudnull> scielence is acceptance
16:40:03 <BjoernT> Thanks for asking, I have nothing special for today. I will go over the wishlist next week
16:40:18 <cloudnull> ok
16:40:21 <cloudnull> sounds good
16:40:49 <cloudnull> #topic Open discussion
16:41:05 <cloudnull> does anyone have anything that they want to talk about? the floor is yours.
16:41:07 <odyssey4me> it might be a good idea in the bug triage meeting to look at new bugs, but also to revisit old bugs
16:41:56 <cloudnull> in the last few we've been focusing on new/high and some of the incomplete, but it may be a good idea to start picking through the wishlist
16:42:03 <cloudnull> and other items.
16:42:20 <cloudnull> lets give it a go next tuesday  ?
16:42:57 <odyssey4me> other than that, I would like to ask that we not get into the bad habit of prematurely backporting patches - it makes reviewing them take longer because you have to verify that the backport is the same as the master patch... and quite often the master patch goes through several iterations
16:43:14 <odyssey4me> we've ended up having patches land in other branches before master by mistake
16:43:30 <evrardjp> +1
16:43:45 <cloudnull> +1
16:44:02 <evrardjp> should there be a timeframe odyssey4me?
16:44:07 <odyssey4me> if you backport from gerrit once the patch in master has merged, the cherry-pick message will be done properly
16:44:13 <cloudnull> I'd say that once a patch has +w its ok to bp
16:44:23 <odyssey4me> evrardjp no timeframe - just no backport until the master patch has merged
16:44:32 <evrardjp> I agree.
16:45:03 <odyssey4me> cloudnull +w is fine too if there's a time crunch or something... but that takes more time as the backporter will have to do the backport form the CLI
16:45:44 <cloudnull> this is true. if you dont know the git CLI you should wait for the patch to merge into master.
16:45:50 <cloudnull> :)
16:46:37 <odyssey4me> :p
16:47:19 <cloudnull> ok motion carries .
16:47:47 <cloudnull> #action we will no longer backport things from master until its been +w / merged into master.
16:48:02 <cloudnull> what else we got ?
16:49:04 <Sam-I-Am> nada here
16:49:32 <cloudnull> then we're done here IMO .
16:49:37 <Sam-I-Am> imo too
16:49:40 <palendae> Yep, don't have anything either
16:49:46 <Sam-I-Am> back to typey typey
16:49:46 <cloudnull> sounds good .
16:49:55 <odyssey4me> \o/
16:49:58 <cloudnull> great work on everything in flight guys
16:50:02 <cloudnull> and thanks
16:50:06 <cloudnull> #endmeeting