16:00:52 <b3rnard0> #startmeeting OpenStack Ansible Meeting
16:00:53 <openstack> Meeting started Thu Feb  5 16:00:52 2015 UTC and is due to finish in 60 minutes.  The chair is b3rnard0. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:56 <openstack> The meeting name has been set to 'openstack_ansible_meeting'
16:00:58 <cloudnull> hey everyone.
16:01:03 <alextricity> howdy
16:01:08 <b3rnard0> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:01:19 <b3rnard0> #topic RollCall
16:01:31 <b3rnard0> hello
16:01:36 <Apsu> ohai
16:01:50 <toxick> orly
16:01:56 <sigmavirus24> o/
16:02:03 <cloudnull> present
16:02:39 <d34dh0r53> present
16:02:42 <hughsaunders> hey
16:02:49 <stevelle> o/
16:02:53 <serverascode> here
16:03:06 <palendae> here
16:03:25 <odyssey4me> o/
16:03:56 <b3rnard0> #topic Review action items from last week
16:04:11 <cloudnull> first up: cloudnull odyssey4me to go through bugs for targeting to milestones/series
16:04:37 <cloudnull> this is done .
16:04:51 <cloudnull> 10.1.2rc1 and 9.0.6 have been released .
16:05:14 <cloudnull> unless odyssey4me you have anything that you want to add about that
16:05:20 <odyssey4me> \o/
16:05:31 <cloudnull> Next:  Apsu Continue working on F5 monitoring spike
16:05:40 <odyssey4me> I think I'll crack a celebratory drink for that. :p
16:05:52 <cloudnull> please do
16:05:53 <Apsu> Yes. Non-critical for a bit, will need to keep pushing it back for right now.
16:06:00 <cloudnull> kk
16:06:23 <cloudnull> next: miguelgrinberg to take the lead on: we'll need a volunteer to prepare a patch to convert rpc_support, maas and anything else rpc specific into a (or many) roles which can be installed by ** rpc after a standard os-ansible-deployment install
16:06:38 <cloudnull> w/ mattt will help miguelgrinberg before he leaves
16:07:12 <cloudnull> which idk if miguelgrinberg is around, i think he is on holiday .
16:07:20 <cloudnull> as is mattt
16:07:25 <cloudnull> so skipping :)
16:07:33 <cloudnull> hughsaunders to read inventory-manage.py
16:07:57 <hughsaunders> hmmm hughsaunders has not read inventory-manage.py
16:08:16 <cloudnull> b3rnard0 ^ action ite,
16:08:26 <hughsaunders> remind me why I was supposed to be reading that?
16:08:42 <b3rnard0> #action hughsaunders to start reading inventory-manage.py
16:08:56 * hughsaunders hopes they have a kindle version
16:09:03 <cloudnull> b3rnard0 is the reminder of things.
16:09:15 <palendae> hughsaunders: We were talking about extracting some bits to make it a more general library, with potentially more back ends
16:09:30 <hughsaunders> ah yes, now I remember
16:09:34 <odyssey4me> hughsaunders to know what the heck it was - I think relating to the inventory blueprint
16:09:36 <hughsaunders> I wanted a system for querying the inventory
16:09:41 <cloudnull> it was tied to bp https://blueprints.launchpad.net/openstack-ansible/+spec/dynamic-inventory-lib
16:09:43 <hughsaunders> and someone mentioned that inventory-manage is probably it
16:09:48 <palendae> hughsaunders: Yeah
16:09:50 <hughsaunders> hence I need to read it
16:09:53 <b3rnard0> #info hughsaunders: We were talking about extracting some bits to make it a more general library, with potentially more back ends
16:10:09 <b3rnard0> #link bp https://blueprints.launchpad.net/openstack-ansible/+spec/dynamic-inventory-lib
16:10:26 <cloudnull> so we'll carry that too.
16:10:32 <mancdaz> here
16:10:39 <cloudnull> next: b3rnard0 to read about link shorteners
16:10:47 <cloudnull> b3rnard0 you cat that all sorted out ?
16:10:52 <cloudnull> :D
16:10:57 <b3rnard0> i read about them tiny urls
16:10:57 <alextricity> lolz
16:11:07 <cloudnull> next: cloudnull plan to pin it to 1.4.1 and then write up process for upgrading.
16:11:09 <hughsaunders> b3rnard0: not sure we actually need to carry that item, it was just a hint for me to read the script so I can make use of it
16:11:18 <d34dh0r53> next b3rnard0 use a link shortener
16:11:35 <cloudnull> we pined oslo.messaging 1.4.1 in 9.0.6 and 10.1.2rc1 so  this was accomplished.
16:11:48 <b3rnard0> #action b3rnard0 use link shortener at next meeting
16:12:14 <cloudnull> and finally: b3rnard0 to prepare his whiskey cabinet for emptying later this year
16:12:22 <cloudnull> ^ get on that b3rnard0
16:12:28 <b3rnard0> on it
16:12:47 <cloudnull> moving on unless we want to talk about other items from last week.
16:12:48 <rackertom> I prefer fiji for my water, though.
16:12:58 <b3rnard0> #topic Vote on the genericized patch and merge process for review "https://review.openstack.org/#/c/152753/" <- this is in response to the community request that the repository be de-rackspace-ified and fulfills the blueprints
16:13:06 <b3rnard0> #link https://review.openstack.org/#/c/152753/
16:13:15 <b3rnard0> #link https://blueprints.launchpad.net/openstack-ansible/+spec/galaxy-roles
16:13:19 <cloudnull> so this is a monster patch.
16:13:23 <b3rnard0> #link https://blueprints.launchpad.net/openstack-ansible/+spec/rackspace-namesake
16:13:33 <palendae> Whooooa
16:13:33 <cloudnull> and odyssey4me  has been reviewing it in depth , so tyvm
16:14:07 <cloudnull> this patch implements our galaxy roles and removes raxisms from the rest of the code base.
16:14:08 <odyssey4me> great reading, it's kinda like an epic heroic fantasy novel... loads of interlinking bits that leave you wondering what's going on until the very last minute
16:14:33 <cloudnull> its more like the never ending story
16:14:37 <cloudnull> ;)
16:14:41 <odyssey4me> hahaha
16:15:06 <cloudnull> the idea is that in Kilo, version 11, we will have a truly community respository of bits .
16:15:08 <odyssey4me> I stopped after a while - didn't go through everything - I hit code fatigue
16:15:59 <cloudnull> that can be customized outside of our reference architecture. with an ultimate goal of having the openstack specific roles as separate repos within stackforge.
16:16:14 <Apsu> cloudnull: OS Ansible Lite in action, I see.
16:16:29 <Apsu> -76843, +27492. Winning
16:16:37 <palendae> I'm willing to sit down and go through this, though probably not all in one sitting
16:17:06 <odyssey4me> yeah - I have actually given it a spin as-is, and it builds... but there are some fundamental questions that I think need to be answered
16:17:08 <cloudnull> for now, I've kept all of the roles as a collapsed arch. and once we're solid on the implementation we'll go see about bothering infra to create us a few more repos.
16:17:25 <odyssey4me> although it's possibly mainly just nomenclature
16:17:31 <palendae> odyssey4me: How's you do it - AIO?
16:17:43 <cloudnull> odyssey4me I've been going through your comments so far , and have made most of the recommended changes.
16:17:50 <odyssey4me> palendae yup
16:18:00 <cloudnull> i was going to pr before the meeting , but then thought that would just be confusing
16:18:14 <palendae> tbh that really sounds like a day-long endeavor to fully review
16:18:17 <palendae> Maybe more
16:18:26 <palendae> It has to be done, though
16:18:26 <Apsu> Probably more
16:18:33 <odyssey4me> my biggest concern is that the longer this sits in review, the more it gets left behind - so we really need to get on reviewing this quickly and revising it until the point that it's at least a like-for-like functional model
16:18:35 <git-harry> cloudnull: I think this patch needs breaking up
16:18:55 <cloudnull> ideally i'd agree with you git-harry
16:18:56 <palendae> git-harry: Have a suggestion for where to make the separations?
16:19:27 <palendae> I don't think anyone disagrees that it's unwieldy and not ideal
16:19:28 <odyssey4me> something very important when reviewing is to also bear in mind what patches have gone in during the last few weeks - we have to check that there are no regressions
16:19:29 <git-harry> Well I've not looked through it but there's always a way
16:19:32 <cloudnull> however our tightly coupled rax infra doesn't translate without a whole lot of shims and hacks to make it work. which will just end up with thesame reslut
16:19:47 <odyssey4me> yes, the same re-slut :p
16:19:56 <cloudnull> ^ yes that one  .
16:20:06 * cloudnull action item learn to type.
16:20:18 <git-harry> I just seems like bad practice
16:20:32 <palendae> It is :p
16:20:33 <cloudnull> git-harry it is.
16:20:51 <git-harry> I doubt anyone will review it properly
16:20:57 <cloudnull> however when the project was moved over to stackforge we didnt do any of this to make it better.
16:21:06 <palendae> ^
16:21:06 <cloudnull> git-harry odyssey4me  has reviewed it so far.
16:21:29 <git-harry> Yes but something that large is very difficult to review properly. Too much is going on
16:21:41 <hughsaunders> cloudnull: wolud it be possible to split the mass move/rename from the other changes?
16:22:03 <cloudnull> removing maas, and some of the rackspace scripts is no problem .
16:22:08 <odyssey4me> I would suggest removing maas and rpc_support entirely first, then basing this patch on that review
16:22:12 <cloudnull> renaming things is .
16:22:33 <cloudnull> rpc is everywhwere. and is not just related to our variable.s
16:22:50 <cloudnull> as is rackspace. and a few other things.
16:23:01 <odyssey4me> all the deletions (not renames/moves) can also be another review, with this one dependant on it
16:23:33 <b3rnard0> #info from cloudnull: removing maas, and some of the rackspace scripts is no problem
16:23:38 <palendae> odyssey4me: Those sound more tenable to me, but cloudnull's the one who's actually done this so far, so I defer to him
16:23:40 <cloudnull> we could do pr the additions and then the deletions , but then we'd need to merge and remove duplicate variables from all.yml and a few other things
16:23:50 <alextricity> I kind of liked how the playbooks were separated into setup/infra/openstack directories. It doesn't look like that's the case any more. If you wanted to break it up you can do it that way. The roles can also be broken up into their respective projects
16:24:11 <palendae> alextricity: I think that was to follow 'normal' ansible conventions
16:24:14 <Apsu> It's not Ansible best-practice.
16:24:17 <palendae> Ansible doesn't seem to like nesting things
16:24:21 <alextricity> darn
16:24:23 <cloudnull> alextricity our broken out directories we're made possible with symlinks and hacks.
16:24:26 <Apsu> ^
16:24:31 <Apsu> And it's ugly
16:24:36 <palendae> Yeah, the repo was all facades
16:24:38 <Apsu> The hacks to make it go, are super ugly
16:24:47 <cloudnull> ^
16:24:53 <alextricity> gotcha
16:24:58 <cloudnull> i will say that it provided structure
16:25:07 <Apsu> http://docs.ansible.com/playbooks_best_practices.html#directory-layout for reference
16:25:12 <cloudnull> and i've tried to keep the structure with namespaced plays
16:25:40 <b3rnard0> #link http://docs.ansible.com/playbooks_best_practices.html#directory-layout
16:26:09 <cloudnull> so the rework has been done to follow, as best i could, http://docs.ansible.com/playbooks_best_practices.html
16:27:06 <b3rnard0> #link http://docs.ansible.com/playbooks_best_practices.html
16:27:32 <cloudnull> so what i want is for people to review it, comment on it, and before it is excepted i'd like to have +6, cores and other.
16:27:40 <odyssey4me> the only way to break this up more would be to essentially rework the current roles in-place, to break out the common roles and ensure the roles are more stand-alone - then to evolve them... that would be a lot of work, which is already in this patch
16:28:44 <Apsu> ^
16:29:00 <odyssey4me> this patch is the end goal which, if we try to do a slow evolution, would probably take a month or two of active work from multiple people
16:29:01 <Apsu> I see minor wings capable of being separated out, and then the main body of coupled -> decoupled work.
16:29:13 <Apsu> So, let's review it and make it go.
16:29:31 <d34dh0r53> agreed, this is some short term pain and then we're done
16:29:46 <odyssey4me> but yeah - I think it is important for us to really understand how this is working - determine if it's the right way of doing it (not just a sound way of doing it)
16:30:00 <cloudnull> once kilo is released and we no longer have to carry raxisms we'll be in a much better place.
16:30:02 <odyssey4me> ideally we don't want to have to do this again
16:30:20 <cloudnull> ^ that
16:30:46 <odyssey4me> kilo is still a few months away, so if we allow this patch to merge - backporting will not be simple
16:30:47 <d34dh0r53> ^^ yes
16:31:00 <odyssey4me> we'll have to develop patches for juno independantly from master
16:31:08 <cloudnull> odyssey4me this is true.
16:31:43 <cloudnull> but if we keep this in the wings, until kilo is here. then we'll be releasing kilo in november like we did with icehouse.
16:31:43 <b3rnard0> #info from odyssey4me we'll have to develop patches for juno independantly from master
16:32:04 <odyssey4me> unless we can make some very slick plays/scripts for upgrading alongside this
16:32:35 <cloudnull> so that is another thing . this patch will upgrade rax juno to this.
16:33:32 <cloudnull> IMO we will never port this patch to 10 or 9 as is.
16:34:09 <cloudnull> i dont think we have any more 10 x features that we need to release.
16:34:23 <odyssey4me> nope - dealing with v9 & v10 is going to effectively be a rax technical debt to deal with... it's not really a generalised community problem
16:34:50 <odyssey4me> feature, probably not - bugfixes, always
16:34:58 <cloudnull> so with the release of 10.1.2 we should have stable rax product and be able to bug fix as needed .
16:35:52 <cloudnull> 9 is in maintenance mode as is.
16:36:51 <cloudnull> so thats all i have to say about that.
16:36:57 * odyssey4me nods
16:37:05 <cloudnull> i'd love to hear from everyone that wants to be involved.
16:37:06 * hughsaunders plugs the mic back in
16:37:35 <cloudnull> so unless anyone else wants to say something regarding this lets move on.
16:37:58 <d34dh0r53> I'll help with reviews
16:38:23 <b3rnard0> #info cloudnull: so what i want is for people to review it, comment on it, and before it is excepted i'd like to have +6, cores and other.
16:38:55 <b3rnard0> #action d34dh0r53 : to help with review of https://review.openstack.org/#/c/152753/
16:39:00 <cloudnull> moving on .
16:39:11 <b3rnard0> #topic Upstream gating and how do we make it better - (cloudnull) - patch in review for some improvements:
16:39:19 <b3rnard0> #link https://review.openstack.org/152965
16:39:31 <cloudnull> so odyssey4me  has done some great work on this so far.
16:40:07 <cloudnull> where / what do we need to make this go?
16:40:09 * cloudnull hands mic to odyssey4me
16:40:18 <odyssey4me> yeah, so for the moment I'm trying to put together a set of scripts to allow localised testing just as the gate is doing
16:40:46 <odyssey4me> in other words you can build up your own environment - AIO or otherwise - and modify whatever, then run the lint/syntax/build/tempest tests just like the gate does
16:41:06 <cloudnull> this is great.
16:41:07 <odyssey4me> I'm still working out the kinks, but the patch is available for comment here: https://review.openstack.org/152965
16:41:24 <odyssey4me> I'm getting some oddities from openstack-infra at the moment.
16:41:50 <odyssey4me> the ideal things is for the openstack-infra and external-CI systems to make use of these scripts instead of other scripts
16:41:51 <palendae> odyssey4me: How/where are you seeing the output from openstack-infra?
16:42:14 <odyssey4me> palendae jenkins check results on the right
16:42:24 <odyssey4me> click the link, then open the log
16:42:30 <palendae> Gotcha
16:43:06 <odyssey4me> I know that hughsaunders has a working set of plays which does much the same bootstrapping stuff... that can be an evolution once these work.
16:43:27 <odyssey4me> if we can ansibilize as much as possible, that'd be amazeballs :p
16:43:42 <palendae> meta-setup plays?
16:44:13 <odyssey4me> for now I'm using these skanky bash scripts to work out all the funny edge cases and such
16:44:37 <hughsaunders> palendae: yeah the jenkins-rpc playbooks that are used for the hardware labs
16:44:47 <odyssey4me> cloudnull did some awesome evolutions of the gate scripts in https://review.openstack.org/152753 so I've added many of them in
16:45:03 <odyssey4me> this, of course, does mean that https://review.openstack.org/152753 will need a nasty rebase
16:45:06 <palendae> hughsaunders: Cool
16:45:32 <cloudnull> odyssey4me im up to the rebase challenge. :)
16:46:56 <odyssey4me> I would like another gate-check script added to the list - one for performance testing, which can run rally
16:47:05 <odyssey4me> any volunteers for putting that together?
16:47:09 <cloudnull> hughsaunders ^ ?
16:47:20 <b3rnard0> git-harry loves rally too
16:47:35 <odyssey4me> it's not critical now - just some time after the dust has settled on this one
16:47:46 <hughsaunders> performance testing on pub cloud isn't great
16:47:57 <hughsaunders> but I would like to see that as a job run from the same jenkins master
16:48:08 <palendae> Yeah, AIO performance testing wouldn't be very reliable, I'd think
16:48:13 <hughsaunders> b3rnard0 is arranging for QE to talk to the performance people to try and make that happen
16:48:24 <odyssey4me> hughsaunders yeah, that's the idea - so anyone can run the job the same way - whether it be in a test environment or in the external CI
16:48:42 <hughsaunders> odyssey4me: in that case I agree
16:49:07 <hughsaunders> I'd love to have all testing processes (performance, security, qe) demystified so we can run them
16:49:08 <odyssey4me> the AIO can't cope with tempest testing, so performance testing is a waste - the idea is to have a single script in the repo which is used for when there is an environment to test
16:49:14 <palendae> hughsaunders: We also have an internal Trello card for stevelle and I to talk to you and jwagner about not doing a full rekick on hardware labs
16:49:27 <b3rnard0> #info from hughsaunders: performance testing on pub cloud isn't great; but I would like to see that as a job run from the same jenkins master
16:50:07 <odyssey4me> we can add a security check script later, once we figure out an appropriate set of tests - that's not essential now
16:50:35 <odyssey4me> the top priorities are lint (incl syntax), build, then functional tests
16:50:43 <hughsaunders> I agree also, those things are long term as they involve other teams
16:51:49 <cloudnull> so lets open up the discussion to anything else that needs to be talked about.
16:51:51 <hughsaunders> odyssey4me: I need try this against an AIO https://github.com/stackforge/os-ansible-deployment/blob/master/rpc_deployment/roles/tempest/files/rpc_tempest_gate.sh#L48 if it works then that could be a good start for AIO functional tests
16:52:19 <b3rnard0> #topic Open discussion
16:52:32 <odyssey4me> hughsaunders yup - I've already instrumented for it: https://review.openstack.org/#/c/152965/21/scripts/gate-check-smoke.sh
16:53:12 <cloudnull> i'd like to say hi to a few new nics here. serverascode and toxick.
16:54:10 <hughsaunders> odyssey4me: nice
16:54:40 <toxick> ohai!
16:55:18 <odyssey4me> :)
16:55:50 <cloudnull> ok well lets call it
16:56:08 <b3rnard0> thanks everyone
16:56:15 <cloudnull> thanks b3rnard0
16:56:21 <odyssey4me> o/
16:56:21 <b3rnard0> #endmeeting