16:00:44 <andymccr> #startmeeting OpenStack-Ansible
16:00:45 <openstack> Meeting started Thu Nov 10 16:00:44 2016 UTC and is due to finish in 60 minutes.  The chair is andymccr. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:48 <openstack> The meeting name has been set to 'openstack_ansible'
16:00:56 <andymccr> #topic Roll Call
16:01:14 <automagically> o/
16:01:24 <asettle> o/
16:01:38 <andymccr> mhayden is way better at meetings clearly!
16:02:08 <cloudnull> o/
16:02:19 <asettle> No, we're just coming in mostly in alphabetical order.
16:02:22 <odyssey4me> o/
16:02:23 <asettle> You know, doing it in an orderly fashion
16:02:23 <andymccr> i'll give it a few mins
16:02:24 <mgariepy> o/
16:02:24 <rromans> .
16:02:40 <jmccrory> o/
16:02:50 <asettle> Totally alphabetically until jmccrory came along.
16:02:52 <asettle> Jeez Jim.
16:03:09 <palendae> o/
16:03:13 <cloudnull> hahahaw
16:03:15 <jmccrory> ughh i shouldn't have said anything at all
16:03:57 <adreznec> o/
16:05:10 <andymccr> ok! thanks for coming everybody lets get this started!
16:05:13 <asettle> jmccrory: stick to Spanish :p
16:05:26 <andymccr> #topic Review action items
16:05:38 <andymccr> ok so there weren't any - so im gonna call that one a resounding success and move on.
16:05:44 <asettle> *claps*
16:05:46 <asettle> Amazing
16:05:56 <andymccr> #topic Project Mascot
16:06:07 <andymccr> From last week's meeting, more of a reminder
16:06:19 <andymccr> feedback on the mascot (not the choice, but the actual draw up) is open until tomorrow pretty much
16:06:45 <andymccr> so if you haven't given feedback already, tomorrow is the closing day
16:06:51 <andymccr> from last week the links are
16:07:07 <andymccr> #link http://tinyurl.com/OSmascot
16:07:11 <andymccr> that's the survey!
16:07:14 <andymccr> and for the image
16:07:24 <andymccr> #link http://i.imgur.com/wub7aro.png
16:08:09 <andymccr> ok, so moving right along!
16:08:21 <andymccr> #topic PTG Atlanta Feb 20-24th
16:08:46 <andymccr> So there is a link for signups now
16:08:51 <andymccr> #link Signup for PTG: https://pikeptg.eventbrite.com
16:10:00 <andymccr> as a side note, this is supposed to be the design summit - so decisions to be made for the Pike cycle
16:10:54 <andymccr> which means we'll need to figure out methods for doing a "midcycle"-esque approach for Ocata
16:11:03 <odyssey4me> ok cool, we'll have to get ducks in a row with regards to expenses and such
16:11:30 <andymccr> yeah - so from a RAX perspective I've tried to get that conversation going, but its approaching fast.
16:11:53 <palendae> I've been needling about it too
16:12:02 <palendae> Fiscal calendars are whack
16:12:09 <andymccr> palendae: yeah...
16:12:16 <palendae> Is there a hard limit on attendees?
16:12:18 <palendae> The 500?
16:12:28 <andymccr> palendae: i'd heard 200... so this is going to be logistical issue.
16:12:31 <palendae> Oof
16:12:34 <palendae> Yeah
16:12:43 <palendae> registering late will be of bigger consequence with this then
16:12:50 <palendae> But that's internal for us
16:13:09 <andymccr> Also i noticed a question lastweek about an email regarding our involvement
16:13:19 <andymccr> so I've already RSVP'd (effectively) a few weeks back to say that OSA will be involved
16:13:19 <spotz> o/
16:13:31 <andymccr> but we can send out an email if needed
16:13:54 <cloudnull> is there an "ATC" code for the PTG?
16:14:05 <adreznec> cloudnull: I don't think so
16:14:07 <andymccr> cloudnull: no.
16:14:16 <cloudnull> makes sense , was just curious
16:14:31 <andymccr> tickets are $100 - since there is no business sponsorship effort that the summit itself drives, im guessing that is why.
16:14:40 <asettle> Right, that makes sense.
16:15:05 <andymccr> ok - we all good on that topic? I think we can have a bigger discussion about how we want to approach PTGs vs Midcycles etc.
16:15:58 <odyssey4me> yeah, it may be worth exploring a fully virtual mid-cycle, with regional meetings and handovers between major time zones
16:16:09 <andymccr> #action sign up for the PTG if you're attending!
16:16:12 <odyssey4me> that said the 'mid cycle' is essentially during the summit time
16:16:41 <andymccr> #topic Upgrade testing
16:17:09 <andymccr> OK! So jmccrory has already put a PR in for keystone, and I'm trying to do the same for glance - to get a pattern of a good start point: https://review.openstack.org/#/c/396219/
16:17:20 <andymccr> #link POC upgrade of glance: https://review.openstack.org/#/c/396219/
16:17:42 <andymccr> would appreciate reviews/thoughts/concerns/questions and any help to do upgrade testing for other roles (once we finalize an approach)
16:18:24 * automagically will take a look. Thanks for getting that work kicked off
16:18:38 <andymccr> excellent, thanks!
16:18:47 <andymccr> #topic Community involvement and release-manager
16:18:54 <andymccr> moving along.
16:18:55 <stevelle> as a point of note on upgrade testing
16:19:03 <andymccr> ohh sorry stevelle :) carry on
16:19:21 <stevelle> glance is trying to implement zero downtime this cycle, so might be better to try for another project instead
16:19:50 <andymccr> stevelle: my opinion is that we start off with upgrade testing on all roles - just a basic, does it upgrade and can we do functional testing
16:20:05 <stevelle> my point is they are changing the upgrades
16:20:08 <andymccr> as a start point (not perfect), but zero-downtime would come later. jmccrory's PR for keystone does it.
16:20:12 <stevelle> the role testing will break
16:20:23 <andymccr> stevelle: but surely it will still work? it just won't work with zero downtime
16:20:29 <jmccrory> the keystone role does both right now, zero downtime and testing of basic upgrades
16:20:33 <stevelle> it will use different commands
16:20:36 <jmccrory> the PR at least
16:20:44 <stevelle> or at least that is the direction they are going
16:21:06 <stevelle> not a big deal, just something that might recommend cinder or another role
16:21:11 <odyssey4me> well, zero downtime upgrades would require implementing the procedure for it
16:21:17 <andymccr> stevelle: i guess it's good to stay on the pace then. i'd like to see upgrades as a first class citizen rather than a "oh well we thought of that a bit down the line"
16:21:24 <odyssey4me> I think the starting test is simply to deploy N-1, deploy N, test
16:21:30 <odyssey4me> no special orchestration
16:21:40 <andymccr> stevelle: good point though - we'll have to look at it, the end aim is to get involved more in the projects and stay up to date with the upgrade procedures.
16:21:53 <odyssey4me> the alternative would be to implement the tests in stable/newton and test upgrades from mitaka to newton - then forward port
16:22:04 <automagically> Is there an etherpad with folks signing up for upgrade work on each role?
16:22:13 <odyssey4me> automagically :)
16:22:18 <stevelle> I intend to add bits to help support zero-downtime, but if the db sync command syntax changes you will end up with a broken role
16:22:21 <andymccr> automagically: let me create one! :)
16:22:39 <stevelle> and as I said, the way they are going, the db sync syntax will change
16:22:45 <andymccr> #link Etherpad to track upgrade testing creation for roles: https://etherpad.openstack.org/p/osa-upgrade-testing
16:22:46 <odyssey4me> I was kinda thinking that perhaps we should use bugs as task trackers - ie a bug per role
16:22:55 <automagically> odyssey4me: ++
16:22:58 <andymccr> thats a good idea
16:23:14 <andymccr> i'd like to nail down a "this is a base of how to do it for x role - now go and replicate!"
16:23:15 <odyssey4me> maybe a blueprint to describe the objective, and link it to the bugs
16:23:38 <odyssey4me> ++ andymccr that would make it easy for people looking to help
16:24:37 <andymccr> ok - anymore on upgrade testing?
16:24:51 <andymccr> #action andymccr to file bugs/blueprint for upgrade testing
16:26:29 <andymccr> ok! So back to community involvement - release-manager etc.
16:27:36 <andymccr> evrardjp (isn't here), but expressed interested in getting involved and being release manager, so I'd like to set that up (if nobody has any issues !)
16:27:48 <andymccr> and i'd also like to open the floor to anybody else to get involved in the various other jobs/tasks that are involved
16:28:12 <odyssey4me> :) release manage is quite demanding - it might be good to have one in the uk and one in the us
16:28:35 <odyssey4me> that way when it's big release time they can hand over instead of staying up late at night waiting for patches to merge
16:28:51 <andymccr> we can find out if we can do that if anybody else is interested. but the message is essentially - if you want to get involved in anyway let me know and we'll figure something out.
16:28:58 <odyssey4me> not sure if the release team is ok with having more than one liason, but it's worth asking
16:29:11 <andymccr> and also, thanks to evrardjp for making my dream of delegating all my work out become closer to reality :D
16:30:21 <odyssey4me> haha
16:30:41 <andymccr> #topic Timezone changes for meetings
16:31:59 <andymccr> Since daylight savings shenanigans is now in place in a lot of the places contributors are worked - id be open to move the meeting to 17:00 UTC instead of 16:00 (will have to look into the process but if there is interest)
16:32:27 <palendae> andymccr: With the intent of moving it again when DST comes back?
16:32:53 <andymccr> palendae: yeah basically, i mean if everybody is effectively used to it being at x local time, and once a year it becomes x-1 or x+1 it gets confusing and annoying.
16:33:49 <odyssey4me> not sure we can easily get a shift in the meeting room
16:33:56 <andymccr> on a separate note - we may want to move our meeting to wednesday or tuesday - infra don't do releases on friday usually, so it may be worthwhile to move our weekly meeting to a tuesday or wednesday unless there are issues with that
16:34:02 <stevelle> I prefer booking against UTC myself
16:34:22 <odyssey4me> also, switching meetings rooms at different times of the year is pretty confusing too
16:34:41 <odyssey4me> http://eavesdrop.openstack.org/
16:35:03 <andymccr> stevelle: agree UTC removes confusion - just concerned that having the meeting an hour earlier (effectively) for our west coast friends (e.g. you!) makes it harder to attend.
16:35:05 <palendae> I'm used to it, honestly, it's just something to be aware of
16:35:19 <palendae> True it does complicate west coast
16:35:41 <andymccr> but if you're ok with it stevelle then we can leave it as is :)
16:35:47 <odyssey4me> I think moving the meeting to earlier in the week would be helpful for getting releases done within the week, but it's not essential.
16:35:49 <stevelle> it's rough, but not as bad as the upstream community meeting  at 6am I have thursdays
16:36:14 <automagically> ouch
16:36:22 <andymccr> ok well if that changes, or if anybody else has issues lets discuss it - let me know and we can look into fixing that up/changing it.
16:37:14 <andymccr> ok cool!
16:37:20 <andymccr> next!
16:37:28 <andymccr> #topic Release planning and decisions
16:38:08 <andymccr> ok - so last week was release week (thanks odyssey4me!)
16:38:18 <odyssey4me> :) all seems to have gone well
16:38:21 <andymccr> next week is the next release, so any work you want in - just a remind to get it pushed through etc.
16:38:24 <andymccr> *reminder
16:38:43 <odyssey4me> loads of optimisations going in now - thanks to all for contributing them
16:38:49 <odyssey4me> looking forward to 14.0.2
16:39:02 <odyssey4me> it's nice to see that we aren't getting too many horrible bugs
16:39:12 <odyssey4me> so newton seems to have been a good release :)
16:39:57 <andymccr> #topic blueprint work
16:40:04 <automagically> My org will be exercising Newton pretty heavily soon…so hopefully we’ll flush out a few more bugs
16:40:16 <andymccr> automagically: sounds good. look forward to it :P
16:40:18 <palendae> automagically: Or prove that it's all just fine.
16:40:40 <automagically> palendae: Yes, that’s also a possibility
16:41:31 <andymccr> so the only blueprint we have for the meeting is still mhayden's RHEL 7 STIG
16:41:44 <andymccr> #link https://review.openstack.org/#/q/topic:bp/security-rhel7-stig
16:41:59 <andymccr> does anybody else have any blueprint work they'd like to address
16:42:08 <mhayden> there's a spec for octavia out there, too
16:42:22 <odyssey4me> the ghost of mhayden is present
16:42:57 <andymccr> mhayden: got a link? :) or i can track down the email
16:43:27 <andymccr> #link spec for octavia: https://review.openstack.org/#/c/392205/
16:44:12 <andymccr> ok moving along then!
16:44:18 <andymccr> #topic open discussion
16:44:22 <andymccr> and with that.
16:44:35 <andymccr> does anybody have anything they'd like to raise/discuss?
16:44:55 <palendae> Some outstanding inventory reviews at https://review.openstack.org/392417, https://review.openstack.org/392057, and https://review.openstack.org/392056
16:45:12 * automagically palendae Will take a look
16:45:14 <odyssey4me> yeah, can we get those rebased - then revoted
16:46:23 <palendae> A few of us are going to talk to the craton team in a little bit
16:46:28 <palendae> May inform where we go with the inventory changes
16:47:13 <andymccr> sounds good
16:47:40 <odyssey4me> I have a few irons in the fire at the moment. I'm pretty close to having role-based container caches being built, making them easy to harvest and re-use, and also speeding up the build time a bit.
16:48:15 <odyssey4me> I've also got to finish up the new tempest test method execution for the integrated build so that we can do scenario-based testing there.
16:48:44 <odyssey4me> I expect to have a prototype of the first up for review in the next day.
16:49:19 <odyssey4me> the tempest bits just need to be rebased and finished up: https://review.openstack.org/371753
16:49:57 <odyssey4me> that was just FYI :)
16:50:23 <odyssey4me> Once I have those done I'll revise the WIP specs I put up.
16:50:35 <andymccr> sounds good
16:51:34 <andymccr> ok anymore for anymore?
16:51:46 <odyssey4me> how do we feel about having a periodic upgrade check running?
16:51:50 <odyssey4me> I'm talking major upgrade
16:52:14 <odyssey4me> it would require us monitoring the openstack-qa mailing list for results
16:52:24 <andymccr> i like the idea personally
16:53:30 <logan-> in the integrated repo? i would run it if the test existed
16:54:56 <odyssey4me> ok, I'll try and work up a prototype and setup an experimental job for it to kick start it.
16:55:22 <odyssey4me> Hopefully then others can climb in to make it work better before we then switch over to making it run periodically.
16:55:37 <andymccr> #action odyssey4me looking into adding a prototype experimental integrated build upgrade test (as a periodical)
16:55:50 <odyssey4me> dammit
16:56:03 <andymccr> hahaha
16:56:05 <logan-> lol
16:56:07 <andymccr> new world order.
16:56:08 <andymccr> OK!
16:56:18 <andymccr> thanks everybody - 4 mins left. but i think we're done here
16:56:32 <andymccr> #endmeeting