16:02:12 <mhayden> #startmeeting OpenStack-Ansible
16:02:13 <openstack> Meeting started Thu Oct  6 16:02:12 2016 UTC and is due to finish in 60 minutes.  The chair is mhayden. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:16 <openstack> The meeting name has been set to 'openstack_ansible'
16:02:17 <mhayden> #topic Roll Call
16:02:20 <andymccr> o/
16:02:26 <mhayden> sorry folks -- was in a VC meeting reading things :P
16:02:45 <rromans> \o
16:02:46 <asettle> \o/
16:03:17 <palendae> Hello
16:03:27 <prometheanfire> o/
16:03:43 <odyssey4me> o/
16:03:48 <michaelgugino> o/
16:03:53 <jmccrory> o/
16:04:27 <mhayden> i'll give it til :05 after
16:05:06 <mhayden> let's roll!
16:05:16 <mhayden> #topic Review action items from last week
16:05:28 <mhayden> one was andymccr working on testing overrides
16:05:36 <mhayden> which i think is moving along -- seen lots of patches
16:05:44 <andymccr> mhayden: done - there's a bug and its moving along, thanks to all who have helped so far
16:05:48 <mhayden> woot
16:05:59 <andymccr> also odyssey4me has done a lot of work to standardize some more. so tick!
16:06:04 <mhayden> and odyssey4me was going to create some newton branches, which is obviously done :)
16:06:15 <mhayden> HOORAY NEWTON BRANCH
16:06:17 <andymccr> all action round here.
16:06:20 * mhayden toots
16:06:27 <mhayden> nice
16:06:32 <asettle> Heheheh toot
16:06:44 <mhayden> okay, on to the next
16:06:56 <mhayden> #topic Updating python modules in Ocata (palendae)
16:07:02 <mhayden> palendae: you're up!
16:07:54 * mhayden toots at palendae
16:08:16 <mhayden> okay we can come back to this one in a bit
16:08:19 <palendae> I brought this up due to https://bugs.launchpad.net/openstack-ansible/+bug/1614211 - our Keystone module in particular has fallen pretty far out of date
16:08:20 <openstack> Launchpad bug 1614211 in openstack-ansible trunk "Playbook Runs Fail in Multi-Domain Environments" [Medium,Confirmed] - Assigned to Nolan Brubaker (nolan-brubaker)
16:08:23 <mhayden> oh nvm :
16:08:24 <spotz> \o/
16:08:47 <palendae> So, we either need to look into updating it, or looking at moving towards something else, like Ansible's built in modules
16:08:55 <palendae> I think automagically added this to summit agenda
16:09:17 <automagically> palendae: Yep, not sure there is much to discuss right now
16:09:20 <andymccr> palendae: do we know if the upstream ansible one is fully functional/updated regularly etc?
16:09:28 <palendae> andymccr, That would require some research
16:09:30 <andymccr> i guess we can discuss that at the summit, but wondering if you knew off hand
16:09:31 <andymccr> ok cool
16:09:35 <palendae> Not off hand
16:09:47 <palendae> Mostly I bring up that we have to revisit these somehow
16:09:58 <automagically> the infra team that works on shade has been involved in most of the PR reviews for upstream OpenStack modules
16:10:04 <mhayden> palendae: any specific action items in the meantime pre-summit?
16:10:04 <palendae> yeah
16:10:14 <automagically> So, the broader OpenStack community is definitely getting voices heard
16:10:28 <palendae> mhayden, Perhaps reviewing the upstream ansible modules. I won't be attending but can drop some links in the etherpad
16:10:33 <andymccr> agree, probably worth moving to the upstream modules then. or at least entertaining the idea
16:11:12 <mhayden> #action summit-attendees Talk about upstream Ansible modules for OpenStack
16:11:33 <mhayden> palendae: anything else?
16:11:40 <palendae> #link https://github.com/ansible/ansible-modules-extras/tree/devel/cloud/openstack
16:11:47 <palendae> I don't think there's much else on this
16:12:01 <mhayden> thanks, palendae!
16:12:10 <mhayden> #topic Install guide testing (asettle)
16:12:13 * mhayden passes the mic to asettle
16:12:19 <asettle> Well hello everyone and thanks for coming
16:12:20 <asettle> :p
16:12:24 <stevelle> no toots?
16:12:30 <asettle> Yeah man, where ma toot?
16:12:31 * admin0 toots
16:12:34 <asettle> Thanks admin0
16:12:50 <mhayden> aye
16:12:56 <asettle> Anyway, newton was out today! yay! I've had general feedback that the install guide is smooth! Few errors overall, but nothing that can't be fixed.
16:13:01 <asettle> Aim is to be completely confident before the summit
16:13:08 <asettle> So people that are now free, please take the time to review
16:13:17 <asettle> Myself, and Ianeta my colleague, are going through and making edits of the guide still
16:13:29 <asettle> But other than that, it's pretty much all done, good to go :)
16:13:32 <asettle> If anyone has any bugs
16:13:36 <admin0> i am running various scenarious on multi-node testing and reporting issues
16:13:41 <asettle> please raise with [DOCS] or [install-guide]
16:13:43 <mhayden> those are some good edits from ianeta -- she fixed a bunch of my terrible grammar
16:13:43 <asettle> admin0: many issues?
16:13:55 <admin0> some :)
16:13:58 <admin0> might have 2 more
16:14:12 <admin0> not blockers, but annoying stuffs
16:14:12 <asettle> mhayden: yes, we had the RPC team editor run over it, she filed bugs with me, so I was able to put them into a patch that Ianeta and I are working through :)
16:14:25 <asettle> admin0: yep, that's what I've heard. Feel free to patch those up yourself, I have confidence in you all.
16:14:35 <asettle> Thanks for taking the time to run through it admin0 :)
16:15:14 <asettle> Anyway, that's all from me. I believe evrardjp is also running through it, so there'll be more bugs around
16:15:22 <asettle> Thanks everyone for your hard work over the last few months on this guide!
16:15:26 <admin0> like keepalive VIP ip not coming up, then setup-infra fails due to repo not found ..and you cannot rerun because the proxy is already set .. so you have to first delete the proxy, run the update, run the playbook again , manually restart the keepalive to bring the VIP up an then can continue again
16:15:26 <mhayden> awesome!
16:15:28 <mhayden> thanks, asettle
16:15:31 <asettle> The aim is to get it on the main docs.o.o site
16:15:36 <asettle> So, stay tuned for that development
16:15:49 <asettle> admin0: ahh good info, okay, thanks
16:16:02 <admin0> will test and file bugs .. lets move o
16:16:06 <mhayden> okay, movin' along
16:16:11 <asettle> :)
16:16:25 <mhayden> #topic Xenial to become a voting job for integrated builds (andymccr)
16:16:33 * mhayden passes the mic to andymccr
16:16:41 <andymccr> ok - so we have xenial support, but the gating is on "non-voting" at the moment
16:16:54 <andymccr> the main reason being, that while it works, our current gate takes a long time and causes failures which need rechecks because of timeouts
16:17:11 <andymccr> thats fine, except if we have 2 gates that both do that, we then have double the chance of failure (for timeouts) and struggle to get patches merged
16:17:39 <andymccr> in Ocata I would envision us moving to use Xenial only - so it may be worth enabling xenial over trusty at this point, but I'm not sure its as cut and dried as "just enable xenial"
16:17:42 <andymccr> odyssey4me: thoughts?
16:17:52 <andymccr> michaelgugino: also thoughts!
16:18:22 <michaelgugino> we previously discussed dropping support for trusty in ocata, so that sounds sensible
16:18:30 <odyssey4me> Ocata - Xenial only, yes - we just need to adjust the jobs for that but don't need to do that immediately
16:18:39 <automagically> I’m all for Newton having a Trusty NV gate if it buys us a Xenial voting gate
16:18:44 <odyssey4me> well, xenial & centos
16:18:49 <palendae> Do we know what hte upgrade path looks like for the distro changes?
16:19:12 <mhayden> andymccr: are we talking about making the xenial job voting in Ocata + Newton?
16:19:22 <michaelgugino> palendae: we previously discussed not supporting upgrade between distros
16:19:22 <andymccr> palendae: not yet, but the issue is mainly that afaik other projects are not testing on xenial at all
16:19:38 <palendae> michaelgugino, That'll be....fun
16:19:41 <andymccr> so even if we want to keep trusty support, i don't believe its feasible.
16:20:03 <odyssey4me> gimme a moment - two meetings argh
16:20:09 <palendae> Sure, I'm just concerned we're going to face a big, big battle getting people to move past Newton if they have to pave
16:20:25 <odyssey4me> the trouble is that for the integrated build we very rarely get two successful results
16:20:30 <odyssey4me> so one needs to be voting, and one non
16:20:59 <odyssey4me> I'm happy to flip Xenial to voting for Newton for the integrated gate... but we do need to recognise that it fails more often than the trusty one.
16:21:00 <michaelgugino> I vote for xenial as that what the community is doing.
16:21:00 <andymccr> i propose: Leave it as is for newton (since we're basically there), in Ocata we switch it, and we discuss at the summit more around the whole trusty-->xenial how we handle that and other bits
16:21:15 <jmccrory> palendae : think upgrades would be possible if the controller hosts are taken down and upgraded one at a time, and then computes whenever convenient
16:21:36 <andymccr> i think there is a larger discussion around reducing the gate time so that the xenial gate is more stable (in terms of timeouts)
16:21:40 <palendae> jmccrory, I already know our team will not accept that
16:21:42 <andymccr> and i have a few ideas around that as do a few of you
16:22:16 <palendae> But in terms of flipping between trusty/xenial, I have no opposition
16:22:28 <palendae> I just want to make sure we've got a decent path forward for existing installs
16:23:37 <andymccr> palendae: i agree, but thats largely "how you deploy/upgrade" it may not fall within OSA itself, the fact that kernel upgrade has to happen is pretty much mandated by the other proejcts and not us. The best we can do is facilitate upgrades in some manner
16:24:14 <palendae> Yeah
16:24:25 <palendae> Again, it's not so much Xenial support itself
16:24:33 <palendae> It's that a lot of installs aren't yet Mitaka
16:24:48 <palendae> So we don't know how Newton/Xenial upgrading actually plays out
16:24:56 <admin0> but can’t we say “to ensure you are aligned with OSA and ready for future, we recommend the followig deployment/upgrade path” ?
16:25:01 <andymccr> ok so for now, should we vote on whether we want xenial or trusty for the main newton voting gate - we can discuss the other bits at the summit.
16:25:08 <andymccr> admin0: definitely
16:25:10 <palendae> Fair
16:25:34 <andymccr> its definitely an important issue and i think we can do a lot to help the upgrade path, just conscious that its a larger discussion than we can really have on irc right now!
16:25:42 <mhayden> ready to vote now?
16:26:14 <andymccr> sure am mhayden - you hit that button!
16:26:15 <mhayden> #startvote Should Xenial or Trusty be the voting gate in Newton? Xenial, Trusty
16:26:16 <openstack> Begin voting on: Should Xenial or Trusty be the voting gate in Newton? Valid vote options are Xenial, Trusty.
16:26:17 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:26:29 <andymccr> #vote Trusty
16:26:34 <palendae> #vote Trusty
16:26:38 <admin0> #vote xenial
16:26:52 <spotz> #vote trusty
16:26:56 <andymccr> automagically: michaelgugino: odyssey4me you guys had voices on this
16:27:05 <michaelgugino> #vote xenial
16:27:12 <automagically> #vote xenial
16:27:20 <palendae> Were we doing 2 votes?
16:27:20 <admin0> \o/  we flip a coin now
16:27:29 <palendae> Flipping Newton immediately after release?
16:27:33 <automagically> #vote Xenial
16:27:41 <mhayden> #vote Trusty
16:27:44 <admin0> #vote xenial
16:27:47 <odyssey4me> I'm not fussed. I'd prefer to leave it trusty now, and switch to Xenial once we have stabilised the time of execution a bit)
16:27:49 <jmccrory> #vote Trusty
16:28:00 <odyssey4me> #vote trusty
16:28:09 <odyssey4me> #vote Trusty
16:28:16 <spotz> yeah I thought we were in concensus of trusty for now xenial Ocata:)
16:28:20 <mhayden> not sure if caps matters :P
16:28:23 <mhayden> #vote WUTWUT
16:28:24 <openstack> mhayden: WUTWUT is not a valid option. Valid options are Xenial, Trusty.
16:28:26 <michaelgugino> I don't think the flip has to be immediate.  I was thinking we should flip the gate for newton to xenial at some near point in the future.
16:28:32 <mhayden> haha, well i guess it doesn't matter on capitalization
16:28:43 <mhayden> #endvote
16:28:44 <openstack> Voted on "Should Xenial or Trusty be the voting gate in Newton?" Results are
16:28:45 <openstack> Trusty (6): palendae, odyssey4me, spotz, andymccr, jmccrory, mhayden
16:28:46 <openstack> Xenial (3): admin0, michaelgugino, automagically
16:28:48 <spotz> must be windows based mhayden:)
16:28:51 <andymccr> michaelgugino: in master we'll move to Xenial for sure
16:28:58 <palendae> Newton/Trusty, Ocata/Xenial is my stance
16:29:09 <andymccr> palendae: yip, ok cool that issue is done then!
16:29:11 <mhayden> so we will keep trusty for now and take a look at switching to xenial later (maybe at summit?)
16:29:28 <andymccr> mhayden: essentially yes
16:29:40 <mhayden> #agreed Newton's default voting gate will remain on Trusty for now. Revisit the choice later this month at the Summit.
16:29:52 <mhayden> do we need to talk about Ocata for now or hold that for the summit?
16:30:16 * mhayden notes we're at half past the hour
16:30:33 <andymccr> mhayden: yeah we'll move Ocata to Xenial but we can discuss at the summit
16:30:50 <mhayden> #action summit-attendees Discuss moving Ocata gate to Xenial
16:30:55 <mhayden> okay, ready for the next topic?
16:30:58 <andymccr> si
16:31:01 * mhayden toots
16:31:12 <mhayden> #topic Filing bugs for gate failures (andymccr)
16:31:24 * mhayden passes the mic back to andymccr
16:31:38 <andymccr> quick one, just a request really - we've had a few gate failures (role specific) for random issues, that are transient and just get rechecked
16:31:44 <andymccr> mostly nova/neutron/cinder that i've worked on/tried to fix.
16:32:00 <andymccr> if we can just file bugs for those if you see them come up - would be greatly appreciated because it allows us to see the state/if it's new etc - and we can track/fix them a bit better
16:32:37 <andymccr> (that is all)
16:32:44 <mhayden> sounds good
16:32:55 <mhayden> #topic Barcelona Summit schedule (andymccr)
16:32:56 <automagically> andymccr: Great idea
16:33:08 * mhayden just tells andymccr to keep the mic until later :)
16:33:10 <andymccr> #link https://etherpad.openstack.org/p/osa-barcelona-schedule
16:33:45 <andymccr> I've added our summit sessions into the etherpad - we should probably decide which ones we want as priority, or we can be more adlib. I think the first 2 sessions (on the wednesday) can be to discuss what we're planning for the summit
16:33:52 <michaelgugino> My internal peeps really want a way to integrate ceph-ansible inventory with osa
16:34:04 <andymccr> and we have fish bowls first thing thursday which are more for a "here's what we've done - here's where we're going" for outsides.
16:34:29 <andymccr> michaelgugino: i have heard some people ask for ceph-ansible to be more closely integrated, so i'm sure we can discuss
16:34:55 <admin0> it will save me hours per day setting-up and re-setting up the ceph cluster to test
16:35:13 <odyssey4me> michaelgugino andymccr I think I added that to the discussion options
16:35:22 <admin0> but again, as operator, if ceph is the way to go, and also mongodb for ceilometer/aodh, those should be automatically installed or have a way to installed
16:35:30 <admin0> like we treat mysql or rabbit
16:35:41 <odyssey4me> admin0 mongodb is no longer the way to go, ceph is preferred actually
16:35:55 <odyssey4me> stevelle can comment in a more informed fashion
16:35:58 <andymccr> so request :) update the etherpad, put +'s next to topics youre really interested in and lets get a headstart
16:35:58 <admin0> even for aodh and ceilometer ?
16:35:59 <automagically> michaelgugino: Have you tried the overlay approach that logan- did
16:36:08 <andymccr> there is also a section if you're giving a talk - people may well be interested in that!
16:36:09 <michaelgugino> ceph is it's own specialty.  And I think the ceph-ansible plays are good.  If we integrate, it should only be consumption.
16:36:13 <automagically> See https://logan.protiumit.com/
16:36:23 <automagically> #link https://logan.protiumit.com/
16:36:24 <odyssey4me> admin0 for gnocchi, yes - ceilometer is becoming just an API
16:36:30 <stevelle> admin0: especially for aodh
16:36:35 <odyssey4me> and for aodh I think it just uses MySQL now
16:36:37 <admin0> odyssey4me: so why is it not in our docs yet :D
16:36:41 <admin0> or in any docs
16:36:46 <admin0> or am i reading the wrong stuff :)
16:36:46 <stevelle> admin0: it's in release notes
16:36:52 <michaelgugino> I have not seen that overlay stuff before
16:38:05 <admin0> stevelle: everyone (via search, links) end up there: http://docs.openstack.org/developer/openstack-ansible/liberty/install-guide/configure-aodh.html :)
16:38:10 <admin0> and not in the release notes :(
16:38:30 <stevelle> admin0: that's liberty
16:38:44 <admin0> same for mitaka, nothing yet for newton
16:39:07 <admin0> was trying to say about actual links and not release notes  .. and not specific liberty
16:39:37 <asettle> admin0: for aodh?
16:39:54 <admin0> that was what stevelle said above :)
16:40:04 <admin0> its news to me and my hands are already ticking to test it out
16:40:15 <admin0> but no docs yet on how to even get started :)
16:40:21 <logan-> thanks automagically. michaelgugino, if you happen to take a look and have any feedback/questions let me know. its an approach i have used successfully since Kilo to combine ceph-ansible and various other unrelated roles with osa
16:40:32 <automagically> admin0 - Open some bugs about the docs plz
16:40:39 <palendae> Or better yet, patches
16:40:42 <stevelle> admin0: we added the mysql support by default in newton, so the mitaka docs won't reflect that :P
16:40:43 <michaelgugino> logan-: will take a look, thanks
16:40:54 <asettle> admin0: all roles are moved into their own docs: http://docs.openstack.org/developer/openstack-ansible-os_aodh/
16:41:05 <mhayden> anything else to add to the summit agenda for now?
16:41:19 <asettle> From the Newton install guide: http://docs.openstack.org/developer/openstack-ansible/newton/install-guide/app-advanced-config-options.html
16:41:30 <asettle> I'm not too sure if that answers your question or not, but that's where it lives.
16:41:31 <admin0> please multi-region support .. make it easy for people who already have a working openstack to have a new one :)
16:41:38 <admin0> so that they can easily migrate /upgrade to this new one
16:41:52 <admin0> just means : integrate with exisiting keystone and install itself as a new region
16:41:59 <odyssey4me> IIRC automagically was going to do a blog post around that?
16:42:11 <automagically> odyssey4me: Yep, still on my TODO list
16:42:29 <automagically> I’m still off in golang land for a bit tho
16:42:59 <admin0> so in the summit, i just need to find the rackspace corner, and i will be able to meet you guys there :D ?
16:43:05 <logan-> for multi-region I did a paste with a POC config I did recently on multi-region. we're pushing to begin adding regions next month, so I will try to get some blogging done as we finalize the configs
16:43:49 <mhayden> okay, let's move on
16:44:11 <mhayden> #topic PTG in Atlanta Feb 20-24 (andymccr)
16:44:26 <mhayden> is there a fee for attending the PTG?
16:44:47 <odyssey4me> admin0 nope, we'll likely be at the design summit most of the time
16:45:03 <andymccr> ok so I know this is far in advance, but I've started getting queries around the PTG - and whether we will be attending. AFAIK there will be RAX attendance, but michaelgugino jmccrory automagically everybody else, would you be able to attend?
16:45:25 <stevelle> good topic
16:45:27 <andymccr> mhayden: im not sure - but i'll find out those details, for now its early doors. so its more just a "heads up" add an action and i'll follow up with more details
16:45:30 <automagically> No idea yet. Possible, but improbably I think at this point
16:45:43 <michaelgugino> what is the PTG?
16:45:45 <palendae> Worth asking now
16:45:51 <michaelgugino> oh, the new 'midcyle' ?
16:45:57 <andymccr> michaelgugino: yeah basically
16:45:58 <palendae> michaelgugino, Summit's being split; PTG is basically where the work will happen
16:46:01 <andymccr> Project Team Gathering
16:46:27 <palendae> But worth letting your management know now
16:46:28 <jmccrory> i'll probably be able to go
16:46:45 <spotz> Foundation said there will still be a design summit at the summits though
16:46:50 <michaelgugino> I can't say.  Presumably yes, if that's where everyone is going to do the work.  But having two summits presents a budgetary problem for my org.
16:46:53 <andymccr> excellent, there isn't really a need to confirm right now - its more a headsup and to let you know that is coming up. Here is some basic info
16:46:57 <palendae> spotz, Right, just not as much as before
16:47:03 <andymccr> #link https://www.openstack.org/ptg/
16:47:06 <palendae> michaelgugino, It does for a lot of people
16:48:03 <mhayden> okay, let's move on to open floor
16:48:05 <stevelle> the way I understand it, the big conference will not have nearly as much work done, so starting to tilt limited budgets toward PTG rather than the big conference might make sense
16:48:08 <mhayden> #topic Open floor
16:48:23 <mhayden> many thanks to the folks who merged some things to help me move along with the RHEL 7 STIG work ;)
16:49:08 <palendae> I've thrown up a POC for taking the documented bash commands and putting them into scripts to actually be run. https://review.openstack.org/#/c/382649/ and https://gist.github.com/nrb/ce831c967192a7c73717f44d35a56905 for sample outpu
16:50:15 <andymccr> palendae: the idea being to run the script in your gist?
16:50:25 <palendae> andymccr, Hopefully, yes
16:50:33 <palendae> To verify that the commands actually work
16:50:51 <palendae> Some obviously will be in isolation and can't
16:51:03 <palendae> And they may not be gateable given they require setting up a whole stack
16:51:06 <andymccr> palendae: ok cool - i'd personally like to see some kind of upgrade gate/check whether thats periodical or not, or just between stable branches - i dont know.
16:51:19 <palendae> But if people don't find that useful just as happy to abandon it
16:51:20 <andymccr> but the feasibility of that is questionable.
16:51:45 <palendae> It pulls out bash from every file, not just the upgrade stuff
16:53:00 <mhayden> anything else for today?
16:53:01 <andymccr> i'll try take a look tomorrow
16:53:06 <michaelgugino> it would be nice if we had a 'scenarios' page that we can use for each role in the docs, to help better formulate testing manually
16:53:21 <asettle> michaelgugino: good suggestion. File a bug and I'll look into it.
16:54:38 <michaelgugino> it would also be nice to have a NV check for 'new code path' in each of the repos
16:55:18 <michaelgugino> something like an extra tox env that is generic, and you can submit something like test-extra.yml or something like that to get gate coverage to prove your feature works in the gate
16:55:48 <michaelgugino> or possibly check-experimental
16:55:56 <palendae> Why not just add the new test with the feature?
16:56:30 <stevelle> ^ possibly w/ check-experimental usage
16:56:35 <michaelgugino> sometimes the features are competing.  Deploying cinder + ceph backend, deploying cinder + 2 ceph backends.  Both should work.
16:57:18 <michaelgugino> Basically, I'm proposing a standard interface for all the roles / projects that patchsets can make use of.
16:57:20 <mhayden> okay, we can carry this over to the main channel
16:57:25 <mhayden> i'll close up the mtg
16:57:28 <mhayden> thanks everyone!
16:57:30 <mhayden> #endmeeting