16:01:00 <odyssey4me> #startmeeting OpenStack-Ansible
16:01:00 <openstack> Meeting started Thu May 12 16:01:00 2016 UTC and is due to finish in 60 minutes.  The chair is odyssey4me. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:05 <openstack> The meeting name has been set to 'openstack_ansible'
16:01:21 <odyssey4me> #topic Agenda & rollcall
16:02:13 <prometheanfire> already here :P
16:02:15 <andymccr> o/
16:02:34 <michaelgugino> here
16:02:38 <ametts> o/
16:03:08 <asettle> yep
16:04:09 <v1k0d3n> o/
16:04:11 <jmccrory_> o/
16:04:16 <stevelle> o/
16:05:02 <odyssey4me> Howdy all :)
16:05:11 <odyssey4me> #link https://wiki.openstack.org/wiki/Meetings/openstack-ansible#Agenda_for_next_meeting
16:05:28 <odyssey4me> #topic Shall we retire https://github.com/openstack/openstack-ansible-py_from_git ?
16:06:22 <cloudnull> o/
16:06:27 <cloudnull> yes
16:06:27 <odyssey4me> We've managed to eradicate this role from stable/mitaka and master. The question is whether we should keep it around because it may be useful to someone, or whether we should retire it?
16:06:29 <cloudnull> let it die
16:07:05 <andymccr> if we're not using/testing it - i think we should let it die
16:07:20 <odyssey4me> yeah, that's my sentiment
16:07:28 <odyssey4me> any objections to doing this?
16:08:02 <jasondotstar> o/
16:08:49 <odyssey4me> alright, I'll process the retirement in the next week
16:09:07 <odyssey4me> #action odyssey4me to retire https://github.com/openstack/openstack-ansible-py_from_git
16:09:07 <d34dh0r53> o/
16:09:20 <odyssey4me> #topic Tests Repo
16:09:42 <odyssey4me> At the summit we discussed splitting the tests from the openstack-ansible repo into its own repo.
16:10:17 <odyssey4me> I wanted to discuss whether this repo should include the bootstrap-host role, or whether we think the bootstrap-host role should be in its own repo?
16:10:45 <prometheanfire> I'm in favor of it being in it's own repo
16:10:54 <prometheanfire> I think it's still useful outside of tests
16:11:02 <odyssey4me> my hope is that we can create a tests repo and consolidate all integrated and role test stuff into it, hopefully massively reducing duplication
16:12:08 <stevelle> I'm confused about moving tests to their own repo
16:12:21 <stevelle> obviously I missed that discussion
16:12:55 <andymccr> my understanding is we'd have a generic "test" repo so we can facilitate the tests for the indivdual repositories,
16:13:14 <cloudnull> ^ +1
16:13:16 <andymccr> at the moment we have a situation where any minor change to the generic testing parts needs to change in the 15 or so repos
16:13:23 <andymccr> but i dont think it needs to do ALL the things
16:13:28 <andymccr> that may be overcomplicating it
16:13:36 <odyssey4me> essentially there is a lot of duplication in the test plays & vars across the roles, so the general idea is to put the common requirements there and have the roles consume those things and only hold the things special to the role
16:13:46 <andymccr> to start with we probably just need keystone, galera, rabbit, memcache
16:14:16 <andymccr> then individual test-vars and inventory/host_vars/group_vars can be included in the roles themselves - which would customize the testing.
16:14:23 <stevelle> I'd suggest we have that stuff centralized if we want to use it: it's in the os_keystone repo
16:14:51 <odyssey4me> ok, so the burning need is primarily for the roles right now
16:15:34 <jmccrory_> prepare-host test playbooks are already starting to drift between IRRs with multi distro changes
16:15:52 <odyssey4me> yeah, keeping them similar is becoming a lot of work
16:16:00 <andymccr> yeh we need to make this happen sooner rather than later.
16:16:14 <andymccr> i already ran into a few bugs that would take a fix to each repo
16:16:16 <odyssey4me> also, for new projects coming in it'd be very useful to have them simply 'include' a base set of infra and build on it
16:16:23 <andymccr> agree
16:16:28 <andymccr> but id like to keep it as simple as possible upfront
16:16:32 <stevelle> ^
16:16:47 <odyssey4me> ok, how do we want to approach doing this?
16:16:47 <andymccr> we can grow it as needed - im scared of over engineering a "DO ALL THE THINGS" testing plan that we really dont need right now
16:16:48 <stevelle> I'd be concerned about it growing to be a rubbish heap
16:17:27 <stevelle> is there a PoC to see scope yet?
16:17:36 <andymccr> stevelle: not yet
16:17:41 <odyssey4me> does one person want to try it out on a github repo for a PoC - then we look at it together, discuss it and take it from there?
16:17:48 <andymccr> odyssey4me: i'll give it a go
16:18:01 <odyssey4me> everyone good with that?
16:18:10 <odyssey4me> what do we want as a success criteria here?
16:18:27 <andymccr> im gonna say glance, keystone, nova, swift all working with a base set of "generic" tasks from a repo?
16:18:42 <odyssey4me> I would suggest a review in for at least two openstack roles that consume a shared set of test configs/resources
16:18:59 <andymccr> sounds good
16:19:34 <odyssey4me> glance/keystone/nova/swift actually sounds like a good set
16:19:48 <andymccr> i might skip glance if it's taking too long :P but yeah.
16:20:02 <andymccr> i think it'll be the easiest to get working upfront
16:20:03 <odyssey4me> sure, I was going to suggest that you could
16:20:18 <stevelle> good plan
16:20:38 <odyssey4me> ok, we'll discuss it again every week and can always review in time too
16:20:50 <odyssey4me> #action andymccr to PoC a role test repository
16:21:07 <odyssey4me> #topic Ops/Contrib Repo
16:21:54 <odyssey4me> At the summit we also discussed having some sort of Ops/Contrib repository where users of OSA could share related plays, tools, or whatever
16:22:16 <michaelgugino> I like that idea, I don't have anything really pressing to put in it at the moment.
16:23:02 <odyssey4me> one thing we could do is direct these sorts of contributions into https://github.com/openstack/osops-tools-generic/
16:23:28 <odyssey4me> OsOps is an Operator community working group.
16:23:59 <odyssey4me> We could submit reviews to have an openstack-ansible folder in there and add the same sort of things
16:24:20 <odyssey4me> my thinking is that it could improve exposure, and also means that we don't have to manage the dumping ground
16:24:46 <michaelgugino> that repo hasn't had a merge since feb.
16:25:28 <odyssey4me> yeah, they're still a pretty new group and the operators are notorious for being too busy to submit code reviews ;)
16:26:01 <odyssey4me> we could, of course, have our own repo and then just add our repo to the bottom of their README as an additional resource
16:26:22 <michaelgugino> I like that idea
16:27:02 <odyssey4me> any thoughts on a repo name for this?
16:27:06 <stevelle> I like the idea of supporting the osops program
16:27:18 <stevelle> but that has problems as noted
16:28:13 <odyssey4me> something like openstack-ansible-contrib ?
16:28:27 <spotz> If not supporting osops what about osaops - yeah I'm late
16:30:13 <michaelgugino> contrib is too developer sounding
16:30:26 <odyssey4me> not a fan of osaops myself - I'd rather not label it 'ops' but instead prefer to keep it generic
16:30:28 <michaelgugino> maybe something like 'add-ons' or something a non dev would use
16:30:42 <michaelgugino> 'extensions' even
16:30:48 <spotz> add-ons is nice
16:30:55 <michaelgugino> or 'extras'
16:31:35 <michaelgugino> we should also change our name from OpenStack-Ansible to something like the other projects (a cute name that means nothing).  I propose 'Jingle'
16:31:47 <cloudnull> hahaha
16:32:06 <odyssey4me> extras I'm ok with I thikn
16:32:09 <odyssey4me> *think
16:32:43 <odyssey4me> lol, renaming won't happen - it will break every downstream consumer
16:34:48 <odyssey4me> any objections to creating an openstack-ansible-extras repository for the purpose of contributors to share stuff outside of the integrated build?
16:36:33 <spotz> +1
16:36:58 <odyssey4me> jmccrory automagically cloudnull d34dh0r53 stevelle mattt hughsaunders andymccr mhayden ping - hello anyone there?
16:37:09 <andymccr> i think my only concern is how we define what goes into that repository
16:37:41 <stevelle> I'm not a hard no on 'extras' at all, just not sure it gives good guidance about what goes into it. Thinking about it :)
16:37:54 <andymccr> yeah i dont mind hte name
16:37:56 <cloudnull> i like osaops
16:38:19 <spotz> yeah cloudnull:)
16:38:24 <odyssey4me> ie openstack-ansible-ops ?
16:38:29 <cloudnull> but im not -1 on extras
16:38:30 <d34dh0r53> ^
16:38:39 <andymccr> that seems fine to me
16:38:56 <d34dh0r53> openstack-ansible-ops looks good to me
16:39:02 <d34dh0r53> extras seems a little vague to me
16:39:15 <andymccr> i guess we can create the repo and define the other criteria once we start seeing traction/use cases
16:39:50 <spotz> andymccr: I'm assuming stuff would still get reviewed so we'd be able to say something wasn't right for the repo
16:40:28 <odyssey4me> yeah, at this point I'm looking to create the repo with nothing in it - I can then propose an initial readme where we can discuss scope and define it
16:41:03 <odyssey4me> I intend to also seed an initial bit into the repo to 'set the scene'.
16:41:33 <michaelgugino> osaops singles a little narrowly focused, but I'm not sure what wouldn't fit under 'ops' that would go in there, so I suppose it's doable.  Just calling it ops seems like it's saying 'you definitely want what's in here'
16:41:50 <michaelgugino> when I think it's more of a 'you might want some of what's in here'
16:42:01 <odyssey4me> It'll basically be a doc describing how you can implement NTP across all your hosts using Ansible, the OSA dynamic inventory and an Ansible Galaxy role
16:43:01 <jmccrory> that sounds good. maybe more of the pre-setup tasks that get asked about, networking, disks, etc
16:43:30 <odyssey4me> yep, that's exactly what I'd like to see go in there
16:43:43 <odyssey4me> cloudnull has some magic to setup all the networking given a set of assumptions
16:44:01 <odyssey4me> these are all useful things, but not things we want to make promises about in the integrated build
16:44:22 <cloudnull> yes thats in my osic repos
16:44:52 <cloudnull> https://github.com/os-cloud/osic-ironic-impl/tree/master/templates
16:45:14 <odyssey4me> I think openstack-ansible-ops would be fine. While I agree with michaelgugino that it does suggest a limited scope, I think useful things for operators is the primary target.
16:45:19 <cloudnull> I also have preseeds for host paritioning and other things if we want to move those bits
16:45:55 <odyssey4me> cloudnull yeah, all those things would be nice to include there for broader exposure
16:46:11 <odyssey4me> and I'll share the repo presence with the osops community
16:46:46 <odyssey4me> alright, let's go with that
16:47:29 <odyssey4me> #action odyssey4me to request the creation of a blank openstack-ansible-ops repository to carry useful plays/tools for operators
16:47:53 <odyssey4me> #topic Open discussion
16:48:18 <odyssey4me> Considering we're pretty much done for time I figured I'd open it up for open discussion instead of continuing with the agenda
16:48:22 <spotz> Is anyone working on the conversion of os-horizon? Don't want to pick one someone's working on
16:48:39 <odyssey4me> if no-one has anything specific then I wouldn't mind discussing the Mid Cycle
16:48:43 <cloudnull> its all your ;)
16:48:57 <stevelle> spotz: I had hoped to but pulled my name off, just not finding time
16:49:23 <spotz> Thanks stevelle, I accidently picked one cloudnull was working on last time so want an unloved one:)
16:50:00 <michaelgugino> cloudnull: have you started the keystone work for xenial?
16:50:05 <cloudnull> I have not
16:50:21 <michaelgugino> I was thinking about picking that up if you don't mind
16:50:25 <cloudnull> go ahead
16:50:35 <michaelgugino> alright, will do.
16:50:36 <cloudnull> ive been a little swamped with osic work
16:51:10 <michaelgugino> Once we have that and galera server merged, the rest of the roles will follow
16:51:53 <michaelgugino> odyssey4me: I had some question about testing
16:52:04 <michaelgugino> can we deploy multiple instances for running different checks in parallel?
16:52:06 <odyssey4me> have we covered all the dependent roles? os_keystone relies on quite a few and I don't think we have all the basic infra roles covered yet?
16:52:30 <odyssey4me> michaelgugino I will take care of getting another functional check in for openvswitch.
16:52:45 <michaelgugino> ok, that's what I was wondering about
16:53:00 <odyssey4me> #action odyssey4me to prep os_neutron openvswitch job in OpenStack-CI
16:53:04 <stevelle> have any of the os_roles started running tempest in their role repo gate?
16:53:33 <odyssey4me> stevelle yes, mattt's been working on that
16:53:49 <odyssey4me> I think nova is done.
16:54:18 <odyssey4me> He's currently revising the tempest role, horizon role and designate role to cover the tempest plugin use-case
16:54:38 <spotz> ironic, switft, nova are theones without names odyssey4me
16:54:39 <odyssey4me> there are a few reviews ongoing - please support him by reviewing.
16:55:02 <stevelle> odyssey4me: found it, thx
16:55:04 <odyssey4me> spotz I think andymccr will cover swift
16:55:29 <odyssey4me> spotz so you're welcome to go with ironic/nova for the var break-out
16:55:53 <spotz> If I get through horizon I'll pick up ironic
16:55:54 <odyssey4me> there is also zaqar and rally, which would be a far easier start
16:56:04 <odyssey4me> nova/ironic have some nasty dragons :p
16:56:16 <spotz> ooh maybe I'll do one of those then try horizon
16:56:43 <spotz> work has been busy, slacking on my reviewing:(
16:57:44 <stevelle> last topic I wanted to ask about, has anyone picked up the challenge of trying to document how to use our inventory more thoroughly yet?
16:57:54 <stevelle> env.d and conf.d bits esp.
16:58:15 <odyssey4me> stevelle nope, not to my knowledge
16:59:26 <stevelle> ok, it's going to start becoming a hotter topic for me as I try to get more folks familiar with OSA. I will need help but will try to at least start a draft on that in the next 2 weeks
16:59:47 <odyssey4me> excellent, thanks stevelle
16:59:53 <spotz> stevelle if you draft I'll help finish
17:01:17 <odyssey4me> alright, we're out of time
17:01:19 <odyssey4me> thanks all!
17:01:22 <odyssey4me> #endmeeting