16:00:25 <nijaba> #startmeeting
16:00:25 <openstack> Meeting started Thu Aug 16 16:00:25 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:25 <nijaba> #meetingtopic Ceilometer
16:00:25 <nijaba> #chair nijaba
16:00:25 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
16:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:28 <openstack> Current chairs: nijaba
16:00:42 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
16:00:42 <nijaba> o/
16:01:05 <jgriffith> o/
16:01:06 <nijaba> hello dhellmann
16:01:10 <nijaba> just started the meeting
16:01:20 <nijaba> hey jgriffith!
16:01:25 <dhellmann> hello!
16:01:26 <dhellmann> ok
16:01:29 <jgriffith> nijaba: Hello!
16:01:43 <nijaba> #topic actions from previous meeting
16:01:58 <nijaba> #topic jaypipes to create ceilometer cookbook
16:02:18 <nijaba> jaypipes does not seem to be around...
16:02:27 <gmb> O/
16:02:36 <gmb> Hi folks.
16:02:38 <nijaba> #action  jaypipes to create ceilometer cookbook
16:02:43 <nijaba> hello gmb
16:02:57 <nijaba> #topic nijaba to do a second thouroughness check on API and report next week
16:03:12 <nijaba> So, here is what I found in terms of discrepencies:
16:03:12 <nijaba> 1. GET /v1 should return detailed information about this specific version of the API.
16:03:12 <nijaba> 2. GET /v1/extensions has not been implemeted yet
16:03:12 <nijaba> 3. GET /v1/sources does not seem to have an equivallent
16:03:12 <nijaba> 4. GET /v1/LIST/  I am not sure how one would know about the components that would be instrumented.  Would that be part of /v1/resources?
16:03:14 <nijaba> 5. GET /v1/LIST/<COMPONENT>/METERS same as above to get a list of meters per component
16:03:16 <nijaba> 6. GET /v1/LIST/METERS same as above regarding a list of all meters
16:03:18 <nijaba> 7. There does not seem to be any summary API left (ie: /]USERS/<USER_ID>/<METER>/VOLUME or /DURATION)
16:03:20 <nijaba> 8. It does not seem possible to specify start_time and end_time as parameters of the queries
16:03:23 <nijaba> That's all I could find, but I may have missed a few...
16:04:03 <dhellmann> start and stop times are going to be GET parameters instead of part of the URL
16:04:37 <nijaba> dhellmann: sounds fine to me, just was not present on the desc when I did the comparison
16:05:08 <dhellmann> yeah, I haven't added that yet :-)
16:05:31 <dhellmann> let's go in order...
16:05:38 <dhellmann> 1. what "information" should be returned?
16:05:53 <nijaba> dhellmann: the version of the API
16:06:03 <dhellmann> so a list of version numbers?
16:06:04 <nijaba> dhellmann: subversion that is
16:06:20 <dhellmann> "v1"?
16:06:23 <nijaba> dhellmann: look at what nova does
16:06:26 <dhellmann> ok
16:06:40 <dhellmann> 2. I will need to look into extensions, too
16:06:50 <dhellmann> 3. I missed that, will add
16:07:12 <dhellmann> 4. I don't know what "components" this means. like nova & quantum, or something else?
16:07:31 <dhellmann> how does "component" differ from source?
16:07:39 <nijaba> 5. nova/quantum/cinder/swift/etc... was the intent
16:07:58 <nijaba> s/5./4./
16:08:12 <dhellmann> ok. we aren't currently recording that anywhere in the meter data, so I will have to think about a source for the info
16:08:15 <nijaba> dhellmann: source could be 2 different deployments
16:08:25 <dhellmann> aha, ok
16:08:32 <dhellmann> so that needs to be config value
16:08:37 <dhellmann> noted
16:08:55 <dhellmann> 5 and 6 are clear now
16:09:15 <dhellmann> 7 isn't done yet, but we'll be doing some work on that as we do our integration work during this current sprint
16:09:24 <nijaba> coolio
16:09:36 <nijaba> so I guess you answered on all items
16:09:44 <nijaba> do you want to mark some actions?
16:10:50 <dhellmann> I'll copy these notes into the comment in that file for reference later, but I don't know which pieces we'll be implementing, yet, so I'd rather hold off on commitments beyond that
16:11:02 <nijaba> sounds good to me
16:11:21 <nijaba> shall we move on?
16:11:28 <dhellmann> k
16:11:33 <nijaba> #topic nijaba to write description of component responsibility
16:11:43 <nijaba> I unfortunately did not get as much time as I wanted to work on this the past week, so I am re-assigning this to me for next week
16:11:43 <nijaba> #action nijaba to write description of componet responsibility
16:12:00 <nijaba> I guess that's it for last week's actions...
16:12:12 <nijaba> We did not seem to have any other topic on the agenda.
16:12:19 <nijaba> #topic Open Discusssion
16:12:20 <dhellmann> I have a couple
16:12:29 <nijaba> please shoot :)
16:12:37 <dhellmann> first, we should coordinate on a presentation for the summit
16:12:39 <dhellmann> at least one
16:13:04 <nijaba> I have proposed a talk for the summit
16:13:09 <dhellmann> oh, good, I hadn't seen that yet
16:13:31 <nijaba> and I think we need to session as part of dev track
16:13:42 <nijaba> one on ceilometer's future in general
16:13:59 <dhellmann> is your proposal for a dev session or for the "conference" part?
16:14:07 <dhellmann> or is that all the same thing this year?
16:14:12 <nijaba> one on the possible heat transfer of the load balancing tool
16:14:24 <nijaba> no, there is still a dev and a conference part
16:14:36 <nijaba> the talk I proposed already is for the conf part
16:14:44 <dhellmann> ok, good
16:14:45 <nijaba> the 2 session is for the summit
16:14:51 <dhellmann> I agree, we need to cover both
16:14:53 <nijaba> s/is/are/
16:15:12 <nijaba> I have not seen the call for summit sessions yet
16:15:16 <nijaba> did I miss it?
16:15:37 <dhellmann> oh, maybe it's not open yet
16:15:43 <dhellmann> I thought i saw something, but maybe that was for the conference
16:15:58 <nijaba> the only one I saw so far was for the conf
16:16:29 <dhellmann> ok
16:16:51 <dhellmann> so I thought I would propose a "this is ceilometer" session for the dev sessions
16:17:03 <dhellmann> cover the architecture, status, etc.
16:17:25 <nijaba> agreed
16:17:35 <dhellmann> how do you feel about collaborating on the presentation portion, nijaba ?
16:17:45 <nijaba> I am ALL open :)
16:18:00 <dhellmann> ok, let's talk about that by email
16:18:41 <nijaba> +1
16:18:57 <nijaba> any other topic?
16:19:06 <dhellmann> we need more reviewers!
16:19:23 <nijaba> #action dhellmann and nijaba to work on sessions for summit via email
16:19:43 <dhellmann> we've had some people say they would be more involved, is anyone looking for ways to help?
16:19:56 <nijaba> gmb: would you like to join as a reviewer?
16:19:58 <dhellmann> I mean anyone here at the meeting?
16:20:11 <gmb> nijaba: I'd be happy to.
16:20:25 <nijaba> dhellmann: should we grant gmb some +2 powers?
16:20:45 <nijaba> His python is much sharper than mine....
16:20:50 * dhellmann maps irc id to person...
16:21:19 <dhellmann> ok, sounds good!
16:21:21 <nijaba> gmb: manager of the OpenStack team at Canonical (the one he is recruiting for as we speak)
16:21:44 <gmb> Yes, it's all the fun of programming exercises and technical interviews here at the moment.
16:21:50 <dhellmann> :-)
16:21:55 <nijaba> #action nijaba to give core reviewer rights to gmb
16:22:00 <dhellmann> cool, welcome aboard, gmb!
16:22:06 <gmb> Thanks dhellmann
16:22:21 <dhellmann> nijaba: we should see about jtrans, too, if he has time
16:22:50 <nijaba> I agree, but we'd need his ok first
16:23:00 <nijaba> do you want to check with him via email?
16:23:28 <dhellmann> #action dhellmann to ask jtrans about interest in reviewer status
16:23:45 <nijaba> btw, did zul (chuck short) fix his commit?
16:23:58 <zul> nijaba: not yet
16:24:13 <nijaba> hey zul!
16:24:21 <nijaba> seem like just one typo away...
16:24:41 <zul> nijaba: yeah i have other priorities right now ill get back to it today
16:24:49 <nijaba> cool, thanks
16:25:34 <nijaba> any other topics?
16:25:58 * dhellmann is done
16:26:35 <nijaba> calling once...
16:26:46 <nijaba> twice...
16:27:02 <nijaba> ok, that seems like a wrap
16:27:11 <dhellmann> thanks for a quick meeting, everyone!
16:27:15 <nijaba> thanks a lot everyone.
16:27:23 <nijaba> #endmeeting