16:00:01 <nijaba> #startmeeting
16:00:01 <openstack> Meeting started Thu Jul 12 16:00:01 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:01 <nijaba> #meetingtopic Ceilometer
16:00:01 <nijaba> #chair nijaba
16:00:01 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <openstack> Current chairs: nijaba
16:00:05 <dhellmann> o/
16:00:15 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
16:00:19 <nijaba> o/
16:00:22 <dhellmann> o/
16:00:25 <gmb> o/
16:00:47 <nijaba> hey, welcome gmb! care to introduce yourself?
16:00:58 <gmb> Sure, nijaba, thanks.
16:01:25 <gmb> Hi everyone; I'm Graham Binns, and I'm the new Launchpad Green Squad Lead at Canonical
16:01:40 <gmb> We'll be working on Ceilometer - as soon as we have the squad assembled
16:01:45 <nijaba> also known as the openstack team ;)
16:01:50 <gmb> :)
16:01:59 <dhellmann> that's great!
16:02:03 <nijaba> great to have you with us!
16:02:08 <nijaba> #topic actions from previous meeting
16:02:12 <gmb> Thanks. I'm excited to be here.
16:02:20 <nijaba> #topic nijaba to send an email to the PPB for Incabation application
16:02:20 <nijaba> This was done and we'll be discussing the results in a bit
16:02:31 <nijaba> #topic nijaba to send call for candidate to the general mailing list
16:02:31 <nijaba> This was done, I believe we even already have 2 candidates
16:02:39 * nijaba ponders adding a third...
16:03:01 * dhellmann thinks we need more voters ;-)
16:03:06 <nijaba> hehe
16:03:14 <flacoste> o/
16:03:18 <nijaba> Well, with condorcet, we could all be candidates!
16:03:28 <dhellmann> true!
16:03:46 <nijaba> is jd___ around?
16:03:51 <jd___> yes
16:03:56 <nijaba> as the next action was for him
16:04:04 <nijaba> great!
16:04:07 <nijaba> #topic jd__ to setup opa voting system to start on 26th and end on Aug 3rd
16:04:07 <nijaba> I gess we just have to carry on this action until then?
16:04:23 <jd___> yes, I can't do this before 26
16:04:27 <nijaba> #action jd to setup opa voting system to start on 26th and end on Aug 3rd
16:04:40 <nijaba> #topic nijaba to prime a roadmap page and invite others to populate it
16:04:40 <nijaba> This was done:
16:04:40 <nijaba> #link http://wiki.openstack.org/EfficientMetering/RoadMap
16:04:53 <nijaba> any suggestion on improving this?
16:05:07 <dhellmann> we should probably post on the mailing list, asking for feedbabck
16:05:16 <dhellmann> or feedback
16:05:26 <nijaba> good point.  I can take this action
16:05:33 <dhellmann> ok
16:05:48 <nijaba> #action nijaba to post roadmap to mailing list, askingfor feeback and volunteers?
16:06:12 <nijaba> #topic jd__ handle counter/meter type for real
16:06:26 <dhellmann> I don't remember that action, what is that about jd___?
16:06:48 <jd___> about adding the type of meters in ceilometer meter code
16:06:57 <jd___> I don't recall if there's a bug opened for that or not
16:07:01 <dhellmann> oh, I remember now
16:07:04 <jd___> but it's on my todo list
16:07:07 <dhellmann> I thought you wanted a floating point meter :-)
16:07:14 <jd___> lol :)
16:07:20 <jd___> and unfortunately it's still on my todo list, I failed
16:07:26 <nijaba> so, should we carry on the action for next meeting?
16:07:31 <jd___> yes please
16:07:39 <dhellmann> is there a bug open for that?
16:07:52 <jd___> dhellmann: I'll check and open one while we continue chatting if not
16:07:57 <nijaba> #action jd___ adding the type of meters in ceilometer meter code
16:07:57 <dhellmann> sounds good
16:08:13 <nijaba> #topic nijaba to document external API use with a clear warning about the limitation of the sum and duration function
16:08:13 <nijaba> I did add a long blurb to the API proposal
16:08:13 <nijaba> #link  http://wiki.openstack.org/EfficientMetering/APIProposalv1#Limitations
16:08:29 <nijaba> feedback on this blurb welcome
16:08:57 <dhellmann> that looks good to me, nice detail
16:09:21 <dhellmann> and much more clear than my original post to the message
16:09:45 <nijaba> it took me a bit to word it correctly!
16:09:58 <nijaba> I guess that's it for last week's actions...
16:10:13 <nijaba> #topic Discuss and define actions from the PPB discussion on Tue regarding our incubation.
16:10:13 <nijaba> #link http://eavesdrop.openstack.org/meetings/openstack-meeting/2012/openstack-meeting.2012-07-10-20.01.html
16:10:13 <nijaba> #link http://eavesdrop.openstack.org/meetings/openstack-meeting/2012/openstack-meeting.2012-07-10-20.01.log.html
16:10:14 <dhellmann> ^message^mailing list
16:10:14 <uvirtbot`> dhellmann: Error: "message^mailing" is not a valid command.
16:10:21 * dhellmann needs more caffeine
16:10:41 <nijaba> So I guess we are all a bit disappointed not to have been accepted right away, but on the bright side, we have not been pushed back either!
16:10:42 <nijaba> What's your feeling about this? What do yo think we should be doing to get in?
16:11:21 <dhellmann> we should address the specific feedback we did get
16:11:31 <flacoste> so it seems that the main question is whether metering is a core feature or not, right?
16:11:35 <dhellmann> I'm a little confused by the "out of scope" response from a few people
16:11:53 <dhellmann> we may need to drum up some support from the user community to combat that
16:11:56 <nijaba> Well, that's an ongoing discussion of the PPB
16:12:03 <nijaba> what is in and out of scope
16:12:09 <nijaba> it started with Horizon
16:12:26 <nijaba> I think that's the only think we cannot directly address
16:12:46 <nijaba> but we can provide better argumentation if any one has any ideas...
16:13:15 <nijaba> We've been asked to update the application to add a table showing the state of integration for each OpenStack project.  I guess I can assign myself to this, if there is no objections.
16:13:17 <jd___> it may be hard indeed
16:13:22 <flacoste> i think there were broad support to the idea that openstack core contains standard hooks for metering
16:13:27 <jd___> nijaba: sounds great!
16:13:32 <flacoste> so that everyone doesn't ahve to reinvent those
16:13:53 <nijaba> #action nijaba to add a table showing the state of integration for each OpenStack project
16:14:23 <nijaba> flacoste: in fact, I think we have more supporters than detractors, if I counted well
16:14:33 <dhellmann> we should also adjust the proposal to reflect a longer incubation period -- they were right that folsom is half over
16:14:40 <flacoste> yep
16:14:58 <nijaba> dhellmann: yes, that's a clear todo
16:15:09 <nijaba> me again?
16:15:24 <dhellmann> you'll be working on it anyway… :-)
16:15:45 <nijaba> #action nijaba to adjust the proposal to reflect a longer incubation period
16:15:55 <nijaba> Another suggestion was to get feedback fromt he potential consumers on the approach, API, etc.  Should we start a poll?
16:16:54 <dhellmann> a poll might be interesting. I was thinking of asking for feedback on the mailing list to make some "noise" about the project from that perspective
16:17:10 <nijaba> that's a form of a free poll
16:17:15 <dhellmann> ture
16:17:18 <dhellmann> ugh
16:17:18 <jd___> as usual, people will wake up when the project will start working for real and be a bit usable
16:17:18 <dhellmann> true
16:17:20 <jd___> :)
16:17:30 <dhellmann> jd___: good poitn
16:17:34 <nijaba> It was also suggested that incubation should be granted *after* the project is fully operational
16:18:00 <nijaba> so may do the poll once we have something complete?
16:18:06 <dhellmann> That seemed odd to me, but I'm prepared to wait.
16:18:10 <jd___> polling can't hurt anyway, but I don't think that'll change, we need more code I guess
16:18:11 <nijaba> shooting for early sept?
16:18:18 <dhellmann> I would like to get some feedback now about the sorts of meters users want
16:18:26 <jd___> nijaba: something like that yeah
16:18:27 <dhellmann> we can wait to ask about the api until we have a proof-of-concept
16:18:46 <nijaba> dhellmann: +1 to ask feeback on counter list
16:18:48 <dhellmann> sept makes sense
16:18:50 <jd___> dhellmann: we can, but I think we already know the meters everybody wants
16:19:04 <jd___> but that doesn't hurt :)
16:19:17 <nijaba> dhellmann: do you want to take that action?
16:19:26 <dhellmann> jd___: we know what the people involved in the early discussions want :-)
16:19:32 <DanD> sorry if you have already done this, have not been able to catch back up. but maybe splitting into chunks would be more appealing. certainly instrumentation of services is core
16:19:32 <dhellmann> nijaba: sure
16:19:57 <nijaba> #action dhellmann to get some feedback now about the sorts of meters users want from the mailing list
16:20:09 <gmb> I've updated http://wiki.openstack.org/EfficientMetering/RoadMap to reflect the longer incubation period.
16:20:13 <jd___> dhellmann: yep, but if only we already had what we want, I'd be happier to ask for even more ideas/wanting from other, but for now… :)
16:20:19 <nijaba> Also, we were suggested to get with dtroyer on getting devstack to set up ceilometer so folks can more easily play around with it.
16:20:25 <nijaba> thanks gmb
16:20:33 <DanD> most provides are probably already invested in a billing solution. but all will suffer if the core OpenStack services are not instrumented properly
16:20:39 <jd___> devstack is a good idea
16:20:42 <dhellmann> jd___: we can ask for priorities.
16:21:03 <dhellmann> nijaba: I can work on the devstack integration
16:21:07 <dhellmann> I'll open a bug
16:21:17 <nijaba> coolio
16:21:29 <jd___> dhellmann: sure, but I've the feeling that it's so "basic" what we decided to implement that it doesn't help to have priorities; but anyway, i'm really not against anything here, just saying my feelings ;)
16:21:39 <nijaba> #action dhellmann to open a bug and work on devstack integration
16:21:56 <jd___> thanks dhellmann for devstack, I think that'll help
16:22:05 <nijaba> anything else?
16:22:22 <dhellmann> jd___: sure, that makes sense. One of the bits of feedback was an apparent lack of input from users (or at least wanting more), so I'm trying to look for ways to address that.
16:22:58 <nijaba> which is weird, since I spent 3 months on this, but I guess I was not doing this publicly..
16:23:22 <jd___> dhellmann: Oh, I didn't know that. Well, that's easy to address then… :-)
16:23:33 <jd___> nijaba: hehe
16:23:51 <jd___> so this feedback is not good, but we can't blame them, so let's fix it ;)
16:23:53 <dhellmann> nijaba: I think it's a matter of volume on the mailing list, and some people not paying attention early on. We did a lot of talking early, then went "heads down" to build something for a stretch of time
16:24:12 <nijaba> dhellmann: true...
16:24:27 <dhellmann> we also had more people involved in meetings early on, and we should go back to the logs and include some of those names in the proposal
16:24:32 <nijaba> dhellmann: but I think we are the first OpenStack project to start from an almost blank page
16:24:50 <nijaba> perhaps excepting glance
16:24:53 <jd___> keystone maybe?
16:25:04 <nijaba> nope, their was prior art in java
16:25:12 <nijaba> s/heir/there
16:25:29 <nijaba> anyway, let's make them happy and ask for feedback!
16:25:34 <dhellmann> exactly
16:25:39 <nijaba> and we have some clear actions defined for that!
16:25:49 <nijaba> thanks dhellmann
16:26:17 <nijaba> any other comments?
16:26:24 <jd___> nop
16:26:31 <dhellmann> no
16:26:42 <DanD> since I am one of the ones that was attempting to participate but got caught up in internal stuff. I would suggest some kind of review of requirements and design
16:26:42 <nijaba> #topic Open Discusssion
16:26:51 <heckj> nijaba: I have an API related request...
16:26:57 <heckj> (snuck in)
16:27:08 <nijaba> DanD: that wouudl be good indeed
16:27:16 <nijaba> heckj: please shoot
16:27:30 <heckj> As you get into the implementation for the API, I'd love to see a resource description of what's getting returned and its format.
16:27:34 <nijaba> DanD: how would you see that happen?
16:28:10 <heckj> dolphm and I were talking about some of how we're doing the keystone API, and one of the things we were wrangling was how anal to be able asserting content-type's for returned resources that weren't predefined.
16:28:10 <nijaba> heckj: for sure, but bad idea to do it before we implement
16:28:14 <dhellmann> heckj: do you mean describing the json format of the response, or the contents of the json?
16:28:15 <jd___> I've opened #1023969 for the counter type stuff FYI
16:28:29 <dhellmann> jd___: thanks
16:28:29 <DanD> good question. maybe a conference call with a diagram or two?
16:28:48 <heckj> nijaba: no argument there. For the keystone draft API, I took a stab in the documentation that was meant to inform the impl, but have left the "spec" open to not constrain it.
16:28:49 <DanD> something that could be the basis for a presentation at the OpenStack meeting in October
16:28:53 <nijaba> DanD: we could set that up
16:29:06 <DanD> that might be a good time to get better support
16:29:13 <heckj> (https://docs.google.com/document/d/1VP-bTBbwsn6q-rDzuS9CEKb2ubE1VjbWRFd4BkkjoOY/edit if you're curious)
16:29:36 <nijaba> heckj: then I guess we should take this as guidelines for implementation/documentation
16:29:41 <nijaba> thanks heckj
16:30:02 <dhellmann> heckj: yes, thanks for the link
16:30:14 <heckj> np - glance has done the same - I riffed off their work. Google docs has been OK for the publish/review process, but not awesome
16:30:16 <dhellmann> when we get to the implementation we can use that as a template for a design doc
16:30:22 <nijaba> DanD: +1 on you proposal.  Anyone else care to comment on this proposal?
16:30:41 <dhellmann> DanD: do you mean a diagram of the architecture?
16:30:49 <DanD> yes
16:31:00 <dhellmann> that makes sense. we should have something like that in our docs anyway
16:31:23 <dhellmann> I can do the diagram
16:31:40 <nijaba> I would be happy to setup something for the first week of august. Google event on air maybe?
16:31:56 <DanD> with some emphasis on the impact to the metered systems. haven't looked at the feedback, but I suspect some pushback by other teams is that they are concerned about what it will do to and cost them. certainly is an internal issue for us
16:32:23 <nijaba> DanD: surprisingly not much pushback in that way at all
16:32:51 <heckj> nijaba: another unrelated suggestion - get a blog post up walking through a metering setup and showing results. It'll drive interest hugely when you're at the point to show it off
16:32:52 <dhellmann> DanD: some of that still needs to be measured, but we tried to design for low impact
16:33:12 <nijaba> Most people are happy when we tell them you can turn off counters
16:33:18 <dhellmann> heckj: yeah, we need the API server before we can show anything :-/
16:33:33 <nijaba> dhellmann: another great suggestion for early sept
16:33:49 <dhellmann> nijaba: true
16:33:52 * nijaba winks at gmb and his recruitment process
16:34:07 <gmb> :)
16:34:07 <dhellmann> maybe we can work it into the docs as a how-to and then link to it on a blog so it shows up on planet.openstack
16:34:54 <nijaba> nice idea indeed
16:35:12 <nijaba> dhellmann: want more actions? ;)
16:35:35 <dhellmann> #action dhellmann create a diagram of ceilometer architecture
16:35:42 <nijaba> \o/
16:36:02 <dhellmann> #action dhellmann write a walk-through of setting up ceilometer and collecting data
16:36:15 <nijaba> \o/x2
16:36:40 <nijaba> so, slightly boring, but  I am going to be off for the next couple weeks.  Any volunteers to handle the next 2 meetings?
16:36:56 <dhellmann> I'm off next week, but can take the week after
16:37:24 <jd___> I'll do
16:37:42 <nijaba> cool!
16:37:57 <nijaba> so jd___ next week, dhellmann the week after!
16:38:27 <jd___> yup :)
16:38:31 <nijaba> anything else?
16:38:57 <flacoste> i'll be unavailable for the next 3 meetings
16:39:10 <dhellmann> I'm starting to look at the classes we'll need to use to set up the API service. one of my co-workers is also interested in those for some quantum work he's doing.
16:39:43 <nijaba> flacoste: please add yourself to the apologies on the meeting agenda wiki page
16:39:49 * nijaba will do the same
16:39:50 <flacoste> nijaba: i will
16:39:59 <nijaba> thanks
16:40:44 <nijaba> flacoste, gmb: any experience with API setup in python?
16:40:54 <nijaba> REST API that is
16:40:57 <flacoste> a lot
16:41:03 <gmb> Hah, yes.
16:41:09 <flacoste> we even wrote a REST framework back in the days
16:41:10 <dhellmann> nijaba, I'm specifically looking at the classes already being used by the other openstack services
16:41:12 <nijaba> any pointers for dhellmann?
16:41:33 <flacoste> for django, tastypie is nice
16:41:35 <dhellmann> we are contemplating moving some more code into common
16:41:48 <nijaba> dhellmann: yep, I tried to look at cinder for that same reason...  Failed to complete my analysis...
16:42:08 <flacoste> but if we are looking for integration with -common
16:42:16 <flacoste> we should look at what the other projects are using
16:42:24 <jd___> +1
16:42:42 <flacoste> although this means that openstack might end up with a nih solution
16:42:47 <dhellmann> at this point the nova code for services is a little messy, but we might be able to extract a base class that would be compatible
16:43:00 <dhellmann> I'm going to look at some of the other services next to see if they are any cleaner
16:43:28 <nijaba> that could be worth another -common thread on the ML
16:43:47 <nijaba> but would suggest to wait til monday that the -dev ml is active
16:44:07 <dhellmann> flacoste: if the existing solutions are all too ugly, we should talk about other options
16:44:12 <nijaba> hope everyone subscribed to openstack-dev
16:44:18 <dhellmann> yes
16:44:42 * nijaba thanks oubiwann for his work on that
16:45:10 <dhellmann> oubiwann says "oh, cool!"
16:46:23 <nijaba> ok, looks like we ran out of topic...
16:46:46 <jd___> so sad :)
16:46:55 <dhellmann> time for lunch!
16:46:57 <nijaba> thanks everyone! great meeting, as always
16:47:06 <jd___> thanks
16:47:09 <jd___> bon appétit dhellmann !
16:47:11 <nijaba> I'll be back tanned and rested in a couple weeks :P
16:47:11 <dhellmann> thanks everyone!
16:47:19 <jd___> heh
16:47:27 <nijaba> #endmeeting