16:00:13 <nijaba> #startmeeting
16:00:13 <openstack> Meeting started Thu Jul  5 16:00:13 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:13 <nijaba> #meetingtopic Ceilometer
16:00:13 <nijaba> #chair nijaba
16:00:13 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
16:00:13 <nijaba> #info jd__ will unfortunately not be able to join us this week
16:00:14 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
16:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:16 <nijaba> o/
16:00:17 <openstack> Current chairs: nijaba
16:00:24 <jd___> o/
16:00:26 <dhellmann> o/
16:00:39 <nijaba> jd___: I thought you could not join?
16:00:46 <nijaba> nice to see you!
16:00:50 <jd___> for now I can, I may leave early
16:00:56 <nijaba> flacoste: around?
16:01:03 <flacoste> i am
16:01:08 <flacoste> o/
16:01:17 <nijaba> ok, great!, let's start!
16:01:27 <nijaba> #topic actions from previous meetings
16:01:27 <nijaba> I don't see any action from the last meeting.  Did I miss anything?
16:01:45 <dhellmann> IIRC the only thing that carried over was the discussion of the incubation proposal
16:01:49 <flacoste> yep
16:02:00 <nijaba> ok, we have that as a topic for today
16:02:03 <dhellmann> well, that and "keep working on the code" :-)
16:02:17 <nijaba> hehe
16:02:19 <nijaba> #topic Discuss and vote the incubation application proposal to be submitted to PPB
16:02:19 <nijaba> #link  http://wiki.openstack.org/Projects/IncubatorApplicationCeilometer
16:02:19 <nijaba> Any remarks before we vote on this?
16:02:57 <dhellmann> I think it looks good, but do we have examples of the proposals other projects have put up (especially successful proposals)?
16:03:08 <jd___> looks good to me
16:03:14 <nijaba> dhellmann: I don't think there has been any...
16:03:26 <dhellmann> ceilometer: breaking new ground, yet again
16:03:42 <nijaba> shall we vote then?
16:03:47 <dhellmann> yes
16:03:52 <nijaba> #startvote Submit the incubation application to the PPB? Yes, No
16:03:52 <nijaba> Please note that to register a vote you have to use #vote yes or #vote no
16:03:53 <openstack> Begin voting on: Submit the incubation application to the PPB? Valid vote options are Yes, No.
16:03:55 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:04:02 <nijaba> #vote yes
16:04:03 <dhellmann> #vote yes
16:04:04 <openstack> nijaba: yes is not a valid option. Valid options are Yes, No.
16:04:05 <openstack> dhellmann: yes is not a valid option. Valid options are Yes, No.
16:04:11 <dhellmann> hahaha
16:04:14 <dhellmann> #vote Yes
16:04:15 <nijaba> #vote Yes
16:04:21 <jd___> #vote yes
16:04:22 <openstack> jd___: yes is not a valid option. Valid options are Yes, No.
16:04:31 <nijaba> amazing these little tools... so picky ;)
16:04:32 <jd___> #vote Yes
16:04:38 <jd___> yeah yeah c'mon openstack!
16:04:46 <flacoste> #vote yes
16:04:47 <openstack> flacoste: yes is not a valid option. Valid options are Yes, No.
16:04:52 <flacoste> ffs
16:04:54 <flacoste> #vote Yes
16:05:03 * dhellmann lol
16:05:11 <nijaba> ok, that's a wrap for the vote
16:05:14 <nijaba> #endvote
16:05:15 <openstack> Voted on "Submit the incubation application to the PPB?" Results are
16:05:16 <openstack> Yes (4): nijaba, dhellmann, jd___, flacoste
16:05:36 <nijaba> So, I'll send a very formal email for our application ASAP
16:05:45 <flacoste> thx!
16:05:48 <nijaba> #action nijaba to send an email to the PPB
16:06:07 <nijaba> #topic PTL election process discussion
16:06:08 <nijaba> When we had our first project meeting on April 26th, it was agreed that Loic Dachary and I would co-lead this project for the first 3 months. Time is soon up for those 3 months, so we should discuss what to do to.
16:06:11 <dhellmann> nijaba, is that a publicly readable mailing list?
16:06:22 <nijaba> it is, yes
16:06:29 <nijaba> the archives are
16:06:35 <nijaba> #link  http://wiki.openstack.org/Governance/Model#Governance%20for%20the%20Individual%20OpenStack%20Projects
16:06:35 <nijaba> #link http://www.cs.cornell.edu/andru/civs.html
16:06:35 <nijaba> #link http://www.opavote.org/
16:06:35 <nijaba> #link http://wiki.openstack.org/Governance/Foundation/TechnicalCommittee
16:06:35 <nijaba> I propose that we:
16:06:36 <nijaba> 1/ Make a call for candidate next week, asking for applicants to do so on the general mailing list
16:06:39 <nijaba> 2/ Open a one week voting period from July 26th til Aug 2nd
16:06:41 <nijaba> 3/ Use the opavote voting as  it is less likely to produce ex-aequo
16:06:43 <nijaba> 4/ Limit voters and candidates to people that have contributed either to the code or to the wiki pages for ceilometer prior to the call for candidates
16:06:45 <nijaba> Comments? Remarks? Suggestions?
16:07:04 * jd___ checks opavote
16:07:41 <dhellmann> the voting limits seem appropriate. do you already have a list of who those people are?
16:07:46 * nijaba waits a couple minutes for people to digest
16:07:54 <nijaba> dhellmann: nope
16:08:07 <flacoste> nijaba: sounds good to me
16:08:10 <nijaba> but it would not be too hard to compile
16:08:10 <jd___> not that many I guess
16:08:31 <jd___> what's the voting system for other PTL elections?
16:08:50 <nijaba> they were using civs, but are about to switch to opa
16:09:04 <jd___> ok, that seems fine anyway :)
16:10:01 <nijaba> looks like we have a general agreement then?  Should we formally vote on this?
16:10:25 <jd___> yes and if you want yes
16:10:27 <jd___> :)
16:10:39 <dhellmann> yes
16:11:19 <nijaba> #startvote go ahead with the proposed PTL election process? Yes, No
16:11:20 <openstack> Begin voting on: go ahead with the proposed PTL election process? Valid vote options are Yes, No.
16:11:21 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:11:28 <dhellmann> #vote Yes
16:11:28 <nijaba> #vote Yes
16:11:39 <jd___> #vote Yes
16:11:57 <flacoste> #vote Yes
16:12:04 <nijaba> #endvote
16:12:05 <openstack> Voted on "go ahead with the proposed PTL election process?" Results are
16:12:06 <openstack> Yes (4): nijaba, dhellmann, jd___, flacoste
16:12:22 <nijaba> cool.  Do you want me to take the call for candidate action?
16:12:52 <nijaba> however, I'll be off until the 28th, so someone else will need to do the opa setup
16:12:56 <nijaba> volunteers?
16:13:08 <jd___> I probably can do this
16:13:14 <nijaba> thanks jd___
16:13:43 <nijaba> #action nijaba to send call for candidate to the general mailing list
16:14:15 <nijaba> #action jd___ to setup opa voting system to start on 26th and end on Aug 3rd
16:14:28 <nijaba> ok, moving on
16:14:36 <nijaba> #topic Discuss project's next priorities
16:14:36 <nijaba> This topic was suggested by dhellmann, so I let him drive it
16:14:54 <dhellmann> Thanks, nijaba.
16:15:25 <dhellmann> It seems to me like we've reached another milestone now that we can actually store data. There are a couple of different directions we can go from here, either one at a time or in parallel.
16:15:51 <dhellmann> There are still quite a few plugins to write, and code to integrate with other projects (especially for notifications, but also for polling).
16:16:07 <dhellmann> We need to build the API server.
16:16:12 <nijaba> I think we may need additional agents too?
16:16:30 <dhellmann> yes, good point, we may need other agents depending on where the plugins need to run
16:16:50 <dhellmann> we need at least one more for polling services through their REST APIs
16:17:08 <dhellmann> we may also want to implement another db backend to ensure that the plugin layer API is not mongodb-specific
16:17:29 <nijaba> I think we need to list these items on a roadmap wiki page, linking to bugs, that people can assign themselves to...
16:17:40 <jd___> nijaba: +1
16:17:48 <dhellmann> good idea
16:17:53 <flacoste> indeed
16:17:53 <nijaba> and then publicise it to try to recruit new coders
16:18:17 <nijaba> that was the idea behing documenting how to write pludgins
16:18:23 <dhellmann> I would like to finish writing some more dev docs before we try to recruit too many more contributors -- I am doing that today and hope to have a patch ready for review tomorrow
16:18:33 <nijaba> sounds great
16:19:00 <nijaba> Should we start a general action to have a ceilometer/roadmap page populated?
16:19:09 <dhellmann> +1
16:19:10 <nijaba> I can prime it
16:19:12 <flacoste> yes
16:19:30 <dhellmann> does anyone have any strong opinion about what we should make our next priority?
16:19:46 <nijaba> #action nijaba to prime a roadmap page and invite others to populate it
16:20:09 <dhellmann> I would like to have the data going end-to-end (agent -> collector -> db -> api -> consumer) soon
16:20:18 <flacoste> yeah
16:20:18 <nijaba> dhellmann: I'd think swift, but that will not match what YOU will want ;)
16:20:18 <jd___> probably the API server
16:20:25 <flacoste> i think the api server is probably the missing piece there
16:20:53 <jd___> and implement the meter type as we discussed several time I think it's still missing
16:20:58 <dhellmann> nijaba, we'll get swift done, don't worry :-)
16:21:17 <dhellmann> jd___ there's a field in the meter messages for "type" but nothing actually uses it right now
16:21:24 <nijaba> dhellmann: leave something for flacoste's team when it get there :)
16:21:35 <jd___> dhellmann: yeah, I should really tackle this down instead of talking about it
16:21:43 <flacoste> nijaba: it's getting there :-)
16:21:50 <nijaba> jd___: feel free to assign an action to yourself ;)
16:21:51 <dhellmann> nijaba, if flacoste wants to work on swift we can wait
16:22:13 <jd___> #action jd___ handle counter/meter type for real
16:22:17 <nijaba> dhellmann: I suspect you will want to do someting with some other tech ;)
16:23:12 <dhellmann> nijaba, yeah, I think ceph already has some monitoring in place, but that's up to another team to handle for now. :-)
16:23:21 <nijaba> k
16:23:35 <nijaba> ok, should we move on?
16:23:58 <dhellmann> yes, I'm done and it sounds like we have a good plan for working out what to do next
16:24:05 <nijaba> #topic Open Discusssion
16:24:16 <nijaba> I have one: External API. Based on the mailing list discussion
16:24:16 <nijaba> #link http://openstack.markmail.org/thread/fwkagzdzpleeclj5
16:24:16 <nijaba> I believe we reached an agreement on the purpose and limitations of the API, but wanted to make sure we were...
16:24:47 <flacoste> nijaba: i really appreciated your clarification email
16:24:50 <jd___> I think so, for now at least :)
16:24:53 <flacoste> and agree with it
16:25:02 <nijaba> flacoste: thanks :)
16:25:33 <dhellmann> yes, nijaba, thank you for that!
16:25:44 <nijaba> I am assigning myself a documentation task for the API with a clear warning about the limitation of the sum and duration function
16:25:55 <nijaba> #action nijaba to document external API use with a clear warning about the limitation of the sum and duration function
16:26:29 <nijaba> well, actually, I will start a doc, which will have to wait for completion hat we have something coded :)
16:27:00 <nijaba> does anyone want want to bring something else?
16:27:13 * dhellmann shakes head no
16:27:22 <nijaba> sounds like a wrap...
16:27:25 <nijaba> 5
16:27:28 <nijaba> 4
16:27:31 <nijaba> 3
16:27:34 <nijaba> 2
16:27:36 <nijaba> 1
16:27:40 <nijaba> #endmeeting