21:02:35 <ttx> #startmeeting
21:02:36 <openstack> Meeting started Tue Jun 19 21:02:35 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:47 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:03 <ttx> vishy: run
21:03:09 <ttx> #info Only 2 weeks left until the milestone-proposed cut for Folsom-2 (July 3)
21:03:37 <ttx> #topic Actions from previous meeting
21:03:42 <ttx> * chmouel to post about python-swiftclient separation to the ML: DONE
21:03:50 <ttx> * chmouel to discuss with CI on enabling swift in devstack-gate
21:04:00 <notmyname> ttx: chmouel asked me to comment. he's not here
21:04:00 <ttx> I think I just saw notmyname discussing it in a previous meeting ?
21:04:20 <notmyname> that hasn't been done, but I discussed it briefly with the ci team in their meeting today
21:04:39 <notmyname> so there is a little more to talk about, but the conversation is definitely started
21:04:45 <notmyname> I can take it as an action item
21:05:00 <ttx> #action notmyname to pursue discussion on enabling swift in devstack-gate
21:05:08 <ttx> * jgriffith to update the ML with Cinder progress
21:05:18 <ttx> I don't think I've seen that
21:05:37 <ttx> let's carry over
21:05:45 <ttx> #action jgriffith to update the ML with Cinder progress
21:05:52 <ttx> * ttx to clarify Horizon 2012.1.1 release process and fix CI to match
21:06:14 <jgriffith> ttx: email sent out to cinder core and select others with no feedback
21:06:27 <ttx> markmc took the lead on that, we now have proposed 2012.1.1 tarballs for all projects that use such versioning, based on current stable/essex branches.
21:06:35 <ttx> jgriffith: could you send it to the general ML ?
21:06:36 <anotherjesse> jgriffith: you might want to cc openstack
21:06:46 <heckj> please
21:06:51 <ttx> #help Please test proposed 2012.1.1 deliverables: https://lists.launchpad.net/openstack/msg13251.html
21:06:55 <jgriffith> Yeah, I can do that, but it's awkward right now anyway because everything is in Draft
21:06:59 <jgriffith> Nobody can pull it
21:07:14 <jgriffith> But yes, after this meeting I'll send an updated to ML
21:07:17 <ttx> jgriffith: thx
21:07:21 <heckj> ty
21:07:31 <ttx> #topic bp-issues script
21:07:44 <ttx> #info I finally took the time to write a tool to single out generic issues with blueprints
21:08:10 <ttx> heckj, notmyname, bcwaldon, vishy, ohnoimdead, danwent: You can use it to find issues about your plan and fix them before I ask you to do so in the meeting
21:08:16 <ttx> Think of it as a pythonized version of me.
21:08:22 <bcwaldon> ttx: excellent
21:08:23 <ttx> #link https://github.com/ttx/bp-issues
21:08:26 <danwent> import ttx
21:08:27 <heckj> sounds nice
21:08:30 <bcwaldon> ttx: please call it ttx.py
21:08:36 <ttx> It catches unassigned/unprioritized stuff, things that are missing from series goals, bad dependency prioritization, etc.
21:08:38 <heckj> yeah ^^
21:08:49 <ttx> #action ttx to rename script to ttx.py
21:08:50 <bcwaldon> ttx: or thierrorize.py
21:09:17 <ttx> It's still a bit early so probably will have a few false negatives
21:09:30 <ttx> and will be updated to catch more stuff as you get better :)
21:09:42 <ttx> #topic Keystone status
21:09:53 <ttx> heckj: hello again :)
21:10:00 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-2
21:10:03 <heckj> ola!
21:10:15 <ttx> Looks good, just a couple of questions:
21:10:23 <ttx> * https://blueprints.launchpad.net/keystone/+spec/stop-ids-in-uris (Guang Yee)
21:10:34 <ttx> You said last week that is actually dependent on implement-v3-core-api...
21:10:42 <ttx> Does it make sense to track it as a separate objective ?
21:10:52 <ttx> Should it depend on (or be depended on by) implement-v3-core-api ?
21:10:53 <heckj> yep - meant to shift it back/merge it, didn't get that done
21:11:07 <heckj> it depends on implement-v3-core-api
21:11:25 <ttx> #action heckj to repurpose stop-ids-in-uris wrt implement-v3-core-api
21:11:33 <ttx> ok, thx
21:11:34 <heckj> yep
21:11:36 <ttx> * https://blueprints.launchpad.net/keystone/+spec/rbac-keystone (dolphm)
21:11:51 <ttx> You mentioned last week that this is also depending on implement-v3-core-api and would likely be split ?
21:12:18 <ttx> split between... a pre-v3 and a post-v3 thing ?
21:13:02 <heckj> have the split blueprints related to V3 & RBAC up, but not fully assigned to people, milestones, etc
21:13:11 <heckj> some of that just nailed down this morning in the keystone meeting
21:13:31 <ttx> OK, that might explain the following...
21:13:36 <ttx> ttx.py picked up the following issue:
21:13:46 <ttx> https://blueprints.launchpad.net/keystone/+spec/rbac-keystone-api
21:13:46 <ttx> * Not in series goal while targeted to a series milestone
21:13:55 <heckj> yeah, that's it exactly.
21:14:03 <ttx> kewl, will let you fix
21:14:13 <ttx> heckj: anything else ?
21:14:33 <heckj> fix in now - nope- questions?
21:14:38 <ttx> How is v3-api feedback/implementation going ? Any cut date on the feedback ?
21:15:08 <bcwaldon> heckj: I've kept the images api v2 spec open through development - I would suggest you do the same
21:15:09 <heckj> excellent feedback - have some ML responses to make. Hoping to nail down consensus sufficient to begin implementation in another 5-10 days
21:15:23 <heckj> bcwaldon: damned good idea
21:15:34 <bcwaldon> heckj: once you start implementing it, you find some pretty dumb stuff
21:15:45 <heckj> totally believe it
21:15:52 <ttx> heckj: so you could start implementing it right now !
21:16:06 <ttx> (let's see if that trap works)
21:16:14 <heckj> ttx: patches welcome!
21:16:30 <gabrielhurley> heckj: I noticed the term "tenant" was still in the v3 API draft... so it's not changing to "project"? /troll
21:16:31 <ttx> touch�
21:17:11 <ttx> ready to switch to swift?
21:17:20 <heckj> would you all tar and feather me if I changed it all RIGHT NOW!?!?
21:17:40 <heckj> s/tenant/project/g
21:17:42 <ttx> #topic Swift status
21:17:48 <ttx> notmyname: yo
21:17:51 <notmyname> hi
21:17:53 <ttx> Next version should be 1.5.1, do you have any plans already ?
21:18:10 <notmyname> I've been out this past week and just catching up today. no plans yet. I
21:18:14 <ttx> We know it will include the swiftclient split and an important bugfix...
21:18:15 <notmyname> miskey
21:18:24 <notmyname> I'll work on that this week
21:18:26 <notmyname> yes
21:18:35 <notmyname> I'll work on setting a date this week
21:18:56 <ttx> notmyname: bp-issues picked up two Essential specs listed in your Folsom plans, without any milestone yet:
21:19:03 <ttx> * https://blueprints.launchpad.net/swift/+spec/extract-client-lib
21:19:04 <ttx> * https://blueprints.launchpad.net/swift/+spec/keystone-middleware
21:19:15 <ttx> Should those both be targeted to 1.5.1 ?
21:19:20 <notmyname> the first will be in 1.5.1 (we just talked about it)
21:19:30 <notmyname> the 2nd I'm not sure yet
21:19:40 <ttx> ok, targeting the first one
21:19:51 <ttx> notmyname: Anything else ?
21:20:02 <notmyname> chmouel said he was going to pick it up, but no work has been done yet
21:20:15 <notmyname> no, nothing else right now. questions?
21:20:18 <bcwaldon> notmyname: isnt there already a python-swiftclient?
21:20:45 <notmyname> bcwaldon: the separation hasn't landed in a release yet
21:21:03 <bcwaldon> notmyname: so python-swiftclient is the product of extract-client-lib?
21:21:11 <notmyname> correct
21:21:13 <bcwaldon> ok
21:21:20 <bcwaldon> i am pleased
21:22:02 <ttx> #topic Glance status
21:22:23 <ttx> bcwaldon: hello
21:22:28 <ttx> #link https://launchpad.net/glance/+milestone/folsom-2
21:22:29 <bcwaldon> ttx: why hello there
21:22:41 * ttx refreshes to avoid last-minute tricks
21:22:48 <heckj> heh
21:22:49 <bcwaldon> ttx: I only changed one bug on you this time
21:22:52 <ttx> bcwaldon: So far, looks like you're still on your way to complete api-2 in folsom-2 ?
21:23:00 <bcwaldon> ttx: doubt it
21:23:16 <bcwaldon> ttx: I'm more comfortable with f-3 for all of api-2
21:23:28 <ttx> Oh ? Which part might not make it ?
21:23:38 <ttx> api-v2-store-access ?
21:23:47 <bcwaldon> ttx: possibly
21:23:59 <bcwaldon> ttx: theres been a lot of refactoring going on recently
21:24:08 <ttx> Was wondering if api-v2-images-pagination and api-v2-images-sorting were actually not implemented yet.
21:24:13 <bcwaldon> ttx: I think we're at a place that we can make measurable progress again, but with only 2 weeks left, i'm not 100% confident
21:24:22 <markwash> ttx: they are
21:24:28 <bcwaldon> ttx: yes, markwash speaks the truth
21:24:43 <bcwaldon> ttx: some of the work we're doing could fit under a few different bps
21:24:49 <ttx> markwash: awesome! set "implementation status" to implemented please
21:24:52 <bcwaldon> ttx: like pagination-related links
21:25:10 <markwash> ttx: sure, sorry I missed that
21:25:29 <bcwaldon> ttx: the tenant-specific swift container storage may slip to f3
21:25:41 <bcwaldon> ttx: its not as important as previously thought
21:25:46 <bcwaldon> ttx: and it hasnt been started, afaik
21:25:50 <ttx> bcwaldon: right
21:26:01 <ttx> bcwaldon: bp-issues just picked up the following issue for you:
21:26:06 <bcwaldon> ttx: a lot should land in the next 7 days, though
21:26:07 <ttx> * https://blueprints.launchpad.net/glance/+spec/kill-registry-server : Targeted to a milestone but has no assignee and unknown status
21:26:19 <markwash> ttx: actually gonna wait until we get the next and first links finished before. . sorry, don't know where my head is
21:26:22 <markwash> bcwaldon: ^^
21:26:32 <bcwaldon> markwash: ok, sorting is done, right?
21:26:41 <markwash> nod
21:26:49 <bcwaldon> ttx: we could argue about it, or just leave it
21:26:56 <ttx> markwash: ack. matybe just add a comment on the whiteboard for the one that is still pending
21:27:59 <ttx> bcwaldon: let's argue about it another day. I did my share of arguing today
21:28:03 <ttx> bcwaldon: Anything else you wanted to mention ?
21:28:15 <bcwaldon> ttx: no sir
21:28:20 <ttx> Questions on Glance ?
21:28:59 <ttx> #topic Quantum status
21:28:59 <markwash> is anybody else here feeling like a stakeholder in v2?
21:29:04 <ttx> oops
21:29:12 <markwash> feels like we're just in a room by ourselves, which is fine too :-)
21:29:28 * ttx lets 20 second for a stakeholder to show up
21:29:34 <markwash> :-)
21:29:49 <ttx> danwent: hey
21:29:53 <danwent> hello
21:29:55 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-2
21:30:03 <bcwaldon> markwash: shh, don't let anyone find out we're changing things!
21:30:08 <danwent> latency should be good b/c we're both in france
21:30:19 <ttx> heh... Still very busy, looks like you should start postponing stuff that will obviously miss the bus, if any
21:30:31 <ttx> Would like to review the essential stuff:
21:30:36 <danwent> already have postponed several things.
21:30:46 <ttx> https://blueprints.launchpad.net/quantum/+spec/improved-nova-quantum-integration
21:30:58 <ttx> You mentioned potentially dropping other stuff to get this completed... how is it going so far ?
21:31:17 <danwent> so Trey will again have cycles to work on this.  Yesterday we also pulled in yong to work on it as well.
21:31:29 <danwent> still may main concern, though tr3buchet expressed confidence
21:31:44 <ttx> https://blueprints.launchpad.net/quantum/+spec/quantum-dhcp: still on track ?
21:31:57 <danwent> this was the thing that was really off-track last time.
21:32:23 <ttx> ah? misunderstood then
21:32:38 <danwent> we now have a design together and the developer making progress, which is a big improvement.  my personal opinion is that the scope of the design is too much work, but he's prioritizing the basic case first, so I think we'll be ok.
21:32:49 <danwent> too much work for F-2 that is.
21:33:14 <ttx> ok, we'll see next week how it goes
21:33:28 <ttx> https://blueprints.launchpad.net/quantum/+spec/new-cli: looks almost there ?
21:33:32 <danwent> indeed.  i've asked for everything to be in for an initial review next week.
21:33:45 <danwent> ttx: yes, very close.  i'm doing some final testing on it.
21:33:58 <ttx> great.
21:34:00 <danwent> we'll probably merge the main branch tomorrow, with any outstanding issues being filed as additional bugs
21:34:00 <ttx> danwent: Anything else ?
21:34:13 <danwent> still a ton to do, but really happy with progress the team is making
21:34:35 <danwent> commits and reviews are way up in the past month or so…. i should put a graph together
21:35:00 * ttx senses a blogpost coming
21:35:03 <ttx> Questions on Quantum ?
21:35:23 <danwent> yes, but F-2 work before blogpost :)
21:35:43 <ttx> #topic Nova status
21:35:52 <ttx> vishy: how was that coffee ?
21:35:58 <vishy> not good
21:36:10 <vishy> ttx: I made it back in time, and the coffee did too
21:36:17 <ttx> vishy: come to my place. I bought an automatic espresso machine with grinder
21:36:21 <vishy> ttx: but it was not in the right location
21:36:33 <vishy> ttx: in the cup or in my tummy would have been the right location
21:36:44 <vishy> ttx: unfortunately it was on the ground and on my shirt
21:36:48 <vishy> == wrong location
21:36:55 <ttx> hmm. Suboptimal
21:36:55 <vishy> :|
21:37:00 <vishy> agreed
21:37:03 <ttx> #link https://launchpad.net/nova/+milestone/folsom-2
21:37:22 <ttx> Looks like we are a bit behind. Should probably start deferring stuff that we already know won't make it
21:37:29 <ttx> First let's review the status on the essential stuff:
21:37:38 <ttx> * https://blueprints.launchpad.net/nova/+spec/general-host-aggregates (jog0)
21:37:54 <ttx> jog0 mentioned last week that this was on track -- but maybe some parts might not land, so it could be split
21:38:10 <vishy> jog0: yes i was chatting today
21:38:23 <vishy> russellb: any progress on the no-db stuff?
21:38:26 <jog0> ttx:  after sorting out some details with vishy  earlier today the first part is on target.  Expect a patch set for review later this week
21:38:35 <ttx> jog0: cool
21:38:43 <ttx> * https://blueprints.launchpad.net/nova/+spec/finish-uuid-conversion (mikal)
21:38:51 <ttx> do we have news on that ?
21:39:13 <russellb> vishy: very litle ... been distracted by other things this cycle
21:39:26 <russellb> been looking this week though
21:39:47 <russellb> still some chance for folsom-2, but more likely folsom-3
21:39:54 <vishy> russellb: that is what I was thinking
21:40:05 <ttx> vishy: my understanding is that there is more coming to finish-uuid-conversion ?
21:41:03 <vishy> ttx: I think the prop in is the last
21:41:14 <ttx> ok
21:41:14 <ttx> * https://blueprints.launchpad.net/nova/+spec/volume-decoupling (vishy)
21:41:21 <ttx> My understanding is that Cinder can now fully be used, so this is complete ?
21:41:36 <ttx> (or not)
21:41:52 <vishy> ttx: well there are a few more things on the whiteboard, but those have their own blueprints in the other projects
21:42:10 <vishy> ttx: so I suppose we could just link those blueprints and mark it implemented?
21:42:15 <ttx> if nothing else needs to land in nova, should be implemented yes
21:42:26 <ttx> What's your plan for F2: keep both options and default to nova-volume ?
21:42:44 <vishy> and use this one: https://blueprints.launchpad.net/nova/+spec/extract-nova-volumes
21:42:57 <vishy> F2 keep both and default to nova-volume
21:42:57 <ttx> right
21:43:09 <vishy> F3 switch the default
21:43:12 <ttx> agreed
21:43:24 <ttx> (after the PPB declares Cinder core (or not))
21:43:33 <ttx> trusted-messaging (ewindisch) is also marked "not started", I suppose it's unlikely to hit F2 now ?
21:44:13 * russellb hasn't heard anything about itlately
21:44:32 <ttx> Finally I was wondering if those two were not already completed:
21:44:39 <ttx> * https://blueprints.launchpad.net/nova/+spec/zeromq-rpc-driver (ewindisch)
21:44:39 <ttx> * https://blueprints.launchpad.net/nova/+spec/lvm-disk-images (Boris Filippov)
21:44:49 <vishy> top one yes
21:44:53 <russellb> zero-mq-rpc-driver is complete
21:44:58 <ttx> ok, adjusting
21:45:05 <vishy> yes both implemented
21:45:26 <ttx> Wanted to discuss a bit about Nova bug triaging
21:45:34 <ttx> The BugTriage day had a good effect on cutting down the number of untriaged bugs, but the numbers are increasing again:
21:45:40 <ttx> http://webnumbr.com/untouched-nova-bugs
21:45:53 <ttx> vishy: how do you suggest we solve that ?
21:45:59 <ttx> Should we run BugTriage days more often ?
21:46:04 <ttx> Should we add BugTriaging to the ReviewDays tasks ?
21:46:11 <ttx> Should we just encourage more devs to do BugTriaging ?
21:46:18 <ttx> Should we recruit a team of triagers ?
21:46:26 <ttx> Should we write a thread on the ML about it ?
21:46:42 <vishy> ttx: yes
21:46:55 <vishy> we need more help triaging
21:46:56 <ttx> yes..to which ?
21:47:11 <vishy> thread to ml to recruit might be a good start
21:47:31 <ttx> vishy: should we open the Nova bug supervisor team to empower more people ?
21:47:56 <ttx> (I proposed to do it across the board but some smaller projects complained)
21:48:14 <jgriffith> ls
21:48:31 <ttx> vishy: ML thread : should I, should you ?
21:48:49 <vishy> lets try recruiting first
21:49:43 <ttx> vishy: you take the action to do the ML post or should I do it for you ?
21:50:04 <vishy> ttx: you can do it!
21:50:07 <ttx> vishy: Anything else ?
21:50:18 <ttx> #action ttx to raise a new thread about Nova bug triaging
21:50:33 <vishy> just tracking down some interesting racy network bug that seems to have crept in
21:50:41 <vishy> otherwise the stability has been pretty good
21:51:01 <vishy> especially considering the amount of changes that have gone in
21:51:18 <ttx> Indeed. Questions on Nova ?
21:52:20 <ttx> #topic Horizon status
21:52:28 <ttx> ohnoimdead: still around ?
21:52:32 <ohnoimdead> o/
21:52:36 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-2
21:52:46 <ttx> Nice progress overall, don't have any comments!
21:53:02 <ttx> Just one question about https://blueprints.launchpad.net/horizon/+spec/global-ajax-communication
21:53:16 <ttx> It's marked "Deferred": should we remove it from Folsom series / folsom-3 milestone ?
21:53:48 <ohnoimdead> yeah, probably. that one sort of turned into a rather large conversation
21:54:12 <ttx> ok, will un-folsom3-it as a start
21:54:15 <gabrielhurley> ohnoimdead, ttx: given what the quantum guys were saying earlier in the meeting, it sounds like https://blueprints.launchpad.net/horizon/+spec/readd-quantum-support may be in jeopardy.
21:54:39 <gabrielhurley> I guess that should also be directed at danwent
21:54:58 <ohnoimdead> ttx: sounds good
21:55:09 <danwent> gabrielhurley:  arvind was supposed to send me an update today
21:55:14 <danwent> but i haven't heard from him.
21:55:29 <danwent> we really narrowed the scope of what we're targeting for F-2, and arvind said he was comfortable with it.
21:55:40 <gabrielhurley> danwent: gotcha
21:55:42 <danwent> will ping him and include you all
21:55:43 <ttx> gabrielhurley: ok, when you get the answer from arvind you can set to "slow progress" or "blocked" with e acomment on the whiteboard
21:55:51 <ohnoimdead> gabrielhurley: we can kick to f-3 if necessary
21:56:06 <danwent> yes, we can
21:56:16 <ttx> gabrielhurley: (only keep it "good progress" if it's on track
21:56:17 <ttx> )
21:56:23 <gabrielhurley> ttx: duly noted
21:56:26 <ttx> ohnoimdead: Anything else ?
21:56:43 <ohnoimdead> nope, i think we are looking good. we got a couple of interns for the summer helping out as well. ;)
21:56:50 <ttx> Questions for Horizon ?
21:57:20 <ttx> #topic Other Team reports
21:57:33 <ttx> Any other team lead with a status report ? annegentle ?
21:58:04 <jgriffith> Well.... yeah, kinda
21:58:21 <jgriffith> Cinder should be available in the next couple of days (out of draft)
21:58:30 <ttx> jgriffith: good good
21:58:42 <jgriffith> Four of the five blueprints should be implemented (at least for first pass)
21:58:55 <jgriffith> nova volume decouple is what I'm trying to finish up now
21:59:05 <jgriffith> that's all
21:59:07 <ttx> ok
21:59:07 <jgriffith> thanks
21:59:15 <ttx> #topic Open discussion
21:59:18 <annegentle> jgriffith: I'll set up a meeting to talk docs
21:59:28 <ttx> Anything else, anyone ?
21:59:34 <jgriffith> annegentle: yes, I haven't forgotten, just still wasn't ready :(
21:59:42 <annegentle> jgriffith: no worries
21:59:50 <ttx> Note that during a webinar today the events team announced that our next Design Summit would be held in San Diego on the week of October 15th
22:00:10 <ttx> Mark your calendars
22:00:22 <annegentle> still working on a "deployment template" document that helps people inform others about their deployment
22:00:33 <annegentle> still invite people to work on an operations manual
22:00:46 <ttx> annegentle: business as usual, I see
22:00:59 <annegentle> ttx: :)
22:01:21 <ttx> annegentle: anything else you wanted to mention before we close it ? Looks like we always are the only ones listening in the end :)
22:01:32 <annegentle> ttx: I wonder if adding a "deployers news" section to this meeting would be useful?
22:01:54 <ttx> annegentle: to inform users of largish changes ?
22:02:05 <ttx> or to brag about deployments ?
22:02:19 <annegentle> ttx: or for deployers to bring their bugs/track stuff?
22:02:25 <annegentle> everyone wants to track stuff :)
22:02:44 <ttx> annegentle: hm, they are supposed to ask questions on each project status update
22:02:50 <heckj> not the only ones...
22:02:58 <annegentle> ttx: ah, ok, it's embedded throughout
22:03:02 * ttx hugs heckj
22:03:29 <ttx> annegentle: yep
22:03:35 <ttx> ok, let's close it
22:03:38 <ttx> #endmeeting