21:02:25 <ttx> #startmeeting
21:02:26 <openstack> Meeting started Tue Jun  5 21:02:25 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:42 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:55 <ttx> Milestone-proposed for Folsom-2 will be cut on July 3. So the affected projects have 4 weeks left.
21:03:06 <ttx> #info Milestone-proposed for Folsom-2 will be cut on July 3. So the affected projects have 4 weeks left.
21:03:15 <ttx> #topic Actions from previous meeting
21:03:24 <ttx> * vishy to adjust 'undefined' folsom bp priorities
21:03:28 * ttx looks it up
21:03:58 <ttx> was done but someone added a new one
21:04:07 <ttx> https://blueprints.launchpad.net/nova/+spec/predictable-s3-image-id
21:04:26 <ttx> let's consider it done :)
21:04:41 <ttx> skipping keystone to let heckj a chance to join us
21:04:47 <ttx> #topic Swift status
21:04:54 <ttx> notmyname: yo
21:04:54 <notmyname> swift 1.5.0 released today
21:05:02 <ttx> \o/
21:05:05 <notmyname> yay :-)
21:05:17 <ttx> A bit early to talk about 1.5.1 ?
21:05:25 <notmyname> heh. ya
21:05:41 <ttx> notmyname: Anything you wanted to mention ?
21:05:59 <notmyname> make sure you read my email or the changelog before upgrading to 1.5.0. there are some required config changes
21:06:23 <ttx> I guess we should also attract distro packagers attention on that
21:06:30 <notmyname> great work from everyone who contributed
21:06:51 <ttx> #action ttx to point Swift distro packagers to required config changes in Swift 1.5.0
21:07:30 <vishy> ttx: Looks like based on the discussion that this should be obsoleted. Eoghan? --Vish (i didn't prioritize that one because i was waiting on eoghan to potentially delete it
21:08:11 <ttx> Note that there are ~78 New Swift bugs that should get triaged on Thursday's BugTriage day !
21:08:23 <ttx> #info Participate to the BugTriage day, see http://wiki.openstack.org/BugDays/20120607BugTriage
21:08:31 <ttx> notmyname: anything else ?
21:08:38 <notmyname> I don't have anything else
21:08:43 <ttx> Questions on Swift ?
21:09:24 <ttx> #topic Glance status
21:09:30 <ttx> bcwaldon: o/
21:09:37 <bcwaldon> hey hey
21:09:37 <ttx> #link https://launchpad.net/glance/+milestone/folsom-2
21:09:43 <ttx> bcwaldon: How is api-v2 going ?
21:09:48 <bcwaldon> It's going great!
21:09:57 <ttx> Is https://blueprints.launchpad.net/glance/+spec/api-v2-links a part of api-v2 ? I see no dependency between the two.
21:10:01 <bcwaldon> markwash and some guys from titan are helping out quite a bit
21:10:15 <bcwaldon> ttx: yes, I'll set deps in a sec
21:10:33 <bcwaldon> and I started work on the db refactoring this week
21:10:36 <ttx> ok, so the set of api-v2 things are still on track so far ?
21:10:38 <bcwaldon> making it fully pluggable!
21:10:42 <bcwaldon> ttx: yes sir
21:10:45 <ttx> My other questions were about:
21:10:53 <ttx> * https://blueprints.launchpad.net/glance/+spec/swift-tenant-specific-storage (dprince)
21:11:00 <ttx> How is that going ?
21:11:06 <bcwaldon> We'll have to ask dprince on that one
21:11:14 <bcwaldon> last I heard he was waiting on some free time to tackle it
21:11:28 <bcwaldon> I had a rough estimate of folsom-2 on completeness
21:11:43 <ttx> ok...
21:11:49 <ttx> * https://blueprints.launchpad.net/glance/+spec/glance-client-v2 (bcwaldon)
21:12:05 <ttx> is that parralel to the api-v2 work, or following it ?
21:12:16 <bcwaldon> it only depends on the spec, not the implementation
21:12:16 <ttx> parallel, even
21:12:31 <bcwaldon> and a lot of that work is actually getting done outside of the context of openstack
21:12:35 <bcwaldon> i.e. a third-party library
21:12:36 <ttx> ok, so still on track for F2 ?
21:12:40 <bcwaldon> yes
21:12:53 <ttx> Looking at https://blueprints.launchpad.net/glance/folsom I see two essential specs for F3 without assignee...
21:12:54 <bcwaldon> things will pick up next week, I promise
21:12:59 <ttx> * https://blueprints.launchpad.net/glance/+spec/glance-client-parity
21:13:04 <ttx> * https://blueprints.launchpad.net/glance/+spec/streaming-server
21:13:09 <ttx> Are you looking for help on those ?
21:13:22 <bcwaldon> I think I have commitments for both
21:13:29 <markwash> ttx when does f-2 close?
21:13:30 <bcwaldon> feel free to action me
21:13:46 * ttx copypastes: Milestone-proposed for Folsom-2 will be cut on July 3. So the affected projects have 4 weeks left.
21:14:11 <ttx> #action bcwaldon to set assignees for glance-client-parity and streaming-server specs
21:14:21 <ttx> bcwaldon: Anything else you wanted to mention ?
21:14:40 <bcwaldon> Nope, I did want to hilight that we are working on making the db layer pluggable
21:14:50 <bcwaldon> so anybody that wanted to explore alternateive db drivers will be able to do so
21:15:08 <bcwaldon> and that is all
21:15:21 <ttx> bcwaldon: so it's now like Nova ? Or more pluggable ?
21:15:38 <bcwaldon> think of it more like Keystone's underlying pluggable data store drivers
21:16:02 <bcwaldon> cutting the tie on sqlalchemy
21:16:08 <ttx> ok
21:16:13 <ttx> Other questions on Glance ?
21:16:53 <ttx> bcwaldon: is there a particular spec that tracks this "pluggable db" work ?
21:17:06 <bcwaldon> it's being lumped into refactor-db-layer
21:17:31 <ttx> oh, F3. I see.
21:17:39 <bcwaldon> yeah, there are a lot of tasks for it
21:17:48 <ttx> I can imagine.
21:17:54 <ttx> #topic Quantum status
21:17:59 <ttx> danwent: hey
21:18:01 <danwent> hello
21:18:07 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-2
21:18:16 <vishy> afk 5 min tracking down phone
21:18:16 <ttx> I'd like to discuss the status of the essential stuff...
21:18:26 <ttx> * https://blueprints.launchpad.net/quantum/+spec/v2-api-melange-integration (jkoelker)
21:18:38 <ttx> it's the one that blocks quantum-horizon and ovs-api-v2-support, right ?
21:18:48 <danwent> yeah, our top priority has been finishing and documenting the v2 API (this BP), to unblock the other work dependent on it
21:19:10 <ttx> how is it going ?
21:19:20 <danwent> yes, and several others.  We've gotten some draft documentation up, so I think all of those other BPs can now start doing design (and coding with unit tests that mock)
21:19:42 <danwent> the v2 API BP is in review, though there are still some non-trivial bits to fix up.
21:19:55 <danwent> I'm optimistically hoping we can have it cleaned-up and merged by end of week.
21:20:07 <danwent> but my bigger prioirty is actually making sure the others are unstuck
21:20:10 <ttx> would be great. Was about to suggest that ;�
21:20:13 <ttx> ;)
21:20:29 <ttx> * https://blueprints.launchpad.net/quantum/+spec/new-cli (yong sheng gong)
21:20:34 <danwent> so I've chatted with all of those BP owners already.  having a call with arvind, who is doing the horizon stuff tomorrow, which is the last one that's really stuck.
21:20:57 <ttx> danwent: I see good progress on that one ?
21:21:04 <danwent> yong is a trooper, he's been making good progess just based on the draft API docs and the v2 API review code
21:21:07 <danwent> yes
21:21:26 <ttx> * https://blueprints.launchpad.net/quantum/+spec/improved-nova-quantum-integration (tr3buchet)
21:21:43 <ttx> is that one well unblocked now ?
21:22:02 <danwent> this is tr3buchet .  he said he has had a branch that does this with Quantum v1 api + melange, but needs to rework that to use quantum v2 api only
21:22:05 <tr3buchet> ttx: i've been sortof waiting for quantum, but it's a state where i can start making progress
21:22:31 <ttx> tr3buchet: still optimistic for F2 deadlines ?
21:22:49 <tr3buchet> ttx: sure.
21:22:50 <ttx> * https://blueprints.launchpad.net/quantum/+spec/quantum-dhcp (Carl Perry)
21:23:04 <ttx> danwent: same question here -- unblocked and on track ?
21:23:16 <danwent> ttx:  they are just getting started.  carlp promised me that they were going to make "amazing" progress on this BP this week :)
21:23:28 <danwent> so i'm looking forward to that :P
21:23:42 <ttx> it's still 4 weeks away.
21:23:51 * ttx loves those slightly-more-spaced milestones
21:23:58 <ttx> danwent: Anything else ?
21:24:32 <danwent> not really.  as a I said, we're working on everything critical for Folsom in F-2, though some of the non-essential stuff will likely spill into F-3.. just don't know which items yet.
21:24:44 <ttx> Note that you have ~25 new bugs to triage on that BugTriage day Thursday !
21:24:56 <danwent> woohoo :)
21:24:58 <ttx> Questions on Quantum ?
21:25:19 <danwent> one other comment
21:25:23 <ttx> go for it
21:25:36 <danwent> added a new BP to track getting the devstack gating working with Quantum enabled:
21:25:36 <vishy> bak
21:25:45 <danwent> https://blueprints.launchpad.net/quantum/+spec/quantum-gate
21:25:57 <danwent> want to get that working ASAP.
21:26:17 <danwent> that's it.
21:26:25 <ttx> #topic Nova status
21:26:30 <ttx> vishy: welcome back!
21:26:38 <vishy> ttx: thx
21:26:58 <ttx> #link https://launchpad.net/nova/+milestone/folsom-2
21:27:02 <ttx> A few questions:
21:27:11 <ttx> * https://blueprints.launchpad.net/nova/+spec/general-host-aggregates (jog0)
21:27:22 <ttx> vishy: Do you know the status of this (essential) one ?
21:27:41 <vishy> ttx: I don't, I was hoping to find jog0 yesterday
21:28:11 <ttx> let's action him on updating status on his bp
21:28:30 <ttx> #action jog0 to update status for general-host-aggregates bp
21:28:39 <ttx> I'm a bit concerned with this one
21:28:46 <ttx> * https://blueprints.launchpad.net/nova/+spec/finish-uuid-conversion (mikal)
21:28:56 <ttx> Same question. I see "Good progress" but no code proposed yet ?
21:28:56 <vishy> the first review is in
21:29:02 <ttx> oh.
21:29:06 <vishy> there is just one more afterwards
21:29:25 <vishy> looks like the blueprint didn't link
21:29:35 <ttx> review link ?
21:30:15 <ttx> https://review.openstack.org/#/c/8171/
21:30:17 <vishy> he accidentally overwrote it
21:30:20 <vishy> i just added back in
21:30:49 <ttx> ok, cool
21:30:54 <vishy> ttx: so that should land quickly and then it is just the security groups table
21:30:55 <ttx> * https://blueprints.launchpad.net/nova/+spec/volume-decoupling (vishy)
21:31:03 <ttx> How is that one going ?
21:31:06 <vishy> that one is making good progress too
21:31:29 <vishy> sleepson- has working branches for the last three items
21:31:34 <ttx> do you have an ETA ? There are a lot of Cinder things to complete for F2
21:31:44 <vishy> they are still in draft mode because they are cleaning them up
21:31:58 <jgriffith> Should be next week (early hopefully)
21:32:01 <vishy> but once those are in we have working cinder parity
21:32:11 <ttx> ok. while we are talking Cinder...
21:32:16 <jog0> ttx, still mapping out the blueprint, will start working on it this week
21:32:24 <ttx> jgriffith: progress on https://blueprints.launchpad.net/cinder/+spec/python-cinder-client ?
21:32:37 <ttx> jog0: still on track for F2 ?
21:32:40 <jgriffith> Pretty much there I beleive
21:32:50 <jog0> ttx: as of now yes.
21:32:50 <jgriffith> Yes, definitely.  I can't update status fields on it though ???
21:33:16 <jgriffith> oops... jog0
21:33:46 <ttx> jgriffith: on python-cinder-client spec ?
21:34:04 <jgriffith> correct
21:34:31 <ttx> jgriffith: err.. you should be able. We'll solve this offline
21:34:42 <ttx> #action ttx to fix jgriffith access to bp updating
21:34:47 <jgriffith> k
21:34:51 <ttx> * https://blueprints.launchpad.net/nova/+spec/ec2-id-compatibilty (SINA)
21:35:02 <ttx> vishy: Unknown status, know if it's being worked on yet ?
21:35:24 <lzyeval> I'll check with our team
21:35:34 <ttx> lzyeval: cool, thx
21:35:48 <ttx> #action lzyeval to update status of ec2-id-compatibilty bp
21:35:56 <ttx> * https://blueprints.launchpad.net/nova/+spec/xenapi-network-info-model (tr3buchet)
21:36:04 <ttx> tr3buchet, vishy: Looks "implemented" to me ?
21:36:13 <vishy> lzyeval: it should follow the same thing we do for glance and cinder uuids This still needs to be done for instances so we can drop the id column and rely solely on uuid
21:36:34 <vishy> ttx: agreed, that went in
21:36:39 <ttx> willfix
21:36:46 <lzyeval> vishy: got it
21:36:47 <ttx> * https://blueprints.launchpad.net/nova/+spec/multi-process-api-service (Huang Zhiteng)
21:37:00 <ttx> vishy: That one was reverted, we should make sure to communicate with the author to get it fixed and resubmitted ?
21:37:34 <ttx> I'm not sure the author will notice the revert by himself
21:38:07 <vishy> ttx: he is already checking into it
21:38:13 <ttx> oh, great.
21:38:21 <vishy> ttx: he was on irc the other day when it happened
21:38:29 <ttx> Finally, one question on the general Folsom plan @ https://blueprints.launchpad.net/nova/folsom
21:38:44 <ttx> config-drive-v2, delete-in-any-state and user-configurable-rbac (all High priority) are not targeted to any milestone...
21:38:55 <ttx> Would be good to make sure their assignees are committed to delivering in Folsom-3 ?
21:39:34 <ttx> vishy: may I action you on that ?
21:39:40 <vishy> sure
21:39:43 <ttx> #action vishy to contact assignees for config-drive-v2, delete-in-any-state and user-configurable-rbac and confirm F3 targeting
21:39:59 <ttx> vishy: Anything on your mind ?
21:40:12 <vishy> ttx: yes there are still stuff on the folsom plan with no assignees
21:40:42 <ttx> vishy: yes, though you got all the "High" covered now
21:40:47 <vishy> this one specifically requires some discussion: https://blueprints.launchpad.net/nova/+spec/differentiate-admin
21:41:26 <ttx> #help there are still stuff on the folsom plan with no assignees
21:41:43 <vishy> ttx: did you have to copy my terrible english :)
21:42:03 <ttx> vishy: half the magic of my typing speed is good use of copypaste
21:42:17 <vishy> That is it from me
21:42:24 <ttx> Wanted to mention Nova has ~230 New bugs to triage, so that's where most of the BugTriage day energy will be spent !
21:42:39 <ttx> #info Nova devs: Make sure to all join #openstack-bugday on Thursday !
21:43:13 <ttx> It looks huge but divided by 20 it's a lot less impressive.
21:43:24 <med_> Does bugday start in your local timezone or at 0:00 UTC?
21:43:39 <ttx> med_: bugday is as long as it's Thursday somewhere.
21:43:56 <ttx> It actually lasts 47 hours and 59 min.
21:44:14 <ttx> Questions on Nova ?
21:44:18 <russellb> should the priority of no-db-messaging (low) be changed since it's a pre-req for no-db-compute (high) ?
21:44:26 <russellb> blueprints ^
21:44:27 <ttx> russellb: yes.
21:44:36 <russellb> k, don't think i can change it
21:44:37 <ttx> vishy: I'll let you do it ? ^
21:44:52 <ttx> devcamcar: around ?
21:44:56 <vishy> russellb: yes i will do it
21:44:59 <russellb> kthx
21:45:08 <ttx> termie: want to replace heckj to report on Keystone ?
21:45:31 <ttx> looks like Seattle was wiped out of IRC
21:45:43 <ttx> Anyone from Keystone or Horizon in the room ?
21:46:33 <ttx> Let's do "other team reports" to see if that creates some vocations
21:46:38 <ttx> #topic Other Team reports
21:46:47 <ttx> jaypipes, mtaylor: ?
21:46:59 <ttx> Any other team lead with a status report ?
21:47:20 <ttx> mtaylor: I saw the zuul announcement, nice work
21:47:23 <jaypipes> ttx: hammering on with Tempest tests... now >300 tests.
21:47:43 <jaypipes> ttx: still work to do on stabilizing some of the errors that are occurring, but slow and steady progress
21:47:47 <ttx> jaypipes: how is the Tempest gate job going ?
21:47:49 <termie> heya, just got back
21:47:58 <termie> what's the question? just basic status?
21:48:15 <jaypipes> ttx: going well. we understand the cause of all failures and errors. just going through the code reviews now.
21:48:24 <ttx> termie: yes, in a minute -- will have a few more precise questions that you may or may not be able to answer
21:48:59 <ttx> jaypipes: doesn't adding new tests make you farther from being able to enable the gate on Tempest ?
21:49:58 <ttx> i.e. are you running towards a target with half your team busily moving it away from you ?
21:50:57 <ttx> sounds like we lost Jay
21:51:13 <ttx> back to our regular programme then...
21:51:16 <ttx> #topic Keystone status
21:51:21 <ttx> termie: heya
21:51:27 <jaypipes> ttx: no, not really... we need to resolve our ongoing "what is a smoke test" debate...
21:51:37 <jaypipes> ttx: look for an update on the QA status meeting this week.
21:51:42 <ttx> jaypipes: ok, thanks!
21:51:45 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-2
21:52:03 <ttx> termie: Had a few questions for heckj that you may or may not be able to answer
21:52:21 <ttx> * https://blueprints.launchpad.net/keystone/+spec/stop-ids-in-uris (Guang Yee)
21:52:37 <ttx> Looks like work has stalled, with the review being abandoned ^
21:54:33 <ttx> hmm, we lost termie
21:55:12 * ttx thinks we should just skip Keystone and Horizon for this week. Nothing urgent anyway.
21:55:35 <ttx> So without further ado...
21:55:38 <ttx> #topic Open discussion
21:55:52 <ttx> Anything newsworthy, anyone ?
21:56:06 <termie> Keystone: domain feature arguments that i am going to win, signed tokens well under way
21:56:09 <termie> ... andy back
21:56:14 <ttx> termie: heh
21:56:27 <ttx> termie: do you know if the feedback on V3 API is complete ?
21:57:03 <termie> ttx: it isn't, i've listed a bunch of things but have not heard from heckj
21:57:12 <termie> (i only added stuff recently, been traveling)
21:57:28 <termie> so more my fault than his
21:57:32 <ttx> ok, will follow up next week
21:58:45 <ttx> termie: my other question was about https://blueprints.launchpad.net/keystone/+spec/stop-ids-in-uris which looks stalled, I guess it's just a matter of pinging Guang Yee
21:58:57 <ttx> and that can wait next week for an update.
21:59:18 <ttx> so unless anyone has something to add...
21:59:27 <termie> i don't see the point of that one, so i suspect it will remain stalled until i do
21:59:50 <ttx> termie: heckj put it as "essential", which is the only reason why I actually care :)
22:00:19 <termie> ttx: aye, i'll ask him about it
22:00:32 <ttx> OK, we are done. See you all on #openstack-bugday on Thursday!
22:00:36 <ttx> #endmeeting