21:01:53 <ttx> #startmeeting
21:01:54 <openstack> Meeting started Tue May 29 21:01:53 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:03 <ttx> Today's usual agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:15 <ttx> #topic Actions from previous meeting
21:02:39 <ttx> pushing back to next week:
21:02:45 <ttx> #action vishy to adjust 'undefined' folsom bp priorities
21:02:55 <ttx> #topic Keystone status
21:02:57 <bcwaldon> his priorities are elsewhere at the moment
21:03:05 <ttx> heckj: o/
21:03:12 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-2
21:03:21 <ttx> heckj: Is status accurate for those ? i.e. mostly not started ?
21:03:59 <heckj> ttx: correct. I'm hunting a few folks to see where they are, haven't received any detail back, so leaveing them in not-started for now. Will push out if they're not going to be able to engage shortly.
21:04:11 <ttx> heckj: how is the feedback on v3 APi going so far ?
21:04:15 <heckj> ttx: may collapse a BP or two besed on feedback
21:04:50 <heckj> API feedback has been excellent - another draft will be forthcoming in the next few days with any luck. Still waiting for some feedback because folks on vacation right now
21:05:22 <ttx> Stil on track to deliver the implementation of the API in F2 ?
21:06:10 <heckj> ttx: That's looking iffy, but we're going to try. Given the draft feedback and round-up process, it may slip into F3
21:06:23 <ttx> ok
21:06:25 <ttx> "stop-ids-in-uris" was in F1 and deferred, do you have news on progress on that ?
21:07:03 <ttx> haven't seen code proposed yet
21:07:21 <heckj> code is under review, just not linked. Moment and I'll get that link
21:07:44 <ttx> #info implement-v3-core-api may slip to F3 due to  draft feedback and round-up process
21:07:52 <ttx> In other news, your Folsom plan at https://blueprints.launchpad.net/keystone/folsom looks good and realistic
21:08:22 <ttx> heckj: anything else ?
21:08:33 <heckj> #link https://review.openstack.org/#/c/7010/ <-- stop-id work
21:08:47 <heckj> nope. Questions?
21:08:55 <ttx> Do you / keystone plan to participate to the Bugtriage day on June 7th ?
21:09:36 <heckj> ttx: yep. We've been trying to keep up on that triage a bit more aggressively, so we're a touch ahead, but a run through would be good regardless
21:09:52 <ttx> cool.
21:09:59 <ttx> Other questions about Keystone ?
21:10:47 <ttx> #topic Swift status
21:10:51 <notmyname> o/
21:10:51 <ttx> notmyname: yo
21:10:57 <ttx> #link https://launchpad.net/swift/+milestone/1.5.0
21:11:06 <notmyname> #link https://github.com/openstack/swift/blob/576be4d77efc57b7ee20f0207845349de9960b1b/CHANGELOG
21:11:14 <ttx> #info Swift 1.5.0 milestone-proposed branch was cut today, waiting for the final go-ahead sometimes Thursday.
21:11:19 <notmyname> swift 1.5.0 is getting ready for release
21:11:22 <notmyname> yes
21:11:27 <ttx> notmyname: I filed bug 1005801 as potentially release-critical
21:11:29 <uvirtbot> Launchpad bug 1005801 in swift "[1.5.0] Missing test/sample.conf in generated tarballs" [High,Confirmed] https://launchpad.net/bugs/1005801
21:11:36 <ttx> We should either fix it (in master and in milestone-proposed) or un-1.5.0-target it
21:11:50 <ttx> no idea of the exact impact, so if you could have a look
21:11:50 <notmyname> ok, I'll look in to that when we're done here
21:12:07 <notmyname> there are a few things that should be mentioned about the 1.5.0 release
21:12:15 <ttx> if you confirm it, I can push fix tomorrow morning if nobody beats me to it today
21:12:28 <notmyname> the first 3 points on the CHANGELOG I linked above will require config changes for deployers
21:13:47 <notmyname> I'm working on an email to be sent to the mailing list at the time of official release to talk about all the changes in this release
21:14:00 <ttx> notmyname: we should probably highlight that directly in the release email announcement. I'll let you write it ?
21:14:18 <notmyname> ya, I'll definitely highlight it
21:14:43 <ttx> In other news, could you confirm that 1.5.1 will be the first version that will no longer have the swift python client lib shipped within swift ?
21:15:18 <notmyname> that's the plan, and I think there is a very good chance that it will happen
21:15:37 <ttx> horizon: might affect you ^
21:15:51 <ttx> notmyname: Anything else ?
21:15:55 <notmyname> nope
21:16:07 <ttx> #info 1.5.1 should be the first version that will no longer have the swift python client lib shipped within swift
21:16:20 <ttx> Questions on Swift ?
21:16:58 <ttx> #info 1.5.0 will require config changes for deployers
21:17:33 <ttx> #topic Glance status
21:17:38 <ttx> bcwaldon: o/
21:17:42 <bcwaldon> alo
21:17:45 <ttx> #link https://launchpad.net/glance/+milestone/folsom-2
21:17:53 <ttx> Got a few questions for you
21:18:09 <ttx> api-v2-images-sorting has no assignee ?
21:18:22 <bcwaldon> correct
21:18:39 <ttx> so you're looking for someone to do the work ? Or you know who will ?
21:19:03 <bcwaldon> I'll do it if nobody volunteers
21:19:08 <ttx> I suppose its status is "not started", then.
21:19:09 <bcwaldon> there's no rush at this point
21:19:31 <ttx> api-v2-images-filtering, swift-tenant-specific-storage: unknown status, I suspect they are "not started" as well ?
21:19:40 <bcwaldon> yep, all not started
21:19:51 <bcwaldon> I'm leaving things undefined until they have asignees
21:19:58 <bcwaldon> then I'm relying on the asignee to track their progress
21:20:08 <ttx> ok
21:20:11 * ttx unfixes
21:20:26 <bcwaldon> it doesn't really matter either way :)
21:20:47 <ttx> api-v2-user-properties looks implemented to me ?
21:21:08 <ttx> https://blueprints.launchpad.net/glance/+spec/api-v2-user-properties
21:21:21 <ttx> or is there more to it ?
21:21:21 <bcwaldon> ttx: I'll have to sync up with markwash_ on that, there will be another patch coming
21:21:29 <ttx> ok
21:21:30 <bcwaldon> we have enough to ship the feature, but more will get done
21:21:41 <ttx> Looking now at the general Folsom plan at https://blueprints.launchpad.net/glance/folsom
21:21:54 <ttx> Aren't separate-client and glance-client-parity already implemented in folsom-1 ?
21:22:00 <bcwaldon> no sir
21:22:03 <ttx> with the python-glanceclient split ?
21:22:17 <bcwaldon> separate-client isnt done till we have parity vfor v1 and a full v2 implementation
21:22:35 <bcwaldon> at that point we can drop the old client from openstack/glance
21:22:46 <ttx> oh, it's still in. I see.
21:22:59 <bcwaldon> yeah, we created the new client
21:23:04 <bcwaldon> need to rally on that now
21:23:13 <ttx> bcwaldon: Anything else you wanted to mention ?
21:23:19 <bcwaldon> negative
21:23:29 <ttx> Does Glance participate to the Bugtriage day on June 7th ?
21:23:53 <bcwaldon> there aren't many bugs to triage, but I'll take all contributions
21:24:02 <ttx> sounds good
21:24:03 <ttx> Questions on Glance ?
21:24:36 <markwash_> bcwaldon: is v2 pagination different than v2 sorting?
21:24:39 <markwash_> blueprint wise?
21:24:42 <bcwaldon> yes
21:24:44 <bcwaldon> as is filtering
21:24:51 <bcwaldon> markwash_:
21:25:02 <markwash_> gotcha, I guess I was thinking we can't do the last links for pagination sensibly without sorting
21:25:07 <markwash_> maybe that is a dependency
21:25:24 <bcwaldon> ok, there may be an order we need to document then
21:25:26 <markwash_> anyway, nikhil and I will probably have energy to devote to the sorting part as well
21:25:32 <bcwaldon> great
21:25:36 <bcwaldon> lets hook up offline
21:25:42 <markwash_> sure
21:25:48 <gabrielhurley> +1 to supporting all that in the API :-)
21:25:58 <ttx> #topic Quantum status
21:26:00 <bcwaldon> +1 to your +1, sir
21:26:04 <ttx> danwent: hey
21:26:05 <danwent> hey
21:26:08 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-2
21:26:21 <ttx> I have a few questions:
21:26:31 <ttx> Looks like v2-api-melange-integration is in the critical path, what's the status on this ?
21:26:54 <ttx> it's blocking a lot of other stuff
21:26:56 <danwent> yes, its our key blocker right now.  talked to jkoelker this morning about it.  they are fully focused on it.
21:27:14 <ttx> do they have an ETA for it ?
21:27:22 <danwent> we're going to try and get some docs published on the API to unblock some of the other folks
21:27:41 <danwent> there's several days of work until its fully tested and can be proposed is my guess.
21:28:09 <danwent> they have it in a side branch that people have access to it though
21:28:19 <danwent> so early integration is possible.
21:28:39 <ttx> yes, some parallelization (through doc or looking into the branch) can't hurt
21:29:02 <ttx> use-common-cfg: could you confirm it's a Folsom goal ? Do you have an assignee for it ?
21:29:05 <danwent> agreed.  I think everyone else who is blocked should at least be able to write-up their designs based on the API doc, so that's the goal.
21:29:20 <danwent> I thought I updated that one this morning… one sec
21:29:23 <ttx> oh, you have one now
21:29:39 <danwent> haha.. that wasn't even a last minute refresh :P
21:29:57 * ttx confirms it for Folsom
21:30:09 <ttx> ovs-api-v2-support: Folsom goal ?
21:30:25 <ttx> fixed now
21:30:30 <danwent> yes
21:30:41 <ttx> OK then, looking at the general Folsom plan at: https://blueprints.launchpad.net/quantum/folsom
21:30:53 <ttx> You have nothing targeted to folsom-3... is that because you want all goals complete by F2 ?
21:31:11 <ttx> and use F3 for anything that gets deferred ?
21:31:20 <danwent> that is the goal.  f-2 is packed though, so the more realistic way to think about it is that F-3 will be overflow
21:31:25 <danwent> yes
21:31:28 <ttx> ok, that works
21:31:37 <danwent> but the good news is that we have people working on all of the important stuff in F-2
21:31:49 <danwent> though odds are it won't all land in F-2
21:31:56 <ttx> #info Goal is to target all features to F2 and use F3 for overflow
21:32:01 <ttx> danwent: Anything else ?
21:32:13 <danwent> other than mounds of code to be written?   nope :)
21:32:16 <ttx> Can you confirm Quantum will participate to the Bugtriage day on June 7th ?
21:32:20 <danwent> yes
21:32:25 <ttx> yeepee
21:32:34 <ttx> Other questions on Quantum ?
21:33:27 <ttx> #topic Nova status
21:33:51 <ttx> So we don't have Vish, still on a beach somewhere sipping Mojitos
21:34:24 <ttx> So I'll monologue all the questions I have, that will make an interesting read for him when he comes back
21:34:33 <ttx> #link https://launchpad.net/nova/+milestone/folsom-2
21:34:55 <ttx> that said, if you know the answer, feel free to answer :)
21:35:24 <ttx> general-host-aggregates (joe gordon): not started ?
21:36:01 <ttx> trusted-messaging (russellb) and ec2-id-compatibilty (sina): unknown status, should i assume not started ?
21:36:16 <rustlebee> trusted-messaging is eric w
21:36:24 <rustlebee> no-db-messaging is me ... not started
21:36:31 <ttx> oops
21:36:46 <rustlebee> i think trusted messaging is started, though
21:36:54 <rustlebee> can't speak much to progress, but started at least
21:36:55 <ttx> quota-refactor (klmitch) : fully implemented, or more to come ?
21:37:20 <ttx> Looking at the general Folsom plan now: https://blueprints.launchpad.net/nova/folsom
21:37:38 <ttx> Still a few "High" priorities that are not targeted to any milestone...
21:37:54 <ttx> so if you are the assignee and know when it should land, just update it:
21:38:00 <ttx> https://blueprints.launchpad.net/nova/+spec/config-drive-v2 (unsassigned)
21:38:05 <ttx> https://blueprints.launchpad.net/nova/+spec/delete-in-any-state (sina)
21:38:10 <ttx> https://blueprints.launchpad.net/nova/+spec/user-configurable-rbac (sleepsonthefloor)
21:38:42 <ttx> ewindisch: news on trusted-messaging ? Is work started there ?
21:38:58 <ttx> jgriffith: around ?
21:39:05 <jgriffith> Yep
21:39:11 <ttx> jgriffith: how is Cinder going today ?
21:39:16 <ttx> A bit more than a month to reach feature parity, still on track ?
21:39:26 <jgriffith> Going pretty good... Yes, I think we should hit that
21:39:36 <jgriffith> Currently the cinderclient is working well against nova
21:39:38 <ttx> jgriffith: What's left to do ?
21:39:51 <jgriffith> cinder itslef is 'working' but...
21:40:03 <jgriffith> Still some problems getting devstack configured to point to the right comps
21:40:22 <jgriffith> Big steps still to be done... Finish all of the seperation out of nova
21:40:33 <jgriffith> create the client in cinder for nova to talkt o
21:40:55 <ttx> jgriffith: so IIUC the important blueprints are:
21:41:00 <ttx> https://blueprints.launchpad.net/cinder/+spec/python-cinder-client
21:41:02 <jgriffith> The attach piece is going to be tricky but I believe vishy has something in mind there
21:41:08 <ttx> https://blueprints.launchpad.net/nova/+spec/volume-decoupling
21:41:23 <ttx> or is there more ?
21:41:38 <jgriffith> This generalizes all of it pretty well
21:41:52 <ttx> ok, will keep an eye on them
21:42:03 <ttx> jgriffith: anything else you wanted to mention ?
21:42:26 <jgriffith> Nope, just plugging away.  Should have vishy and anotherjesse back later this week :)
21:42:30 <ttx> Any Cinder question ?
21:43:07 <ttx> #topic Horizon status
21:43:10 <ohnoimdead> yo!
21:43:14 <ttx> ohnoimdead: hey!
21:43:19 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-2
21:43:28 <ttx> ohnoimdead: status looks good to me
21:43:43 <ttx> About switch-to-cinder-client, there is a bit of a race condition here...
21:43:52 <ttx> ...as the cinder-client itself will be released at folsom-2
21:44:01 <ttx> I guess we'll have to do a pre-release somewhere ?
21:44:16 <ohnoimdead> yeah, that doesn't sound unreasonable
21:44:39 <ttx> we might get our act together and fix the client versioning/releases by then
21:44:48 <ohnoimdead> that would be swell. ;)
21:45:12 <ttx> anything you wanted to mention on folsom-2 progress ?
21:45:19 <ohnoimdead> fyi we also added https://blueprints.launchpad.net/horizon/+spec/readd-quantum-support and https://blueprints.launchpad.net/horizon/+spec/quantum-workflow-integration for re-introducing the quantum ui
21:45:36 <ohnoimdead> i want to not mention node.js
21:45:46 <gabrielhurley> ohnoimdead: then why did you mention it?
21:46:04 <ohnoimdead> gabrielhurley: mention what?
21:46:12 <gabrielhurley> ohnoimdead: exactly.
21:46:51 <ttx> those two blueprints you mentioned... I suspect they will be added to folsom goal and targeted to some milestone in the near future ?
21:47:06 <ohnoimdead> yes, i was going to let devin target them
21:47:14 <ttx> ok
21:47:23 <ttx> Looking at the Folsom general plan at: https://blueprints.launchpad.net/horizon/folsom
21:47:40 <ttx> ohnoimdead: There are 5 "High" priority blueprints in there that are not targeted yet
21:47:47 <ttx> I suppose they will end up targeted to folsom-3 ?
21:48:12 <ttx> (unless shit happens ?)
21:48:34 <gabrielhurley> the asset-compression bluprint is actually in code review right now...
21:48:34 <ohnoimdead> yeah. at least one of those is actually done and just not updated :/
21:48:59 <ttx> I kinda like it that way, rather than than the other way around.
21:49:03 <gabrielhurley> heh
21:49:12 <ttx> i'll let you fix it :)
21:49:13 <gabrielhurley> we'll take a look at 'em and clean 'em up
21:49:31 <ttx> ohnoimdead: Anything else you wanted to not mention ?
21:49:32 <ohnoimdead> and bug devin to target them
21:49:41 <ohnoimdead> NO
21:49:45 <ohnoimdead> i mean, no thank you
21:49:53 <ttx> ohnoimdead: Horizon bugs are pretty well triaged, do you plan to participate to the Bugtriage day on June 7th anyway ?
21:50:28 <ohnoimdead> might participate for a bit
21:50:37 <ttx> Cool. Other questions for Horizon ?
21:51:11 <ttx> #topic Other Team reports
21:51:19 <ttx> jaypipes, mtaylor: ?
21:51:23 <ttx> oubiwann: ?
21:51:42 <oubiwann> ttx: nothing from me
21:51:55 <ttx> Any other team lead with a status report ?
21:52:32 <ttx> #topic Open discussion
21:52:44 <ttx> Does anyone want to organize a realworld event on that June 7 bugtriage day ?
21:53:47 <med_> jgriffith, I can set something up in Fort Collins if you want to come up....
21:54:01 <med_> not sure there's any cinder triaging to do though.
21:54:40 <ttx> heh, probably not yet
21:55:05 <jgriffith> med_: Sounds good to me
21:55:06 <ttx> anyway, if you want to, just edit http://wiki.openstack.org/BugDays/20120607BugTriage to mention it
21:55:40 <jgriffith> med_: Actually there may be... if local folks are familiar with the client project_id settings etc
21:55:54 <jgriffith> med_: ttx thanks!
21:56:06 <ttx> Anything else ? Anyone ?
21:56:08 * med_ will look into it and contact jgriffith later.
21:56:55 <ttx> ok then
21:56:59 <ttx> #endmeeting