#openstack-meeting Meeting

Meeting started by nijaba at 16:01:26 UTC (full logs).

Meeting summary

    1. agenda http://wiki.openstack.org/Meetings/MeteringAgenda (nijaba, 16:01:26)

  1. meeting organisation (nijaba, 16:01:37)
    1. This is 3/6 meetings to decide the details of the architecture of the Metering project https://launchpad.net/ceilometer (nijaba, 16:01:37)
    2. Today's focus is on the definition of external REST API (nijaba, 16:01:37)
    3. There has not been enough discussions on the list to cover all aspects and the focus of this meeting was modified to cope with it.#info The meeting is time boxed and there will not be enough time to introduce inovative ideas and research for solutions. (nijaba, 16:01:37)
    4. The debate will be about the pro and cons of the options already discussed on the mailing list. (nijaba, 16:01:37)

  2. actions from previous meetings (nijaba, 16:02:14)
    1. dachary add info to the wiki on the topic of poll versus push (nijaba, 16:02:26)
    2. dhellmann: reformulate the API proposal as a start point for the dicussion on the ML (nijaba, 16:03:25)

  3. Agree on update to schema to include JSON formated metadata (nijaba, 16:05:55)
    1. http://wiki.openstack.org/EfficientMetering#Storage (nijaba, 16:05:55)
    2. AGREED: to update to schema to include JSON formated metadata (nijaba, 16:10:40)

  4. Agree on API proposal (nijaba, 16:10:56)
    1. http://wiki.openstack.org/EfficientMetering/APIProposalv1 (nijaba, 16:10:56)
    2. AGREED: on API proposal http://wiki.openstack.org/EfficientMetering/APIProposalv1 (nijaba, 16:15:01)

  5. Agree on format for date_time (nijaba, 16:15:22)
    1. Suggestion is to use ISO but seeking validation for best practice for REST (nijaba, 16:15:22)
    2. ACTION: nijaba to add the use to UTC for datetime (nijaba, 16:17:03)
    3. ACTION: flacoste to follow on the discussion about a bus only implementation (nijaba, 16:17:43)
    4. AGREED: to use ISO for datetime (nijaba, 16:18:54)

  6. Agree on the use of a transparent cache for aggregation (nijaba, 16:19:11)
    1. AGREED: caching is an implementation detail (nijaba, 16:23:58)

  7. Open discussion (nijaba, 16:24:28)
    1. ACTION: dhellmann to document a counter for discrete event as an example (nijaba, 16:29:02)


Meeting ended at 16:31:15 UTC (full logs).

Action items

  1. nijaba to add the use to UTC for datetime
  2. flacoste to follow on the discussion about a bus only implementation
  3. dhellmann to document a counter for discrete event as an example


Action items, by person

  1. dhellmann
    1. dhellmann to document a counter for discrete event as an example
  2. flacoste
    1. flacoste to follow on the discussion about a bus only implementation
  3. nijaba
    1. nijaba to add the use to UTC for datetime


People present (lines said)

  1. nijaba (84)
  2. dhellmann (35)
  3. flacoste (19)
  4. openstack (4)


Generated by MeetBot 0.1.4.