#openstack-meeting Meeting

Meeting started by dachary at 16:00:22 UTC (full logs).

Meeting summary

    1. https://lists.launchpad.net/openstack/msg11523.html (dachary, 16:00:22)

  1. actions from previous meetings (dachary, 16:00:22)
    1. http://eavesdrop.openstack.org/meetings/openstack-meeting/2012/openstack-meeting.2012-05-03-16.00.html (dachary, 16:00:22)
    2. dachary removed obsolete comment about floating IP http://wiki.openstack.org/EfficientMetering?action=diff&rev2=70&rev1=69 (dachary, 16:00:22)
    3. dachary o6 : note that the resource_id is the container id. http://wiki.openstack.org/EfficientMetering?action=diff&rev2=71&rev1=70 (dachary, 16:00:23)
    4. The discussion about adding the source notion to the schema took place on the mailing list https://lists.launchpad.net/openstack/msg11217.html (nijaba, 16:01:25)
    5. The conclusion was to add a source field to the event record, but no additional record type to list existing sources. (nijaba, 16:01:25)
    6. jd___ add Swift counters, add resource ID info in counter definition, describe the table http://wiki.openstack.org/EfficientMetering?action=diff&rev2=57&rev1=54 (jd___, 16:03:08)

  2. meeting organisation (dachary, 16:04:37)
    1. This is 2/5 meetings to decide the details of the architecture of the Metering project https://launchpad.net/ceilometer (dachary, 16:04:37)
    2. Today's focus is on the definition of external REST API (dachary, 16:04:37)
    3. There has not been enough discussions on the list to cover all aspects and the focus of this meeting was modified to cope with it. (dachary, 16:04:37)
    4. The meeting is time boxed and there will not be enough time to introduce inovative ideas and research for solutions. (dachary, 16:04:37)
    5. The debate will be about the pro and cons of the options already discussed on the mailing list. (dachary, 16:04:38)
    6. https://lists.launchpad.net/openstack/msg11368.html (dachary, 16:04:38)

  3. API defaults and API extensions (dachary, 16:05:28)
    1. AGREED: Ceilometer shouldn't invent its own API extensions mechanism... it should use the system in Nova. (dachary, 16:09:20)
    2. https://github.com/cloudbuilders/openstack-munin (dachary, 16:10:18)
    3. https://github.com/sileht/openstack-munin (dachary, 16:10:23)
    4. ACTION: dachary add info to the wiki on the topic of poll versus push (dachary, 16:12:17)

  4. API defaults (dachary, 16:13:08)
    1. GET list components (dachary, 16:13:14)
    2. GET list components meters (argument : name of the component) (dachary, 16:13:14)
    3. GET list [user_id|project_id|source] (dachary, 16:13:14)
    4. GET list of meter_type (dachary, 16:13:14)
    5. GET list of events per [user_id|project_id|source] ( allow to specify user_id or project_id (dachary, 16:13:14)
    6. GET sum of (meter_volume, meter_duration) for meter_type and [user_id|project_id|source] (dachary, 16:13:15)
    7. other ? (dachary, 16:13:16)
    8. GET list of events per user_id && project_id (dachary, 16:14:20)
    9. http://wiki.openstack.org/OpenStackRESTAPI (dachary, 16:15:48)
    10. http://wiki.openstack.org/EfficientMetering#Meters (dachary, 16:16:48)
    11. http://wiki.openstack.org/EfficientMetering#API (nijaba, 16:23:45)
    12. AGREED: all meters have a [start,end[ ( start <= timestamp < end ) that limits the returned result to the events that fall in this period (dachary, 16:26:45)
    13. AGREED: all queries have a [start,end[ ( start <= timestamp < end ) that limits the returned result to the events that fall in this period (dachary, 16:26:58)
    14. ACTION: dhellmann reformulate the API proposal as a start point for the dicussion on the ML. (dachary, 16:49:58)
    15. ACTION: dhellmann: reformulate the API proposal as a start point for the dicussion on the ML (dhellmann, 16:50:17)
    16. ACTION: dachary push next meetings one week (dachary, 16:50:58)


Meeting ended at 16:59:20 UTC (full logs).

Action items

  1. dachary add info to the wiki on the topic of poll versus push
  2. dhellmann reformulate the API proposal as a start point for the dicussion on the ML.
  3. dhellmann: reformulate the API proposal as a start point for the dicussion on the ML
  4. dachary push next meetings one week


Action items, by person

  1. dachary
    1. dachary add info to the wiki on the topic of poll versus push
    2. dachary push next meetings one week
  2. dhellmann
    1. dhellmann reformulate the API proposal as a start point for the dicussion on the ML.
    2. dhellmann: reformulate the API proposal as a start point for the dicussion on the ML


People present (lines said)

  1. dachary (106)
  2. nijaba (60)
  3. dhellmann (57)
  4. ss7pro (31)
  5. woorea (23)
  6. jaypipes (19)
  7. DanD_ (14)
  8. Divakar (5)
  9. openstack (4)
  10. Weighed (3)
  11. jd___ (3)
  12. sprintnode (2)
  13. Guest32307 (1)


Generated by MeetBot 0.1.4.