21:00:44 <ttx> #startmeeting
21:00:45 <openstack> Meeting started Tue Apr 10 21:00:44 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:00:52 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:00:53 <soren> ttx: o/
21:00:59 <devcamcar_> o/
21:01:06 <ttx> #info We will (ab)use the meeting to discuss Design Summit content
21:01:21 <ttx> #info But first do a quick roundtable on Essex post-release status, for those projects that released last Thursday
21:01:28 <ttx> #topic 2012.1 post-release status
21:01:40 <ttx> heckj: How is Essex Keystone looking, a few days after the storm ?
21:01:49 <heckj> Pretty darn good!
21:02:02 <ttx> No bug needing an urgent backport ?
21:02:03 <annegentle> ttx: o/
21:02:11 <heckj> We have a couple new bugs-that-are-really-feature requests in now
21:02:22 <ttx> heckj: cool
21:02:26 <ttx> bcwaldon: Glance still looks good ?
21:02:35 <bcwaldon> ttx: hardcore
21:02:36 <heckj> Nothing that's killing us. One that is currently incomplete that we'll triage on, but initial reports are all pretty good
21:02:52 <ttx> vishy: How is Nova Essex looking, now that a few days have passed ?
21:03:01 <vishy> ttx: pretty good.
21:03:10 <vishy> there have been some backports already
21:03:27 <vishy> a few of the extensions were discovered to be broken when we started writing docs
21:03:29 <vishy> :|
21:03:40 <ttx> There are 6 bugs nominated for Essex backport already:
21:03:43 <ttx> #link https://bugs.launchpad.net/nova/essex
21:03:51 <vishy> and canonical has a couple of issues with migrations and deprecated auth
21:04:10 <markmc> vishy, any thoughts on how soon you'd like use to do 2012.1.1 for nova ?
21:04:29 <vishy> markmc: no unsure
21:04:34 <ttx> vishy: would be good to docuemnt broken extensions in the release notes, if not done already
21:04:36 <vishy> markmc: i would give it a few weeks though
21:04:40 <markmc> vishy, ok, cool
21:04:48 <vishy> ttx: unfortunately
21:04:55 <vishy> ttx: gerrit is not updating properly
21:05:04 <vishy> ttx: the essex targetted bugs
21:05:12 <vishy> for example the first one has been merged already
21:05:27 <ttx> oh. I'll have to look into it. I wrote that trigger.
21:06:10 <ttx> #action ttx to look at the stable/essex bugclosing trigger logic (see bug 974293)
21:06:11 <uvirtbot> Launchpad bug 974293 in nova/essex "Instances directory gets deleted during unit test suite run" [High,In progress] https://launchpad.net/bugs/974293
21:06:34 <ttx> vishy: anything else that need our urgent attention ?
21:06:41 <vishy> i don't think so
21:06:47 <ttx> devcamcar: is horizon still clear ?
21:06:59 <ttx> (cue laughter)
21:07:36 <ttx> Everyone: any remark on the release process ? Things we should fix next time ?
21:07:47 <devcamcar_> ha
21:07:49 <devcamcar_> yes things are looking great
21:07:58 <annegentle> vishy: how can we know which extensions are borked?
21:07:58 <gabrielhurley> if horizon does end up making a 2012.1.1 I'd nominate bug 973836 for backport, but it's not serious enough to trigger one on its own by any means.
21:07:58 <uvirtbot> Launchpad bug 973836 in horizon "ImportError handling in override mechanism is broken" [Medium,Fix committed] https://launchpad.net/bugs/973836
21:08:16 <devcamcar_> we have couple of minor items that we are considering for back port
21:08:30 <ttx> gabrielhurley: fix should be backported to stable/essex in all cases
21:08:39 <gabrielhurley> ttx: k
21:08:44 <devcamcar_> I'm using the tag essex-backport-potential for triage
21:09:03 <ttx> the 2012.1.1 drop is more a matter of saying "you should really not be using the release tarball anymore"
21:09:07 <vishy> annegentle: there are two so far os-hosts and os-networks
21:09:13 <vishy> we can backport the fixes
21:09:17 <devcamcar_> all in all the feedback has been positive
21:09:26 <vishy> annegentle: but they are broken in the official essex release
21:09:42 <annegentle> vishy: ok, I'll update the release notes
21:09:50 <vishy> annegentle: thanks
21:10:04 <ttx> Anything else before we move to design summit tracks ?
21:10:31 <ttx> #action annegentle to update release notes to account for broken extensions
21:10:53 <ttx> vishy: those are extensions that are not tested by any of our tests ?
21:11:51 <vishy> ttx: they are not tested by any integration tests
21:12:03 <vishy> ttx: the fakes work fine :|
21:12:41 <ttx> jaypipes: ^ sounds like an area where we'd like converage :/
21:13:03 <ttx> ok, let's switch to design summit now
21:13:08 <ttx> #topic Design summit tracks content
21:13:20 <ttx> Are you all OK to close the session proposals now ?
21:13:29 <devcamcar> ttx: horizon is looking good
21:13:31 <ttx> Late proposals should just get an unconference slot. There will be plenty available.
21:13:37 <jgriffith> ttx: Yes, I believe so for Volume
21:13:43 <vishy> ttx: I noticed one hole in the nova props
21:13:54 <ttx> vishy: which ?
21:14:12 <vishy> ttx: it recently got mentioned on the list
21:14:21 <vishy> ttx: metadata, we have two related sessions
21:14:52 <vishy> ttx: but we don't have one specifically covering metadata communication channel
21:15:19 <ttx> vishy: if you need a new one filed, could you do it in the next 5 min ?
21:15:24 <vishy> ttx: perhaps we can squeeze it into the config drive session and extend
21:15:32 <heckj> ttx: keystone is already full to the top
21:15:46 <ttx> we'll discuss it when we arrive in Nova sessions
21:16:03 <ttx> #topic Common development track
21:16:09 <ttx> Track is complete. I could easily have filled twice the time though...
21:16:20 <ttx> I expect quite a few of those discussions to trigger unconference follow-ups.
21:16:25 <ttx> #topic Swift track
21:16:29 <ttx> notmyname: yo
21:16:36 <ttx> Track looks good to me.
21:16:38 <notmyname> it's filled, but as yet unscheduled
21:16:52 <ttx> notmyname: do you want me to handle initial scheduling ?
21:17:22 <notmyname> yes
21:17:29 <notmyname> h wait
21:17:30 <notmyname> no
21:17:36 <notmyname> I want to do the initial schedulng
21:17:36 <ttx> ok :)
21:17:54 <ttx> ok, just ping me if my superb UI is confusing
21:17:57 <heckj> ttx: happy to do initial scheduling, but need some "how do you do it…" instructions
21:17:59 <notmyname> heh, ok
21:18:08 <ttx> you can tell why I didn't contribute to Horizon yet
21:18:29 <ttx> #action ttx to send instructions on scheduling
21:18:31 <ttx> #topic Deployment/Ops track
21:18:38 <notmyname> same here :-)
21:18:39 <comstud> there's a 'Scheduling' button on the track
21:18:43 <comstud> that's as far as I've gotten
21:18:43 <comstud> :)
21:18:44 <ttx> notmyname: I think you are almost good
21:18:45 <notmyname> we've got one session that needs fixing
21:18:55 <notmyname> but the time is allocated
21:19:05 <ttx> you also need to adjust time to make it schedulable
21:19:08 <notmyname> yes
21:19:29 <notmyname> at least one session will need to be cut to allow it to fit into the scheduling constraints
21:19:40 <notmyname> probably http://summit.openstack.org/sessions/edit/149
21:19:45 <ttx> I take it you'll do the initial scheduling for that track as well ?
21:19:50 <notmyname> err http://summit.openstack.org/sessions/view/149
21:20:04 <notmyname> wait, that's already 25 minutes
21:20:29 <notmyname> perhaps the packaging one http://summit.openstack.org/sessions/view/26
21:20:33 <notmyname> justinsb_: ^
21:20:52 <ttx> notmyname: yes, you can place it just before the break to allow easy overflow
21:21:14 <ttx> #topic Nova core track
21:21:19 <ttx> vishy: yo
21:21:38 <vishy> i think that none is gtg
21:21:42 <vishy> * one
21:21:54 <ttx> vishy: isn't that the one that needs a slot for metadata ?
21:22:15 <vishy> I'm thinking we can squeeze it into existing discussions
21:22:30 <ttx> ok
21:22:33 <ttx> #topic Nova other track
21:22:45 <ttx> vishy: Mostly done too... I'd suggest:
21:22:57 <vishy> we have config drive and guest networking, we can cover it in those
21:23:19 <vishy> the last one was recently added, it does seem useful but something has to go down to 25 min
21:23:30 <vishy> thoughts on which one we could shorten?
21:23:44 <ttx> you need to get rid of 3 25-min equivalents
21:24:16 <ttx> I'd push "Enhancing OpenStack for Federated OpenStack" to Ecosystem track
21:25:08 <vishy> i think it got pushed from the ecosystem track
21:25:13 <soren> Heh :)
21:25:18 <ttx> magic !
21:25:43 <ttx> vishy: push it back, if Lloyd can't have it, that will be unconference
21:25:59 <vishy> actually it might have gotten pushed from common
21:26:02 <vishy> cool done
21:26:17 <lloydde> it was eco
21:26:19 <vishy> so i guess i will accept guest agents and shorten it
21:26:34 <ttx> sounds good
21:26:40 <ttx> vishy: do you want me to handle initial scheduling ? If yes, any constraint ?
21:27:06 <vishy> yes i will make a first pass
21:27:21 <vishy> there are a few sessions from other tracks that i want to attend so i might have to coordinate
21:27:41 <ttx> there will be adjustments once the initial schedule is posted
21:27:51 <heckj> ttx: had a little flaw with getting schedules to line up with slots and times - sent you mail, we can resolve offline
21:28:08 <ttx> #topic Nova hypervisors track
21:28:11 <ttx> soren: hey
21:28:14 <soren> o/
21:28:36 <soren> Apart from a bare metal session that needs a bit of coordination, we're in good shape.
21:28:39 <vishy> soren: I pushed three baremetal talks to that track
21:28:48 <soren> There were three sessions on that topic.
21:28:49 <vishy> soren: ah ok you saww that :)
21:28:58 <soren> I talked to the proposers to try to get them to agree.
21:29:10 <soren> ...so that we'll only do one session.
21:29:17 <ttx> you still have one more slot proposed than you can accomodate
21:29:30 <soren> I guess I'll need to approve one of them now, so that you can lock things down?
21:29:44 <ttx> I will only lock new proposals
21:29:55 <soren> Ah, cool.
21:30:02 <soren> Hmm...
21:30:07 * soren takes a look at the list
21:30:13 <ttx> soren: you should deny your waitlist one, probably
21:30:19 <soren> Yeah.
21:30:31 <ttx> will let you do it.
21:30:40 <soren> Oh, right, it should be.
21:30:45 <ttx> soren: want me to handle initial scheduling ? If yes, any constraint ?
21:31:31 <soren> That would be awesome.
21:31:37 <soren> No constraints that I know of.
21:31:52 <ttx> cool
21:32:03 <ttx> #topic Nova scaling track
21:32:07 <ttx> comstud: o/
21:32:09 <comstud> o/
21:32:20 <ttx> looking good I think
21:32:25 <comstud> i see you accepted my last one.. so
21:32:27 <comstud> i think we're good
21:32:28 <ttx> comstud: do you want me to handle initial scheduling ? If yes, any constraint ?
21:32:41 <comstud> I can take care of it.. I have a partial order in mind
21:32:45 <ttx> ok
21:32:51 <ttx> #topic Nova volumes track
21:32:58 <ttx> jgriffith: o/
21:33:02 <jgriffith> Mine's pretty easy...
21:33:13 <jgriffith> Only one I was waiting on was Renuka...
21:33:31 <jgriffith> Don't think I'm going to hear anything back so I'll probably just reject hers and use a new one for same topic
21:33:32 <ttx> jgriffith: you should reject his and accept yours ?
21:33:42 <ttx> ok
21:33:42 <jgriffith> ttx:  :)
21:33:48 <jgriffith> Yep, I'll do that now
21:33:49 <ttx> please do.
21:34:03 <ttx> jgriffith: want me to handle initial scheduling ? If yes, any constraint ?
21:34:48 <ttx> If there is time left at the end of the meeting, I'll do a quick explanation on the scheduler
21:34:54 <jgriffith> ttx: Sure, no constraint assuming they still all fall on first day.  With all the other topics regarding seperation of nova componenents there might be something
21:35:11 <jgriffith> that would make more sense but shouldn't matter too much
21:35:24 <ttx> #topic Keystone track
21:35:28 <ttx> heckj: looks complete to me ?
21:35:59 <ttx> you tried scheduling already, so that's covered
21:36:07 <heckj> ttx: it is, but I can't shift the 30 minute item to the top slot, need your assistance to make it work
21:36:31 <heckj> ttx: sent email, figured we solve it offline
21:36:37 <ttx> heckj: just clear the field where the 101 is
21:36:43 <ttx> click modify
21:36:49 <ttx> that should clear the slot
21:36:50 <heckj> try it yourself - didn't work. Explained in email
21:37:09 <heckj> If you want me to take the time, I can explain here
21:37:21 <ttx> nah, will solve offline
21:37:27 <ttx> #topic Glance track
21:37:31 <ttx> bcwaldon: o/
21:37:56 <bcwaldon> hello
21:38:00 <ttx> You're slightly over-subscribed at this point. Maybe:
21:38:04 <ttx> API extensions: the good, the bad, and the ugly -> Ecosystem ?
21:38:17 <bcwaldon> It could live several places
21:38:25 <bcwaldon> I'm fine moving it away from glance
21:39:04 <ttx> there is no room anywhere...
21:39:23 <bcwaldon> ha, well then we'll just have to deal with it :)
21:39:35 <ttx> just move it to Ecosystem, the sessions that Lloyd will reject will end up in Unconference slots
21:39:49 <bcwaldon> ttx: ok
21:40:39 <ttx> bcwaldon: will you have time to do initial scheduling yourself ?
21:40:48 <bcwaldon> ttx: yes sir
21:40:51 <ttx> cool
21:41:14 <ttx> Pro tip: if you have a 25-min session that is likely to be too short for a topic, place it just before a coffee break.
21:41:20 <ttx> #topic Quantum/Networking track
21:41:23 <ttx> danwent: yo
21:41:26 <danwent> hi
21:41:34 <danwent> so i took a first crack at a schedule
21:42:00 <ttx> looks complete now
21:42:04 <danwent> main interaction with another track is that Horizon track has a session on Quantum integration that we don't want to conflict with
21:42:06 <danwent> yup
21:42:22 <ttx> we can fix it if we get no luck
21:42:28 <ttx> #topic Horizon track
21:42:52 <ttx> devcamcar: looks good ?
21:43:16 <ttx> devcamcar: let me know if you want me to do the initial scheduling for you.
21:43:42 <devcamcar> ttx: we perfectly filled our allotted time so i'm happy with where we ended up
21:43:49 <devcamcar> if you could take a first pass at it that would be fantastic
21:43:58 <ttx> devcamcar: noted
21:44:09 <ttx> #topic Documentation track
21:44:12 <annegentle> hey
21:44:31 <annegentle> so I am full up, but need one 55 minute slot
21:44:32 <ttx> looks good too
21:45:03 <annegentle> er. That probably doesn't sound good. What I mean is, the "scheduling" isn't letting me assign 2 slots to one proposal
21:45:28 <annegentle> ttx: if you can double-check me and push to Sched that would be great
21:46:20 <ttx> annegentle: oh, that's because your 55min session is all over the break
21:46:47 <ttx> will ping you after
21:46:55 <ttx> #topic QA track
21:46:55 <annegentle> ttx: ok, sounds good, or tomorrow's fine too
21:46:59 <ttx> jaypipes: hey
21:47:29 <ttx> jaypipes: Looks like you should move "Nova API external testing" to Ecosystem track ?
21:47:49 <ttx> Then your track looks good to me.
21:47:55 <ttx> is jaypipes around ?
21:48:30 <ttx> hmm, I'mm move it for him then
21:48:32 <ttx> I'll*
21:48:46 <jaypipes> ttrifonov: yep
21:48:52 <ttx> almost
21:48:57 <jaypipes> oh, crap, another user beginnng with tt :(
21:49:12 <ttx> jaypipes: should I move it for you ?
21:49:12 <jaypipes> ttx: yes, that would be good, thanks.
21:49:15 <ttx> ok
21:49:42 <ttx> #topic Ecosystem track
21:49:46 <ttx> lloydde: o/
21:49:54 <lloydde> |o
21:49:58 <ttx> OK, you should not have more crap landing on your track anymore :)
21:50:05 <ttx> So with all the other pushing stuff to your track it's quite oversubscribed now
21:50:14 <lloydde> fantastic, 1st thing tomorrow rinse and repeat
21:50:16 <ttx> You will have to refuse a number of them and push them to the Unconference room instead.
21:50:24 <ttx> note that I've a bit of good news though
21:50:32 <lloydde> and put a page on the wiki for ppl putting hat in early for unconf
21:50:38 <ttx> I suggest we use Bayview B (120) instead of Golden Gate (50) for the track
21:50:47 <ttx> and use Golden gate for unconference
21:50:57 <ttx> does that make sense ?
21:51:09 <lloydde> that sounds like a good idea, as 120 for unconf might be intimidating
21:51:13 <ttx> i suspect the scheduled Ecosystem track will attract more people
21:51:18 <annegentle> ttx: sounds great
21:51:33 <ttx> We also have the option to use the ballroom for selected Ecosystem talks
21:51:47 <ttx> if teher is anything that really stands out...
21:51:49 <lloydde> saving the ballroom for you
21:51:49 <ttx> there*
21:51:59 <lloydde> ^_~
21:52:00 <uvirtbot> lloydde: Error: "_~" is not a valid command.
21:52:10 <lloydde> ^_~
21:52:20 <ttx> annegentle, lloydde: do you think you could have some use for it ?
21:52:33 <lloydde> nothing stands out to me, you annegentle?
21:52:38 <ttx> or better have them all in Bayview B (simpler)
21:52:50 <annegentle> ttx: I was wondering if some deployment topics would be large enough for the ballroom
21:53:27 <annegentle> ttx: I guess, the sooner we push to sched.org, the sooner we know where overflow is?
21:53:29 <ttx> I'll let you look into it. As far as scheduling goes, the ballroom is manual
21:54:21 <ttx> annegentle: see at the bottom of http://summit.openstack.org/sessions/trackstatus
21:54:54 <annegentle> ttx: ok, nice graphs
21:55:03 <ttx> Unless there is something that really stands out, staying in Bayview B will be simpler
21:55:24 <annegentle> ttx: I'm all for simple
21:55:34 <ttx> ack
21:55:57 <ttx> lloydde, annegentle: anything else ?
21:56:19 <lloydde> nope, I'll be frantic for your and annegentle assistance by tomorrow midday ;-)
21:56:27 <annegentle> :) nope
21:56:38 <ttx> We all delegated the hard task of saying no to you -- make sure that people you reject know they can get unconference slots
21:56:51 <ttx> you could even pre-book them
21:57:13 <lloydde> yes, plan to have them filled out before date
21:57:25 <ttx> cool
21:57:28 <lloydde> meaning their proposal sticky gets prepopulated
21:57:41 <ttx> #topic Open discussion
21:57:46 <ttx> Anything else, anyone ?
21:59:03 <ttx> I guess not. Looks like we got great content. A few days left to nail the schedule.
21:59:04 <ttx> Cheers
21:59:13 <comstud> woot
21:59:21 <danwent> yup, thanks for the new tool.  quite slick.
21:59:26 <ttx> #endmeeting