20:07:04 <n0ano> #startmeeting
20:07:04 <mikeyp> been busy, so orchestration was back burner till essex RC
20:07:05 <openstack> Meeting started Thu Mar 22 20:07:04 2012 UTC.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:07:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:07:34 <n0ano> understand, I've kind of been in holding mode thinking that we'll do most of the work at the essex summit
20:07:40 <n0ano> #topic meeting time
20:08:28 <n0ano> Given Thierry's email let's just definitively say that the Orchestration meeing is at 20:00UTC irrespective of daylight savings time
20:09:56 <mikeyp> agreed.  Updated wiki to that effect,to avoid confusion
20:10:27 <n0ano> sounds good
20:10:37 <mikeyp> Main other agenda item is the summit, and what we should accomplish before then.
20:10:45 <n0ano> #agreed meeting time is 20:00UTC
20:10:56 <mikeyp> Is orchestration listed as a session topic yet ?
20:11:12 <n0ano> #topic Orchestration summit topic
20:11:21 <sriramhere> sorry guys
20:11:25 <sriramhere> u am ack
20:11:37 <sriramhere> i'm back
20:11:50 <n0ano> sriramhere, np, did you see what we've talked over so far?
20:11:59 <sriramhere> I submitted a session proposal
20:12:01 <sriramhere> yes
20:12:05 <mikeyp> sriramhere: ack :-)
20:12:17 <n0ano> excellent, have you heard any confirmation on that?
20:13:01 <sriramhere> not yet.
20:13:18 <n0ano> OK, we'll keep and eye on that and try and make sure it happens
20:13:19 <sriramhere> i wanted to briefly talk abt what i had in my mind while submitting the proposal, and what more we can do before the summit
20:13:34 <sriramhere> i submitted under Brainstorm -
20:13:57 <n0ano> brainstorm sounds appropriate
20:14:13 <sriramhere> mainly to hash out the gaps in the previous blueprints (if at all) and why orchestration slipped out of Essex (so that we can address that)
20:14:44 <sriramhere> also, if we can make more progress on blueprint, that d be good.
20:15:08 <sriramhere> i also would have liked a presentation session - if we have more clarity on the design.
20:15:35 <sriramhere> currently, we have bunch of alternatives talked about, but we need to get to the next step
20:16:00 <n0ano> not sure we have a full idea for a presentation yet, the multiple alternatives would indicate the brainstorm is really what's required
20:16:18 <n0ano> do we have the alternatives written down anywhere?
20:16:44 <sriramhere> yes, they are under http://wiki.openstack.org/NovaOrchestrationSpecForFolsom
20:17:42 <mikeyp> biggest issue is weaving this all into the cells and resource caching changes.  That will probably impact the design.
20:18:55 <n0ano> so where are the resource caching changes being documented, we'll need to know that to do things right
20:19:05 <sriramhere> Also, session proposal made me submit new blueprint - which uses the above wiki as spec placeholder
20:19:43 <sriramhere> bp itself (derived mostly from previous bp) is at https://blueprints.launchpad.net/nova/+spec/nova-orchestration
20:19:50 <mikeyp> would need to look at capacity cache changes.
20:20:19 <sriramhere> what i found on the cache changes is old. let me get the link
20:20:26 <sriramhere> it would be good if someone can update it
20:21:10 <sriramhere> http://wiki.openstack.org/EssexSchedulerImprovements - is this correct?
20:22:16 <mikeyp> All of this is why I suspect we're somewhat stalled until the summit - the orchestration idea is valide, but there have been significant changes in essex
20:22:29 <mikeyp> mainly scalability, and the referece I'm using is the code
20:22:52 <mikeyp> also, I need to jump off shortly.
20:23:08 <mikeyp> Can we post an agenda for next week so we can be more productive ?
20:23:44 <n0ano> mikeyp, sure, that's a good idea, that'll give us some time to think about things a little.
20:24:21 <sriramhere> mikeyp - would you be able to document something about the cache?
20:25:05 <mikeyp> I can dig up the existing documentation and get references on it
20:25:09 <sriramhere> gr8
20:25:13 <n0ano> I'm thinking the agenda for next week is `Orchestration and resource cache - read the linked blueprints and come prepared'.
20:25:21 <sriramhere> ok
20:25:43 <mikeyp> sounds like a plan
20:26:14 <n0ano> #action mikeyp - provide references to docs on resource cache
20:26:34 <n0ano> #action n0ano - post agenda for next week's meeting
20:27:04 <sriramhere> #action n0ano sriramhere  - read the blueprints mikeyp publishes and come prepared for discussion.
20:27:29 <n0ano> so I'm thinking we're good for today (all the work is next week), anything else before we close?
20:27:37 <mikeyp> nothing from me.
20:27:41 <sriramhere> also, can we do skype or some voice call for more active disccusions?
20:28:07 <sriramhere> other than that, nothing from me
20:28:09 <mikeyp> thats possible
20:28:33 <n0ano> note we don't know who will be there, there could be others trying to attend the IRC channel
20:28:47 <sriramhere> lets convene here, and take it from there
20:29:05 <n0ano> OK, talk to you then
20:29:14 <sriramhere> thanks!
20:29:44 <n0ano> #endmeeting