22:02:20 <bhall> #startmeeting
22:02:21 <openstack> Meeting started Tue Mar 20 22:02:20 2012 UTC.  The chair is bhall. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:02:27 <bhall> should be a short one today
22:02:37 <somik> hello all!
22:02:49 <bhall> agenda is here: http://wiki.openstack.org/Network/Meetings
22:03:01 <bhall> #topic rc1
22:03:07 <bhall> Essex-RC1 is out: https://bugs.launchpad.net/quantum/+milestone/essex-rc1
22:03:09 <debo-os> observations: more people are saying hello whjen danW is not around
22:03:15 <bhall> haha
22:03:27 <bhall> we'll see if he reads the logs afterwards, eh?
22:03:32 <debo-os> :)
22:03:34 <bhall> so.. Essex-RC1 is out: https://bugs.launchpad.net/quantum/+milestone/essex-rc1
22:03:40 <bhall> please test
22:03:44 <bhall> try it out.. find bugs and file them, etc
22:03:57 <bhall> the distros are working on packaging
22:04:03 <SumitNaiksatam> Hi all!
22:04:05 <bhall> at this point it looks like debian is getting close (thanks Ghe!)
22:04:17 <bhall> Fedora is also coming along
22:04:40 <Salv-orlando> Hi
22:04:50 <bhall> #topic priorities on folsom
22:05:02 <bhall> dan kindly encourages every one to respond to the mailing list thread regarding priorities for folsom
22:05:03 <edgarmagana> ufff.. what a topic!
22:05:12 <bhall> please respond with your ideas if you haven't already
22:05:16 <bhall> #topic priorities for folsom
22:05:18 <bhall> :)
22:05:35 <SumitNaiksatam> taking bets now: who types faster, brad or dan! :-)
22:05:36 <debo-os> 1) scalability
22:05:44 <bhall> SumitNaiksatam: oh, I type much faster :)
22:05:52 <bhall> debo-os: respond to the mailing list ;)
22:06:23 <debo-os> i was the 1st to respond to dan's thread
22:06:25 <debo-os> ;)
22:06:31 <jlm^> 2) Stability ?  :)
22:06:32 <bhall> good
22:06:48 <bhall> jlm^: yeah, that'd be nice too
22:07:26 <wwkeyboard> 3) plugins, in or out? :)
22:07:41 <SumitNaiksatam> i think these are better defined/targeted with some specific goals in mind, otherwise very opended
22:08:04 <bhall> wwkeyboard: that's a good one as well
22:09:03 <bhall> SumitNaiksatam: yeah, agreed
22:09:24 <cdub> wwkeyboard: what do you mean by in or out?
22:09:30 <wwkeyboard> bhall: I have some more ideas for the list, I just think that needs to be settleed soon
22:10:01 <wwkeyboard> cdub: I'll explain in an email to the list, it will take more discussion that can/should be covered right now
22:10:08 <cdub> heh, ok, np
22:10:10 <bhall> wwkeyboard: I know there has been some talk about it on the mailing list.. I think a proposal would be great (separate repository, each in its own repository, etc)
22:11:08 <bhall> #topic devstack exercise script review
22:11:13 <bhall> devstack exercise script review: https://review.openstack.org/#change,4665
22:11:16 <bhall> would be nice to get some more eyes on that
22:11:31 <edgarmagana> bhall: working on that!
22:11:43 <debo-os> ok .... I put changes asked by Dean
22:11:47 <bhall> edgarmagana: great, thanks
22:11:51 <debo-os> I oculdnt keep him happy on 1 front ....
22:11:59 <debo-os> it needs mysql to query quantum network uuids
22:12:07 <debo-os> since the cli output is not as well formatted as in nova cli
22:12:14 <debo-os> danwent has a bug to track
22:12:19 <debo-os> to fix CLIs
22:12:32 <debo-os> we originally thought we would fix devstack after the CLI
22:12:50 <anotherjesse> debo-os: nova cli is painful
22:12:51 <debo-os> :)
22:13:01 <anotherjesse> we need to switch to tabs and make it easy to script
22:13:12 <vishy> anotherjesse: yes plz
22:13:15 <debo-os> quantum output is not even on a single line
22:13:16 <davlaps> +1
22:13:20 <bhall> yeah, both of the CLIs need to be more easily parseable
22:13:27 <anotherjesse> bhall: folsom ftw
22:13:30 <vishy> bhall: I feel like that defeats the purpose of an exercise
22:13:48 <vishy> bhall: as in it should be a straight through flow so it is easy to understand how to use the cli
22:14:05 <vishy> bhall: perhaps it should be broken up into a few different exercises?
22:14:32 <bhall> sure.. but I'll let debo/davelaps take tha tone
22:14:33 <debo-os> vishy: the quantum exercise is just one file but is broken up into different tests
22:14:53 <debo-os> each test can be separately triggered
22:15:04 <vishy> debo-os: yeah i understand, basically the idea of exercise scripts are to demonstrate how to use the command line
22:15:11 <debo-os> oh got it
22:15:13 <vishy> debo-os: so that a user could copy and paste commands from the script
22:15:26 <debo-os> from that perspective mysql is also a cmd line ;)
22:15:47 <vishy> debo-os: we have a very small number of helpers for the exercises where it is just too painful ( like get_field)
22:15:56 <vishy> debo-os: and die
22:16:27 <vishy> debo-os: it would be awesome to look at the quantum exercise and see how to create a quantum network and put an instance in it in one simple flow...
22:16:43 <vishy> debo-os: I don't get that out of the current script, I have to follow method calls etc.
22:16:46 <debo-os> vishy: I think it does that
22:16:56 <debo-os> ok I can do 2 things
22:17:09 <debo-os> 1 full blown exercise and 1 quantum-lite
22:17:26 <debo-os> in fact the 1st version which you had reviewed it was like that :)
22:17:32 <debo-os> one single flow
22:18:03 <debo-os> thx for all the feedback .... will do all this ...
22:18:09 <debo-os> should be done in a day
22:18:11 <davlaps> vishy: you can blame me for the functions. i thought it made it easier to see how to do each task.
22:18:25 <bhall> #action debo-os to refactor quantum exercise script
22:18:32 <davlaps> debo-os: i'm happy to help out with the refactoring..
22:18:59 <bhall> ok.. anything else on the exercise script?
22:19:06 <debo-os> no
22:19:16 <bhall> #topic summit
22:19:19 <bhall> anyone still trying to get into dev summit can get on waitlist: https://docs.google.com/spreadsheet/viewform?formkey=dE1qYkI4ck5KY2NHd0o5c0k4d1hHeHc6MQ#gid=0
22:19:52 <bhall> hopefully everyone already registered..
22:20:26 <bhall> ok.. moving on
22:20:32 <bhall> #topic open discussion
22:20:37 <bhall> anyone have anything they want to talk about?
22:21:04 <wwkeyboard> Is anyone here using melange with quantum? I found a bug that may cause an inconvinence.
22:21:36 <bhall> wwkeyboard: we do.. do you have a bug filed already?
22:21:50 <wwkeyboard> I haven't filed it yet, and if noone is using it I'll just merge in the fix
22:22:19 <cdub> bhall: I think the fallout from https://github.com/openstack/quantum/commit/c6e1c616ad2ad3949b7bec36233d7aac885922c4 is understood at this point
22:22:43 <cdub> bhall: but do you have an opinion on setup.py using scripts vs console_scripts?
22:22:50 <bhall> wwkeyboard: ok, sounds good
22:23:07 <bhall> cdub: I just want us to do what the other projects do
22:23:15 <wwkeyboard> Ok, then I'll write it up. but if you look in the interfaces table you'll see device_id contains integer IDs instead of UUIDS
22:23:24 <wwkeyboard> this was recently fixed, but there is no migration.
22:23:27 <bhall> it sounds like you asked monty to go chase down the ptl's and figure out what the direction is
22:23:35 <cdub> bhall: yeah
22:23:55 <cdub> and we have interim workaround for fedora
22:23:55 <SumitNaiksatam> question for davlaps: with regards to the tty image with multiple interfaces that you are pointing to now in devstack, does it get a DHCP IP address for multiple interfaces, or only for the default interface (eth0)?
22:24:13 <davlaps> SumitNaiksatam: for multiple interfaces..
22:24:14 <bhall> cdub: ok, good.  hopefully we'll get that all sorted out soon
22:24:40 <bhall> wwkeyboard: does this require any quantum manager (melange ipam lib or connection) changes?
22:25:18 <wwkeyboard> No
22:25:29 <SumitNaiksatam> davlaps: thanks...ok, in our setup only one interface was getting the IP, and the others were getting if we manually initiated udhcpc, so just wondering what was going awry
22:25:49 <wwkeyboard> I can't see where that field is used yet, but I'm using it to fix filtering by IPs
22:25:50 <bhall> wwkeyboard: ok, good
22:26:18 <davlaps> SumitNaiksatam: np. using quantum.sh script you should see all interface come up with ips..
22:26:21 <bhall> SumitNaiksatam: that seems to be how the normal tty-linux image works.. are you seeing that with the tty-quantum image?
22:26:35 <SumitNaiksatam> bhall: yes
22:27:01 <SumitNaiksatam> bhall/davlaps: thats what I was trying to get confirmation on
22:27:05 <bhall> SumitNaiksatam: ok, I'll try it out today and see what happens in my setup
22:27:27 <SumitNaiksatam> bhall/davlaps: thanks!
22:28:08 <bhall> ok.. anyone have anything else?
22:29:10 <bhall> ok.. see ya'll next week
22:29:13 <bhall> #endmeeting