18:00:49 <heckj> #startmeeting
18:00:50 <openstack> Meeting started Tue Mar 13 18:00:49 2012 UTC.  The chair is heckj. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:10 <heckj> #topic Keystone RC1 bugs, open issues, discussion, etc (freeform today)
18:02:29 <heckj> New bugs popped up over the past day against Keystone. #Link https://launchpad.net/keystone/+milestone/essex-rc1
18:03:06 <heckj> er, is anyone besides me here?
18:03:28 <chmouel> hello
18:04:07 <heckj> heya
18:05:08 <heckj> I'll wait for general status until some others wander in and raise their hands
18:05:39 <heckj> chmouel: I added detail to the memcache unit test issue that I'm seeing. It's really odd - was planning on tracking it down today, since I'm pretty sure it's environmental in some form.
18:06:00 <chmouel> I am not sure how to reproduce this one 954057
18:06:03 <heckj> chmouel: totally works on devstack and my linux host, fails repeatably and consistently on my laptop
18:06:49 <chmouel> is the python-iso8690 (or  something like that) is installed?
18:06:54 <heckj> #link https://bugs.launchpad.net/keystone/+bug/954057
18:06:55 <uvirtbot> Launchpad bug 954057 in keystone "memcache test failing in python 2.6" [High,Confirmed]
18:07:29 <heckj> chmouel- yep, that's installed and verified. The timing check just isn't triggering in that one unit test, and so the assertion isn't raised.
18:07:32 <heckj> I'm not sure why though
18:07:45 <chmouel> i think major is telling me in a private message that it seems to be timezone related
18:07:51 <chmouel> any chance you can try that?
18:08:39 <heckj> what do I do to twiddle the timezones related to the timestamp creation?
18:09:12 <chmouel> is your VM set in UTC+0 ?
18:09:13 <heckj> I guess I'll read through the iso8601 help and see if there's something there?
18:09:26 <chmouel> ie: what's the output of date
18:12:44 <heckj> just added the logging to see what it's doing, running now
18:13:33 <heckj> Here'e the failed logging output:
18:13:36 <heckj> ======================================================================
18:13:36 <heckj> FAIL: test_expired_token (test_backend_memcache.MemcacheToken)
18:13:37 <heckj> ----------------------------------------------------------------------
18:13:37 <heckj> Traceback (most recent call last):
18:13:38 <heckj> File "/Users/heckj/src/keystone/tests/test_backend.py", line 299, in test_expired_token
18:13:38 <heckj> self.token_api.get_token, token_id)
18:13:38 <heckj> AssertionError: TokenNotFound not raised
18:13:38 <heckj> -------------------- >> begin captured logging << --------------------
18:13:39 <heckj> root: DEBUG: expire time is 2012-03-13 11:02:32.110603
18:13:39 <heckj> root: DEBUG: data_ref is 2012-03-13 11:02:32.110603
18:13:39 <heckj> --------------------- >> end captured logging << ---------------------
18:14:55 <rackerhacker> howdy guys
18:15:01 <chmouel> if you backout my memcache tests is that still going on
18:15:06 <chmouel> rackerhacker: hey
18:17:21 <heckj> I found at least one issue - the SQL backend is a strict < check, not <=
18:22:48 <heckj> rackerhacker: you said you had some insight?
18:23:07 <heckj> (that little > --> >= tweak didn't make a difference in the code)
18:24:24 <rackerhacker> heckj: just that i can flip time zones and make the tests pass/fail
18:24:30 <rackerhacker> they pass on utc, fail on everything else
18:24:52 <rackerhacker> i tried PDT/CDT/EDT and it failed on all
18:24:58 <heckj> ah, that's what chmouel was just saying
18:25:18 <rackerhacker> i'm afraid my python skills aren't decent enough to figure out why
18:25:43 <chmouel> this is weird it fails on test_backend when my change was in auth_token and should not touch that
18:29:10 <heckj> Putting this aside for a moment, getting to the meeting
18:29:33 <heckj> #link https://launchpad.net/keystone/+milestone/essex-rc1
18:29:54 <heckj> couple of new bugs overnight that I think are pretty relevant to an RC1 release - tracebacks related to the templatedService catalog.
18:30:29 <heckj> I could use some help nailed those down - getting them at least returning NotImplemented or polite error messages rather than tracebacks.
18:30:44 <heckj> #link https://bugs.launchpad.net/keystone/+bug/954089
18:30:46 <uvirtbot> Launchpad bug 954089 in keystone "service-list returns empty set for TemplatedCatalog backend" [Critical,Confirmed]
18:30:52 <heckj> #link https://bugs.launchpad.net/keystone/+bug/954087
18:30:53 <uvirtbot> Launchpad bug 954087 in keystone "endpoint-list with TemplatedCatalog backend raises AttributeError" [Critical,Confirmed]
18:31:06 <heckj> ayoung: you around?
18:32:16 <heckj> ayoung has a review up for LDAP documentation: #link https://bugs.launchpad.net/keystone/+bug/949521
18:32:18 <uvirtbot> Launchpad bug 949521 in keystone "Document the LDAP Identity Driver" [Critical,Confirmed]
18:32:53 <heckj> And we have the "how are we using config" that's holding up two bugs (thread on the mailing list)
18:33:11 <heckj> SOren's also reported a new bug: #link https://bugs.launchpad.net/keystone/+bug/952977
18:33:13 <uvirtbot> Launchpad bug 952977 in keystone "Can't fetch EC2 credentials" [High,Confirmed]
18:33:24 <annegentle> heckj: you asked my question, "which conf file?" :)
18:34:50 <heckj> annegentle: excellent.
18:34:56 <heckj> (did I answer?)
18:35:17 <annegentle> heckj: I can leave a comment on the bug, but young's doc doesn't say which conf file.
18:35:50 <heckj> annegentle: ah, that one! Yeah, we'll get that in and updated with a configuration file. He means the keystone config, but it's not clear.
18:36:34 <heckj> well quiet today - any questions or general discussion? Opinions on the whole config thingy?
18:36:58 <annegentle> heckj: I'm also wondering about the basic install doc, are we doing "install from source" or "install from these distros" (ubuntu/debian, rhel/fedora?)
18:37:51 <heckj> annegentle: I'll make sure to at least get a "install from source" fully operational for you. I haven't seen the latest debian packaging that Ubuntu (zul, adam_g, etc) have been rolling.
18:38:05 <heckj> I don't know at all what the RHEL/fedora packages are doing
18:38:25 <heckj> annegentle: what are other openstack projects doing?
18:38:53 <annegentle> heckj: I think that the projects all will rely heavily on distros
18:39:09 <annegentle> heckj: packages will lag like they did with diablo
18:39:25 <annegentle> heckj: so I need to write install docs that should "just work" but also have a list of known bugs that get into the release I guess
18:39:33 <annegentle> heckj: with workarounds
18:39:56 <annegentle> heckj: also, the openstack/identity-api repo probably needs a final polish prior to release
18:40:07 <heckj> annegentle: then it makes sense to match those and have similiar installation docs. I haven't done any precise/ubuntu testing at all - I think we probably need to make a call out to folks to help us with notes on that.
18:40:19 <annegentle> heckj: pretty sure it doesn't reflect reality. I do think api.openstack.org has a view of reality though.
18:40:34 <heckj> #action: joe to make a call out to the mailing list for package-based testing and notes from the success/failure
18:41:06 <heckj> #action: heckj to make call to mailing list for assistance in closing down these remaining bugs
18:42:33 <heckj> Anything else folks?
18:42:51 <annegentle> not from me, thanks for the info
18:44:20 <heckj> okay - thanks all. Ending it here
18:44:23 <heckj> #endmeeting