21:06:16 <ttx> #startmeeting
21:06:17 <openstack> Meeting started Tue Mar  6 21:06:16 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:06:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:06:21 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:06:37 <ttx> We'll look into the RC1 bug lists, and see if we are on track
21:06:45 <ttx> #info To visualize convergence towards the final objective, I created RC bug charts:
21:06:52 <ttx> #link http://wiki.openstack.org/releasestatus/rc1.html
21:07:02 <ttx> This should help in assessing if we are going in the wall, or are making good progress.
21:07:31 <ttx> Skipping keystone until zns or heckj joins
21:07:35 <ttx> #topic Swift status
21:07:39 <ttx> notmyname: o/
21:07:42 <notmyname> hi
21:07:54 <ttx> 1.4.7/1.4.8 plans ?
21:08:06 <notmyname> great question, I'm glad you asked :-)
21:08:31 <ttx> hehe
21:08:54 <notmyname> we have a couple of patches that need to be released asap (they affect durability in large clusters), and so we will be releasing 1.4.7 late this week with 1.4.8 to follow in a couple of weeks as the final essex release
21:09:13 <zns> ttx: hi - I'm hereā€¦ but heckj is already driving keystone and I'm not up to speed.
21:09:15 <notmyname> the important patches are https://github.com/openstack/swift/commit/f51c1de52d04aba57d2b5586f65070b79a39ca4b and https://github.com/openstack/swift/commit/3c7e983793654899b22e801c7f655fa70b0399af
21:09:17 <heckj> o/ (sorry I'm late)
21:09:34 <notmyname> but all of the patches until now will be going in to 1.4.7
21:09:49 <ttx> 1.4.7 release ETA set to Friday, this week ?
21:09:51 <notmyname> this will also give a nice head-start on testing for exxex
21:10:02 <notmyname> yes, 1.4.7 on friday is the goal
21:10:16 <notmyname> 1.4.8 on or around the 22nd
21:10:24 <ttx> #action ttx to adjust tentative Swift 1.4.7/1.4.8 release dates
21:10:31 <ttx> notmyname: Anything else ?
21:11:01 <notmyname> I think that's all I have about current swift stuff. I encourage everyone to start thinking about what they want to discuss about swift at the summit
21:11:16 <notmyname> well, think about everything else too :-)
21:11:25 <ttx> Questions on Swift ?
21:11:55 <ttx> #topic Keystone status
21:12:01 <ttx> zns, heckj: o/
21:12:07 <heckj> o/
21:12:08 <ttx> #link https://launchpad.net/keystone/+milestone/essex-rc1
21:12:14 <ttx> I see 11 open bugs there.
21:12:21 <ttx> Does that list accurately represent all the currently-known release blockers ?
21:12:30 <ttx> Or do you still have to run through the buglist and target more ?
21:12:35 <heckj> ttx: still in progress to get bugs triaged - not complete, btu the ones there represent work against RC1
21:12:50 <ttx> Was thinking about bug 947013, for example
21:12:50 <uvirtbot`> Launchpad bug 947013 in keystone "user-list throws error/traceback when it should provide nice "unauthorized" message" [Medium,Confirmed] https://launchpad.net/bugs/947013
21:13:12 <heckj> ttx: also haven't caught up on bugs -> blueprints for the folsom summit, which is also in progress
21:13:49 <ttx> heckj: remember RC1 is supposed to be releasable, unless something new comes up that justifies an RC2
21:13:52 <heckj> ttx: if anyone believes a bug is higher importance, i'm requesting they contact me directly to assign to a higher priority or begin the work to complete it.
21:14:00 <ttx> so it's important to come up with a complete RC buglist
21:14:01 <heckj> ttx: yeah, got it.
21:14:11 <heckj> ttx: again, got it. Like I said - in progress.
21:14:12 <ttx> Bug 943722 needs an assignee.
21:14:12 <uvirtbot> Launchpad bug 943722 in keystone "token auth needs unit tests" [Critical,Confirmed] https://launchpad.net/bugs/943722
21:14:17 <ayoung> I can take it
21:14:33 <ttx> ayoung: great, assign yourself please
21:14:46 <ayoung> done
21:14:52 <ttx> Any blockers on the other bugs ?
21:15:20 <heckj> ttx: review is still needed before I can reasonably answer that
21:15:53 <heckj> ttx: focus for everyone right now is bugs and docs improvement, leading to solid product and "how to" on all fronts prior to release.
21:16:08 <ttx> no, I mean... on the bugs already on the list, are there anything blocking the fix that you want to raise a flag about ?
21:16:40 <ttx> or do they all look "fixable"
21:17:06 <heckj> ttx: from that list, no - there's some ongoing discussion that just moved to the list about using openstack-common - some needs related to testing and how they work need to get worked out. All the bugs currently listed look fixable - no blocks for the list extant.
21:17:21 <ttx> heckj: Cool. Anything else ?
21:18:06 <heckj> Open request again for folks to send me use cases around keystone deployment, or otherwise add to the wiki page (link in a sec)
21:18:17 <ttx> Questions about Keystone ?
21:18:33 <heckj> #link http://wiki.openstack.org/KeystoneFolsomSummitTopics, http://wiki.openstack.org/KeystoneUseCases
21:18:43 <heckj> in prep for keystone discussions at Folsom design summit
21:19:04 <ttx> heckj: RC1 bug countdown graph available at http://wiki.openstack.org/releasestatus/rc1.html -- in case you missed the link earlier
21:19:13 <heckj> ttx: thanks!
21:19:27 <ttx> #topic Glance status
21:19:34 <ttx> jaypipes/bcwaldon: yo
21:19:44 <ttx> #link https://launchpad.net/glance/+milestone/essex-rc1
21:19:54 <ttx> 4 open bugs left.
21:20:11 <ttx> That list looks complete. Any bug missing from that list ?
21:20:18 <jaypipes> ttx: no status report. there are open reviews needing to occur.
21:20:31 <jaypipes> ttx: at PyCon this week so not going to be a whole lot of time
21:20:37 <ttx> Bug 945173, maybe ?
21:20:39 <uvirtbot> Launchpad bug 945173 in glance "Specify image_id with 'glance add'" [Medium,In progress] https://launchpad.net/bugs/945173
21:20:47 <ttx> Or bug 939257 ?
21:20:48 <uvirtbot> Launchpad bug 939257 in glance "container_format is not mandatory in glance add" [Undecided,In progress] https://launchpad.net/bugs/939257
21:21:00 <jaypipes> AFAIK, both have code up for review
21:21:10 <ttx> Right, so they will be in RC1 but not blocking
21:21:18 <ttx> Bug 934492 needs an assignee
21:21:19 <uvirtbot> Launchpad bug 934492 in glance "bin/glance should allow nullable Name to match API spec" [Low,Triaged] https://launchpad.net/bugs/934492
21:21:34 <ttx> (or be untargeted)
21:21:40 <jaypipes> ttx: when is RC1 again?
21:21:56 <ttx> jaypipes: whenever the RC1 bug list is empty
21:22:10 <jaypipes> ttx: k
21:22:19 <ttx> Hopefully sometimes in the next 2 weeks.
21:22:40 <jaypipes> ttx: k, I will look for a volunteer for 934492.
21:22:47 <ttx> and Glance and Keystone being a bit upstream from Nova (or Horizon) the sooner the better.
21:23:07 <ttx> #action jaypipes to find volunteer for 934492
21:23:14 <ttx> jaypipes: Anything else ?
21:23:19 <jaypipes> ttx: no
21:23:22 <ttx> Questions on Glance ?
21:23:50 <ttx> #topic Nova status
21:23:54 <ttx> vishy: hey
21:23:59 <vishy> hi
21:24:00 <ttx> #link https://launchpad.net/nova/+milestone/essex-rc1
21:24:06 <ttx> 12 bugs open.
21:24:24 <ttx> hmm...13 actually
21:24:34 <ttx> vishy: Is it a complete representation of release blockers ?
21:24:34 <vishy> yeah just targeted another one :)
21:24:45 <ttx> Or should we still planify some kind of big bug prioritization meeting to make sure we evaluated all the reported issues ?
21:24:57 <vishy> ttx: I can't say that for sure. It is a representation of ones that I know about
21:25:20 <vishy> prioritization would be great since I'm sure that there are some that are important that I haven't found yet
21:25:33 <ttx> vishy: do you think we can come up with something more scientific to process all the data we have, or should we rely on informants to flag the bugs ?
21:25:51 <vishy> ttx: not sure
21:26:01 <vishy> ask nova-core to do a bug triage?
21:26:30 <ttx> the problem with asking everyone to go through all the bugs is how much duplication of effort that creates
21:26:53 <vishy> ttx: we could divide bugs up into chunks
21:26:57 <vishy> and give a few to everyone
21:27:21 <ttx> vishy: let's talk of that offline -- and fix the ones we have already first
21:27:30 <vishy> ttx; sounds good
21:27:40 <ttx> #action vishy and ttx to discuss how to ctach release-critical bugs
21:27:48 <ttx> There are a number of bugs without an assignee on the RC1 list:
21:27:54 <ttx> Bug 928819
21:27:55 <uvirtbot> Launchpad bug 928819 in nova "Launching instance fails in Precise A2 - network/manager.py too many values to unpack" [High,Confirmed] https://launchpad.net/bugs/928819
21:28:02 <ttx> Who wants that one ? Had code proposed but missing a test
21:28:25 <vishy> so all four of the unassigned ones should be pretty simple
21:28:31 <vishy> just need volunteers :)
21:28:38 <ttx> jkoelker was on it, but review stalled on the need for a test
21:28:44 <ttx> Bug 946427
21:28:45 <uvirtbot> Launchpad bug 946427 in nova "Authorizing ICMP w/o specifying types adds 1-65535/tcp and 1-65536/udp" [High,Confirmed] https://launchpad.net/bugs/946427
21:28:56 <ttx> bug 947776
21:28:56 <uvirtbot> Launchpad bug 947776 in nova "need flag to disable ratelimiting" [High,Triaged] https://launchpad.net/bugs/947776
21:29:05 <ttx> bug 948286
21:29:05 <uvirtbot> Launchpad bug 948286 in nova "euca-describe-instances returns ImageNotFound on first run" [High,Triaged] https://launchpad.net/bugs/948286
21:29:13 <ttx> We need volunteers!
21:29:24 <vishy> ttx: maybe we should take them to the ml
21:29:34 <jdg> I'll look at the Precise bug
21:29:49 <mnewby> I'll take 948286
21:29:50 <ttx> Right, if nobody works on them there is no way we can keep them as release blockers :)
21:29:56 <russellb> i can take whichever :)
21:30:22 <ttx> jdg, mnewby, russellb: Thanks! Assign yourself.
21:30:48 <ttx> #action vishy to take leftover RC1 bugs (if any) to the ML for volunteers
21:31:00 <ttx> vishy: Anything else ?
21:31:39 <vishy> just a reminder to core to let me know about potential release blockers so i can target them
21:31:45 <vishy> I will put that in the email too
21:31:49 <ttx> vishy: do you want to discuss the Nova subtracks for the design summit now ?
21:32:18 <ttx> vishy: or brainstorm a bit more before we do ?
21:32:22 <anticw> hammertime
21:32:29 <vishy> brainstorm for a bit
21:32:34 <vishy> we can discuss next week
21:32:40 <ttx> ok
21:32:43 <anticw> the root-wrapper ... can we talk about how that's supposed to work?
21:32:51 <ttx> Questions on Nova ?
21:32:56 <anticw> yes
21:32:59 <ttx> anticw: sure
21:33:06 <ttx> anticw: maybe talk to me after the meeting
21:33:23 <anticw> given i still need sudo to run it ... and it's python ... and i can setr PYTHON_PATH ... i can pervert what it does
21:33:25 <ttx> anticw: since I wrote it I should be able to explain it.
21:33:42 <anticw> what's more, it's not clear if it letsd me run dd ...  and it doesn't (because it can't) check arguments ... then i can use dd to replace /etc/passwd
21:33:45 <anticw> or tee
21:33:50 <anticw> so it's not clear how this helps
21:34:07 <ttx> anticw: sure, we can discuss that off-meeting together
21:34:14 <ttx> #topic Horizon status
21:34:15 <anticw> in fact it moves the mess that is /etc/sudoers* to python code ... and uses matching there ... but doesn't change how it works
21:34:18 <anticw> which is the problem
21:34:30 <devcamcar> o/
21:34:34 <ttx> devcamcar: o/
21:34:36 <ttx> devcamcar: Wanted to talk about E4 tarball re-publication
21:34:40 <devcamcar> yep
21:34:58 <devcamcar> we've had the discussions, i think we just need to pick a path and move forward
21:35:00 <ttx> anticw: will ping you on #openstack-dev when the meeting is over
21:35:11 <ttx> Horizon E4 published tarball was broken due to missing MANIFEST.in, which is fixed now
21:35:16 <ttx> The current pre-rc1 snapshots are OK, is it worth republishing it or should we rather spend our time on RC1 work ?
21:35:25 <ttx> My opinion is that what's done is done, we should race towards RC1, and anyone who needs a working tarball before then can use a recent snapshot
21:35:32 <devcamcar> ttx: i agree
21:35:48 <devcamcar> most of remaining issues are related to translations or minor bugs
21:35:53 <ttx> devcamcar: cool. I also push CI so that we get a test that will avoid such issue in the future
21:35:57 <devcamcar> and a few upstream packaging issues
21:36:05 <ttx> #link https://launchpad.net/horizon/+milestone/essex-rc1
21:36:08 <devcamcar> that'd be great
21:36:28 <ttx> devcamcar: so the 18 remaining bugs are all translations or minor bugs ?
21:36:43 <devcamcar> we had a situation where we had some project structure changes we wanted to wait until end to introduce so we wouldn't cause everyone with outstanding reviews to have to rebase
21:36:48 <devcamcar> and ended up breaking the packaging
21:36:55 <devcamcar> damned if you do etc :)
21:37:07 <ttx> I know the feeling
21:37:23 <ttx> 3 unassigned bugs on the list
21:37:30 <ohnoimdead> ttx: we should be down to 12 confirmed and 4 in progress
21:37:33 <ttx> devcamcar: Should I assign "nebula" to those until you get someone more specific working on it ?
21:37:34 <devcamcar> ttx: mostly yes - we also have a few minor ux improvements to work in
21:37:39 <devcamcar> ttx: i only see 2 unassigned?
21:37:45 <ttx> damn it :)
21:37:54 <devcamcar> ttx: oh, there's another that is unassigned but that's because it was fixed inadvertently by another patch
21:38:00 <devcamcar> and is marked fix committed
21:38:08 <ttx> just one left unassigned now ;)
21:38:12 <devcamcar> ok :)
21:38:21 <devcamcar> i think we should be able to provide a pretty solid rc in about a week
21:38:27 <ttx> I checked that 40 minutes ago :)
21:38:36 <devcamcar> 40 minutes? that's forever in openstack time
21:38:55 <ttx> bug 934064 -> assign to Nebula ?
21:38:56 <uvirtbot> Launchpad bug 934064 in openstack-dashboard "Installing openstack-dashboard on Precise removes Keystone package" [High,In progress] https://launchpad.net/bugs/934064
21:39:12 <ttx> or do you have someone in mind ?
21:39:29 <devcamcar> its purely an upstream packaging issue i believe - need to investigate further
21:39:34 <devcamcar> i'll assign to nebula for now and we'll track it
21:39:39 <ttx> ok
21:39:46 <ttx> devcamcar: Anything else ?
21:39:48 <devcamcar> looks like chuck short is all over it
21:39:58 <devcamcar> that is all for now!
21:40:14 <ttx> Now I need to erase that picture from my mind before going to sleep
21:40:20 <ttx> Questions for Horizon ?
21:40:36 <devcamcar> ttx: actually looks like 934064 is already fixed upstream
21:40:57 <devcamcar> will wait for confirmation from chuck though
21:40:57 <ttx> devcamcar: cool, update it
21:41:14 <devcamcar> will at least tag it in progress ;)
21:41:24 <ttx> #topic Incubated projects and other Team reports
21:41:34 <ttx> danwent, troytoman: yo
21:41:37 <danwent> hi
21:41:45 <danwent> https://bugs.launchpad.net/quantum/+milestone/essex-rc1
21:41:59 <danwent> nothing big or scary, just a few things we're looking to fix up for rc1
21:42:05 <danwent> does friday make sense as a target date?
21:42:32 <ttx> danwent: if you get to the bottom of the list, why not
21:42:42 <ttx> danwent: remember RC1 is supposed to be your Essex release until proven otherwise
21:42:50 <danwent> k, great.  I think that's definitely achieveable.  Yup.
21:42:58 <ttx> so you might want to be careful rather than doing too early
21:43:21 <ttx> Since once RC1 is out you open master for Folsom dev
21:43:40 <danwent> ok, will talk with the team about it, but I don't think we're planning on adding any new features.  may want to check what coverage we have on 12.04 yet, as that packaging just came together (thanks chuck!)
21:43:46 <ttx> and if a RC2 is needed it's built from milestone-proposed
21:43:52 <danwent> k
21:44:13 <ttx> that said, you're not core so you can do what you want :)
21:44:19 <ttx> (for Essex)
21:44:27 <danwent> ok, that's all from me.
21:44:44 <ttx> Any other team lead with a status report ? annegentle, mtaylor ?
21:44:55 <annegentle> Doc Day in full swing!
21:45:05 <ttx> Join #openstack-docday !
21:46:04 <annegentle> we'd welcome feedback on this outline http://etherpad.openstack.org/drs6dPNF4p
21:46:45 <ttx> #help please provide feedback on outline at http://etherpad.openstack.org/drs6dPNF4p
21:46:52 <ttx> annegentle: anything else ?
21:47:06 <mtaylor> ttx: things are great
21:47:19 <mtaylor> ttx: also, jeblair is looking in to the current usage cap on cloud servers
21:47:55 <ttx> mtaylor: so we could use more builders at peak time ? Cloudy.
21:48:13 <mtaylor> ttx: we hit a "we can't spin up more servers" error
21:48:31 <mtaylor> ttx: we may be leaking servers - no final status - but we're looking at it
21:48:33 <ttx> EFINITECLOUD
21:48:46 <ttx> mtaylor: ok, thx for the update
21:48:49 <mtaylor> ttx: oh, also - when we say "open dev for folsom"
21:49:04 <mtaylor> ttx: don't we actually mean "branch stable/essex" ?
21:49:42 <ttx> hmm, actually I meant branch milestone-proposed
21:49:54 <ttx> but at some point we need to call that stable/essex
21:50:15 <mtaylor> okie
21:50:18 <ttx> you also need to push a few versioning updates to master to "open folsom"
21:50:54 <mtaylor> ++
21:51:03 <ttx> #action ttx and mtaylor to investigate actions around branches when we "open Folsom"
21:51:13 <ttx> #topic Open discussion
21:51:20 <ttx> The big DST madness will hit us starting next week, with US adopting DST while Europe and others stay outside DST
21:51:34 <ttx> Meeting times stay the same in UTC
21:51:38 <ttx> So for US people our meetings will start one hour later starting next week.
21:51:52 <russellb> yay time zones
21:52:13 <ttx> I can't wait until this meeting is back at 11pm. Sigh :)
21:52:18 <ttx> Anything else, anyone ?
21:52:57 <ttx> Guess not. Happy RC bug hunting !
21:53:02 <ttx> #endmeeting